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ABOUT THIS COURSE 

Course Prerequisites 

This manual assumes the user has an intermediate knowledge of Microsoft Excel and 
Microsoft Access, as well as a basic knowledge of Windows and web browsers. 

 

Course Overview  

Welcome to Introduction to Microsoft Power BI! This powerful collection of software, apps, 
and services will help you analyze your organization’s data and uncover insights and trends. 
This course will show you how to link and model data in Power BI and create visual reports 
that reveal data insights. Although the Power BI desktop client will be the primary focus, an 
introduction to the Power BI web app will also be provided. 

 

Course Objectives 
By the end of this course, users should be comfortable with: 

• The purposes and basic functions of the core Power BI components 

• Using the Power BI desktop client and web app 

• Connecting to a data source using either the Power BI desktop client or the web app 

• Modeling data 

• Creating reports and visualizations 
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How To Use This Book 

This course is divided into five lessons. Each lesson focuses on several key topics, each of 
which are broken down into easy-to-follow concepts. At the end of each topic, you will be 
given an activity to complete. At the end of each lesson, we will summarize what has been 
covered and provide a few review questions for you to answer. Supplemental learning for 
selected topics is provided in the form of Lesson Labs at the end of this book. 

Before you begin, download the course’s Exercise Files to a convenient location. They will 
be referenced throughout this course and are a key part of your learning experience. 

The samples referenced throughout this course have been provided by obviEnce 
(www.obvience.com) through Microsoft. More information is available at 
https://docs.microsoft.com/en-us/power-bi/sample-datasets. 

Please note that the Power BI desktop client is updated monthly and the web app is 
updated weekly. Therefore, the images you see in this course may differ from the current 
services. This manual uses the January 2018 version of the desktop client and web app. 

Before beginning, users should install the Power BI desktop client and sign up for the 
service. 

 

  

http://www.obvience.com/
https://docs.microsoft.com/en-us/power-bi/sample-datasets
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LESSON 1: 
GETTING STARTED 

 

 

Lesson Objectives 

In this lesson you will learn how to: 

• Describe the components of Power BI 

• Work with Power BI files 

• Connect to data sources with the Power BI desktop client  

• Create a report and visualizations  

• Work with visualizations 
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TOPIC A: An Introduction to 
Power BI  
 

To start this course, you will learn about the different elements of the Power BI service and 
its fundamental components. You will also take your first look at desktop client and web 
app interfaces. 

 

Topic Objectives 

In this topic, you will learn: 

• What Power BI is 

• About the Power BI building blocks 

• About the desktop client interface 

• When to expect Power BI updates  
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What is Power BI? 

Power BI is a collection of software, apps, and services designed to aggregate data so users 
can easily report on and interpret it. It offers many easy-to-use visualization and reporting 
tools. It also supports a wide range of data sources, from Facebook analytics to Azure data 
warehouses and everything in between. 

There are three key parts to Power BI, which are all supported by the Power BI service: 

 

Power BI also offers many different connectors so that its data can be shared with, and 
embedded into, Microsoft apps such as SharePoint and Teams. 

Typically, users will start by creating a report in Power BI from connected data sources. The 
user then publishes that report to the service and shares it, making it available to other 
users via the web interface and mobile apps. The web interface and mobile apps also 
support dashboards, which provide a customized summary of report visualizations, and 
workspaces, which allow users to create custom dashboard collections. 

 

  

Desktop 
Client

Mobile 
Apps

Web 
Interface

Power BI 
Service 
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The Building Blocks of Power BI  

Let’s look at how all these elements work together in Power BI. 

 

It all starts with the dataset, which simply means the data you have connected to. This 
might be an Excel workbook, Facebook analytics, and/or an SQL database (just to name a 
few of the options). These datasets are then added to reports as visualizations, which 
present that data in a graphical way.  

  

Workspace

Dashboard

Tile

Report

Visualization

Dataset
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For example, sales by region might be presented as a map, with a bubble representing each 
amount: 

 

The Power BI web and mobile apps go a step further with dashboards, which allow you to 
collect visualizations from different reports into a single location. (The desktop client does 
not offer this feature.) For example, you might have a different dashboard for each region in 
your company, or a separate dashboard for revenue and expenses.  

Each dashboard is made up of tiles, which are simply visualizations linked back to the 
original report. These dashboards can be collected into workspaces. 

  



[19] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

The Power BI Desktop Interface  

To use the Power BI desktop client, get the installation package from the Windows Store or 
the Power BI website (https://powerbi.microsoft.com/en-us/desktop/). Once you have 
installed it, double-click the icon to start it: 

 

 

The app will then launch and display the Start screen: 

 

Here, you can explore what’s new, find help, watch videos, and create and open reports. 

  

https://powerbi.microsoft.com/en-us/desktop/
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When this window is closed, the main interface will be displayed:  

 

 

Let’s explore each part. 

 

1: Title Bar 
The name of the program and the currently open file are displayed here.  

2: Quick Access Toolbar 
As the name implies, the Quick Access toolbar gives you quick access to frequently used 
commands. Use the drop-down arrow to remove icons or change its position. 

3 and 4: Ribbon Interface 
Displays tab commands organized into groups. If you click the different tabs (4), you will see 
the commands (3) change. Some of the commands might be grayed out (unavailable) if they 
are only usable in certain situations.  

Power BI also features contextual tabs, which appear when you are working with a specific 
object or group of information. These tabs are usually denoted by a different color: 
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5: Program and Account Management 
Using the top set of icons in the top right-hand corner of the screen, you can change how 
the ribbon is displayed, minimize the window, maximize/restore the window, or close the 
current file. Below this, you will see your Microsoft account name (or a command to sign 
in), a chevron to minimize the ribbon, and a help icon. 

6: Navigation Pane 
From top to bottom, choose if you want to work with reports, data, or relationships. 

7: Canvas 
The data in the currently open file will be shown here. In Report view, this is where you will 
create and work with visualizations. 

8: Task Panes 
Additional commands appear in these vertical task panes. Here, you can see the two default 
task panes: Visualizations/Filters and Fields. 

9: Page Navigator and Status Bar 
Navigate through and manage pages in your report. 

 

Important Information About Power BI Updates 

The Power BI desktop client is updated monthly and the web app is updated weekly. 
Therefore, the images you see in this course may differ from the current services. However, 
the general instructions should stay the same. 
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If you are using the desktop client, the Start screen will prompt you if updates are available. 
You can also access a link to see new features: 
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Activity 1-1: An Introduction to Power BI 
In this activity, learners will install and launch the Power BI desktop client. They will also 
explore the Power BI web app. 

1.  Download and install the Power BI desktop client from the Microsoft Store: 

 
 

(If you have already downloaded and installed the app, skip to the next step.) 

  

2.  Double-click the icon to launch it: 
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3.  Click “Sign in:” 

 

 

(If you are already signed in, close the Start screen and skip to Step 6.) 

  

4.  Enter your email address and click “Sign in:” 
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5.  Enter your password and click “Sign in:” 

 

6.  The Power BI interface will now be displayed. Review the parts of the interface and 
move your mouse over some of the commands to see more information: 
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7.  Next, launch Microsoft Edge and navigate to https://app.powerbi.com/. Sign in 
when prompted to see the Power BI web app: 

 
 

8.  Take a moment to explore the app: 

 

   

9.  Close all open windows to complete this activity. 

https://app.powerbi.com/
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TOPIC B: Working with Power 
BI Desktop Files 
 

Like many other Office programs, Power BI has its own file format (.pbix), as well as the 
ability to create, open, and save standalone files. It also syncs with the Power BI web app so 
that your data can be accessed from anywhere, including Power BI mobile apps. 

 

Topic Objectives 

In this section, you will learn how to: 

• Create, save, and open Power BI files 

• Publish files to the Power BI web app 
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Opening Files  

To open a file, click File → Open: 

 

 

(You can also click a shortcut in the “Recent items” list to open it directly.) Next, navigate to 
your file, select it, and click Open: 
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The file will now open in a new instance of Power BI, ready for use: 

 

 

Saving Files  

To save a file, click File → Save or Save As: 
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The Save As dialog will open. Here, you can choose a location and name for your file. Click 
Save when you are ready: 

 

 

The file will now be saved. 

 

Creating a New File  

To create a new Power BI file, click File → New: 
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A new Power BI instance will open: 

 

 

You can now work with the file. 

 

Publishing to the Power BI Web App 

To publish your data to the Power BI web app, click File → Publish → Publish to Power BI, or 
click the Publish command on the Home tab: 
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If prompted, save your changes: 

 

 

And sign in if prompted: 

 

 

  



[33] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

Next, select a destination for the file. We will use the default “My workspace:” 

 

 

When the process is complete, you will see a notification: 

 

 

You can open the data in the Power BI web app or click “Got it” to return to the Power BI 
desktop client. We will learn more about the Power BI web app in Lesson 5. 
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Activity 1-2: Working with Power BI Desktop 
Files 
In this activity, you will open an existing Power BI file and use it to set up a new file. 

1.  Open Power BI: 

 

  

2.  Close the Start screen if it appears. Then, click File → Open: 
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3.  Navigate to your Exercise Files folder. Select Activity 1-2 and click Open: 

 

  

4.  Now, let’s save a copy of this file so we can modify it. Click File → Save As: 
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5.  Navigate to your desktop. Then, enter “<Your Name> Sample File” as the file name. 
Click Save: 

 

   

6.  Now we are ready to publish this file to the Power BI web app. Click Home → 
Publish: 
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7.  First, you will be asked to choose a destination for the file. The default location is 
fine, so click Select: 

 

 

(If you are prompted to sign in, do so.) 

   

8.  When you receive a completion notification, click the top link to see it in the web 
app: 
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9.  The Power BI web app will open and display the report. Click any of the tabs at the 
bottom to see a sample page: 

 

   

10.  Review the report page, and then close your Internet browser to complete this 
activity: 
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TOPIC C: Connecting to Data 
Sources with Power BI 
Desktop 
 

Your first step after creating a Power BI file will be to connect your data to it. We will cover 
the two most common scenarios (Excel workbooks and Access databases) and show you 
where to find additional options if you need them. We will also discuss creating a manual 
dataset and managing data sources. 

 

Topic Objectives 

In this section, you will learn: 

• How to connect to an Excel workbook or Access database 

• How to view all connection options 

• How to create a manual dataset 

• How to manage data sources 
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Connecting to an Excel Workbook 

To connect to an Excel workbook, open the target Power BI file. (Here, we are starting from 
a new file.) Click Home → Get Data arrow → Excel: 
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The Open dialog will appear. Navigate to your file, select it, and click Open: 

 

 

Next, the Navigator will appear. On the left side, check the items you want to load into the 
current Power BI data model. (You can also click any item to preview it.) Click Load when 
you are ready: 
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Your data will then be loaded. You can view it by clicking the Data icon in the navigation 
pane: 

 

You can change the table currently being displayed by clicking any item in the Fields pane 
on the left side of the window. 

 

Connecting to an Access Database 

To connect to an Access database, click Home → Get Data: 
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You will now see a list of all connection options. Click “Access database” to select it and 
then click Connect: 

 

 

Just as before, the Open dialog will appear. Navigate to your file, select it, and click Open: 
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Next, the Navigator will appear. On the left side, check the items you want to load into the 
current Power BI data model. (You can also click any item to preview it.) Click Load when 
you are ready: 

 

 

The data will now be loaded and will be accessible via Data view, just as when we imported 
an Excel workbook. 
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Viewing All Connection Options 

Let’s take a closer look at the Get Data dialog, which appears when you click Home → Get 
Data: 

 

Simply choose a source from the list on the right and click Connect to see the related 
options for specifying details about the source. On the left side, you can use the categories 
or the search field to narrow down the list on the right. 
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Creating a Manual Dataset 

If your data does not yet exist, you can create a manual dataset that will be stored within 
Power BI. To start, click Home → Enter Data: 

 

 

The Create Table window will appear: 
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To start, rename the table columns by double-clicking them. (You should also enter a table 
name in the field at the bottom of the dialog.) Then, enter your data into the table. (You can 
add more rows by pressing the down arrow key from the last row, and more columns with 
the right arrow key from the last column.) Once your data is entered, click Load to complete 
the process: 
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The table will now be added: 

 

 

Managing Data Sources 

To manage the data sources in a Power BI file, click Home → Edit Queries drop-down arrow 
→ Data source settings: 
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Here, you can view and edit the data sources currently connected to this file: 
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Activity 1-3: Connecting to Data Sources with 
Power BI Desktop 
In this activity, you will connect two data sources to a new file. 

1.  Open Power BI. A new file should be displayed. 

  

2.  First, let’s import our main sales workbook. Click Home → Get Data arrow → Excel: 
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3.  Navigate to the Lesson 1 folder of your Exercise Files. Click to select the Sales Data 
file and click Open: 

 

  

4.  The Navigator will open. Check all four worksheets on the left side: 
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5.  Click Load: 

 

   

6.  The data will be loaded (this may take a moment). When it is complete, you will 
see a summary of the operation: 

 

 

In this case, we had a few errors, which is not uncommon when importing data 
from other applications. We will learn how to manage these errors in the next 
lesson. For now, close the dialog box. 
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7.  Next, we need to import the district information, which is in an Access database. 
Click Home → Get Data: 

 

   

8.  You will now see a list of all connection options. Click “Access database” to select it 
and then click Connect: 
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9.  The Open dialog will appear, and Lesson 1 of your Exercise Files should be 
displayed. (If it is not, navigate to it now.) Click the District Directory file to select it 
and click Open: 

 

   

10.  Check the single table in this database (District List) and click Load: 
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11.  The data will be loaded. We can see it in the Fields pane, but click the Data icon in 
the navigation pane to take a closer look: 

 

  

12.  Click each of the tables to see the data they contain: 

 

  

13.  Save your file as Activity 1-3 Complete and close Power BI. 
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TOPIC D: Creating a Report 
with Visualizations 
 

Now that we understand how to use Power BI and connect data to it, it is time for the fun 
part: creating a report with visualizations. Visualizations are simply graphics that represent 
data from one or more sources connected to a Power BI file.  

 

Topic Objectives 

In this topic, you will learn how to: 

• Use the Visualizations and Fields task panes 

• Create, move, and resize visualizations 

• Interact with visualizations 

• Change the visualization type 
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Using the Visualizations Pane 

First, let’s look at the task panes you will use when creating a visualization. The first task 
pane is Visualizations: 

 

 

The top of the task pane (1) shows both the name and an arrow to collapse or expand it. 
Next, there is a gallery (2) of available visualizations. (Click the ellipses to see options to 
manage visualizations.)   

The tabs (3) in the middle of the pane control what tools appear in the bottom part. Here, 
you can see the Fields and Format icons, respectively. Depending on the visualization you 
are working with, you may also see an Analytics icon. 

In the bottom of the pane, you will see commands related to the selected tab. Here, we 
have focused on the Fields and Filter commands, since we will explore the Format tab in the 
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next topic. These commands allow you to specify data to be displayed in the visualization 
(4) and filtering options (5), and will differ depending on the visualization selected.  

 

Using the Fields Pane 

The second task pane is Fields: 

 

 

Just like the Visualizations pane, at the top (1) you will see the task pane name and an 
arrow that allows you to collapse it. Below this is a search field (2). Entering a term here will 
show matching terms in the bottom part of the pane (the field display list). 

By default, the field display list will group items by table, query, or a custom hierarchy. You 
can use the arrows to expand (3) or collapse (4) these lists. When a group is expanded, you 
will see the individual data fields (5). 
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Creating a Visualization 

To create a visualization, click the related icon in the Visualizations pane: 

 

 

We want to see the number of stores in each territory, so we have chosen Map, which will 
show the value for each location as a bubble of relative size.  

Once you click an icon, a placeholder will appear for that visualization. Now, we can add 
data to it by dragging and dropping items from the Fields pane. First, let’s expand the Store 
category so we can see all the fields: 
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Next, we will click and drag the Territory field to the Location well: 

 

 

The map will populate with this data, showing where the territories are. Now, let’s drag the 
Total Stores field to the Size well: 
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We can now see the total stores by territory, with each data point (number of stores) 
represented as a bubble: 

 

We can easily see that North Carolina has the largest number of stores, while Kentucky and 
Delaware have the fewest.  

 

Interacting with Visualizations 

You can hover over different parts of a visualization to see more information. For example, 
in the visual we created earlier, we can hover over any bubble to see the name of the 
territory and the total stores: 
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You can also add fields to the Tooltips well to display their data here. For example, here we 
have added the New Stores field, so we can see also how many of the total stores are new 
stores: 

 

 

We can use the mouse or keyboard to move around the map. The plus and minus keys (or 
the scroll wheel on the mouse) allow you to scroll in or out to see a larger or smaller area: 
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If there is more than one visualization on a page, they will act as a filter on each other. For 
example, this report shows an overview of store sales. If we only want to see the values for 
Lindseys, we can click that item from the pie chart: 

  

 

Now, the other visualizations will update and show only the data related to the Lindseys 
chain: 

  

To return to the overall view, click the filtered item again.  
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You can also use the Filters section of the Visualizations pane to customize the data: 

 

 

Changing the Visualization Type 

You can change the visualization type by clicking another icon in the Visualizations task 
pane:  
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The change will be applied, and Power BI will keep the same data fields where possible: 

 

 

If you do not like the new visualization, use the Undo command on the Quick Access 
toolbar, or click the previous visualization icon in the Visualizations task pane.  
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Moving and Resizing Visualizations  

To move a visualization, click and drag it by its title bar to the desired location: 

 

 

If you click the visualization’s border to select it, you will see handles around its edges: 
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Click and drag these handles to change the visualization’s size:  
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Activity 1-4: Creating a Report with 
Visualizations 
In this activity, we will continue working with our retail report and add some visualizations. 
Note that we have included a more comprehensive data set than what was previously 
imported, for illustration purposes.  

1.  Open Power BI and open Activity 1-4: 

 

  

2.  Ensure Page 1 is displayed, providing a blank canvas: 

 

 

(If it is not displayed, click its tab at the bottom of the screen.) 
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3.  We want to create two visualizations that show a revenue breakdown by both 
division and state. A treemap might be a good way to show the breakdown by 
division, so click the Treemap icon in the Visualizations pane: 

 

  

4.  A treemap placeholder will be added. We want to see the total revenue value, so 
expand the Fact category and find the Total Revenue field: 
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5.  Drag it to the Values well in the Visualizations pane: 

 

  

6.  The visualization will start to populate: 
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7.  Since we want to see a breakdown by division, let’s search for that field: 

 

   

8.  Next, click and drag the bottom result to the Group well in the Visualizations pane: 

 



[72] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

9.  The visualization will now show total revenue by division: 

 

   

10.  We also want to see total revenue by state. Ensure the visualization is selected 
(showing a border around it). Then, click Home → Copy: 
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11.  Click Home → Paste: 

 

  

12.  A copy of the visual will appear on top of the original. Click its title bar and drag it 
to the right side of the canvas: 

 

  



[74] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

13.  Now we can change the breakdown to state, instead of division. Click the X next to 
the Division field in the Visualizations pane to remove it: 

 

  

14.  Now, search for “state” in the Fields pane: 
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15.  Drag the State field from the State group to the Group well in the Visualizations 
pane: 

 

  

16.  The total revenue by state will now be shown: 

 



[76] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

17.  A map visualization might be better for this data. Click the “Filled map” icon in the 
Visualizations pane: 

 

  

18.  The visualization will update: 
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19.  Click and drag the visualization’s bottom left handle down and to the left to make 
it larger: 

 

  

20.  Save your work as Activity 1-4 Complete to finish this activity. 
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TOPIC E: Doing More with 
Visualizations 
In the last topic, we explored how to create a report with a visualization. In this topic, we 
will take a closer look at some of the viewing and formatting options available when 
working with visualizations.  

 

Topic Objectives 

In this section, you will learn how to: 

• Format visualizations 

• View visualization data 

• Use Focus Mode and Spotlight 

• Remove a visualization  
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Formatting Visualizations  

To format a visualization, click the Format tab in the Visualizations task pane: 
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The options in the bottom part of the pane will change, and will be slightly different for 
each visualization: 
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Note that if you open this pane without anything selected, you will see options to modify 
the page itself: 
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In either situation, you can click a category to expand it, and then use the related controls 
to modify the selected visualization. For example, let’s say we want to add a border to our 
map. We will start by clicking the Border category to expand it: 

 

 

After toggling this feature to On, we can click the color picker and choose a color: 

 

(Note the “Revert to default” link. This option is available in most formatting categories and 
is very useful for resetting a visualization to its default appearance.) 
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Here is what our visualization looks like with the new border: 
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Viewing Visualization Data 

Although we can see what fields are displayed in a visualization via the Fields section of the 
Visualizations pane, it does not show the specific data. To see the data, move your mouse 
over the visualization, click the ellipses in the top right corner (called the “More options” 
menu), and click Show Data: 
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You can now see a table of the related data at the bottom of the window: 

 

 

When you are finished, click “Back to Report” to close this view. 
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Using Focus Mode and Spotlight 

There are two additional tools that you can use to focus on a visualization. The first is Focus 
Mode, accessible by moving your mouse over the visualization and clicking the icon next to 
the “More options” menu: 
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This will show the visualization in a full-screen style: 

 

Just as when viewing visualization data, you can click “Back to Report” to return to the 
regular canvas view. 
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Spotlight is accessed from the “More options” menu: 

 

 

This dims the rest of the report, putting the focus on the selected visualization: 

 

Click the Spotlight command again or press Esc on your keyboard to return to regular view. 
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Removing a Visualization  

To remove a visualization, click the ellipses and click Remove: 

 

 

The visualization will be removed from the page. This does not affect the underlying data in 
any way. 
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Activity 1-5: Doing More with Visualizations 
In this activity, you will continue working with your map visualization. 

1.  Open Power BI and open Activity 1-5: 

 

  

2.  First, let’s view the data for the map to confirm it is correct. Move your mouse over 
the visualization and click the ellipses to open the “More options” menu: 
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3.  Click Show Data: 

 

  

4.  Review the data at the bottom of the screen. Then, click “Back to Report:” 
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5.  Now, let’s change the map’s colors. Click the Format tab in the Visualizations task 
pane: 

  

   

6.  Click the “Data colors” category to expand it: 
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7.  Click the Minimum color picker: 

 

   

8.  Choose a light shade of red: 
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9.  The map will now show lower values in red, and higher values in green: 

 

   

10.  Now, let’s place a focus on this visualization. Click the “More options” menu and 
click Spotlight: 
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11.  The effect will be applied: 

 

  

12.  Save your work as Activity 1-5 Complete to finish this activity. 
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Summary 
In this lesson, you learned the basics of working with Power BI. We learned how to use the 
interface, work with Power BI files, connect to data sources, create a report, and create 
visualizations.  

 

Review Questions 
 

 What are the six building blocks of Power BI? 

 

 How do you connect to an Excel workbook from Power BI? 

 

 What are the two task panes used when creating a visualization? 

 

 How do you see the data related to a visualization? 

 

 True or False: Removing a visualization also removes the related data. 
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LESSON 2: 
WORKING WITH DATA 

 

 

Lesson Objectives 

 

In this lesson you will learn how to: 

• Transform and sanitize data 

• Use the Query Editor 

• Model data 

• Manage relationships 
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TOPIC A: Transforming and 
Sanitizing Data 
 

In the last lesson, we learned how to import a data source and create visualizations from it. 
However, we also saw that sometimes data will not import correctly. You may also need to 
clean up (sanitize) data or modify it in order to be of the most value in Power BI. 

 

Topic Objectives 

In this section, you will learn how to: 

• Use Data view 

• Clean irregularly formatted data 

• Manage columns 

• Sort table data 
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Using Data View 

To access Data view, click the second icon in the navigation pane: 

 

 

On the right side, you will see the Fields task pane (1), which we saw in the last lesson. The 
selected table will be displayed in the main window (2). At the top, the expression editor 
(3) is where you will enter functions, and the status bar (4) shows the current table name 
and the number of rows. 
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Cleaning Irregularly Formatted Data 

To clean up table data, start by selecting the desired column: 

 

 

Next, use the appropriate tools on the Modeling tab: 

 

 

Here, you can set the data type, format, category, and summarization.  
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In this example, the Data Category is not set. Let’s set it to Country/Region: 

 

 

Now, Power BI knows how to best use this data – for example, we could now create a map 
visualization from it. 
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Here is another example. The Date column in this table also includes the time, which is 
unnecessary. We can change the data type to just date: 

 

 

(All of the data will be retained; it will simply not be displayed.) 
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We can also simplify the date format: 

 

 

This makes the date much easier to read: 
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Managing Columns  

You can also choose to show or hide fields or even entire tables from Report view. Simply 
right-click the item in the Fields pane and select “Hide in Report View:” 

 

 

(You can also right-click columns in Data view to access this option.) Notice that you can 
also delete or rename columns and tables from this right-click menu. To display a hidden 
field, de-select the “Hide in Report View” option. 

  



[105] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

Sorting Table Data 

When viewing table data, you can choose what column is sorted by using the “Sort by 
column” menu: 

 

 

You can also right-click any column header and choose an ascending or descending sort. 
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Activity 2-1: Transforming and Sanitizing 
Data 
In this activity, you will begin working with a retail data set. 

1.  Open Power BI and open Activity 2-1: 

 

  

2.  Click the Data view icon in the navigation pane: 
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3.  First, let’s hide tables that are for reference purposes only (meaning we will not 
use them to create reports or visualizations). Right-click the Order Details Status 
table and click “Hide in Report View:’’ 

 

  

4.  Notice that the table name is now gray, meaning it is hidden from Report View. 
Repeat Step 4 for the Orders Status table: 
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5.  Next, let’s review the data and see where we can sanitize it to make it easier to 
work with. We will start with the Customers table. Click the first entry in the Fields 
task pane to see this table (if it is not already displayed): 

 

   

6.  You can see that the Home Phone field is empty in all rows. Right-click it and click 
Delete: 
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7.  When you are prompted to confirm the operation, click Delete: 

 

   

8.  Next, click the Modeling tab: 

 

   

9.  Click the Address column. Confirm that the Data Category menu entry matches the 
column name: 
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10.  Repeat for the remaining columns to the right. All columns should be correct 
except Web Page. Choose the correct categorization for this column: 

 

  

11.  Finally, let’s sort by customer last name instead of company name. Right-click this 
column and click Sort Ascending: 
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12.  The change will be implemented: 

 

  

13.  Save your work as Activity 2-1 Complete and close Power BI. 
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TOPIC B: Using the Query 
Editor  
 

If you have more advanced data transformation requirements, you can use Power BI’s 
Query Editor. Here, you can transform data in bulk, perform merge and append operations, 
and much more. 

 

Topic Objectives 

In this section, you will learn how to: 

• Open the Query Editor 

• Use the Query Editor interface, including the Query Settings pane 

• Use Merge and Append queries 
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Opening the Query Editor 

To open the Query Editor, click Home → Edit Queries: 

 

 

The Query Editor Interface 

When the Query Editor opens, you will see the following interface: 

 

On the left (1), you will see a list of queries, with the data displayed in the center pane. Its 
settings can then be modified using the commands on the ribbon (2). These settings are 
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listed in the Query Settings pane (3), which we will take a closer look at in a moment. Once 
you have finished making your changes, click Home→ Close & Apply (4). (You can also click 
the drop-down arrow to apply your changes and stay in the window or close the window 
without applying your changes.) 

 

Using the Query Settings Pane 

Let’s take a closer look at the Query Settings pane: 

 

 

The Properties section of the Query Settings pane shows the name of the current item and 
a link to view all its properties. Then, the Applied Steps section shows each action. You can 
click the cog icon on the right of an action to see the settings or move your mouse over the 
item to make the X available (which will undo this action). 
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You can also right-click any action to see more options: 

 

 

Using Merge Queries 

Just as in Microsoft Access, merge queries will join two tables together. In this example, we 
want to merge the two Orders Status tables together: 
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To start, we will select the Orders Status table (which we want to keep) and click Home → 
Merge Queries: 

 

 

The Merge dialog will open. You will see the current table at the top. We can now select the 
table to be merged with it: 
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Now, click the column which will be matched from both tables: 
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Finally, change the type of join (if necessary – Left Outer will be selected by default) and 
click OK: 

 

 

The merge will now be completed: 
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Using Append Queries  

An Append query works a bit differently – it adds one data source into another, while 
keeping the original data. In this example, we want to append our Manual Orders table to 
the Orders table: 

 

 

To start, we will select the primary table (Orders) and click Home → Append Queries: 

 

 

Now, the Append dialog box will open. You can choose to append two tables together, or 
three or more. For this example, we only have two tables, so we can choose the Manual 
Orders table and then click OK: 
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The data will now be appended: 
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Activity 2-2: Using the Query Editor 
In this activity, you will use the Query Editor to modify and append data. 

1.  Open Power BI and open Activity 2-2: 

 

  

2.  Click Home → Edit Queries: 

 

  

3.  First, let’s append new data to the Customers table. Click the Customers entry on 
the left side of the window: 
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4.  Note the current table size in the status bar: 

 

  

5.  Click Home → Append Queries: 
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6.  The Append dialog box will open. Click the “Table to append” menu and click New 
Customers: 

 

   

7.  Click OK to complete the operation: 
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8.  The data will be appended. Note the action item in the Applied Steps portion of 
the Query Settings pane: 

 

   



[125] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

9.  You can see that the Web Page and Notes columns are empty for both the existing 
and new data. Hold the Ctrl key and click both columns to select them: 

 

   

10.  Click Home → Remove Columns: 
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11.  The action will now appear in the Query Settings pane: 

 

  

12.  On second thought, we may need those columns. Click this entry and click the X to 
undo the action: 
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13.  Click Home → Close & Apply to apply your changes and return to Power BI: 

 

  

14.  Once the operation is complete, save your work as Activity 2-2 Complete and close 
Power BI. 
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TOPIC C: Data Modeling 
 

In addition to basic data management tools, Power BI also includes the ability to create 
tables, calculated columns, and measures. It is also important to know that Power BI uses 
DAX (Data Analysis Expression) as its formula language. 

 

Topic Objectives 

In this topic, you will learn: 

• About DAX 

• How to create tables, calculated columns, and measures 
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What is DAX? 

DAX (Data Analysis Expression) is a type of formula language used to create custom 
calculations and measures. It is designed to work based on data relationships, referring to 
tables and columns to provide relational analysis and more complex functions than 
traditional formulas. 

 

Creating a New Table 

To create a new table that returns specified values from the dataset, click Modeling → New 
Table: 

 

 

The expression editor will now become active. Replace the word “Table” with the name of 
the new table: 
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Now, you can type the DAX function. We are going to use the VALUES function to return a 
list of distinct values. As we start typing, Power BI will try to automatically complete the 
function. Press Enter to select the highlighted function, or if there is more than one function 
listed, use the arrow keys to select a different item: 

 

 

Once this function has been entered, we can choose the table and field it will apply to: 

 

 

We can now add the closing bracket and press Enter or click the checkmark to create the 
function: 
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The table will now be created:  

 

 

You can continue to add more columns to this table. It can also be uses it in visualizations 
and reports like any other dataset. 

 
Creating a New Calculated Column 

To create a new table column that returns a particular set of values from your data, open 
the table, choose the column you want the new column to be placed after, and click 
Modeling → New Column: 
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Just as when we were creating a table, the column will be created using the expression 
editor with a DAX function. We are going to create a new column that displays the value in 
the Period column as the proper month name. 

We will start by changing the placeholder “Column” text to “MonthName:” 

 

 

Next, we will add the FORMAT function: 
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Now, we will choose the Date field from the current table: 

 

 

And enter “MMM” as we want a three-letter month: 
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After adding the closing parenthesis and pressing Enter, our new column will be created: 

 

 

Creating a New Measure 

A measure is a formula that shows a value calculated from specified data. When you create 
a new measure, it will be stored within whichever table is currently active. Although it does 
not really matter where the measure is stored, we recommend storing it with the related 
table so you can find it later if needed. 
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To start, select the active table and click the New Measure command on the Home or 
Modeling tab: 

 

 

Now, enter the name of the measure, enter the function, and choose the data: 

 

 

In this case, we have created a measure called “Var Plan,” which will show the variance 
between the actual data and the planned data. 
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We can now use this measure to create a simple visualization showing the variance by 
month: 
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Activity 2-3: Data Modeling 
Your sales team has asked you to help them answer three questions about your 
organization’s retail data. In this activity, you will answer these questions using data 
modeling tools. 

1.  Open Power BI and open Activity 2-3: 

 

  

2.  The first question the sales team has is how to easily see which orders are past 
due. (Invoices are always due at the end of the quarter in which they were issued.) 
Let’s use a calculated column for this purpose. To begin, switch to Data view: 
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3.  Since we want to work with invoice data, select that table from the Fields pane: 

 

  

4.  Now, click Home → New Column: 
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5.  The new column will be created, ready to accept the expression that will define its 
data: 

 

  

6.  Replace the word “Column” with “InvoiceDue:” 
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7.  Now, we want to return the end of the quarter date, based on the value of another 
column. Type the letter “E” and then double-click the “ENDOFQUARTER” function 
from the list: 

 

  

8.  Now we can choose what data this value should be based on. Type “Inv” and then 
double-click the “Invoice Date” field from the Invoices table: 

 

  

9.  Double-click “Date” to return a full date:  
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10.  Add a closing bracket, double-check the expression, and press Enter: 

 

  

11.  The InvoiceDue column will now be created. It will return the end date of each 
quarter based on the Invoice Date field: 

 

  

12.  The next question comes from the sales manager, who wants to restructure the 
districts and would like a list of where current customers are located. This will 
require a new table, so click Modeling → New Table: 
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13.  The new table will be created. Enter “District Summary” as the table name: 

 

  

14.  We want to return unique values from the State/Province field of the Customers 
table. This means we will use the VALUES function: 

 

  

15.  Type an opening bracket. A field list will then appear. Scroll down slightly and 
double-click the State/Province field from the Customers table: 
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16.  Close the bracket and press Enter: 

 

  

17.  The table will now be created: 
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18.  Finally, the team wants to know the total unit price from all sales (excluding taxes 
and shipping). To do this, we will create a measure and then display it as a 
visualization. Let’s place it in the Order Details table, which contains the unit price 
values. Click this table to select it: 

 

   

19.  Now, click New Measure on either the Home or Modeling tabs: 

 

   

20.  Name the new measure “TotalOrderValue:” 
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21.  Type SUM for the function: 

 

  

22.  Type a bracket, type the letter “O,” and double-click the Unit Price field in the 
Order Details table: 

 

  

23.  Type a closing bracket and then press Enter to complete the measure: 
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24.  Now, let’s display this new measure as a visualization. Switch back to Report view: 

 

  

25.  Click the Card visualization from the Visualizations pane: 
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26.  Check the new TotalOrderValue measure: 

 

  

27.  The total will be displayed: 

 

  

28.  Save your work as Activity 2-3 Complete and close Power BI. 
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TOPIC D: Managing 
Relationships 
 

Just as in Access, relationships define how the tables and fields in your database relate to 
each other. Once these relationships have been defined, reports and visualizations will be 
able to draw information from all of them just as if they were one large dataset. 

 

Topic Objectives 

In this section, you will learn how to: 

• Use the Relationships view 

• Create, edit, and delete relationships 

• Use the Manage Relationships dialog 
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Using the Relationships View 

To access Relationships view, click the third icon in the navigation pane: 

 

 

You will then see a view of all the tables and fields in the current data sources, and how 
they are linked: 
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Creating Relationships 

To create a relationship between two fields, drag one field to the other. Here, we are linking 
two Employee ID fields: 
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The relationship will then be created, as indicated by a white arrow: 

 

 

As in Access, the direction of the arrow and the symbols on it provide more information 
about the relationship.  

 

Editing Relationships 

To edit a relationship, double-click it: 
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The “Edit relationship” dialog will open: 

 

 

Here, you can specify the tables (1) and fields (2) that are related. At the bottom, you can 
set options (3) like cardinality. Click OK when you are finished editing the relationship to 
apply the changes.  
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Deleting Relationships 

To delete a relationship, right-click it and click Delete: 

 

 

Then, click Delete to confirm the operation: 

 

 

Always be very careful when deleting relationships, as they may adversely affect the 
integrity of your data, and therefore your ability to build visualizations! 
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Using the Manage Relationships Dialog 

You can quickly access the Manage Relationships dialog from the Home tab in any view: 

 

 

This dialog allows you to create, manage, view, and edit relationships: 

 

 

There is also a command here to automatically detect and build relationships – useful if you 
have imported several different data sources that are not yet related. 
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Activity 2-4: Managing Relationships 
In this activity, we will review and update the relationships in our sample file. 

1.  Open Power BI and open Activity 2-4: 

 

  

2.  Click the Relationships icon in the navigation pane: 
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3.  Review the relationships in this data file. You can see that the New Customers 
table, which we appended to the Customers table earlier in this lesson, was 
erroneously linked to the Employees table: 
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4.  Right-click the relationship line and click Delete: 

 

  

5.  Click Delete to confirm the operation: 
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6.  We can also see that the Customers table is not linked to the Orders table. Click 
and drag the Order ID field from the former table to the latter: 
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7.  The relationship will be created. Double-click the line to see its details: 
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8.  Review the cardinality options and confirm that the relationship type is set 
correctly. (Many orders can belong to one customer.) Click OK to close the dialog 
box: 

 

   

9.  Let’s do a final check to make sure all relationships are configured correctly. Click 
Home → Manage Relationships: 
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10.  The Manage Relationships dialog box will open. Click Autodetect: 

 

  

11.  Power BI should detect two new relationships. Click Close when you see the 
notification: 
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12.  Review the two new relationships added. Close the dialog box: 

 

  

13.  Save your work as Activity 2-4 Complete and close Power BI. 
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Summary 
In this lesson, we learned how to prepare data before creating visualizations. You should 
now be familiar with transforming and sanitizing data using Data view and the Query Editor. 
You should also be familiar with data modeling using DAX and managing relationships. 

 

Review Questions 
 

 What is DAX? 

 

 Where should a measure be stored? 

 

 Which tab contains commands to set the data type, format, category, and 
summarization? 

 

 How do you create a relationship between two fields in Relationships view? 

 

 How do you open the Query Editor? 
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LESSON 3: WORKING WITH 
REPORTS AND VISUALIZATIONS 

 

 

Lesson Objectives 

 

In this lesson you will learn how to: 

• Manage report pages 

• Change report view options 

• Work with visualizations and their data 

• Add static objects to a report 
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TOPIC A: Managing Report 
Pages 
 

In this lesson, we will turn our focus back to Report view. You can add multiple pages to a 
report, and add, delete, and modify them as required. 

 

Topic Objectives 

In this topic, you will learn how to: 

• Navigate through report pages 

• Show and hide pages 

• Add, delete, and rename pages 

• Change page order 
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Navigating Through Pages 

To view a different report page, simply click its tab at the bottom of Report view: 

 

 

Its contents will then be displayed.  
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Showing and Hiding Pages 

To temporarily hide a page, right-click its tab and click Hide Page: 

 

 

The page tab will then be grayed out. You can show it again by right-clicking the page tab 
again and de-selecting Hide Page: 

 



[168] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

Adding Pages 

There are two ways to add a new page. You can create a duplicate of the current page from 
the right-click menu: 

 

 

Or, you can create a blank page using the plus sign at the end of the page tab list: 
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Deleting Pages 

To permanently delete a page, move your mouse over the page tab and click the X: 
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You can also delete a page from the right-click menu: 

 

 

In either case, you will be prompted to click Delete to confirm the operation: 
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Renaming Pages 

The final command on the right-click menu is Rename Page: 

 

 

This command will change the page tab name into an editable field. Simply type the new 
name and press Enter to apply it: 

   

 

Changing Page Order 

Finally, to change the order of pages, simply click and drag the tab: 

 

Release your cursor when you have reached the desired location. 
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Activity 3-1: Managing Report Pages 
In this activity, we will set up the report that will be used throughout this lesson. 

1.  Open Power BI and open Activity 3-1: 

 

  

2.  The Info page should be displayed by default. This is important information but 
does not need to be displayed to our report users. Right-click the page tab and 
click Hide Page: 
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3.  Click the Page 1 tab to view it: 

 

  

4.  There are two different visualizations on this page. Let’s create a separate page for 
each of them. First, let’s set up the pages. Right-click the Page 1 tab and click 
Rename Page: 

 

  

5.  Type, “Report by Division” in the field and press Enter: 
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6.  Now, click the plus sign to create a new page: 

 

   

7.  Right-click this new tab and click Rename Page: 

 

   

8.  Type, “Report by State” in the field and press Enter: 
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9.  Now, go back to the Report by Division page by clicking its tab. Click the border of 
the map visualization to select it and click Home → Cut: 

 

   

10.  Go back to the Report by State tab. Click Home → Paste: 
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11.  The visualization will now be moved onto the new page: 

 

  

12.  Finally, let’s move the Info page to the end of the page tab list. Click and drag the 
page tab to its new position: 

 

  

13.  Save your work as Activity 3-1 Complete and close Power BI. 
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TOPIC B: Changing Report 
View Options  
 

One tab we have not yet explored is the View tab. Here, you can change the view and layout 
of the current report.  

 

Topic Objectives 

In this section, you will learn: 

• How to set page view options 

• How to customize your view 

• About phone and desktop layout 
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Setting Page View Options 

To set page view options, click Home → Page View: 

 

 

This menu allows you to fit the current canvas to the page, the screen width, or to its actual 
size. 

 

Customizing Your View 

Next, let’s look at the Show group on the View tab: 

 

 

The three options on the left allow you to customize the canvas and its objects, allowing 
you to show gridlines, turn on snap, and lock the objects on the current page. 
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The Field Properties option allows you to show or hide the related task pane, where you can 
customize the field name and description: 

 

 

The Selection Pane option will also show a task pane: 

 

 

Here, you can select objects by clicking them from the task pane. You can also show, hide, 
and change the order of objects. 
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Using Phone vs. Desktop Layout 

So far, we have been using desktop layout, which is the standard view for the Power BI 
desktop client. This presents the report in a standard landscape-style format: 

 

 

However, if you are designing reports that will be used in Power BI mobile apps, you may 
want to add a mobile view. To start, click View → Phone Layout: 

 

You will now see a blank, scrollable canvas in the shape of a smartphone, with the existing 
visualizations listed in a pane on the right: 
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Click and drag the visualizations to the canvas to add them. You can also size and place 
them as desired: 

 

 

(You cannot create new visualizations in this view.) When you are finished, click Desktop 
Layout on the View tab to return to the full interface.  
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Now, when users access this report on a smartphone, they will see the phone layout instead 
of the desktop layout. 
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Activity 3-2: Changing Report View Options  
In this activity, we will create a smartphone view for one of our reports, and modify our 
view options. 

1.  Open Power BI and open Activity 3-2: 

 

  

2.  Ensure the “Report by Division” page is selected, as this is the report we want to 
create the smartphone view for. Click View → Phone Layout: 
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3.  The new view will be displayed, with a blank layout in the canvas area and the 
visualizations to the right: 

 

  

4.  Now, drag the chart onto the smartphone canvas, lining it up as shown here: 
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5.  If necessary, click the visualization to select it. Then, drag the bottom right handle 
down and to the right to make it slightly larger, as shown here: 

 

   

6.  Return to desktop layout using the View tab: 
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7.  Notice that our original report has not changed. However, it could use some layout 
improvements. Check the “Show Gridlines” and “Snap Objects to Grid” options on 
the View tab: 

 

   

8.  Click and drag the visualization to the position shown here: 
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9.  Now, resize the visualization to the dimensions shown here: 

 

  

10.  Save your work as Activity 3-2 Complete and close Power BI. 
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TOPIC C: Working with 
Visualizations  
 

Next, we are going to take a closer look at working with visualization data. This is the 
biggest strength of Power BI: the ability to quickly and easily view your data in different 
ways. 

 

Topic Objectives 

In this section, you will learn how to: 

• Drill through data 

• Change category and summarization options 

• Arrange visualizations  

• Edit interactions 

• Add custom visualizations to Power BI  
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Understanding Drillthrough Options 

When a report has time data, Power BI automatically breaks it down by time period. For 
example, this dataset originally had only the ReportingPeriodID field, but Power BI broke it 
down into the remaining components: 

 

 

This breakdown can then be used to drill through data in different ways using either the 
visualization itself or the Visual Tools – Data/Drill tab: 

 

 

The single arrows allow you to move through a single hierarchy of data, while the double 
arrows allow you to move through multiple hierarchies (if available – otherwise they will 
navigate through the single hierarchy). 
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For example, if we drill all the way through the data, we will see a total for the fiscal year: 

 

 

Notice that the visualization title has updated, too. 

 

Changing Category and Summarization Options 

Earlier, we looked at setting the category and summarization options when working with 
raw data in Data view. You can also change these options on the fly from the Modeling tab 
while in Report view: 
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You can also right-click field(s) in the Value well of the Visualizations pane and customize 
how to show it: 

 

 

Arranging Visualizations 

So far, we have been working with the Visual Tools – Data/Drill tab. Let’s look at the Format 
tab; specifically, the Arrange group: 
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If you have worked with graphics in other Office applications, these commands work in a 
similar way. For example, if we want to left-align these two text cards, we can hold Ctrl, 
click each of them to select them, and then click Align → Align left: 

 

 

The cards’ left borders will now be aligned: 
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Editing Interactions 

The Interactions group of the Visual Tools – Format tab controls how visualizations affect 
each other: 

 

 

If you have a visualization with drilldown options, you can uncheck the “Drilling filters other 
visuals” option so that it does not affect the other visuals.  

To customize how visualizations interact with each other, select the target visualization and 
click the “Edit interactions” command. This will show additional options on each 
visualization: 
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(Note that the selected visual, the pie chart in the top left, does not have these options. This 
indicates that we are modifying its interaction with the other visualizations.) 

The highlighted icon on each item indicates what type of interaction it has with the selected 
visualization. Typically, you can choose Filtering or None, but these options may vary by 
visualization. (For example, the chart has a Highlight icon.) Simply click the icon that defines 
how you want the selected visualization to interact with it. Here, we are turning filtering off 
in the Total Sales Variance chart: 

 

 

When you have finished setting your options, click “Edit interactions” on the Visual Tools – 
Format tab to return to normal view. 
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About Custom Visualizations  

If you have custom visualizations available through your organization, or need a custom 
visualization from the Microsoft Store, you can access them through the Home tab or the 
ellipses in the Visualizations pane: 

 

 

Simply choose your source, and then browse for the desired visual. It will then be available 
in the Visualizations pane just like the default visualization options. 
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Activity 3-3: Working with Visualizations 
In this activity, we will adjust the position of a visualization, add drilldown options to it, and 
customize its interactions. 

1.  Open Power BI and open Activity 3-3: 

 

  

2.  The “Report by Division” page should be displayed. (If not, click its tab to view it.) 
Notice that we have added a pie chart to this page that displays the number of 
customers. We have also turned off the canvas gridlines: 
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3.  First, let’s align these two objects. Hold the Ctrl key and click each visualization: 

 

  

4.  Click Visual Tools – Format → Align → Align middle: 
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5.  The objects will now be aligned at their middle point. Click the bar chart to select 
it: 

 

   

6.  Now, let’s add a time value to the chart. This will add more meaning to the data 
and provide drilldown options. In the Fields pane, expand the Date table and check 
the YQM data hierarchy to add it to the chart: 
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7.  Drilldown options will now appear on the chart. We want our other chart to 
remain static while drilling down, however, so click Visual Tools – Format and 
ensure the “Drilling filters other visuals” option is unchecked: 

 

   

8.  Right now, we are seeing the total revenue by division. Let’s drill down a level, to 
see the revenue by year. Click the double down arrow to do this: 
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9.  Drill down once more to see the revenue by quarter: 

 

   

10.  Review the data. Then, click the up arrow twice to return to the original view: 

 

  

11.  Save your work as Activity 3-3 Complete and close Power BI. 
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TOPIC D: Adding Static Objects 
to a Report 
 

To wrap up this lesson, we will look at some of the static objects you can add to a report, 
such as shapes, images, and text boxes. We will also take a quick look at working with static 
objects and arranging them on the page. 

 

Topic Objectives 

In this section, you will learn how to: 

• Insert pictures, text boxes, and shapes 

• Work with static objects 
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Inserting Pictures 

To add a picture to a report, click Home → Image: 

 

Then, navigate to the file, click to select it, and click Open: 
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The image will then be added to the page: 

 

 

Inserting Text Boxes 

To add a static text box to a page, click Home → Text box: 
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The text box will be inserted and selected: 

  

 

Simply type your text, and use the mini toolbar to format it as necessary: 
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Inserting Shapes 

The last option we will look at is drawing a shape. Click Home → Shapes and choose the 
shape you want to add: 

 

 

It will be added to the page, and can be moved and resized as desired: 
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Working with Static Objects 

You can manage static objects just like visualizations. For example, use the handles to resize 
an object: 

 

 

Click and drag it to move it: 
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Click the “More options” icon to see options to remove or spotlight it: 

 

 

You can also use the Visual Tools – Format tab to arrange and distribute objects: 
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Activity 3-4: Adding Static Objects to a 
Report 
In this activity, we will add a picture and a text box to the report we have been working on. 

1.  Open Power BI and open Activity 3-4: 

 

  

2.  The “Report by Division” page should be displayed. (If not, click its tab to view it.) 
Click Home → Text box: 
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3.  The text box will be inserted. Click and drag the bottom right handle up and to the 
right to create a rectangle of approximately the size shown here: 

 

  

4.  Now, click and drag the text box, and move it to the position shown here: 

 

(It should snap into place.) 



[210] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

5.  Click inside the text box and type, “Report by Division:” 

 

   

6.  Select the text. Use the mini toolbar to increase the size to 28: 
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7.  Add a bold effect: 

 

   

8.  The title is now complete: 
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9.  Click outside the text box to de-select it. Now, let’s add an image. Click Home → 
Image: 

 

  

10.  The Open dialog will appear. Navigate to your Exercise Files, open the Lesson 3 
folder, select the Report Image file, and click Open: 
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11.  The image will be inserted. Click and drag it to the top left corner of the canvas: 

 

  

12.  Click and drag the bottom right handle down and to the right to make it the same 
size as the canvas: 
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13.  Now, let’s place the picture in the background. Click Visual Tools – Format → Send 
backward → Send to back: 

 

  

14.  The report background is now complete: 

 

  

15.  Save your work as Activity 3-4 Complete and close Power BI. 
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Summary 
In this lesson, we learned more about reports and visualizations. You should now feel ready 
to set up report pages and view options, work with visualizations, and add static objects. 

 

Review Questions 
 You have hidden a page in your report showing next year’s budget. You are now 

ready to share it with others. How do you show it? 

 

 True or False: Always duplicate a page when creating a phone layout so the desktop 
layout is not lost. 

 

 You have a chart with drilldown enabled, but you do not want the other 
visualizations on the page to change when the user is drilling through the data. 
Where do you set this option? 

 

 How do you add a local picture to a report page? 

 

 How do you add an online picture to a report page? 
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LESSON 4: A CLOSER LOOK AT 
VISUALIZATIONS 

 

 

Lesson Objectives 

 

In this lesson you will learn how to create and manage the following types of visualizations: 

• Matrixes 

• Tables 

• Charts 

• Maps 

• Gauges 

• Cards 

• KPIs 

• Slicers 
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TOPIC A: Matrixes, Tables, and 
Charts 
 

In this lesson, we will take a closer look at some of the visualizations available in Power BI. 
To begin, we will explore matrices, tables, and charts. 

 

Topic Objectives 

In this topic, you will learn how to: 

• Create matrix, table, and chart visualizations  
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Creating a Table 

First, let’s look at creating a basic table: 
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Once we add the visualization, we can choose the fields to display by checking them in the 
Fields task pane. This will automatically add them to the Values well, which is the only well 
available for tables: 

 

 

Note, however, that you can add filters to customize table display.   
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For example, here we have added the TotalSales field to the table: 

 

 

We can then add the FiscalMonth field to the “Page level filters” area:  
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And then choose the month to see data for: 

 

 

(If we want the filter to be available for other visualizations on this page, we could add the 
filter to the “Page level filters” area. Or, add it to the “Report level filters” area to make it 
available across all pages.) 
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To clear the filter, click the eraser icon at the top of the list: 

 

 

Creating a Matrix 

A matrix is similar to a table but has additional flexibility and displays data in a crosstab-
style view. Its icon is next to the Table icon in the Visualizations pane: 
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Let’s add the same fields to the matrix that we used for the table: 

 

 

We can see sales by business unit, separated by district, with a total for each. Drilldown 
options are also available as each business unit is separated into districts: 

 

 

As well, notice the scroll bar at the bottom of the matrix – use this to view more data. 
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The “Drillthrough filters” section also allows you to filter data, just as we did with tables. 
Simply check the data to view and uncheck the data to hide: 

 

Note that in this example, these filter options will affect the table as well since they are 
using the same data fields. 

 

Overview of Chart Types 

As of this writing, there are 16 types of charts available in the Visualizations pane: 
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Let’s take a quick look at each type, moving from left to right and top to bottom. 

Chart Type Description 

Stacked Bar Display relationships between values. 

Stacked Column Display relationships between values within categories, or 
changes over time. 

Clustered Bar Display multiple relationships between values. 

Clustered Column Display multiple relationships between values within 
categories, or changes over time. 

100% Stacked Bar Display relationships between values within categories (or 
changes over time) as related to the whole. 

100% Stacked Column Display relationships between values as related to the 
whole. 

Line Show the progression of values over time. 

Area Show relationships between values over time. 

Stacked Area Show relationships between values over time as part of a 
whole. 

Line and Stacked Column Display relationships between values within categories, or 
changes over time, with a constant line. 

Line and Clustered Column Display relationships between values within categories, or 
changes over time, with a constant line. 

Ribbon Similar to a Line chart, but with a 3-D display and additional 
data options. 

Waterfall Displays the cumulative effect of positive or negative 
values. 
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Scatter Displays values for two variables within a dataset.  

Pie Displays values as part of the whole. 

Donut Also displays values as part of the whole but allows 
comparison of more than one data series. 

 

Creating Charts 

All charts are created in a similar way and offer similar features. Let’s create a simple line 
chart for this example: 
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We will add the TotalSales field as the Values, and the FiscalMonth as the Axis: 

 

 

Just as with other visualizations, we can add filters to customize the data. We can also add a 
legend to show another category: 
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Here are the results: 

 

 

You can change the chart type at any time by choosing another icon: 
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And do not forget about the Format tab, which you can use to customize your chart: 
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Activity 4-1: Matrices, Tables, and Charts 
In this activity, you will begin creating a company scorecard report.  

1.  Open Power BI and open Activity 4-1: 

 

  

2.  The Company Scorecard page should be displayed. (Make sure it is selected.) Our 
first task is to show the sum of revenue, broken down by division and industry. 
Let’s use a matrix to display this data. Click the Matrix icon in the Visualizations 
task pane: 
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3.  Since we want to see the total revenue as the matrix data, locate this field in the 
Fact category. Drag it to the Values well: 

 

  

4.  Add the Industry field (from the Industry group) to the Rows well and the Division 
field (from the BU group) to the Columns well: 
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5.  Resize the matrix so all data is displayed: 

 

   



[233] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

6.  Next, we want to know how much revenue varied from the budget, summarized by 
month. Let’s use a waterfall chart to display this data. Click a blank area of the 
canvas to de-select the matrix. Click the Waterfall icon in the Visualizations pane: 

 

   

7.  Set up the fields as shown here: 
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8.  This does not show the data as clearly as we would like. Click the “Line chart” icon 
to change the visualization: 

 

   

9.  Review the results: 
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10.  Resize and align the visuals as shown here: 

 

  

11.  Save your work as Activity 4-1 Complete and close Power BI. 
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TOPIC B: Maps 
 

The next type of visualization we will explore is maps. Bubble and filled maps are excellent 
for geographical breakdowns, while treemaps show parts of data as they relate to the 
whole. 

 

Topic Objectives 

In this section, you will learn how to: 

• Create treemaps, bubble maps, and filled maps  
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Creating a Treemap 

Treemaps show a visual breakdown of data as it relates to the whole. Let’s try creating one 
to show how much each district contributed to annual sales. We will start by choosing the 
Treemap visual: 
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Now, we can add the TotalSales and District fields as the Values and Group, respectively: 

 

 

Notice the additional field areas in the Visualizations pane: 

• Details: Add more text to the treemap shapes. For example, we could add the DM 
field to show the District Manager’s name for each district. 

• Color Saturation: Color fields in relation to a particular data set. For example, we 
could add Sales Per Square Foot to this well. Darker shades would represent a higher 
value, while lighter shades would represent a lower value. 

• Tooltips: Similar to Details, but only shows the data when the user moves their 
mouse over the visualization. 
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Creating a Bubble Map 

There are two types of geographical map visualizations in Power BI. The basic map 
visualization is also called a bubble map because of how it represents data: 

 

 

Here, we have added the placeholder, and moved and resized it to make it easier to see. 
The next step is to add a location-based field to the Location well. If you have latitude and 
longitude values, you can use those wells instead: 
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Next, we need to choose what will determine the size of each bubble. In this case, we will 
use the TotalSales field: 

 

 

Here are the results: 
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Notice that you can add more fields in the Legend, Color saturation, and Tooltips fields to 
make your map even more meaningful. Filters are also available: 
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As a final note, the Format tab of the Visualizations task pane contains lots of options to 
customize the appearance of your map. Of particular note is the Theme menu: 

 

 

By default, a road map is used, but several other options are also available. 
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Creating a Filled Map 

A filled map works the same way as a bubble map, except it fills in geographical areas based 
on the data set. Let’s try changing our bubble map to a filled map: 

 

 

In this case, no data points are displayed as the PostalCode field is too specific. We can fix 
this by clicking the X next to this field to remove it, and adding the Territory field instead: 

 

 

Filled maps have all the same options as previously discussed, including Legend, Color 
saturation, and Tooltips wells; filters; and a wide range of formatting options. 
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Activity 4-2: Maps 
In this activity, we will add two maps to our Company Scorecard report. 

1.  Open Power BI and open Activity 4-2: 

 

  

2.  First, let’s create a treemap to show revenue by region. Click the Treemap icon in 
the Visualizations task pane: 
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3.  Add the Region field (from the State group) to the Group well. Add the Total 
Revenue field (from the Fact group) to the Values well: 

 

  

4.  Resize and position the visualization as shown here: 
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5.  Next, let’s add a similar visualization, but using the State field instead. De-select 
the treemap by clicking a blank area of the canvas. Then, click the Map icon from 
the Visualizations task pane: 
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6.  Add the State field (from the State group) to the Location well. Add the Total 
Revenue field (from the Fact group) to the Size well: 

 

   

7.  Resize and position the visualization as shown here: 
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8.  Let’s customize this visualization. Click the Format tab in the Visualizations task 
pane: 

 

   

9.  Click the Data Colors category. Then, click the color picker: 
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10.  Click any color you like from the menu: 

 

 

11.  The color will then be applied. Now, use the Ctrl + Shift keyboard shortcut to zoom 
into the eastern continental U.S. If necessary, click and drag the map to change the 
focus as shown below: 

 

  

12.  Save your work as Activity 4-2 Complete and close Power BI. 
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TOPIC C: Cards, Gauges, and 
KPIs 
 

The next set of visualizations we are going to explore show data points either on their own 
or as they relate to a target. This is particularly useful if you want to emphasize a particular 
value (such as sales to date) or progress towards a target (such as sales to date compared to 
sales targets). 

 

Topic Objectives 

In this section, you will learn how to: 

• Create single and multiple row cards 

• Create gauges and KPIs 
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Creating a Card 

Cards show one or more rows of data. Like other visualizations, the card data updates if the 
source is refreshed or the user interacts with other visualizations on the page: 

 

 

They are excellent for highlighting key points and creating data summaries.  

Let’s try creating a multi-row card; note that the single-row card icon is to its left. 
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We can now check the fields we would like displayed: 

 

 

You can use the Filters section of the Visualizations task pane, and the Format tab, to 
customize the card’s display. 

 

Creating a Gauge  

The next visualization we will explore is the gauge, which shows progress towards a goal: 
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Now we can specify the fields to include. Our target value is our total units last year, while 
the value to be shown is the total units this year: 

 

 

Notice that we can set minimum and maximum values based on other data fields. You can 
also manually specify these options under the Format tab of the Visualizations task pane: 

 



[254] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

Creating a KPI 

A KPI visualization also displays progress towards a goal or the percentage of a value, but 
with more detail. Let’s try creating this visualization to see if we are matching last year’s 
sales: 

 

 

We will add the TotalSales field as the Indicator (the value to measure), the TotalSalesLY 
field as the “Target goal” (the value to compare against), and the FiscalMonth as the “Trend 
axis” (to categorize progress): 
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We can now see the progress, and that we are 91% above this KPI! Note that the KPI is 
formatted in green because we have met or exceeded it; it would be red if we have not yet 
met our goal.  

This can be changed in the Format tab of the Visualizations pane. You can also set if high or 
low are the preferred values: 
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Activity 4-3: Cards, Gauges, and KPIs 
In this activity, we will add a gauge and a card to our Company Scorecard report. 

1.  Open Power BI and open Activity 4-3: 

 

  

2.  First, we want to show the total revenue as compared to last year. We will use a 
gauge to display this data, so click that icon from the Visualizations task pane: 
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3.  Check the Total Revenue field to add it to the gauge:  

 

  

4.  We want to compare it to last year’s revenue, which is not in this dataset. Click the 
Format tab of the Visualizations task pane to enter it manually: 
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5.  Expand the “Gauge axis” section and enter “330500000” in the Max field: 

 

   

6.  Resize and position the gauge as shown here: 
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7.  We also want to quickly see the percentage of revenue from subscriptions. We will 
use a card to display this data. De-select the gauge and click the Card visualization: 

 

   

8.  Check the “Sum of Subscription Revenue” field to add it to this card: 
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9.  Resize and reposition the card as shown here: 

 

   

10.  Save your work as Activity 4-3 Complete and close Power BI. 
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TOPIC D: Slicers 
 

The final visualization we will explore in this lesson is a bit different than the other types we 
have looked at. Slicers allow users to filter data on the fly, even with the Power BI web and 
mobile apps. (They are different from the Filters section of the Visualizations pane only in 
that users may not have access to these tools in the apps, and slicers are much more user-
friendly.) If you have used slicers in Excel, the concept is the same. 

 

Topic Objectives 

In this section, you will learn how to: 

• Create and use slicers 

• Customize slicer display 

• Change slicer mode and orientation 
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Creating a Slicer  

To create a slicer, simply click the related icon from the Visualizations task pane: 

 

 

Then, choose the slicer field: 

 

 



[263] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

The slicer is now ready to use: 

 

 

Using Slicers 

Using a slicer is as easy as clicking the item you want to filter the data by: 

 

 

Here, we have chosen to view data only for the Fashions Direct chain.  
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Here is another example, where we have filtered sales data by month: 

 

 

To clear the filter, uncheck the box or click the Clear Selections command in the top right 
corner of the slicer: 
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Customizing Slicer Display 

By default, users can only select one item from a slicer at a time. This option can be changed 
in the Format tab of the Visualizations task pane by setting the Single Select option to Off: 

 

 

An option to show a “Select All” control is also available here, along with many other 
formatting choices. 
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Changing Slicer Mode 

By default, slicer values are shown as a list, where the user checks the data they want to 
view. However, you can change this display to a dropdown list. Click the arrow in the top 
right corner of the slicer and click Dropdown: 

 

 

Here is how the slicer now appears: 

 

 

Note that, however, it works in the same way. You can change it back to a list at any time by 
clicking the arrow icon and clicking List. 
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Changing Slicer Orientation 

You can also display a slicer as a list of buttons, allowing the user to click the items they 
want to see. Click the Format tab in the Visualizations task pane, click the Orientation menu, 
and choose Horizontal: 

 

 

Here is how our slicer now looks; we can click any month icon to see its data. Note the 
arrows that allow you to view more buttons: 
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Activity 4-4: Slicers 
In this activity, we will add the final element to our Company Scorecard report: a slicer. 

1.  Open Power BI and open Activity 4-4: 

 

  

2.  Click the Slicer icon from the Visualizations task pane: 
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3.  Resize and reposition it as shown here: 

 

  

4.  Add the Name field from the Executive group to the slicer: 
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5.  Now, let’s customize the slicer display. Click the Format tab in the Visualizations 
task pane: 

 

   

6.  Expand the General category. Change the orientation from Vertical to Horizontal: 
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7.  This will display the slicer as a row of buttons: 

 

   

8.  Click the “Outline color” color picker. Choose the top shade of teal: 

 

   



[272] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

9.  Now, scroll down in the pane and expand the Selection Controls section. Ensure 
both options are set to “On:” 

 

   

10.  Now, try clicking one of the executives’ names from the new slicer: 
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11.  Observe how the data changes: 

 

  

12.  Click the Clear Selection icon in the slicer: 

 

  

13.  Save your work as Activity 4-4 Complete and close Power BI. 
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Summary 
In this lesson, we looked at the different kinds of visualizations available in Power BI. You 
should now feel comfortable creating and customizing all types of visualizations. 

 

Review Questions 
 

 What is the process for creating any kind of visualization? 

 

 How do you display a slicer as a list of buttons? 

 

 If you want to show the cumulative effect of positive or negative values, what chart 
type would you choose? 

 

 What is the difference between the KPI and gauge visualizations? 

 

 What are the two types of geographical map visualizations? 
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LESSON 5: INTRODUCTION TO THE 
POWER BI WEB APP 

 

 

Lesson Objectives 

 

In this lesson you will learn how to: 

• Use the Power BI web app 

• Connect to data sources from the Power BI app 

• Use workspaces, dashboards, reports, and other Power BI app features 
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TOPIC A: Getting Started 
 

So far, we have focused on the Power BI desktop client. However, Power BI also features a 
web app that is very useful for users who primarily need to view reports (rather than 
modifying the underlying data or report structure). In this topic, we will begin exploring the 
Power BI web app. 

 

Topic Objectives 

In this section, you will learn how to: 

• Access and use the Power BI web app 

• Identify differences between the web app and desktop client 
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Opening the Power BI Web App 

To start, enter https://app.powerbi.com into your browser’s address bar. You will be 
prompted to sign in and then the app will be displayed: 

 

  

https://app.powerbi.com/
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The Web App Interface  

Let’s take a closer look at the web app interface: 

 

 

1: App Launcher 
Click the yellow icon to see shortcuts to other Office 365 apps. 

2: Breadcrumb Trail 
Shows where you currently are in Power BI. Click a location to go to it. 

3: Office 365 Commands  
From left to right: 

• View Office 365 notifications 

• Manage Power BI settings 

• Download Power BI tools 

• Access help and support resources 
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• Give feedback 

• View your Office 365 profile 

4: Search field 
Search Power BI data. 

5: Navigation pane 
Access different parts of the Power BI app. Click a chevron to expand sub-categories; click 
the down arrow to collapse them. All workspaces will be displayed in this pane, with the 
related dashboards, reports, workbooks, and datasets listed as sub-items. Simply expand 
the desired workspace and then click the item you want to view. 

6: Canvas 
Visualizations in the current item (dashboard, report, etc.) will be shown here.  

7: Get Data 
Use this link to quickly import data sources. Samples can also be accessed from here. 
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Web App Building Blocks 

Let’s review the elements of Power BI: 

 

 

The Power BI web app focuses on dashboards, which allow you to collect visualizations 
from different reports into a single location. Each dashboard is made up of tiles, which are 
simply visualizations linked back to the original report. As well, dashboards can be organized 
using workspaces. 

  

Workspace

Dashboard

Tile

Report

Visualization

Dataset
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Key Differences 

To summarize, here is a list of some of the key differences between the Power BI desktop 
and web clients. 

Power BI Desktop Client Power BI Web App 

• Runs off a single computer • Cloud-based (can be accessed from 
anywhere) 

• Designed for managing data, building 
reports, and viewing reports 

• Designed for viewing and managing 
reports 

• No sharing features • Extensive sharing features and 
integration with Office 365 

• Updated monthly • Updated weekly 
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Activity 5-1: Getting Started 
In this activity, you will open and explore the Power BI web app. 

1.  Launch Microsoft Edge and navigate to https://app.powerbi.com/. Sign in when 
prompted to see the Power BI web app: 

 

  

2.  Click the “Shared with me” category from the navigation pane: 

 

https://app.powerbi.com/


[283] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

3.  Do you have any shared items? 

 

  

4.  Now, click the chevron next to the Workspaces category: 
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5.  What workspaces are available to you? 

 

   

6.  Click the chevron again to hide the Workspaces sub-menu: 
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7.  Expand the “My Workspace” category: 

 

   

8.  Do you have any items in your workspace? 

 

   

9.  This activity is now complete. Leave your browser open for the next activity. 
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TOPIC B: Connecting to Data 
Sources with the Power BI 
Web App 
 

You can also connect to data sources directly with the Power BI web app. It also offers some 
unique options, like sample data and content packs. 

 

Topic Objectives 

In this section, you will learn how to: 

• Connect to local data files, live data sources, content packs, and samples 
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Connecting to Local Data 

To connect to a file on your PC (such as an Excel workbook or Power BI desktop file), click 
the Get link in the Files section of the Start screen: 
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Now, click Local File: 
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Now, browse to the file, select it, and click Open: 

 

 

The data will now be connected: 
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Connecting to Live Data 

There is also an option on the Get Data page to connect to live data from a database 
service: 

 

 

Now, choose your content service: 
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Click Connect to view available servers and connect to them: 

 

 

Connecting to Content Packs 

A content pack is like a set of templates for Power BI. It typically includes pre-defined 
visuals and reports based on a specific dataset (like Microsoft Dynamics or MailChimp.) 
Content packs can be provided by other organizations or developed by Power BI users and 
shared within your company. 
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You can connect to content packs from the Getting Started screen: 

 

 

If you click Get under the Services section, third-party content packs will be shown: 
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Click the appropriate link for the pack you want to download for more information and 
connection options. 

 

Connecting to Samples 

You can also access samples from the Get Data page: 
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Once you click the Samples link, you will see a list of available items. Click any icon to 
continue: 

 

 

Then, click Connect to confirm the operation: 
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The dataset will then be added: 
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Activity 5-2: Connecting to Data Sources with 
the Power BI App 
In this activity, you will connect the Power BI web app to a local data file. You will also check 
if there are any content packs available in your organization. 

1.  Ensure Microsoft Edge is open and the Power BI app is displayed. 

  

2.  Click the Get Data link in the bottom left corner of the window: 
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3.  Click Get in the Files section: 

 

  

4.  Click Local File: 
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5.  Browse to the Lesson 5 folder of your Exercise Files. Select Activity 5-1 and click 
Open: 

 

   

6.  The data file will now be imported: 
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7.  Now, let’s explore available content packs. Click the Get Data link again: 

 

   

8.  Click Get in the “My organization” section: 
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9.  The AppSource window will open. Are there any content packs for your 
organization? 

 

   

10.  Close the AppSource window: 

 

  

11.  This activity is now complete. Leave your browser open for the next activity. 
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TOPIC C: Using Workspaces, 
Dashboards, and Reports  
 

Let’s take a closer look at the object structure in Power BI. Remember, the Power BI web 
app is built around on dashboards, which allow you to collect visualizations from different 
reports into a single location. Dashboards can be organized using workspaces.  

 

Topic Objectives 

In this section, you will learn how to: 

• View and manage Power BI content 

• View workspaces, dashboards, and reports 

• Manage reports 
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Viewing and Managing Power BI Content  

To view and manage the content and data sources in your Power BI app, click My 
Workspace from the navigation pane: 

 

 

You will now see an overview of your Power BI content. Notice the tabs that allow you to 
quickly view and manage each content type: 
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Let’s take a closer look at the options available: 

 

 

1: Create 
Create a new report, dashboard, or dataset. 

2: Search Field 
Search all content sources for a particular term. 

3: Sort 
Change how the content list is sorted. 

4: Content Icon 
Dashboards, reports, workbooks, and datasets are identified by a unique icon. 
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5: Favorite 
Click the star to favorite this item. Favorites can easily be accessed from the navigation 
pane: 

 

 

 

6: New Item 
An asterisk denotes a new item. 

7: Actions 
Shows what actions are available for this object. (Available actions depend on the content 
type and your permissions.) From left to right, here you can see icons to share the content, 
view related objects, change its settings, and remove it. 
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Note that you can quickly access content object options by clicking the chevron next to My 
Workspace in the navigation pane, moving your mouse over the target object, and clicking 
the ellipses: 

 

(Remember, you can view the object’s contents by clicking its link.)  
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Viewing a Workspace 

First, let’s take a closer look at workspaces. To view a workspace, click the Workspaces 
category in the navigation pane and click the target workspace from the menu: 

 

 

(Note that here we have the default My Workspace, as well as workspaces for SharePoint 
groups and other apps. Workspaces must be created by the system administrator.) 
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The workspace contents will then be displayed: 

 

 

Now, click any item to see the related content.  

You can also quickly view and access objects in the default My Workspace from the 
navigation pane by clicking the chevron and then clicking the object you want to view: 
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Viewing Dashboards and Reports 

You can access dashboards and reports from the navigation pane or the Workspaces page: 

 

 

Just click the link for the object you want to view. Here, we have viewed the “Sales and 
Marketing Sample” report: 
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Managing Reports 

Although you must use the Power BI desktop client to create reports, the Power BI web app 
does contain many features to customize and edit these reports: 

 

 

1 and 2: Action Bars 
The commands at the top of the report are divided into two sections. The left section (1) 
contains file-related commands: 

• The File menu contains additional commands to save, print, publish, download, and 
export this report. 

• The View menu contains options to change the report display, as well as toggle task 
panes on or off. 

• Click “Edit report” to access the Visualizations and Fields panes (which are the same 
as in the Power BI desktop client) and other advanced commands. 

• The Explore button shows a menu with options to drill through and view data. 
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• Click Refresh to reconnect to the original data source and update the data, if 
necessary. 

• Finally, Pin Live Page allows you to pin the entire page to a dashboard. 

The right section (2) contains commonly used commands to view related data, add the 
report as a favorite, and subscribe to or share it. The “More options” menu (accessible from 
the ellipses icon) includes commands to export the data or generate a QR code for quick 
access. 

3: Visualization Commands 
Just as in the Power BI desktop client, you can move your mouse over a visualization to see 
commands to pin the visualization, switch to Focus Mode, and access the More Options 
menu. (This menu contains commands to export, show, spotlight, and sort data.) 

4: Canvas 
Visualizations are displayed in the main area of the report, called the canvas. 

5: Page Tabs 

Use these tabs to navigate through and view the report’s pages. 

6: Filters Task Pane 
View and modify report filters. 
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Activity 5-3: Using Workspaces, Dashboards, 
and Reports 
In this activity, you will explore the data in the file we imported in the last activity. 

1.  Ensure you have completed Activity 5-2. 

  

2.  Click My Workspace in the navigation pane: 
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3.  The workspace contents will be displayed. Click each tab to view the related 
contents: 

 

  

4.  First, let’s explore the dashboard that was created when we imported this file. 
Click the Dashboards tab and click the Activity 5-1 link, or click the link in the 
navigation pane: 
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5.  This dashboard contains only one report. Click its icon: 

 

   

6.  Review the contents of the report: 
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7.  Click the “Edit report” command: 

 

   

8.  Review the available options and task panes: 
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9.  Move your mouse over any visualization. Notice that it can be edited: 

 

   

10.  Click “Reading view” to return to that mode: 

 

  

11.  This activity is now complete. Leave your browser open for the next activity. 
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TOPIC D: Creating Custom 
Dashboards 
 

We know that dashboards allow you to collect and organize report visualizations. These 
visualizations remain linked to their original report, ensuring you are always viewing the 
most up-to-date information. For example, your organization may have individual reports 
for sales, revenue, and expense data. You can collect the visualizations relating to your 
specific department or region on your own dashboard to make it easy to quickly access the 
information that is relevant to you.  

 

Topic Objectives 

In this section, you will learn how to: 

• Create and manage dashboards 

• Add custom tiles and visualizations to a dashboard 
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Creating a Dashboard 

To create a new dashboard, click the chevron next to the Workspaces item in the navigation 
pane and click the target workspace: 

 

 

Next, click Create → Dashboard: 
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When prompted, type the name of your dashboard and click Create (or press Enter): 

 

 

The dashboard will now be created, and can be accessed from the navigation pane: 
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Pinning Visualizations to a Dashboard 

You can add any visualization you like to a dashboard from a report. For this example, let’s 
navigate to the “Sales and Marketing Sample” report: 

 

 

Now, we can move our mouse over any visualization and click the “Pin visual” icon: 

 

  



[320] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

We will then be prompted to specify where to add the visualization to. For this example, we 
will choose the dashboard we just created, but note that you can create a new dashboard 
from here as well: 

 

 

You can now go to the dashboard, or close the notifications and return to the report. Let’s 
go to the dashboard: 
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The visualization is now available on the selected dashboard: 

 

 

You can:  

• Click the visualization to go to the source report 

• Move and resize the visualization 

• Move your mouse over the visualization and click the ellipses menu in the corner to 
view additional options, including deleting it from the dashboard 
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Adding Custom Tiles 

Power BI also allows you to add custom tiles to a dashboard, like images and text boxes. To 
start, open the dashboard from the navigation pane. Then, click the “Add tile” icon: 
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Now, choose what to add and click Next: 

 

 

Finally, enter the object details (in this case, the title and URL) and click Apply: 
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The tile will then be added: 

 

 

You can work with these custom tiles in the same way as visualization tiles. 
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Managing Dashboards 

In the top right corner, you will see options to manage your dashboard: 

 

 

From left to right, the commands are: 

• Add a custom tile 

• View content related to the visualizations on this dashboard 

• Set this as your featured dashboard so it is automatically displayed when you open 
the workspace 

• Mark this dashboard as a favorite 

• Enable notifications when there are changes to this dashboard 

• Share this dashboard 

• Change to phone view 

• Access more options, including commands to delete, print, and refresh the dashboard 
and change its settings 
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Activity 5-4: Creating Custom Dashboards  
In this activity, you will create a custom dashboard. 

1.  Ensure you have completed Activity 5-3. The Activity 5-1 report should be 
displayed: 

 

(If it is not displayed, click its link from the navigation pane.) 

  

2.  We want to create a dashboard summarizing revenue. First, let’s add the KPI 
visualization to this dashboard. Move your mouse over the visualization and click 
the pin icon: 
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3.  The “Pin to dashboard” dialog will open. Click the “New dashboard” radio button: 

 

4.  Type, “Activity 5-4” for the dashboard name and click Pin: 
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5.  You will see a notification that the dashboard has been created: 

 

6.  Move your mouse over the “Total Revenue by Region” visualization and click the 
pin icon: 
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7.  Ensure that Activity 5-4 is selected as the dashboard and click Pin: 

 

8.  Repeat Steps 6 and 7 to pin the “Total Revenue by State” visualization to the new 
dashboard: 
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9.  Now, use the notification link or the navigation pane to go to the new dashboard: 

 

10.  Close all notifications for a better view: 
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11.  Review the dashboard: 

 

  

12.  Click the Favorite icon to add it to that category of the navigation pane: 

 

  

13.  This activity is now complete. Leave your browser open for the next activity. 
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TOPIC E: Power BI Web App 
Features 
 

To wrap up this lesson, we will explore some of Power BI’s data analysis features which, as 
of this writing, are unique to the web app. 

 

Topic Objectives 

In this section, you will learn about: 

• Using Insights and Q & A 

• Customizing Q & A suggestions 
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Using Insights 

The Power BI web app features Insights, which provide related data and statistics for a 
particular visualization within a dashboard. To view these insights, move your mouse over 
the visualization and click the ellipses icon that appears: 

 

 

Then, click “View insights:” 
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You will now see the data insights in a pane on the left side of the window: 

 

 

You can pin this data as its own visualization, or click ellipses icon at the top of this pane to 
see more options, including exporting the data and generating a QR code for quick access: 
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Using Q & A 

Another interesting feature is Q & A, which allows you to ask questions about your data: 

 

 

If you click in this field, you will see a number of pre-populated questions: 
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Click to select one of these questions, or type your own question in the field. With either 
action, additional suggestions to refine the question will appear in an auto-complete menu. 
Click to select the desired criterion: 

 

 

Here we have asked for sentiment by geography, so a bubble map has automatically been 
created from the underlying data: 

 

 

We can pin this visual using the command in the top right corner of the screen, or click Exit 
Q & A to return to the dashboard. 
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Customizing Q & A Suggestions 

To customize the suggestions presented by Q & A, move your mouse over the dashboard 
entry in the navigation pane, click the ellipses, and click Settings: 

 

  



[338] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

The Settings page for this dashboard will be displayed. Click the Datasets category: 

 

 

Now, expand the “Featured Q & A questions” section and click the “Add a question” link: 
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Type the question and click Apply: 

  

 

Now, the question will be added to the Q & A list: 

 

 

  



[340] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

Activity 5-5: Power BI Web App Features 
In this activity, you will use Insights and Q & A. 

1.  Ensure you have completed Activity 5-4. The Activity 5-4 dashboard should be 
displayed: 

 

(If it is not displayed, click its link from the navigation pane.) 
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2.  Click the “Ask a question about your data” field: 

 

  

3.  We want to view a summary of customers by state, so click “customers” from the 
suggested list: 
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4.  Now, click “by state” from the auto-complete menu: 

 

  

5.  The data will now be displayed: 
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6.  Click the chevron in the Visualizations task pane: 

 

   

7.  Click a few visualization icons to experiment with different display options: 

 

 

Return to the Table visualization when you are finished. 
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8.  Let’s add this information to our dashboard. Click “Pin visual:” 

 

   

9.  Ensure that the Activity 5-4 dashboard is selected and click Pin: 
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10.  Click the notification link to go back to the dashboard: 

 

  

11.  The visualization will now be added to the dashboard. Move your mouse over it 
and click the ellipses icon: 
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12.  Click “View insights:” 

 

  

13.  You will now see insights related to this data: 

 

  

14.  Close your browser to complete this activity. 
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Summary 
In this lesson, we took a closer look at the features in the Power BI web app. You learned 
how to open the app; connect to data in it; use workspaces, dashboards, and reports; 
create custom dashboards; and use Q & A and Insights to get even more out of your data. 

 

 

Review Questions 
 Which Power BI client is designed for managing data? 

 

 How do you drill through data when viewing a report in the Power BI web app? 

 

 What is a content pack? 

 

 How do you view data insights? 

 

 How do you pin a visualization to a dashboard? 
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LESSON LABS 

 

Lesson 1  

Lesson Lab 1-1 

Objective To understand how to open and use Power BI files. 

Briefing You have been given an existing Power BI data file. You want to 
see what data it contains and what reports have been created. 

Tasks • Open the Sample Data file. 

• Explore the Visualizations and Fields task panes. 

Sample Data 

 

Follow-Up Questions If you have access to the Power BI web app, publish the Sample 
Data file and review its contents. 
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Lesson Lab 1-2 

Objective To add an Excel file to your Power BI data source. 

Briefing After reviewing the existing Power BI data file, you noticed that 
the regional list of directors is missing. You want to import this 
file and start creating a new report.  

Tasks • Open the Power BI Sample Data file. 

• Connect to the Excel Sample Data file. 

• Add two visualizations to the Demographic Summary 
page: 

• A pie chart showing New Hires as the Values and 
Gender as the Legend 

• A donut chart showing New Hires as the Values 
and Ethnicity as the Legend 

• Format, place, and resize these visualizations however 
you like. 

• Try interacting with each visualization to see how they 
affect each other. 

Sample Data 

 

Follow-Up Questions Review the other two report pages and see how the 
visualizations interact with each other. 
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Lesson 2  

Lesson Lab 2-1 

Objective To manage the Excel data we imported in the last lesson. 

Briefing You want to explore and update the Excel data you imported 
into your Power BI file in the last Lesson Lab. 

Tasks • View the Directory table in Data view. 

• Rename the “Phone Number” column to “Director’s 
Number.” 

• Ensure each column has the correct data category 
applied (if applicable). 

• Link the Region field in the Directory table to the Region 
field in the BU table. 

Sample Data 
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Lesson Lab 2-2 

 

Objective To add information from the Directory table to the BU table. 

Briefing You have some ideas for using calculated columns and 
measures to add more meaning to your Power BI file. 

Task • Add a column to the BU table to show which director 
each VP reports to.  

• Use a measure to calculate the average tenure in years. 
(Hint: There is a similar measure for days and months.) 

Hints If you get stuck, review the completed Sample Data file. 

Sample Data 

 

 

  



[352] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

Lesson 3  

Lesson Lab 3-1 

Objective To create a scorecard that will look the same on all devices. 

Briefing You want to create an easy-to-read scorecard that will show 
both new hires and separations (employees who have left the 
company). 

Task • Create a new report page named Scorecard. Set the size. 
Move this page after the Info page. 

• Add a line chart with the New Hires and Separations 
fields as the Values. Add the YQM hierarchy as the axis. 

• Position this chart at the bottom of the page. Resize as 
necessary. 

Hints You can change page size in the Visualizations task pane, under 
the Format tab, when no visualizations are selected. 

Sample Data 

 

Follow-Up Questions Explore the drill-down feature. Leave the chart drilled to 
quarter. 
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Lesson Lab 3-2 

Objective To add a few final touches to your Scorecard report. 

Briefing You want to finalize your scorecard report and create a phone 
view. 

Tasks • Continue working with the Scorecard report. 

• Add a text box with the title “Hiring Scorecard.” Feel free 
to use whatever font, color, and/or effects you like. 

• Add the Sample Data image. 

• Resize and position these objects as necessary. 

• Create a phone view that matches the desktop view we 
have already created. 

Sample Data 
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Lesson 4  

Lesson Lab 4-1 

Objective To create a new report in your sample file. 

Briefing You need to create a New Hires report for your manager that 
shows the progression of new hires over time, a geographical 
breakdown of new hires, and a chart of full-time vs. part-time 
new hires.  

Task Create a new report page named “New Hires Report.” Add 
three visualizations to show the information requested. 

Sample Data 

 

Follow-Up Questions Use a text box to add a title to the report. Format it any way 
you like. 
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Lesson Lab 4-2 

Objective You have sent your report to your manager. She has made two 
additional requests.  

Briefing Your manager wants to easily see how many active employees 
there are. She also wants to monitor bad hires (those who 
leave within 60 days of their start date) with the goal of 
keeping it under 15% of active employees. 

Task Add two visualizations to display this data. Rearrange the 
report visualizations if needed. 

Sample Data 

 

Follow-Up Questions Add a slicer to filter the values by year. 
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Lesson 5  

Lesson Lab 5-1 

Objective You are now ready to share your Power BI file with your 
organization. 

Briefing You need to connect your Power BI file to the web service and 
then share key information with your organization.  

Tasks • Log into the Power BI web app. 

• Connect the Sample Data file. 

• View the dashboard and report in this file. 

Sample Data 

 

Follow-Up Questions Be sure to review all report pages. 
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Lesson Lab 5-2 

Objective To create a custom dashboard. 

Briefing Your manager wants a summary that she can share with her 
director. 

Tasks • Ensure you have completed Lesson Lab 5-1. 

• Create a new dashboard named “Lesson Lab 5-2.” 

• Open the New Hires Report. Review all five pages and 
pin any three visualizations to the new dashboard. 

• Add the new dashboard as a favorite and share it with a 
classmate. 

Hints If you are completing this course on your own, you can skip the 
sharing step. 

 

  



[358] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

COURSE WRAP-UP 

Keyboard Shortcut Quick Reference Sheet 

 (Power BI Desktop Client) 

 

Fi
le

 M
an

ag
em

en
t  

Create a new file Ctrl + N 

Save a file Ctrl + S 

Open the Save As dialog F12 

Open a file Ctrl + O 

Close current window Alt + F4 

Get Help F1 

 E
di

tin
g  

To
ol

s 

Select all items on current page Ctrl + A 

Copy selected object(s) Ctrl + C 

Cut selected object(s) Ctrl + X 

Paste selected object(s) Ctrl + V 

Undo last action Ctrl + Z 

Redo last action Ctrl + Y 
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Fo
rm

at
tin

g 
To

ol
s  Apply bold formatting Ctrl + B 

Apply underlining Ctrl + U 

Apply italic formatting Ctrl + I 
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Post-Course Assessment 
 How do you connect to an Excel workbook from the Power BI desktop client? 

a. File → Connect → Excel 

b. Home → Get Data arrow → Excel  

c. Tools → Import → Excel Workbook  

d. All of the above 

 

 What are the basic steps for creating any visualization? (Select all that apply.) 

a. Click the visualization icon from the Visualizations pane  

b. Install the necessary visualizations package 

c. Set the fields to display in the Fields pane 

d. Ensure all fields are related 

 

 Which Power BI client is designed for managing data? 

a. Desktop 

b. Web 

c. Mobile 
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 What is DAX?  

a. The Power BI file format 

b. A type of formula language used to create custom calculations and measures 
in Power BI  

c. An XML data schema 

d. A legacy database file format 

 

 What types of content can you connect to with the Power BI web app? 

a. Content packs 

b. Local files (like Excel workbooks) 

c. Live data (like SQL databases) 

d. All of the above 

 

 What is a measure? 

a. Table that returns specified values from a dataset 

b. Column that returns specified values from a dataset 

c. Formula that shows a value calculated from specified data 

d. Editor that allows you to enter a DAX expression 
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 You have a chart with drilldown enabled, but you do not want the other 
visualizations on the page to change when the user is drilling through the data. 
Where can you disable this feature in the Power BI desktop client? 

a. Select the visual, click the Visual Tools – Format tab, and uncheck “Drilling 
filters other visuals” 

b. Ensure the visualization’s fields are different than the other visualizations on 
the page  

c. Click the ellipses and uncheck “Linked drilldown” 

d. You cannot disable this feature for the other visualizations  

 

 If there is more than one visualization on a page, which of the following statements 
are true? 

a. They will act as a filter on each other 

b. They must use the same design theme 

c. They must be the same size 

d. All of the above 

 

 How do you see a visualization’s data in the Power BI desktop client? 

a. Click the ellipses in the top right corner of the visualization and click Show 
Data  

b. Right-click it and click Show Data 

c. Press Ctrl + D with the visualization selected 

d. Any of the above 
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  What is a slicer? 

a. A drilldown type 

b. A tool that allows the user to capture a static image of a visualization 

c. A table filtering option only available for data imported from Excel 

d. A visualization that allows users to filter data on the fly 
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Course Summary 
Congratulations on completing Introduction to Microsoft Power BI training. During this 
course, you learned how to: 

• Use the Power BI desktop client and web app 

• Connect to data sources 

• Create and manage visualizations, including: 

• Matrices and tables 

• Charts 

• Maps 

• Cards 

• Gauges 

• KPIs 

• Slicers 

• Transform, sanitize, and model data 

• Use the Query Editor 

• Manage relationships 

• Manage report pages 

• Change report view options 

• Add static objects to a report 

• Use workspaces, dashboards, and reports in the Power BI web app 

• Use Insights and Q & A in the Power BI web app 

 

You should now feel comfortable linking and modeling data in Power BI, and then using that 
data to create visual reports and reveal data insights. 
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ANSWER KEYS  

Lesson 1 Review Questions  
 What are the six building blocks of Power BI? 

Workspaces, dashboards, tiles, reports, visualizations, and datasets. 

 

 How do you connect to an Excel workbook from Power BI? 

Click Home → Get Data arrow → Excel. 

 

 What are the two task panes used when creating a visualization? 

Visualizations and Fields. 

 

 How do you see the data related to a visualization? 

Move your mouse over the visualization, click the ellipses in the top right corner, 
and click Show Data. 

 

 True or False: Removing a visualization also removes the related data. 

This statement is false. Removing a visualization does not affect the related data. 
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Lesson 2 Review Questions  
 

 What is DAX? 

A type of formula language used to create custom calculations and measures. 

 

 Where should a measure be stored? 

Ideally, with the related table. This is not a requirement of Power BI – it is simply so 
you can find it later if needed. 

 

 Which tab contains commands to set the data type, format, category, and 
summarization? 

The Modeling tab. 

 

 How do you create a relationship between two fields in Relationships view? 

Drag one field to the other. 

 

 How do you open the Query Editor? 

Click Home → Edit Queries. 
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Lesson 3 Review Questions  
 

 You have hidden a page in your report showing next year’s budget. You are now 
ready to share it with others. How do you show it? 

Right-click the page tab and click Hide Page to de-select it. 

 

 True or False: Always duplicate a page when creating a phone layout so the desktop 
layout is not lost. 

This statement is false. Creating a phone layout will automatically create an 
alternate version of the report – there is no need to duplicate it. 

 

 You have a chart with drilldown enabled, but you do not want the other 
visualizations on the page to change when the user is drilling through the data. 
Where do you set this option? 

Uncheck the “Drilling filters other visuals” option on the Visual Tools – Format tab. 

 

 How do you add a local picture to a report page? 

Click Home → Image. 

 

 How do you add an online picture to a report page? 

As of this writing, all images must be stored locally to be added to a report. 
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Lesson 4 Review Questions  
 

 What is the process for creating any kind of visualization? 

Click its icon from the Visualizations pane and then choose the fields to display. 

 

 How do you display a slicer as a list of buttons? 

Click the Format tab in the Visualizations task pane, click the Orientation menu, and 
choose Horizontal. 

 

 If you want to show the cumulative effect of positive or negative values, what chart 
type would you choose? 

Waterfall. 

 

 What is the difference between the KPI and gauge visualizations? 

Both display progress towards a goal, but in different ways. 

 

 What are the two types of geographical map visualizations? 

Bubble (standard) and filled. 
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Lesson 5 Review Questions  
 

 Which Power BI client is designed for managing data? 

The Power BI desktop client. 

 

 How do you drill through data when viewing a report in the Power BI web app? 

Click Explore on the top action bar. 

 

 What is a content pack? 

A set of templates for Power BI that includes pre-defined visuals and reports based 
on a specific dataset. 

 

 How do you view data insights? 

Move your mouse over the visualization, click the ellipses icon, and click “View 
insights.” 

 

 How do you pin a visualization to a dashboard? 

Move your mouse over the visualization and click the pin icon. In the dialog box that 
appears, select or create a dashboard and click Pin. 
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Post-Course Assessment 
 How do you connect to an Excel workbook from the Power BI desktop client? 

a. File → Connect → Excel 

b. Home → Get Data arrow → Excel  

c. Tools → Import → Excel Workbook  

d. All of the above 

To connect to an Excel workbook, click Home → Get Data arrow → Excel. 

 

 What are the basic steps for creating any visualization? (Select all that apply.) 

a. Click the visualization icon from the Visualizations pane  

b. Install the necessary visualizations package 

c. Set the fields to display in the Fields pane 

d. Ensure all fields are related 

Click its icon from the Visualizations pane and then choose the fields to display. No 
special package is required, and if a relationship is needed, Power BI will prompt you 
to create one. 

 

 Which Power BI client is designed for managing data? 

a. Desktop 

b. Web 

c. Mobile 

The Power BI desktop client is designed for managing data. 
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 What is DAX?  

a. The Power BI file format 

b. A type of formula language used to create custom calculations and measures 
in Power BI  

c. An XML data schema 

d. A legacy database file format 

DAX is a type of formula language used to create custom calculations and measures. 
It is used in Power BI, Excel, and many other data-related applications. 

 

 What types of content can you connect to with the Power BI web app? 

a. Content packs 

b. Local files (like Excel workbooks) 

c. Live data (like SQL databases) 

d. All of the above 

The Power BI web app can connect to all of these data sources, and more. 

 

 What is a measure? 

a. Table that returns specified values from a dataset 

b. Column that returns specified values from a dataset 

c. Formula that shows a value calculated from specified data 

d. Editor that allows you to enter a DAX expression 

A measure is a formula that shows a value calculated from specified data. 
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 You have a chart with drilldown enabled, but you do not want the other 
visualizations on the page to change when the user is drilling through the data. 
Where can you disable this feature in the Power BI desktop client? 

a. Select the visual, click the Visual Tools – Format tab, and uncheck “Drilling 
filters other visuals” 

b. Ensure the visualization’s fields are different than the other visualizations on 
the page  

c. Click the ellipses and uncheck “Linked drilldown” 

d. You cannot disable this feature for the other visualizations  

If you have a visualization with drilldown options, you can uncheck the “Drilling 
filters other visuals” option so that it does not affect the other visualizations.  

 

 If there is more than one visualization on a page, which of the following statements 
are true? 

a. They will act as a filter on each other 

b. They must use the same design theme 

c. They must be the same size 

d. All of the above 

If there is more than one visualization on a page, they will act as a filter on each 
other. 
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 How do you see a visualization’s data in the Power BI desktop client? 

a. Click the ellipses in the top right corner of the visualization and click Show 
Data  

b. Right-click it and click Show Data 

c. Press Ctrl + D with the visualization selected 

d. Any of the above 

To see the data in a visualization, click the ellipses in the top right corner (called the 
“More options” menu), and click Show Data. 

 

 What is a slicer? 

a. A drilldown type 

b. A tool that allows the user to capture a static image of a visualization 

c. A table filtering option only available for data imported from Excel 

d. A visualization that allows users to filter data on the fly 

 Slicers allow users to filter data on the fly, even with the Power BI web and mobile 
apps. 
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APPENDICES 

Glossary 
card 

Visualization that shows one or more 
dynamic rows of data. 

connectors 

Software component that connects data 
with the Power BI apps. 

content pack 

Set of pre-defined visuals based on a 
specific dataset. 

dashboard 

In Power BI, a customized summary of 
report visualizations. 

dataset 

Another term for data source, such as an 
Excel workbook, Facebook analytics, or a 
SQL database. 

DAX (Data Analysis Expression) 

A type of formula language used to create 
custom calculations and measures. 

gauge 

Visualization that shows progress towards 
a goal. 

 

KPI 

Visualization that shows progress towards 
a key metric or goal. 

matrix 

Visualization that displays data in a 
crosstab format. 

Power BI  

a collection of software, apps, and 
services designed to aggregate data so 
users can easily report on and interpret it. 

Q & A 

Power BI web app feature that allows the 
user to ask natural-language questions 
about the data in a dashboard. 

Query Editor 

Power BI feature that provides advanced 
data transformation features. 

Quick Access toolbar 

Interface element that provides quick 
access to frequently used commands. 

 



[375] Introduction to Microsoft Power BI 

© 2005-2021 Ultimate IT Courses All rights reserved. 

report 

Collections of visualizations. 

slicer  

Dynamic data filter. 

table 

Visualization that displays data in a 
standard row/column format. 

tile 

Dashboard component; visualization 
linked back to the original report. 

treemap 

Visualization that shows a visual 
breakdown of data as it relates to the 
whole. 

visualization 

Highly customizable object that presents 
data in a visual way. 
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