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ABOUT THIS COURSE 

Course Prerequisites 

This manual assumes the user has completed the first part of the Microsoft 365 Excel 
courseware or has an understanding of the information presented in that course, including: 

• Getting started with the app 

• Working with formulas and functions 

• Modifying worksheets 

• Printing workbook contents 

• Managing workbooks 

• Customizing the Excel environment 

 

Course Overview  

Welcome to the second part of our Microsoft 365 Excel courseware. This version of Excel 
incorporates some new features and connectivity options in efforts to make collaboration 
and production as easy as possible. 

This course is intended to help all users become familiar with the more advanced selection 
of features of Excel. We will cover how to create and use advanced formulas, analyze data, 
organize worksheet data with tables, visualize data with charts, work with graphical objects, 
and enhance workbooks.  

 

Course Objectives 

By the end of this course users should be comfortable in creating advanced formulas, 
analyzing data with functions, analyzing data using functions and PivotTables, working with 
tables, visualizing data with charts, working with graphical objects, and enhancing 
workbooks. 
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How to Use This Book 

This course is divided into seven lessons. Each lesson focuses on several key topics, each of 
which are broken down into easy-to-follow concepts. At the end of each topic, you will be 
given an activity to complete. At the end of each lesson, we will summarize what has been 
covered and provide a few review questions for you to answer. Supplemental learning for 
selected topics is provided in the form of Lesson Labs at the end of this book. 

Before you begin, download the course’s Exercise Files to a convenient location. They will 
be referenced throughout this course and are a key part of your learning experience. 
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LESSON 1: 
CREATING ADVANCED FORMULAS 

 

Lesson Objectives 

In this lesson you will learn how to: 

• Apply range names 

• Use specialized functions 
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TOPIC A: Apply Range Names 
To help ensure that everyone who works on the same workbook can understand the 
formulas and calculations, one option is to use cell and range names. While cell references 
can be used to identify where formulas are getting information to calculate data, it is not 
always obvious. Excel allows you to give names to individual cells and cell ranges, and then 
use those names in formulas and functions. Then, at a glance you can understand what data 
is being used in a formula or function.  

 

Topic Objectives 

In this session, you will learn: 

• About cell and range names  

• How to add range names using the Name box and the New Name dialog box 

• How to edit and delete range names  

• How cell and range names are used in formulas  
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Range Names 

Range names are meaningful labels that you can assign to individual cells or cell ranges. You 
can use a range name anywhere you would use a cell reference or cell range reference. This 
means you can use a name such as “Employees” to describe a range of cells rather than 
their reference (such as C2:C55).  

For example, consider the following worksheet. Cells A2 and B2 have been given names 
(TotalSales and TotalExpenses, respectively) and those names have been used in a formula 
in cell C2 (=TotalSales-TotalExpenses): 
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As an added bonus, range names are absolute references. This means that if you copy a 
formula or use AutoFill while using named ranges, the formula will maintain its original cell 
references: 

 

Range names make formulas much more readable, improve worksheet clarity, and greatly 
improve worksheet organization. Range names can even help in the overall design of your 
worksheet. 

Most small worksheets are usually constructed by filling a sheet with data and then 
performing calculations. However, range names enable you to create a worksheet by doing 
the opposite: constructing formulas and then adding the data. When you are designing your 
worksheet, you can create formulas using names instead of traditional cell references, and 
then define the names for the corresponding ranges as data becomes available.  
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For example, below is an empty worksheet with a defined formula but no defined names, 
which results in a #NAME error. This error will remain visible until both “Value1” and 
“Value2” have been defined: 

 

Keep in mind when choosing cell or range names that all names must start with a letter, 
underscore, or backslash. Beyond the first character, you can add any letter or number you 
wish. Additionally, names cannot contain any spaces, nor can they contain cell references. 
Finally, it is important to know that cell and range names are not case-sensitive.  
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Adding Range Names Using the Name Box 

To apply a cell name or range name, first use your cursor to select the cell(s) that you want 
to name. Next, type the name that you would like to use into the Name Box:  

 

Pressing Enter will apply this name. From then on, you will be able to select this range by 
clicking the Name Box drop-down menu and clicking on the range name that you set:  
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Adding Range Names Using the New Name Dialog Box 

Cells and cell ranges can also be named using the New Name dialog box. While this 
technique takes a little bit longer, you have more control over what cells the name refers to. 
To open the New Name dialog box, click Formulas → Define Name:  

 

When the New Name dialog box is displayed, you will see that the Name field appears at 
the top. The Scope drop-down menu allows you to choose if this new name will be applied 
to only the current worksheet or the entire workbook. Inside the Comment text area, you 
can enter a brief description of the named cell or range. By default, the cells that were 
selected when the Define Name command was clicked will already be filled into the Refers 
to field. If you wish, you can change this selection by clicking on the cell selector ( ):  
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Once you enter your options and click OK, the named range will be created. 

 

Clicking the New button will open the New Name dialog box, which you can use to create a 
new range name:  
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If you select a name from the list in the Name Manager dialog box and then click the Edit 
button, the Edit Name dialog box will be shown:  

 

This dialog box is identical to the New Name dialog box; the only difference is that it will be 
prepopulated with information from the selected range name.  

To delete a range name, click to select the range name in question and then click the Delete 
button:  

 

A dialog box will then open to ask you to confirm this action. Click OK to complete the 
deletion process.  
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Finally, the Filter command is used to show only certain ranges based on specified criteria:  

 

This is particularly useful when working with a workbook that contains a large amount of 
range names, as you can quickly narrow down the list to only those ranges that you would 
like to work with.  

 

Using Range Names in Formulas 

Cell and range names are not just useful in keeping your workbooks more organized; they 
can also help immensely in the creation of formulas. This is because after you have defined 
a cell or range name, you are able to use that name in place of the usual cell reference. This 
makes formulas much more readable.  

For example, below you can clearly and quickly see what this formula does. If it used 
standard cell references, it would be more difficult to understand:  

 

Perhaps one of the easiest methods to enter cell and range names into a formula is to use 
the Formula AutoComplete feature. In the same way the AutoComplete feature suggests 
function names based on the first few characters that you type into the Formula Bar, it will 
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also suggest cell and range names in a small menu. Double-clicking on a suggestion in this 
menu will insert it into the formula:  

 

You can differentiate names from functions and other objects suggested by the small tag 

icon that appears by each name ( - function, - named cell or range,  - table). 

In addition to manually entering cell and range names, you can also utilize the Use in 
Formula command to insert existing cell and range names into formulas. To access this 
command, click Formulas → Use in Formula:  

 

This action will display a drop-down menu listing all of the existing cell and range names. 
Clicking on an option will insert its reference into the Formula Bar.  
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Activity 1-1: Using Range Names in Formulas 

Using the features that you learned about in this topic, you will complete a small sales 
worksheet. 

1.  To begin, open Activity 1-1 from your Exercise Files folder:  

 

2.  To create the first range name, use your cursor to select cells B4:B6:  

 

3.  Next, type “Prices” inside the Name Box. Press Enter: 
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4.  The selected range now has “Prices” as a range name: 

 

5.  Now, let’s try another method to create another range name. First, use your cursor 
to select cells C4:C6:  

 

6.  Next, click Formulas → Define Name:  
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7.  The New Name dialog box is now displayed. Ensure that “Quantity” appears inside 
the Name text box and that the Scope drop-down menu is set to Workbook. Click 
OK:  

 

8.  The selected range now has “Quantity” as a range name: 

 

9.  You have one more range name to create. Use your cursor to select cells D3:D6: 
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10.  Click Formulas → Create from Selection: 

 

11.  In the Create Names from Selection dialog box, ensure that the “Top row” 
checkbox is selected and click OK: 

 

12.  Next, you need to create a formula that will calculate the cost of the items 
(Quantity*Prices). Select cell D4:  
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13.  Click inside the Formula Bar and type “=”: 

 

14.  Next, type “Prices” followed by an asterisk:  

 

Note that because Prices is a range name, its text will appear blue in the Formula 
Bar and blue shading will appear around that range of data on the worksheet.  



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

30 

15.  Still inside the Formula Bar, type “Q” and then double-click the Quantity result 
from the small menu that appears:  

 

16.  The Quantity name now appears within the Formula Bar in red text, with its 
associated range shaded in red in the worksheet: 
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17.  Press Enter to apply the formula. You will see the results appear in cells D4 through 
D6:  

 

(You may receive a “Formula Spilled” alert, indicating that the formula returned 
multiple values, so they were spilled into the neighboring blank cells. Because each 
of the named ranges contains more than one value, Excel must predict the correct 
calculation for each value.) 

18.  Save the current workbook as Activity 1-1 Complete and then close Microsoft 365 
Excel to complete the exercise. 
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TOPIC B: Use Specialized Functions 
A function is a predefined formula that is available in Excel and performs a specific 
calculation based on specified values, called arguments. While the basic functions in Excel 
cover the majority of use cases, there are some situations where a specialized function is 
more appropriate. To find and use specialized functions, you must be familiar with their 
syntax and understand how they work on a fundamental level. 

 

Topic Objectives 

In this session, you will learn: 

• About function categories  

• About function syntax 

• About function entry dialog boxes  

• How to use nested functions  

• About automatic workbook calculations  

• How to show and hide formulas  

• How to enable iterative calculations 

• About finding Excel Functions 
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Function Categories 

Every built-in function that is available in Excel has been categorized into one of 12 
standard categories. These categories are available on the Formulas tab, with some 
categories available under the More Functions drop-down menu:  

 

(Note that you can expand the number of standard categories using add-ons.)  

Here is a list of what types of functions each of the available categories contains: 

Financial This category contains dozens of functions that can be used to 
calculate financial data such as compound interest, rates of return, 
and depreciation. 

Logical The functions in this category are used to return values that are 
either true or false. Typically, these functions are used in 
conjunction with other formulas.  

Text Functions in this category are used to manipulate text. For 
example, you will find functions that will replace text or convert 
text to uppercase.  

Date & Time These functions can be as simple as calculating the current date to 
calculating the number of workdays in a year. 

Lookup & 
Reference 

The functions in this category are used to find specific values in a 
specified range or table. 

Math & Trig This category includes a variety of common mathematical 
functions. 
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Statistical The functions in this group are used to perform a variety of 
statistical analysis tasks. For example, you will find functions to 
calculate mean and median data.  

Engineering This category includes functions that are commonly used in 
engineering settings. 

Cube The functions in this category are used to perform complex data 
analysis using OLAP (Online Analytical Processing) cubes. 

Information Functions in this category give you information about the 
worksheets in your workbook and the data that they contain. For 
example, one function has the ability to determine the type of data 
in a cell. 

Compatibility The functions in this category are unique in that they are actually 
older versions of functions that are still available. Such functions 
are useful if you are working with workbooks that were created in 
older versions of Excel.  

Web The functions found in this category are used to return data from 
web services, return data from XML content, and return URL-
encoded string data.  
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Function Syntax 

To successfully use functions in Excel, you must first understand the required values for the 
function, and the order in which they are used. This is known as syntax. Excel displays the 
syntax of a function by first stating the function, then, in brackets, listing the required 
arguments. Any argument enclosed in square brackets ([]) is optional, where all other 
arguments are required. Whenever you are entering a function, either in a cell or in the 
Formula Bar, Excel will display the function syntax in a ScreenTip, and the current argument 
will be bold: 

 

Functions are a major part of what makes Excel so popular, so now we will explore some 
different types of functions and learn some tricks that you can use to perform complex 
calculations. Just keep in mind that even the most complex of formulas can be broken down 
into simple parts. Remember to pay attention to the order of precedence (using the 
BEDMAS acronym) and the number of parentheses you use.  

The SUMIF Function 

=SUMIF(range, criteria, [sum_range]) 

The SUMIF function is used to calculate the sum of values in a specified range if they meet a 
specified criteria. For example, you could calculate total sales figures and only include 
numbers that are less than a specified value. The sum_range argument is optional; you can 
use it if you want to add cells to the sum other than those specified in the argument. If you 
choose to leave out this argument, the function will only calculate the sum of the values 
from the previous range argument. 
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Below are some example of the SUMIF function in action:  

Function Description 

=SUMIF(A1:C10, “<5”) Only numbers in the range A1:C10 that are 
under 5 will be added together. 

=SUMIF(A1:C10, “December”, D1:D10) Only numbers in the range D1:D10 will be 
added together where they correspond with 
the text entry of “December” in the range 
A1:C10.  

=SUMIF(A1:A10, 5) All numbers with the value of 5 that fall within 
the A1:A10 range will be added together. 

 

The AVERAGEIF Function 

=AVERAGEIF(range, criteria, [average_range]) 

The AVERAGEIF function will return the average of every cell within a range if the specified 
criteria are met. For example, if you want to calculate the average sale amount in a set 
range of sales data only for sales below a certain amount you could use this function. The 
average_range argument is optional; it can be used if you want to add cells to the sum 
other than those specified by the range argument. If you choose to leave out this argument, 
the function will only calculate the average of the values from the range argument.  

Below are some AVERAGEIF functions in action: 

Function Description 

=AVERAGEIF(A1:C10, “<5”) The average of all numbers in the range A1:C10 
that are under 5 will be calculated. 

=AVERAGEIF(A1:C10, “December”, 
D1:D10) 

The average for the numbers in the range D1:D10 
will be calculated where they correspond with 
the text entry of “December” in the range 
A1:C10.  
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The COUNTIF Function 

=COUNTIF(range, criteria)  

The COUNTIF function will count the number of cells in a specified range if the criteria are 
met. For example, this function could be used to count the number of sales associates who 
have sold X number of products.  

Function Description 

=COUNTIF(A1:C10, “<5”) This function will count all cells within the A1:C10 
range where the value is 5 or lower. 

=COUNTIF(A1:A10, 5) This function will count all cells within the A1:A10 
range only where the value is 5. 

 

IFS Functions 

The functions that have been covered so far (AVERAGEIF, COUNTIF, and SUMIF) all have an 
equivalent IFS function that allow you to perform those respective calculations on data that 
requires more than just one specified criteria.  

With a few exceptions, such functions have very similar syntax:  

=SUMIFS(sum_range, criteria_range1, criteria1, [criteria_range2], [criteria2], …) 

=AVERAGEIFS(average_range, criteria_range1, criteria1, [criteria_range2], [criteria2], …) 

=COUNTIFS(criteria_range, criteria1, [criteria_range2], [criteria2], …) 
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The COUNTA Function 

=COUNTA(value1, [value2],…) 

The COUNTA function is used to count the number of cells specified by the argument 
(value1, value2, etc.) that are not empty.  

Function Description 

=COUNTA(A1:A10) All cells that contain data within the A1:A10 cell range 
will be counted. 

=COUNTA(A1:A10, B1, C1) All cells that contain data within the A1:A10 range, as 
well as cells B1 and C1, will be counted. 

 

 

Finding Excel Functions 

While you become familiar with Excel functions, you may find it challenging to know which 
function to use in specific situations. In such cases tools are available to help you identify an 
appropriate function for your purpose.  

One option is the Search for a function feature in the Insert Function dialog box: 
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As the Search for a function textbox suggests, type a brief description of what you want to 
do and then click Go. Excel will offer matching suggestions in the Select a function list. 
Clicking a function will display the syntax and provide a brief description: 

 

You can also select a function category from the Or select a category drop-down list. This 
will display a list of available functions in that category, in alphabetical order, in the Select a 
function list: 
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Once you have selected the appropriate function, click OK to open the Function Arguments 
dialog box, where you can define the required parameters: 
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Function Entry Dialog Boxes 

Functions can be entered into a worksheet using a number of different methods. Perhaps 
the most straightforward way is to type the function directly into the Formula Bar – in the 
same way that you would type a regular formula. For example, if we want to use the SUM 
function to calculate the sum total of the values inside the A1:A6 range, we would select the 
cell where the result will be displayed and type “=SUM(A1:A6)” into the formula bar:  

 

  



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

42 

Pressing Enter or clicking the Enter button will then enter the function into your worksheet 
and then produce the result: 
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While manually entering a function into the Formula Bar can often be the fastest way to 
enter a function, it is sometimes a difficult method to take advantage of when you are 
unsure of a function’s syntax. In such cases, you want to open the Insert Function dialog 
box. To open this dialog box, first select the cell in which you want the result of the function 
entered and then click Formulas → Insert Function, or click the Insert Function button that 
is beside the Formula Bar:  

 

The Insert Function dialog box provides you with a search area (1) that you can use to find a 
particular function that you need, as well as a category drop-down menu (2) that displays 
all of the functions that belong to a specified category: 
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Near the bottom of this dialog box you will see a list of functions (3) that are shown based 
on your search or the category that you selected. Clicking any of the functions that are 
listed here shows you a preview (4) of what the syntax for the selected function is and a 
brief description of what that function is used for.  

Once you find and select a function, click OK to enter it into your worksheet. This action 
typically displays the Function Arguments dialog box: 

 

Using the controls in this dialog box, you are able to (1) add arguments to the function that 
you selected. For this example, as we are working with the SUM function, we are able to 
choose data ranges that will be entered into the function for us. You will also see (2) a 
description of the current argument and the result in the middle section of the dialog box. 
You will also see (3) the formula result and have access to a link at the bottom of the dialog 
box to get help on the function.  

Clicking the OK button will enter the function into the worksheet using the arguments that 
you selected.  
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Using Nested Functions 

Some situations require that a function be nested inside of another function. This means 
that you are using the results of the nested function as arguments. For example, here is an 
example of a nested function:  

=IF(SUM(A1:A5)>10, SUM(A6:A10), 0) 

In this example, two SUM functions have been nested inside of a single IF function. The way 
this example works is that IF the SUM of data in cells A1:A5 is greater than 10, then this 
formula will SUM the values of cells A6:A10 and display that result. IF the SUM of data in 
cells A1:A5 is less than 10, then “0” will be displayed instead.  

 

Automatic Workbook Calculations  

By default, Excel workbooks will calculate the results of formulas automatically. 
Occasionally, you may want to switch your workbook calculations to manual recalculation 
so that you have more control over when formulas are calculated. Typically you would do 
this if you are working with a particularly large workbook and the response times in Excel 
are slowed when you change a value and numerous formulas calculate the results of this 
change at the same time.  

To change the calculation options, click Formulas → Calculate Options. This drop-down 
command includes the Automatic (default), Automatic Except for Data Tables, and Manual 
options:  

 

If you switch to the Manual option, you can then calculate formulas in your workbook 
manually by clicking Formulas → Calculate Now:  
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Alternatively, you can also choose to calculate only those formulas on the current 
worksheet by clicking Formulas → Calculate Sheet:  

 

 

Showing and Hiding Formulas  

To make creating and reviewing worksheets a bit easier, you can show the formulas (instead 
of the result) on the worksheet and the printed page. To do this, click Formulas → Show 
Formulas: 

 

This action shows formulas within the sheet instead of the calculated results: 
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Enabling Iterative Calculations 

While you would typically want to avoid circular references (formulas that refer to cells that 
contain the same formula), there are situations where this is desirable. In Excel, you are 
able to accommodate such situations by enabling iterative calculations and choosing the 
exact number of iterations required. Iterative calculations are those calculations that repeat 
until a desired condition is reached. Typically, these are used when building more complex 
calculations, such as those used to calculate tax accrual.  

To enable iterative calculations, first open the Excel Options dialog box by clicking File → 
Options. Next, display the Formulas category. Finally, check the Enable iterative calculation 
check box:  

 

With iterative calculation enabled, any formulas that contain circular references will 
calculate up to the value found in the Maximum Iterations increment box (100 by default). 
The Maximum Change text box contains the maximum change value (.001 by default) to 
control how much the results change.  
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 Activity 1-2: Using Specialized Functions 

You have a large worksheet that contains the details of dozens of loans. A payment rate for 
each loan must be calculated according to the terms that have been provided for each. You 
will use the PMT function and the Function Arguments dialog box to complete this task.  

1.  To begin, open Activity 1-2 from your Exercise Files folder:  

 

2.  First, click to select cell G3: 
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3.  Next, click Formulas → Financial → PMT:  

 

4.  The Function Arguments dialog box appears. Within this dialog box you need to 
enter all of the arguments. As the interest rate is stored in cell E3, type “E3” into 
the Rate text box:  
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5.  As these are annual interest rates and the payments will be monthly, you need to 
divide this value by 12. Type “/12” following the cell reference in the Rate text box:  

 

6.  The next argument is Nper, or the number of payment periods over the life of the 
loan. This information is contained in cell D3, but it is provided in years. Because 
you need to enter it as months, type “D3*12” into the Nper text box: 
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7.  The next argument is Pv, or present value. This is the amount of money that is 
being borrowed. This information is contained in cell C3, so type “C3” into the Pv 
text box: 

 

8.  Leave the Fv (Future Value) argument field empty. This argument will default to 0, 
which is what we want. (This means there will be no part of the loan left 
outstanding at the end of the payments.) We will also let the Type field default to 
0, meaning payments will be due at the end of the payment period. Click OK to 
create the function: 
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9.  You now have a result in the cell G3. You will also see the PMT function in the 
Formula Bar: 

 

10.  Now it is time to enter this formula for the rest of the data rows. To do this, click 
cell G3 to make it active, and then drag the AutoFill handle in the lower right 
corner of the cell down to G94: 
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11.  Release the mouse button. You will see that the loan payments for each entry have 
been calculated:  

 

12.  Save the current workbook as Activity 1-2 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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Summary 
In this lesson you learned about range names and how to apply them. Additionally, you 
learned about the different function categories and specialized functions that are available. 
You should also now be familiar with function syntax, nested functions, automatic 
workbook calculations, and iterative calculations. 

 

 

Review Questions 
1. For a selected range, where do you type in a new range name? 

 

2. How many function categories are there in Microsoft 365 Excel? 

 

3. What is the command sequence to show formulas rather than calculated values in 
cells? 

 

4. What is a nested function? 

 

5. What is the command sequence to change workbook calculations to manual? 
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LESSON 2: 
ANALYZING DATA WITH LOGICAL AND 

LOOKUP FUNCTIONS 

 

Lesson Objectives 

In this lesson you will learn how to: 

• Use text functions 

• Use logical functions  

• Use lookup functions  

• Use date functions  

• Use financial functions 
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TOPIC A: Use Text Functions 
Now that you are familiar with Excel’s more commonly used functions, you will learn about 
some of its more specialized ones. In this topic you will learn about functions that are 
specific to text analysis.  

 

Topic Objectives 

In this session, you will learn: 

• About text functions  

• About LEFT and RIGHT functions  

• About the MID function  

• About the LEN function  

• About the TRIM function  

• About the UPPER, LOWER, and PROPER functions 

• About the TEXTJOIN function  

• About the TRANSPOSE function 
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Text Functions 

Text functions are used in Excel to analyze text-based worksheet data. While such functions 
can be used for data analysis, they are typically used instead to prepare data for analysis. 
This is because they allow you to format textual data for use in other areas. For example, 
you can use text functions to import textual data from another workbook and format it so 
that it meets the formatting requirements for the destination workbook.  

 

The LEFT and RIGHT Functions 

=LEFT(text, [num_chars])  

=RIGHT(text, [num_chars])  

The LEFT and RIGHT functions are used to return a specific number of characters from 
either the left or the right side of a text string. Typically, these functions are used in 
situations where you need to transfer text to a destination where there is a limit on the 
number of characters each entry may have. The text argument is used to declare which text 
you would like to transfer, while the [num_chars] argument is used to declare how many 
characters you would like transferred.  
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Suppose that cell A1 contains “John Smith” as a text string in a worksheet. Examine the 
possible examples of how the LEFT and RIGHT functions would work with this data: 

Function Description 

=RIGHT(A1) As the num_chars argument was not set in this function, it will 
default to one character. This means that the output for this 
function would be “h” – the last letter on the far right of the text 
string. 

=RIGHT(A1, 5) With the num_chars argument set to 5, this function would result 
in “Smith” as an output – the last five letters on the far right of 
the text string.  

=LEFT(A1, 5) With the num_chars argument set to 5, this function would result 
in “John ” (including the space) as an output – the first five letters 
on the far left of the text string.  

=LEFT(“John”) This function would return only “J” as an output because the 
num_chars argument was not set. 

 

 

The MID Function 

=MID(text, start_num, num_chars) 

Similar in use and design to the LEFT and RIGHT functions, the MID function returns 
characters from the middle of a text string. As with the LEFT and RIGHT functions, the text 
argument is used to reference the cell(s) with the text string in question or to enter a text 
string directly into the function surrounded by double quotation marks. The start_num 
argument is unique to the MID function as it tells the function which character in the text 
string to start with. The num_chars argument then allows you to set the number of 
characters that you would like to return from the starting point that you set in the previous 
argument. Keep in mind that while the num_chars argument behaves the same as it does in 
the LEFT and RIGHT functions, it is required in order for the MID function to operate 
correctly.  
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Suppose that A1 contains “John Smith” as a text string in a worksheet. Examine the possible 
examples of how the MID function would work with this text string:  

Function Description 

=MID(A1, 5, 5) In this case, the text is contained within cell A1. The start_num 
argument is set to 5, so the function starts five characters 
(including spaces) into the text string. The num_chars 
argument is set to five so the five characters after the starting 
position will be returned. This means that “Smith” would be 
the output for this formula. 

=MID(A1, 1, 4) In this case, the text is contained within cell A1. The start_num 
function is set to 1, so the function starts at the beginning of 
the text string. The num_chars argument is set to 4 so the four 
characters after the starting position will be returned. This 
means that “John” would be the output for this formula. 

 

 
The LEN Function 

=LEN(text) 

The LEN (short for length) function’s sole purpose is to return the number of characters that 
appear within a text string. While there can be many uses for this function, it is typically 
used to ensure that text strings are of the correct length. For example, you could use this 
function to make sure that all of the text data within a row is under a specified length. The 
only argument in this function, text, is used to specify where the text data that you would 
like to count is stored.  
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Suppose that A1 contains “John Smith” as a text string and B1 contains “Jane Doe” as a text 
string. Examine the possible examples of how the LEN function would work with this 
information in mind: 

Function Description 

=LEN(A1) In this case the LEN function has the text argument set to A1. This means 
that a count of the text string within this cell will be returned. The output 
of this function would then be 10. 

=LEN(B1) In this case the LEN function has the text argument set to B1. This means 
that a count of the text string within this cell will be returned. The output 
of this function would then be 8. 

 

 

The TRIM Function 

=TRIM(text) 

The TRIM function is used to remove any empty spaces from text strings, excluding spaces 
between words. This function can be very useful in solving data compatibility issues. For 
example, a frequent problem in data entry is random spaces at the beginning or end of a 
text string. Such problems can greatly affect your ability to work with text-based data.  

Note that the only argument in this function, text, is used to specify where the text data 
that you would like to work with is stored. 
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Suppose that A1 contains “ John Smith” as a text string and B1 contains “Jane ” as a text 
string. Examine the possible examples of how the TRIM function would work with this 
information in mind: 

Function Description 

=TRIM(A1) In this case the TRIM function has the text argument set to A1. “John 
Smith” will be returned with all of the spaces at the beginning of this text 
string removed. 

=TRIM(B1) In this case the TRIM function has the text argument set to B1. “Jane” will 
be returned with all of the spaces at the end of this text string removed. 

 

 

The UPPER, LOWER, and PROPER Functions 

=UPPER(text) 

=LOWER(text) 

=PROPER(text) 

The UPPER, LOWER, and PROPER functions are used to change the casing of text-based 
data. The UPPER function converts all lowercase characters into uppercase, while the 
LOWER function will do the opposite. The PROPER function will only capitalize the first 
character of each word in a text string. For all of these functions, the only argument is text. 
This is used to indicate the text-based data that you would like this function to work with.  
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Suppose that A1 contains “John Smith” as a text string and B1 contains “jANe smiTh” as a 
text string. Examine the possible examples of how the UPPER, LOWER, and PROPER 
functions would work with this information in mind: 

Function Description 

=UPPER(A1) In this example, the UPPER function converts all of the text within cell 
A1 to uppercase. This means that the output would be “JOHN SMITH”. 

=LOWER(A1) In this example, the LOWER function converts all of the text within cell 
A1 to lowercase. This means that the output would be “john smith”. 

=PROPER(B1) In this example, the PROPER function ensures that only the first 
character in each word in cell B1 is capitalized. This means that “Jane 
Smith” would be the resulting output. 

 

 
The TEXTJOIN Function 

=TEXTJOIN(delimeter, ignore_empty, text1, [text2], …) 

The TEXTJOIN function allows you to combine (concatenate) text strings together from 
multiple cells into a single cell. This function can save you an enormous amount of time if 
you need to combine data from multiple sources into one cell.  

The delimiter argument is used to define a text string (empty, or one or more characters) 
that will separate the text strings you are joining. The ignore_empty argument is either 
TRUE (default) or FALSE and allows the function to ignore empty cells that are defined by 
the text arguments. Finally, the text arguments allow you to define the text strings, or 
ranges of strings that you want to join. 
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Suppose that A1 contains “John Smith” as a text string, B1 is blank, and C1 contains “Jane 
Doe” as a text string. Examine the possible examples of how the TEXTJOIN functions would 
work with this information in mind: 

Function Description 

=TEXTJOIN( “, “, TRUE, A1, B1, C1) In this example, the TEXTJOIN function combines 
cell A1, add a comma and a space, ignore cell B1 
because it is empty, then add cell C1. The output 
would be “John Smith, Jane Doe”. 

=TEXTJOIN( “, “, FALSE, A1, B1, C1) In this example, the TEXTJOIN function combines 
cell A1, add a comma and a space, add another 
comma and space for cell B1, because the empty 
cell is not ignored, then add cell C1. The output 
would be “John Smith, , Jane Doe”. 

TEXTJOIN( , TRUE, A1, B1, C1) In this example, because the delimiter argument is 
empty, the TEXTJOIN function combines cell A1, 
ignore cell B1, because the ignore_empty 
argument is TRUE, then add cell C1. The output 
would be “John SmithJane Doe”. 
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The TRANSPOSE Function 

=TRANSPOSE(array) 

The Transpose function shifts a vertical range of cells to a horizontal range or vice versa. To 
operate correctly, this function needs to be entered as an array formula in a range that has 
the same number of rows and columns.   

For example, suppose that you wanted to transpose the values in column A so that they 
appear horizontally on row 1:  
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To do this, first select the destination cells that you would like the results to be shown in:  

 

Next, you would enter the transpose function into the Formula Bar with the original cell 
range as the argument – in this case it would be “=TRANSPOSE(A1:A5)”:  

 



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

66 

Press Ctrl + Shift + Enter to enter this function as an array formula and the results will be 
displayed within the selected cells:  
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Activity 2-1: Analyzing Data Using Text Functions 
Using some of the text functions that you have learned about in this session, you would like 
to automate portions of an invoice form to decrease the time needed for data entry. 

1.  To begin, open Activity 2-1 from your Exercise Files folder:  

 

2.  First you would like to find the first initial from the first name that is entered into 
column A. Click to select cell C2 and type “=LEFT(A2)” into the Formula Bar: 

 

3.  Press the Enter key on your keyboard and you will see that the previously selected 
cell now displays the initial from the first name (“J” in this case): 
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4.  Next, you need to do the same thing and find the first initial from the last name 
that is entered into column B. Click to select cell D2 and type “=LEFT(B2)” into the 
Formula Bar: 

 

5.  Press the Enter key on your keyboard and you will see that the previously selected 
cell now displays the initial from the last name (“S” in this case): 

 

6.  Now you need to use the TEXTJOIN function to fill in the Full Initials column. Click 
to select the E2 cell and then type “=TEXTJOIN(,TRUE,C2,D2)” into the Formula 
Bar: 
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7.  Press the Enter key and you will see that the values from cells C2 and D2 have been 
combined to show the full initials: 

 

8.  Finally, you would like to automatically fill in the shipment method based on the 
number of characters that appear in the invoice number. If the invoice has more 
than five characters, then it is designated a rush order and if it is five characters or 
less, it is a standard order. Select H2: 

 

9.  Type “=IF(LEN(G2)>5, "RUSH", "STANDARD")” into the Formula Bar: 

 

10.  Press the Enter key on your keyboard and you will see that this particular order is a 
rush order because its invoice number is more than five characters: 

 



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

70 

11.  Use the Auto Fill feature to copy the formulas that you entered during this activity 
into the adjacent cells in row 3:  

 

12.  Save the current workbook as Activity 2-1 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC B: Use Logical Functions 
Logical functions are used to ask yes or no questions related to your data. In this session you 
will learn all about the logical functions that are available in Excel 365, including the AND, 
OR, and IF functions.   

 

Topic Objectives 

In this session, you will learn: 

• About logical functions  

• About logical operators 

• About the AND function  

• About the OR function  

• About the IF function 

• About the IFS function 
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Logical Functions 

Excel contains a collection of logical functions that allow you to essentially ask yes or no 
questions related to your data. Such questions return a positive (TRUE) or negative (FALSE) 
response. Logical functions also allow you to perform calculations when certain conditions 
are met. For example, logical functions could be used to ask your data if the sales 
department met its goals for this quarter, or it could be used to find out if the sales 
department met its goal, and if so, what the bonus would be for the team members.  

 

Logical Operators 

Logical operators are used to compare two values against one another to see if they meet a 
specified logical condition. For example, should the values meet the logical condition (2 > 1) 
then the output would be the logical value of TRUE. If the values do not meet the logical 
condition (2 < 1), then the output would instead be FALSE. Due to this behavior, logical 
operators are instrumental in constructing conditions for functions and calculations to run 
correctly.  

  



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

73 

Below you will find a table with all of the logical operators that are available in Excel 365 
and what they do: 

Operator Symbol Examples with TRUE Result 

Equal to = 1 = 1 

Greater than > 2 > 1 

Less than < 1 < 2 

Greater than or equal to >= 2 >= 2 
3 >=2 

Less than or equal to <= 2 <= 2 
1 <=2 

Not equal to <> 1 <> 2 

 

 

The AND Function 

=AND(logical1, [logical2], …) 

This function returns a TRUE value when all of the arguments are true. On the flipside, it 
returns a FALSE value when any of the arguments in this function are false. While there can 
be a varied amount of use cases for this function, you would typically use it for conditional 
purposes. For example, you could use this function to check whether all of the departments 
in an organization have met all of their goals for the current quarter.  

The first argument that is required in this function is logical1. You can have up to 30 of 
these arguments in one AND function with each argument separated by a comma. These 
arguments are where you enter the logical values and operators that you would like to test 
for (e.g. A1>B2). Additionally, you also have the option of entering a formula as a single 
argument.  
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Suppose that A1 contains the value of 15, while cell B1 holds the value 20, and C1 contains 
25. Additionally, assume that D1 holds the logical value of FALSE: 

 

 

Function Description 

=AND(A1<B1, B1>C1) While the value of A1 is less than the value in B1, B1 is actually 
less than C1. As not all of the arguments in this function are 
true, the AND function will output FALSE.  

=AND(A1<B1, B1<C1) The value of A1 is less than B1, and similarly the value of B1 is 
less than C1. As all of the arguments in this AND function have 
returned as true, the output for this function would be TRUE.  

=AND(D1) The value of D1 holds the logical value of FALSE so the output 
of this AND function would also be FALSE.  

=AND(2*2=4) In this function a simple equation has been added as an 
argument. As this equation is correct (2X2=4) the output from 
this AND function would be TRUE. 

 

The OR Function 

=OR(logical1, [logical2], …) 

The OR function is similar to the AND function with one key difference: the OR function 
returns a TRUE value if any of the arguments evaluate to TRUE. With the same 30 
arguments limit as the AND function, the OR function is constructed in the same manner 
and supports the same items (formulas, cell references, etc.). Typically, this function would 
be used to determine if there is a TRUE value in a group of data. For example, you could use 
it to quickly see if anyone in your sales department has made sales over a particular dollar 
amount in any one of the four months of this quarter.  
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Suppose that A1 contains the value of 15, while cell B1 holds the value 20, and C1 contains 
25. Additionally, assume that D1 holds the logical value of FALSE: 

 

 

Function Description 

=OR(A1<B1, B1>C1) While the value of A1 is less than the value in B1, B1 is 
actually less than C1. Even though only one of the arguments 
in this function has returned as TRUE, the OR function will still 
output TRUE.  

=OR(A1<B1, B1<C1) The value of A1 is less than B1, and similarly the value of B1 is 
less than C1. As all of the arguments in this OR function have 
returned as true, the output for this function would be TRUE.  

=OR(D1, A1<5) The value of D1 holds the logical value of FALSE and the data 
in A1 is not less than 5, so both of these arguments resolve to 
FALSE. This means that the output for this OR function would 
also be FALSE.  

 

 
The IF Function 

=IF(logical_test, [value_if_true], [value_if_false]) 

The IF function is one of the most commonly used logical functions. It sets a cell value based 
upon whether a logical test resolves to be true or false. For example, you could use this 
function to test if a salesperson in your organization exceeded a sales goal. If that resolves 
to true, then this function could output a bonus amount. If it resolves to false, then this 
function could output a zero amount.  
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The IF function has three arguments: logical_test, value_if_true, and value_if_false. The 
logical_test argument is where you create the condition that you would like to test. The 
value_if_true argument will be the output of this function if the condition is found to be 
true. Similarly, the value_if_false argument will be the output if the condition is found to be 
false. Keep in mind that the value arguments in this function can hold both text and 
numerical data; however, all text data must be enclosed in double quotation marks. 

Suppose that A1 contains the value of 15, while cell B1 holds the value 20, and C1 contains 
25. Additionally, assume that D1 holds the logical value of FALSE: 

 

 

Function Description 

=IF(A1<B1, “Yes”, “No”) In this example, A1 is in fact less than B1 so this 
function would output Yes.  

=IF(A1<B1, B1*C1, “No”) In this example, A1 is less than B1 so this function 
would output the result of the B1*C1 formula - 500 in 
this case.  

=IF(A1>B1, “Yes”, “No”) In this example, A1 is less than B1 so this function 
results in No as the output. 

 

The IFS Function 

=IFS(logical_test1, value_if_true1, [logical_test2], [value_if_true2], …) 

The IFS function is an evolution of the IF function that was introduced in Excel 2016. It is an 
alternative to using nested IF functions, where you want to test multiple conditions and 
return multiple results based on those conditions. It is much easier to use and much easier 
to understand than a complex nested IF function, and you should keep it mind as you begin 
to use more complex logical analysis in your workbooks. 
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The IFS function only has two required arguments: logical_test1, and value_if_true1. Each 
argument is similar to those in the IF function, but the benefits of the IFS function are 
realized when you begin to add additional arguments. The IFS function checks whether the 
first condition (logical_test1) is true, and, if so, returns the value_if_true1 argument. If the 
first condition is false, it moves to the next condition and performs the same analysis again, 
then continues through all of the logical tests. If none of the logical tests are true the IFS 
function will return #N/A. You can prevent this outcome by making the last logical test in 
your IFS function TRUE. 

Suppose that A1 contains the value of 15, while cell B1 holds the value 20, and C1 contains 
25. Additionally, assume that D1 holds the logical value of FALSE: 

 

 

Function Description 

=IFS(A1>B1, A1, B1<C1,B1) In this example, A1 is in fact less than B1 so the 
first logical test is false. In the second logical 
test, B1 is less than C1, therefore the function 
would output the contents of cell B1, 20.  

=IFS(A1<B1, “A1”,B1<C1,”B1”) In this example, both of the logical tests are 
true. The function would output the string “A1” 
because it returns the value_if_true of the first 
logical test that is true.  

=IFS(A1>B1, A1, B1>C1,B1,TRUE,C1) In this example, both the first and second logical 
tests resolve to FALSE. The third logical test has 
been defined as TRUE, so the function would 
output the contents of cell C1, 25. 
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Activity 2-2: Analyzing Data Using Logical Functions 
You have been tasked with maintaining a worksheet that is used to determine whether 
employees qualify for a bonus. Use the functions you learned about in this lesson to 
determine which employees will receive a bonus and complete the data in the ID column. 

1.  To begin, open Activity 2-2 from your Exercise Files folder:  

 

2.  First you need to fill in the ID column. This data is the first name and last name 
separated by an underscore (_). While you can do this manually, the TEXTJOIN 
function is built for exactly this type of work. Select cell C5, then, in the Formula 
Bar, type “=TEXTJOIN(“_”,TRUE,A5,B5)” 

 

3.  Press Enter, to enter the formula, then select cell C5 again, hover your cursor over 
the cell handle until your cursor icon turns into a small black cross: 

 



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

79 

4.  Double click on the cell handle to automatically copy your formula down the 
column, to cell C14: 

 

5.  Next, you need to determine which salespeople are going to receive a bonus. 
Bonuses are dispensed when the representative exceeds their weekly sales goal, 
and if their call reports are complete. For this purpose, you can use the AND 
function. Use your cursor to select cells G5 on the worksheet:  
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6.  Inside the Formula Bar, type “=AND(D5="Yes",E5>F5)” and then press Enter: 

 

7.  Because both logical tests are true, the formula returns the value of TRUE in cell 
G5. Now drag the AutoFill handle at the bottom right of the cell down to cell G14:  

 

8.  All sales representatives who have met both conditions now show a value of TRUE 
in this column. To add the bonus amount to column H, first select cells H5 through 
H14:  
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9.  Inside the Formula Bar, type “=IF(G5:G14=TRUE,K2, 0)”. Because this is an array 
function, press Ctrl + Shift + Enter:  

 

10.  The bonus information has now been calculated for all employees in this 
worksheet:  

 

11.  Save the current workbook as Activity 2-2 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC C: Use Lookup Functions 
Looking up a specific value within a dataset is one of the more common tasks you will 
complete in Excel. In this session you will learn about the various lookup functions that are 
available and the situations where they can be most effective. 

 

Topic Objectives 

In this session, you will learn about: 

• The LOOKUP function  

• The HLOOKUP function 

• The VLOOKUP function 

• The MATCH function 

• The INDEX function 
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Lookup Functions 

Lookup functions are used to find and return a value by searching a corresponding row or 
column. For example, suppose that you are trying to find a product name that corresponds 
to a product number. You could use one of the lookup functions to search for the product 
number and then return the value from an adjacent column (Product Name in this case): 

 

 

The LOOKUP Function 

=LOOKUP(lookup_value, lookup_vector, [result_vector])  

The LOOKUP function requires three arguments. The first is the value that you are searching 
for, followed by the area that you would like to search, and then the corresponding range 
from which you would like the results to be shown. For example, let’s suppose that you 
want to find out the product name for product number 48948 in the following worksheet:  
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To do this using a LOOKUP function, you would use the following formula:  

 

As you can see, the value that you are looking up is entered first (48948), followed by the 
lookup area (A2:A4), and it is ended with the results area where the corresponding result is 
found (B2:B4). In this case, the result is “Keyboard:” 
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The VLOOKUP Function 

=VLOOKUP(lookup_value, table_array, col_index_num, [range_lookup]) 

The VLOOKUP (vertical lookup) function operates in a similar way to the LOOKUP function. 
It is used when you need to find things in a table or range only by row, and it does this by 
only looking for a value that appears in the left-most column of an array and then returns 
the corresponding value from any other column that you specify.  

For example, let’s suppose that you want to find the unit price for product number 15467. 
To do this, you would enter the following formula:  

 

As you can see, the value that you are looking for is entered first 15467), followed by the 
array (A1:C4). Following this is the column index number. Columns in the selected range or 
table are numbered from left to right, with the first column numbered 1, the next 2, and so 
on. In this example, as we are looking for the unit price, we entered 3 for the third column. 
Finally, you can then choose between looking for approximate or exact matches. In this 
example FALSE was chosen because we wanted an exact match.  
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The final result returned by the formula is 49.99: 

 

 

 
The HLOOKUP Function 

=HLOOKUP(lookup_value, table_array, row_index_num, [range_lookup]) 

The HLOOKUP function is very similar to the VLOOKUP function, but it works horizontally 
rather than vertically. Like the others, it is used when you need to find things in a table or 
range only by column. It does this by only looking for a value that appears in the top-most 
row of a table and then returns the corresponding value from any other row that you 
specify.  
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For example, let’s suppose that you want to find unit price for “USB Cable” product. To do 
this, you would enter the following formula:  

 

As you can see the value that you are looking up is entered first (“USB Cable”), followed by 
the lookup area (A1:D3) that includes the whole range (or table). Following this is the row 
index number. Rows in the selected range or table are numbered from top to bottom, with 
the first row numbered 1, the next 2, and so on. In this example, as we are looking for the 
unit price, we entered 3 for the third row. Finally, you can then choose between looking for 
approximate or exact matches. In this example FALSE was chosen as we wanted an exact 
match.  
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The final result is 4.99 being returned by the formula: 

 

 

The MATCH Function 

= MATCH(lookup_value, lookup_array, [match_type]) 

The MATCH function searches for a value in a range of cells and then returns its position. 
This function requires two arguments: the value that you are searching for, followed by the 
range of cells that you would like to search. Note that this function is not case-sensitive. 

You can also use the optional match_type argument to customize the function’s behavior: 

Match_Type Behavior 

1 (or omitted) Finds the largest value that is less than or equal to the lookup value. 
Requires the lookup_array argument values to be in ascending order. 

0 Finds the first value exactly matching the lookup_value argument.  

2 Finds the smallest value that is greater than or equal to the lookup 
value. Requires the lookup_array argument values to be in 
descending order. 
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For example, let’s suppose that you want to find the most expensive product in this 
worksheet: 

 

To do this using a MATCH function, you would use the following formula:  

 

We know we do not sell any products over $1,000, so we have entered that as the lookup 
value, followed by the lookup area (Column C). We have also omitted the match_type 
argument as we want the default behavior.  
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In this case, results are returned showing the most expensive product is in Row 4 of our 
dataset: 

 

 

The INDEX Function 

INDEX(reference, row_num, [column_num], [area_num]) 

The INDEX function returns a value from a table or range. It also offers an alternative 
syntax, which allows you to use it with an array: 

INDEX(array, row_num, [column_num]) 
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For example, let’s suppose that you want to find the value at the very end of this range:  

 

To do this using an INDEX function, you would use the following formula:  

 

In this case, the value in Row 4, Column 3 of the range A1:C4, 49.99 is returned: 
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Activity 2-3: Analyzing Data Using Lookup Functions 
Using a lookup function, you would like to find the total amount of sales that were made by 
a particular employee.  

1.  To begin, open Activity 2-3 from your Exercise Files folder:  

 

2.  Click cell D1 to place your cursor there:  
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3.  You would like to find out the weekly sales that Lucas made, so start by typing 
“=VLOOKUP(“Lucas”,” into the Formula Bar (without the outer most quotation 
marks):  

 



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

94 

4.  Next, you need to add the cell range that you are working with. For this example, 
type “A5:E14,” (without quotation marks), following the comma:  

 

5.  Now you need to enter the column of the data you would like to use as a result. In 
this case you want the weekly sales to be shown, so type “4,” as the Weekly Sales 
column is further from the left:  
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6.  Finally, you need to decide if you would like only exact matches to be used or 
approximate matches. For this example, you would like exact matches, so type 
“FALSE” followed by a closing parenthesis:  

 

7.  With the formula now completed, press Enter. The weekly sales that Lucas made 
will now be shown in D1:  

 

8.  Save the current workbook as Activity 2-3 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC D: Use Date Functions 
Entering the current date and time into a worksheet is one of the more common tasks that 
you will complete using Excel. In this topic, you will learn how to add date information using 
the TODAY and NOW date functions.  

 

Topic Objectives 

In this session, you will learn: 

• About the TODAY function  

• About the NOW function  

• How to serialize dates and times with functions 
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The TODAY Function 

About as simple as a function can get, the TODAY function has no arguments: 

=TODAY() 

When executed, it will simply print today’s date into a cell:  

  

  



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

98 

The NOW Function 

The NOW function is also very simple and uses no arguments: 

=NOW() 

It prints the current date and time into the cell where the function is placed:  

 

Usually this function would be used in conjunction with others to complete time 
calculations. 
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Serializing Dates and Times with Functions  

If you are using formulas where you only need the month or a specific time of day, there are 
a number of different functions that you can use to gather that information from an original 
date or time serial value. For example, here you can see the YEAR, MONTH, DAY, HOUR, 
MINUTE, and SECOND functions serializing the date in A1 and the time in A2:  

 

Each of these functions only accept one argument – a reference to the cell that contains the 
date or time value. For example, here you can see the syntax of a YEAR function pointing to 
cell A1:  

=YEAR(A1) 
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Activity 2-4: Analyzing Data Using Date Functions 
You would like to fill out an invoice tracking sheet using some of the date functions that you 
learned about in this topic. 

1.  To begin, open Activity 2-4 from your Exercise Files folder:  

 

2.  Ensure that cell B2 is selected and then type “TODAY()” into the formula bar:  

 

3.  Press Enter and the current date will be shown as a value in previously selected 
cell:  
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4.  Click cell C2 and type “=NOW()” into the formula bar:  

 

5.  Press Enter and the current date and time will be the value shown in the previously 
selected cell:  
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6.  Select cell C2 once again. Change the number format to Time by clicking Home → 
Number Format → Time:  

 

7.  With the time number format applied to the selected cell, you will see that its 
value will now only show the current time:  

 

8.  Save the current workbook as Activity 2-4 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC E: Use Financial Functions 
As Microsoft Excel is widely used by many accounting and finance professionals, it includes 
a number of special financial functions. For example, some financial functions can be used 
to calculate loan interest, while others can be used to determine the value of investments 
over time. During this topic you will learn about the four major financial functions that are 
available in Excel 365.  

 

Topic Objectives 

In this session, you will learn about: 

• The IPMT function 

• The PPMT function 

• The NPV function 

• The FV function 
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The IPMT Function 

=IPMT(rate, per, nper, pv, [fv], [type]) 

The IPMT function is used to calculate the interest payment that is due for a period on a 
loan that has a fixed interest rate with regular payments. Alternatively, this function could 
also be used to calculate the return per period on an investment with the same restrictions.  

The rate argument is where you declare the interest rate per period. For example, if you 
were trying to calculate the interest payment on a loan that has a 3% annual interest rate, 
you would divide 3% by 12. 

The per argument is the period over which you need to calculate the interest. For example, 
if the period of the loan is four years and payments are being made monthly, the per 
argument would be 48. If annual payments are being made, the per argument would be 4.  

The total number of payments for the loan or investment are entered as the nper 
argument. For example, if payments are being calculated on a three-year investment, nper 
would be 36.  

Finally, the pv argument is where you enter the principal of the loan or total amount of 
money being invested.  

In addition to the required argument, the IPMT function includes two optional arguments: 
fv and type. The fv argument is used to enter the future value of the investment after all 
payments have been made to it, or if working with a loan, the balance of the loan. If you 
choose not to set this argument, it defaults to 0 (the typical balance of a loan after all the 
payments are made). Finally, the type argument is used to indicate if payments are due at 
the end of each payment period (indicated by “0” or by omitting the argument), or at the 
beginning (indicated by “1”). If left blank, this argument defaults to 0.  

Suppose that in a worksheet, A1 contains the value of $15,000, while cell B1 holds the value 
6%, and C1 contains the value 4: 
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With that information in mind, below you can see how an IPMT function could be 
constructed to determine how much interest the borrower would owe one and a half years 
into the four-year loan: 

Function Description Result 

=IPMT(B1/12, 18, C1*12, A1) This function calculates 
how much interest a 
borrower will owe for the 
loan (A1), one and a half 
years into the term (18) 
with an annual interest 
rate of 6% (B1/12) and a 
total term of four years 
(C1*12).  

($50.46) 

 

If this was from the lender’s perspective, the function would be almost the same, but the 
principal would be a negative value as they would be paying that out. This would result in a 
positive end result rather than a negative one.  

Function Description Result 

=IPMT(B1/12, 18, C1*12, -A1) This function calculates 
how much interest is 
owed to you as the 
lender of the loan (-A1), 
one and a half years 
into the loan (18) with 
an annual interest rate 
of 6% (B1/12) and a 
total term of four years 
(C1*12).  

$50.46 
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The PPMT Function 

=PPMT(rate, per, nper, pv, [fv], [type]) 

The PPMT (payment) function is used to calculate the amount owed against the principal on 
a loan (or gained from an investment) over a select period and a fixed interest rate. Like the 
IPMT function, the PPMT function uses the exact same arguments: rate, per, nper, pv, [fv], 
and [type]. You could even add the result from the same period of the same loan calculated 
by the IPMT function to the result using the same arguments from the PPMT function to 
calculate the total payment for the selected period.  

Suppose that in a worksheet, A1 contains the value of $15,000, while cell B1 holds the value 
6%, and C1 contains the value 4: 

 

With that information in mind, below you can see how a PPMT function could be 
constructed to determine the required payment on the principal of a loan, one and a half 
years into the four-year loan: 

Function Description Result 

=PPMT(B1/12, 18, C1*12, A1) This function calculates the 
amount owed to the 
principal of a loan (A1), one 
and a half years into the 
loan (18) with an annual 
interest rate of 6% (B1/12) 
and a total term of four 
years (C1*12).  

$(301.81) 
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The NPV Function 

=NPV(rate, value1, [value2], …) 

If you are unfamiliar with NPV (net present value) calculations, they are used to compare 
the value of money today to the value of money in the future, taking inflation and returns 
into account. In particular, the NPV function is used to calculate the net present value of an 
asset or investment using the estimated (or known) future cash flow, as well as the discount 
rate per period.  

The rate argument in this function is used to declare the discount rate per period. The value 
arguments are used to represent any future cash flow. For example, suppose that an initial 
cost of $75,000 is incurred (A1) with a discount rate of 9% (A2). The cash flows for the next 
consecutive four years are $16,000, $14,000, $12,000, and $10,000 (A3:A6) respectively:  

 

The NPV function could then be constructed as follows: 

Function Description Result 

=NPV(A2, A3:A6) This function calculates the net present 
value of $75,000 with a discount rate of 
9% (A2) and future cash flow (A3:A6). 

$42,812.87 

 

Keep in mind that the output from this formula does not include the initial cost. To factor 
that into the result, you would subtract the result from the initial cost. With that in mind, 
the NPV for this example would be $32,187.13. 
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The FV Function 

=FV(rate, nper, pmt, [pv], [type])  

The FV function is used to calculate the future value of an investment that has a fixed 
interest rate, as well as a fixed or periodic payment schedule. Like most of the other 
financial functions covered in this topic, the FV function uses many of the same arguments.  

The rate argument is where you declare the interest rate per period. For example, if you are 
trying to calculate the interest payment on an investment that has a 3% annual interest 
rate, you divide .03 by 12 and enter that result (.0025 in this case) as the argument.  

The total number of periods from now that you want to use to calculate the future value of 
the investment are entered as the nper argument. Keep in mind that the periods entered 
into this argument are the same as the ones used to calculate the rate argument.  

The pmt argument is where you enter the payment that is being made for each period. For 
example, if you are paying $200 a month into this investment over 10 years, you would 
enter 200 as the pmt value. It would also mean that the nper value would be 120 (12 x 10).  

In addition to the required argument, the FV function includes two optional arguments: pv 
and type. The pv argument is used to enter the present value of the investment. This would 
be used if you need to calculate the future value of a one-time investment that has a fixed 
interest rate. The type argument is used to indicate if payments are due at the end of each 
payment period (indicated by “0” or by omitting the argument), or at the beginning 
(indicated by “1”). If left blank, this argument defaults to 0.  

Suppose that in a worksheet, A1 contains the value of -$15,000 (initial investment), while 
cell B1 holds the value 6% (annual interest), and C1 contains the value -$200 (additional 
monthly payments). As well, assume that the investor wants to contribute the additional 
monthly payments for a period of 25 years: 
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With that information in mind, below you can see how an FV function could be constructed 
to determine the future value of this investment: 

Function Description Result 

=FV(B1/12, 25*12, C1, A1) This function calculates the 
future value of the initial 
investment (A1), combined 
with a monthly contribution of 
(C1) over a period of 25 years 
(25*12) with a fixed annual 
interest rate of 6% (B1/12). 

$205,573.34 

 

Note that because you are calculating an investment, the initial payment (pv) and monthly 
payment (pmt) need to be entered as negative values to receive a positive result. On the 
other hand, entering positive values would result in a negative value.  
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Activity 2-5: Using Financial Functions 
You have been given the task of calculating the net present value of an investment, as well 
as calculating the future value of an investment. 

1.  To begin, open Activity 2-5 from your Exercise Files folder:  

 

2.  Let’s start with the NPV calculation. Click inside cell B8 to select it:  
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3.  Next, in the Formula Bar, type “=NPV(”: 

 

4.  Now you need to enter the discount rate (rate argument). In this example it is 3%, 
so enter the B3 cell reference:  
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5.  The future cash flow (value argument) now needs to be entered. Add a comma and 
then enter the B4:B7 range followed by a closing parenthesis:  

 

6.  Press Enter to apply the new function. You will see the result in the currently 
selected cell:  

 

7.  Keep in mind that this result does not factor in the initial cost (B2). In order to 
calculate the true NPV of this investment, the initial cost of the investment needs 
to be subtracted from the value that was returned from the NPV function. In this 
example, the NPV for this investment would be $367,981.54. 
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8.  Next, you need to calculate the future investment value using the information a 
little lower on this worksheet. Click to select cell B15:  

 

9.  Inside the Formula Bar, type “=FV(B13/12”: 
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10.  Now add the period that you wish to use to calculate the future value (nper). In 
this example it is 25 years, so in the Formula Bar add a comma and then type 
“25*12”: 

 

11.  Next, you need to declare what the monthly contribution to this investment will be 
after the initial investment (pmt). In the Formula Bar, add a comma and type the 
“B14” cell reference:  
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12.  Finally, you need to enter the present value of the investment (pv). In the Formula 
Bar, add a comma and then type B12 followed by a closing parenthesis:  

 

13.  Press Enter to apply the new formula. You will see that the value of this investment 
will be $183,874.85 after 25 years of contributions and the initial investment of 
$1,500: 

 

14.  Save the current workbook as Activity 2-5 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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Summary 
In this lesson you learned about using text functions to manage and manipulate text, using 
logical functions to answer questions, as well as how to use lookup functions to find 
information. You have also learned how to use date functions to return date information. 
Additionally, you learned about the different financial functions that are available and how 
they operate. 

 

Review Questions 
1. What is the TRIM function used for? 

 

2. What is the TEXTJOIN function used for? 

 

3. What are the only two possible outputs from a logical function?  

 

4. What is the difference between the TODAY function and the NOW function? 

 

5. What is the FV function used for? 
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LESSON 3: 
ORGANIZING WORKSHEET DATA WITH 

TABLES 

 

Lesson Objectives 

In this lesson you will learn how to: 

• Create and format tables 

• Modify tables 

• Use table references 
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TOPIC A: Create and Format Tables 
While formulas and functions are great at analyzing data within your workbook, they are 
more apt at analyzing entire workbooks rather than specific sets of data. If you need to 
analyze smaller sets of data within a large workbook or break down large sets of data into 
smaller parts, then converting your data into tables is often the best solution. Tables allow 
you to use Excel’s powerful organizational capabilities without modifying the data itself. 
Using tables, you can narrow down specific data, focus on only the important information, 
and more.  

 

Topic Objectives 

In this session, you will learn: 

• About tables  

• About the components of a table  

• How to use the Create Table dialog box  

• About the Table Design contextual tab 

• How to use and apply table styles, as well as Quick Styles  

• How to customize row display  
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Tables 

A table is a specially designated range of information that has added functionality. You can 
have multiple tables per worksheet, and tables can be as large or small as the amount of 
data you want to work with. Tables can be created from existing data ranges or from empty 
ranges and then populated afterwards. Once a table has been created, it will automatically 
be given a generic name such as “Table1” or “Table2” depending upon the number of tables 
present in the current workbook; however, these names can be changed at any time. 
Additionally, tables are flexible in that you can convert a table back to a normal range at any 
point without affecting the contents.  

A table is made from adjacent columns of data, with a unique label or heading for each 
column. Columns and rows may be added to a table just as you would when working with a 
normal range.  

Remember that each worksheet has a lot more rows than columns. This design is well 
suited for data organized in long, adjacent, list-like columns: 
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Table Components 

A number of components come together to create a table. Here is an overview of each 
element. 

 

The Header Row (1) displays the column headers (or names) for each column in the 
table. For each header within the Header row, you will see the Header Row drop-down 
arrow (2). This is used to access filter and sort commands.  

Banded Rows (6) allow you to easily differentiate between each row that appears within 
the table, while the Total Row (3) is used to display the results of calculations that are 
done on a column-by-column basis. When the Total row is selected it also includes the 
Total Row drop-down arrow (7). This gives you quick access to functions that can 
perform calculations on the table data.  

Finally, the First Column (4) option applies a bold effect to first column to the table to 
differentiate it from other columns. The Last Column (5) option, when applied, will do 
the same thing to the last column of data.  
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The Create Table Dialog Box 

The Create Table dialog box is used to convert existing ranges of data into a table. To access 
this dialog box, select the cell range that you would like to convert into a table and then 
click Insert → Table:  

 

The Create Table dialog box will open. You will see the selected range (using absolute cell 
references) in the “Where is the data for your table?” text box. You can enter a different 
range into the provided field or, select one with your mouse by clicking the Cell Selector 
button:  

 

Checking the “My table has headers” checkbox indicates that the first row in the selected 
range contains column names. If your data does not have headers (or column names), Excel 
inserts a header row and give the columns generic names of “Column”, followed by a 
sequential number. Clicking the OK button converts the selected cell range into a table.  
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The Table Design Contextual Tab 

Whenever you are working with a table, the Table Design contextual tab appears on the 
ribbon. Using the controls on this tab, you can modify just about any aspect of your table:  

 

Here is a brief description of the various groups that are situated on this tab and the 
commands and options that they contain.  

Properties This group allows you to view and edit the current table’s 
name. You can also redefine the table size using the Resize 
Table command.  

Tools Within this group, the Remove Duplicates command allows 
you to remove duplicate values from the current table. The 
“Summarize with PivotTable” command will create a 
PivotTable out of the current table, and the “Convert to 
Range” command will convert it back to a regular range. You 
can also insert a slicer into the table using the Insert Slicer 
command. 

External Table Data The commands in this group are used to export table data to 
other applications, as well as manage data links to external 
resources.  

Table Style Options The checkbox controls in this group allow you to toggle on or 
off available table components.  

Table Styles This group displays a gallery of styles that you can apply to the 
current table.  
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Styles and Quick Style Sets 

Similar to cell styles, table styles are preconfigured formatting options that can be applied 
to tables. They allow you to quickly apply a splash of color to your tables and in some cases 
enhance their readability. While you do have the option of configuring your own table style, 
you can also select from a variety of preconfigured quick styles. You can find all of these 
quick styles within the Table Styles group of the Table Design tab:  

 

Clicking the More arrow ( ) within the Table Styles gallery expands it to show more 
options:  
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Clicking any style option inside the Table Styles gallery applies it to the current table:  

 

To clear an applied style, click the More arrow ( ) within the Table Styles gallery, and then 
click Clear:  
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The table is then displayed with no style at all:  

 

 

 
Customizing Row Display 

Rows in a table can be customized through the enabling (or disabling) of banded rows and 
the inclusion of total rows. To toggle banded rows, first select the table that you would like 
to work with and then click the Banded Rows checkbox in the Table Style Options group:  

 

While banded rows are enabled by default to make the data easier to read, disabling it is 
always an option:  
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Clicking the Total Row checkbox in the Table Style Options group inserts a Total row at the 
bottom of the table:  

 

When the Total Row is shown, you will see that it appears bold and one or more of the 
columns will display a total:  
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Activity 3-1: Creating and Modifying a Table 
You have decided that because the Weekly Sales & Bonus Payout worksheet will become 
larger on a weekly basis, it is a good idea to convert the range into a table to facilitate data 
analysis. You would also like to apply a new table style to it. 

1.  To begin, open Activity 3-1 from your Exercise Files folder:  

 

2.  First, use your cursor to select the A4:G14 cell range:  

 

3.  Next, click Insert → Table:  
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4.  In the Create Table dialog box, you will see that the range you previously selected 
is listed inside the “Where is the data for your table?” text box:  

 

5.  Ensure that the “My table has headers” checkbox is checked and click OK:  

 

6.  You will see that the previously selected range has now been converted into a 
table:  
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7.  Now, you need to apply a new table style. With any of the cells inside the table 
selected, open the Table Design contextual tab. Within the Table Styles group, click 

the More arrow ( ): 

 

8.  A variety of different quick styles to choose from is now displayed. For this 
example, click Table Style Medium 8:  

 

9.  The new style is now applied to the current table:  
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10.  Save the current workbook as Activity 3-1 Complete and then close Microsoft 365 
Excel to complete this exercise. 

 

  



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

131 

TOPIC B: Modifying Tables 
Once you have created and formatted a table, you will have access to many tools that will 
allow you to quickly organize and manage your data. During this topic you will learn how to 
resize a table, and how to quickly summarize your data. You will also learn how to clean 
your data by removing duplicates. 

 

Topic Objectives 

In this session, you will learn: 

• How to add and remove rows and columns 

• About total row functions 

• How to remove duplicate values  

  



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

132 

Adding Rows and Columns 

Once you have created a table in Excel, there are many ways that you can easily add or 
remove table rows and columns.  

To add rows at the bottom of the table, you can simply select any cell immediately below 
the table and type your data: 

 

When you press Enter (or Tab or select a cell outside of the table) Excel automatically 
expands the table to include the new row. The new row will include any formulas that are 
used in the table: 
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Similarly, if you select a cell immediately to the right of a table and enter data, Excel 
automatically expands the table to include the new column: 

 

This functionality is called Table AutoExpansion. You can control this behavior by clicking on 
the Control AutoCorrect Options button that appears next to added row or column, and 
selecting the appropriate option: 
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Selecting Undo Table AutoExpansion removes the column or row from the table, but the 
data you entered remains, and the AutoCorrect Options button is still displayed, allowing 
you to select Redo Table AutoExpansion:  

 

Selecting Control Auto Correct Options launches the AutoCorrect dialog box where, on the 
AutoFormat As You Type tab, you can set your preferences for automatically including new 
rows and columns in tables, and automatically filling formulas in tables: 
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If you select Stop Automatically Expanding Tables after clicking the Auto Correct Options 
button, the AutoCorrect Options button is no longer visible when working on your tables. To 
open the AutoCorrect dialog box, click File → Options, then select the Proofing category in 
the Excel Options dialog box and click AutoCorrect Options: 

 

You can also add rows and columns to a table by selecting a cell, row, or column in the table 
and clicking Home → Insert, then selecting from the available options: 
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Similarly, you can delete rows or columns by clicking Home → Delete, and selecting either 
Delete Table Rows or Delete Table Columns: 

 

You can also adjust the size of your table by clicking Table Design → Resize Table: 

  

This opens the Resize Table dialog box, where you can define the new range of your table. 
Keep in mind that the headers must remain in the same row, and the resulting table range 
must overlap the original table range: 
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Additionally, options to add or remove row and/or columns are available by right-clicking a 
cell in the table and selecting from the available options in the menu: 
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Total Row Functions 

As we discussed earlier in the lesson, you can add a Total Row to your tables by clicking the 
Total Row checkbox in the Table Style Options group of the Table Design contextual tab. 
Now we will explore some of the functions that are available in this row to help analyze and 
summarize your data. 

Selecting any cell in the Total Row displays the Total Row drop-down arrow, which provides 
function options for calculating the total for that particular column: 
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In the below example   

 

It is important to note, though, that the functions that you select are not necessarily the 
functions that are used to display the value. In this example, if we select cell E15, the sum of 
the Weekly Goal column, we will see in the Formula Bar that the function used is actually 
SUBTOTAL: 

 

SUBTOTAL functions are used to perform calculations on only subsets of data within a range 
or table. In this case it is particularly useful to display the table total values when filters are 
applied to the table 
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In the below example, a filter has been applied to hide several of the sales representatives. 
Note that the results in the total row only reflect the data that is visible after the filter is 
applied: 

 

If you prefer, you can manually enter functions in the Total Row cells. In the below example 
the Weekly Goal column total is a true SUM function, showing the total for all rows, while 
the Weekly Sales column remains a SUBTOTAL function, only showing the total for the rows 
that are not hidden: 

 

 

SUBTOTAL Function 

Now that you have seen how the SUBTOTAL function is used in the Total Row, here is some 
more detail on the function syntax and arguments.  

=SUBTOTAL(function_num, ref1, [ref2], […]) 

The function_num argument is used to define other functions that you would like to use to 
calculate subtotals. Functions are called using numeric values of 1 to 11 when including 
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hidden values and 101 to 111 when excluding them. For example, if you want to subtotal 
using the SUM function and include hidden values in the calculation, you would type “9” as 
the argument. To exclude the hidden values, as in the example shown above, you would 
type “109.” 

Below is a table that tells you which value calls which function in the function_num 
argument:  

Function Argument 
Including Hidden Values 

Function Argument 
Ignoring Hidden Values 

Function 

1 101 AVERAGE 

2 102 COUNT 

3 103 COUNTA 

4 104 MAX 

5 105 MIN 

6 106 PRODUCT 

7 107 STDEV 

8 108 STDEVP 

9 109 SUM 

10 110 VAR 

11 111 VARP 

 

The reference arguments (ref1, ref2, etc.) identify the ranges that you want to subtotal. 
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Removing Duplicate Values 

Duplicate values in data can be a common occurrence, especially in larger datasets, where 
data has originated from multiple sources, and they can be difficult to identify, when 
dealing with many columns and rows. It is important, however, to identify and remove 
duplicates from your data to ensure accuracy and that your analyses are correct. 

While there are many strategies for identifying and removing duplicate data, Excel has a 
built-in function to remove duplicate values from tables (or ranges) that can be very 
effective. To use this function, click anywhere inside of a table and then click Table Design 
→ Remove Duplicates: 

 

You can also access this function by clicking Data → Remove Duplicates, when working with 
ranges. 

This displays the Remove Duplicates dialog box. Here, you can select the columns that 
contain the duplicates that you would like to remove (By default all of the columns in the 
table will be selected). 

 

Use caution when selecting only some of the columns, as it may create a situation where 
you can unintentionally delete data that is not a duplicate. In the below example there are 
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three instances of the name Ron in the dataset, but only two of the rows are identical 
across all of the columns. Extra care should be taken whenever you are removing duplicates 
and using only some of the columns to define them: 

 

Once you have selected the columns, click OK in the Remove Duplicates dialog box. Any 
duplicate value that is found is then removed. An information box appears that informs you 
of the number of duplicate values found and how many unique values remain: 
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Activity 3-2: Modifying Tables 

You would like to analyze the top sales associate data in the Weekly Sales & Bonus Payout 
worksheet that you have been working on.  

1.  To begin, open Activity 3-2 from your Exercise Files folder:  

 

2.  To begin your analysis, you want to add a total row to your table. Click anywhere 
within the table then click Table Design → Total Row:  
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3.  A Total Row is added to your table, with a total amount in the Weekly Goal 
column:  

 

4.  First, you want to add a count for the number of sales representatives. Select cell 
C16, then click the total row drop-down arrow and select Count: 

 



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

146 

5.  You see that the count of sales representatives is 11, but you know that there are 
only 10. You realize there must be duplicate data: 

 

6.  To remove the duplicate, click Table Design → Remove Duplicates: 

 

7.  The Remove Duplicates dialog box opens. Leave all of the columns selected and 
click OK: 
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8.  An information window appears, indicating that one duplicate has been removed 
and there 10 unique values remaining. Click OK:  

 

9.  With the duplicate now removed you can now add a total to the Weekly Sales 
column. Select Cell E15, click the dropdown arrow, and select Sum: 
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10.  You can now add a column to your table by selecting cell G4 and typing “% of Total 
Sales”, then pressing Enter: 

 

(Adjust your column width as required to view the text in the header.)  

11.  In cell G5, type the formula “=E5/$E$15” and press Enter, then set the format of 
the column to percentage, and center the content: 
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12.  You can now add sum of the % of Total Sales column by selecting cell G15, clicking 
the drop-down arrow, then selecting Sum: 

 

13.  You can now filter the table to show only the sales representatives who reached 
their weekly goal by clicking the header row drop-down arrow of the Weekly 
Sales column, then selecting Number Filters, then Greater Than: 
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14.  In the Custom AutoFilter dialog box, type “15000” next to the “is greater than” 
selection, then click OK: 

 

15.  You will now see the three sales representatives who reached their weekly goal, 
but the % of Total Sales column is showing percentages only for the total sales of 
the three. You want to see the percentages based on the total. To do this, select 
cell E15, then select the Subtotal formula in the formula bar and type 
“=SUM([[Weekly Sales]])” to replace it: 

 

16.  Press Enter to apply the formula. You will see that the value in the Total Row of the 
Weekly Sales column is now the sum of all of the sales, not just the ones that are 
visible. You will also see that the values in the % of Total Sales column are now 
displaying correctly: 
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17.  Save the current workbook as Activity 3-2 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC C: Table References 
Using tables is an excellent way to quickly define, organize, and analyze specific groups of 
data. By using table names and structured references you can simplify the process even 
more. In this topic you will learn how to name your tables and then use that information in 
structured references and database functions. You will also learn how to convert your table 
back to a range. 

 

Topic Objectives 

In this session, you will learn: 

• About naming tables 

• How to use structured references 

• How to use database functions 

• How to convert a table to a range 
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Naming Tables 

As you learned earlier in this course, applying names to cells and ranges can help you create 
workbooks that are easy to understand and work with. Tables are automatically named by 
Excel as they are created, with a generic name of “Table” with a sequential number at the 
end, depending on how many existing tables you have in your workbook. Giving your table a 
unique name that clearly describes the purpose or use of the table will make the structure 
of your workbook, and the formulas you use, easier to understand.  

As with ranges and cells, there are several ways to name your table. The simplest is to first 
select a cell anywhere in your table, then type the new name of the table in the Table Name 
text box in the Properties group of the Table Design contextual tab, then press Enter: 

 

You can also open the Name Manager dialog box, to edit your table name, by clicking 
Formulas → Name Manager: 
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In the Name Manager dialog box, you can select and edit your table name: 

 

In the Edit Name dialog box, you can edit the table name, and also add comments that can 
help you and other users understand the use of the table. You will notice, though, that the 
Refers to field is grayed out, because, unlike a range, table size is dynamic, so it cannot be 
set using the Name Manager: 
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Using Structured References 

A structured reference, also known as a table reference, is a unique way of referencing 
tables and their elements that uses a combination of table and column names, instead of 
cell addresses. 

This special syntax is used in tables because they are dynamic, and normal cell references 
cannot adjust as tables are modified. 

Some of the benefits of structured references are: 

• They are easily created, by selecting the table elements you want to refer to. 

• They update automatically when elements of the table are changed. 

• They can be used inside and outside of the table, which can make your workbooks 
easier to understand. 

• They take advantage of the auto-fill feature of AutoCorrect, filling the entire column 
of a table with a formula after entering it in just one cell. 

As an example, in the following table, there is an open column that is used to calculate the 
dollar amount that a sales representative was over or under their weekly goal: 
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To calculate this column using structured references, first select cell F5, and type the equal 
sign (=) in the Formula Bar: 

 

Then click on cell D5 to automatically add the structured reference, using the column name. 
In this case “[@[Weekly Sales]]:” 

  

  



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

157 

To complete the formula, type the minus sign (-), then click on cell E5: 

 

Again, Excel adds the structured reference using the column name. Pressing Enter 
completes the formula. Not only do the formula results appear in cell F5, but it is auto-filled 
to all the cells in the Over/Under column: 
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You can also use structured references in formulas outside of a table. In the example below, 
there is a field to show the number of sales representatives who have not reached their 
weekly goal. You could use normal cell references to create this formula, but if the table 
gets larger or changes, the formula may no longer refer to the correct cells. Using 
structured references ensure that the calculation is always correct. 

To continue with the example, to create this structured reference outside of a formula, you 
would first select cell H5, then use the COUNTIF function by typing “=COUNTIF(“ in the 
Formula Bar: 

 

For the range argument, select the column with the values you want to count (if they match 
the criteria argument). In this case you select the range D5:D14: 
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Because the formula is outside of the table, the reference contains not only the column 
name (Weekly Sales), but also the table name (Sales), or “Sales[[Weekly Sales]].” To 
complete the formula, you would type a comma (,) to move to the next argument, then 
type a less than symbol, in parentheses (“<”), then an ampersand (&), then click on cell E5, 
and finally type a closing bracket and press Enter: 

 

The formula calculates that seven sales representatives did not meet their weekly goal: 

 

Letting Excel define the structured reference, by selecting cells and ranges, greatly simplifies 
the process of using these formulas. The syntax is complicated, and can be confusing at first, 
but as you become more familiar with tables and structured references you will come to 
understand them better and appreciate their value in complex workbooks.  

 

Database Functions 

Database functions are similar to subtotal functions, in that they allow you to perform 
common operations on a specified subset of data. Unlike the subtotal function though, 
where the criteria is whether the data is hidden or not, database functions allow you to use 
criteria for the data in each column of your data set.  

The syntax of a typical database functions is: 

=DCOUNT(database,field,criteria) 
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Before creating a database function, you must first define the criteria you will be using 
somewhere within your workbook, using column names that exactly match the column 
names of your database. In the example below, we have created a range with all of the 
column names, but have only added criteria for the Quantity and Order Price columns: 

 

To count the number of orders in the database where the quantity is less than 10 and the 
order price is greater than 200, first select the cell where you want to enter the function, 
then type “=DCOUNT(“ in the Formula Bar: 

 

To define the database argument, select the full range or table of data, or, to better 
understand structured references, you can start typing the table name and the Excel 
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AutoComplete function suggests available table names. You can use the arrow keys to 
select the table and press Tab to apply it: 

 

To continue defining the table, type an open square bracket ([), then use the arrow keys to 
select [#All], press Tab to apply it, then type a closed square bracket (]). In structured 
references, this describes the entire contents of the table, including headings, data, and 
total rows: 
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Once you have entered a comma to move to the next argument, define the field argument 
by selecting the full column that contains the items you want to count, or, in the case of a 
table, you can click the table header, and Excel inserts the structured reference in the 
function: 
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You would define the final argument, criteria, by selecting the cells that contain all of the 
column names and related criteria. In this example, select the range A1:D2, and finally, type 
a closed bracket to complete the function, then press Enter: 

 

The function counts one order where the quantity is less than 10 and the order price is 
greater than 200: 
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Now that the function has been created, changing the criteria in the criteria range changes 
the criteria for the function. In this example, changing the quantity to less than 50 shows 
that there are 10 orders in the dataset where the quantity is less than 50 and the order 
price is greater than 200: 

 

Because the function is built to include criteria for all of the columns, you can set the 
criteria any way you like. In the below example, there are seven orders with a unit price of 
less than 100 and an order price of greater than 200: 
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Below is a table of the available database functions, giving you the flexibility to perform 
many common operations on a specified subset of your data: 

DAVERAGE Calculates the average of values in a field of a list or database, that satisfy 
specified conditions 

DCOUNT Returns the number of cells containing numbers in a field of a list or 
database that satisfy specified conditions 

DCOUNTA Returns the number of non-blank cells in a field of a list or database, that 
satisfy specified conditions 

DGET Returns a single value from a field of a list or database, that satisfies 
specified conditions 

DMAX Returns the maximum value from a field of a list or database, that satisfy 
specified conditions 

DMIN Returns the minimum value from a field of a list or database, that satisfy 
specified conditions 

DPRODUCT Calculates the product of values in a field of a list or database, that satisfy 
specified conditions 

DSTDEV Calculates the standard deviation (based on a sample of a population) of 
values in a field of a list or database, that satisfy specified conditions 

DSTDEVP Calculates the standard deviation (based on an entire population) of 
values in a field of a list or database, that satisfy specified conditions 

DSUM Calculates the sum of values in a field of a list or database, that satisfy 
specified conditions 

DVAR Calculates the variance (based on a sample of a population) of values in a 
field of a list or database, that satisfy specified conditions 

DVARP Calculates the variance (based on an entire population) of values in a field 
of a list or database, that satisfy specified conditions 
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Converting to Range 

There may be times when you decide that using a table for your data is not the best option 
for your purposes. In these cases, it is simple to remove the table structure from your data. 

To convert your table to a range, first select any cell within the table, then click Table 
Design → Convert to Range: 

 

An information window appears asking you to confirm that you want to convert your table 
to a range. Click Yes: 

 

The table features, such as the sort and filter arrows, are no longer available for this data, 
but the table style formatting, and the Total Row remain, and all structure references will 
be converted to cell references: 
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Activity 3-3: Table References  

You have been asked to create a workbook to analyze the daily SKU sales, by SKU number, 
and by order type. To complete this task, you decide to use database functions with 
structured references.  

1.  To begin, open Activity 3-3 from your Exercise Files folder:  

 

2.  First select the table, then click Table Design, and type “Daily_Orders” in the Table 
Name field:  
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3.  Press Enter to update the table name, then select cell D4 and type “=DCOUNT(“ in 
the Formula Bar: 

  

4.  Now begin typing the table name, “Daily_Orders” to display table name 
suggestions: 

 

5.  With the Daily_Orders table highlighted, press Tab to accept the suggestion: 
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6.  Next, type an open square bracket ([) to show suggestions for table elements. Use 
the arrow key to select “#All” from the list, then press Tab to accept: 

 

7.  You can now type a closed square bracket (]) and a comma (,) to complete the 
database argument:  

 

8.  To define the field argument, click the table header “Order Number.” Excel enters 
the structured reference automatically: 
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9.  To define the criteria argument, and complete the formula, first type a comma (,) 
to move to the next argument, then select the range A3:B4: 

 

10.  Press the F4 key to make this an absolute reference, then press Enter: 

 

11.  You will see that the formula returns the value 99, as there are 99 rows in the 
table, and no criteria have been entered:  
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12.  Now type “Online” in cell A4. You will see that 50 of the order types were Online:  

 

13.  Type the SKU number “0406” in cell B4. While you would expect the count value to 
change, it has not: 

 

14.  This is because the heading in cell B3, “SKU No.”, does not match the column name 
in your table. Change the text in cell B3 to “SKU” to match the column name. Now 
you will see that the count value has changed: 

 

15.  You can now select cell E4 and follow the same steps, but this time use the DSUM 
function and use the table header “Order Price” for the field argument: 
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16.  You will now see the sum of orders where SKU 0406 had an order type of Online: 

 

17.  Save the current workbook as Activity 3-3 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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Summary 
In this lesson you learned how to organize your worksheet data with tables. You can now 
create, format, and modify tables. You can also use structured references, as well as the 
subtotal and database functions. Taking advantage of all these tools will enable you to learn 
more about your data than ever before. 

 

 

Review Questions 
1. What is the command sequence to add a table? 

 

2. How do you add a Total Row to a table? 

 

3. What type of functions do Total Rows use by default? 

 

4. How can you remove duplicate values from a table? 

 

5. When you convert a table to a range, what happens to the structured references? 
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LESSON 4: 
VISUALIZING DATA WITH CHARTS 

 

Lesson Objectives 

In this lesson you will learn how to: 

• Create charts 

• Modify and format existing charts 

• Create a trendline 

• Create advanced charts 
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TOPIC A: Create Charts 
Charts are an enormous help when people do not have time to study the data and only 
need a brief overview of the relevant information. In this topic, you will learn how to create 
charts of different types, using different methods in Excel 365. 

 

Topic Objectives 

In this session, you will learn: 

• About charts 

• About chart types 

• How to insert a chart 

• How to resize and move a chart  

• How to add additional data  

• How to switch between rows and columns 
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Charts 

Charts are graphical representations of data and relationships in a dataset. They are 
commonly used in situations where viewers need to be able to quickly interpret data, 
without having to take a close look at the worksheet itself.  

For example, here you can immediately see on this chart that Division A generates the vast 
amount of sales within the organization, while Division D generates the least: 
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Chart Types 

There are many different chart types to choose from, each tailored to display specific types 
of data. To further customize their appearance, each chart type then has even more sub-
types from which to choose. All of these chart types and sub-types are accessed using the 
Insert Chart or Change Chart Type dialog boxes. To open the Insert Chart dialog box, click 
the Insert tab and click the option button ( ) in the Charts group while the dataset that you 
would like to represent is selected:  

 

Alternatively, you can click Insert → [Any Chart Category] → All Chart Types. 
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The Insert Chart dialog box consists of two tabs – Recommended Charts and All Charts. The 
Recommended Charts tab are displayed by default and suggest a few chart types that best 
fit the data that you are trying to represent. Usually, there a few options to choose from 
with the top-most option being the most recommended one:  
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The All Charts tab displays a list of primary chart types on the left, with a gallery of sub-
types on the right: 
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Below is a breakdown of each chart type that is available and what data each type is best 
suited to display: 

Column Best suited to display data changes over time or to compare separate 
data points. 

Line Typically used to display data changes over a period of time. 

Pie Used to compare different data points in relation to a total. For 
example, you could use this chart type to show the total expenses of 
a company broken down by department.  

Doughnut Like a pie chart, doughnut charts show the relationship of parts to a 
whole, but unlike pie charts, they can show more than one data 
series, one within another. 

Bar Typically, this chart type is used to compare different data points. It is 
similar to the Column chart type, but instead has the X-axis as the 
vertical axis and the Y-axis as the horizontal axis.  

Area This chart type is typically used to illustrate rates of change over a 
period of time, as well as include the total value in a trend.  

XY (Scatter) Used to illustrate values from a variety of different trends and their 
relationship to one another.  

Bubble Similar to an xy (scatter) chart, a bubble chart offers an additional 
axis to define the size of a data point. 

Stock As the name implies, this chart type is designed to show data 
fluctuations in a stock market.  

Surface While more complex than other options, this chart type is used to 
find favorable patterns between two separate data sets.  

Radar This chart type is used to compare values from multiple data sets all 
on the same chart with each separate data (category) on a separate 
axis. Typically, this chart type is best suited to identify outliers and 
commonalities between data points.  

Treemap This chart type is designed to display hierarchical data through 
nested rectangles. Each branch of the tree is shown as a rectangle 
which is then tiled with smaller rectangles that show sub-branches.  
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Sunburst Displays data hierarchy as a series of rings where each ring 
represents the children of the ring it encloses.  

Histogram A column chart that is designed to show frequency data.   

Box & 
Whisker 

Also known as a box plot, this chart type is designed to depict groups 
of numerical data as boxes on the chart. These boxes also have a line 
that extends from each end (whiskers) that are used to describe 
upper and lower quartiles.   

Waterfall Sometimes referred to as a flying bricks chart or a Mario chart, this 
chart type represents data through a series of columns that are 
suspended in mid-air. These are typically used to understand how an 
initial value (e.g. sales revenue) is affected by positive or negative 
values (e.g. staff costs).  

Funnel Displays the values over multiple stages in a process, where the 
values decrease between stages, allowing the bars to resemble a 
funnel. 

Combo This type of chart combines the features of the bar chart and the line 
chart. Typically, this type of chart is useful if you need to compare 
values in different categories.  

Map Used to show categories and compare values across geographical 
regions, including countries, regions, states, counties, or postal 
codes. 
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Chart Insertion Methods 

When inserting a new chart into a worksheet, you should always select the dataset that you 
would like represented. If you select only one cell within the dataset in question, Excel 
automatically tries to guess the data range that you are trying to represent. While this is a 
good idea in theory, in practice this feature does not always work as intended.  

Additionally, when you are inserting charts remember to include the row or column header 
when selecting the dataset. This ensures that categories that you want plotted along the X 
axis of the chart are your column labels from the dataset and the data series are row labels. 
Once the data set, including labels, is selected, you can then insert a chart using one of 
several options. The most direct way is to use the commands inside the Charts group of the 
Insert tab. However, you can also use the Insert Chart dialog box, or insert the most 
recommended chart type for the selected data using keyboard shortcuts.  

If you would like the most recommended chart type to be inserted onto the same 
worksheet, you would press Alt + F1. If you want the default chart type to be inserted into a 
new worksheet, press F11. 
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Resizing and Moving the Chart  

Once a chart has been added to a worksheet, you are able to resize and move the chart 
around as you wish. To move a chart, click to select the chart and then drag it to its new 
destination. Release your mouse button to place it there:  

 

To resize the overall size of a chart, first click to select it. Next, click the Format contextual 
tab and examine the Size group. Inside of this group you are able to enter the exact height 
and width of the chart: 
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Alternatively, you can resize a chart using the resize handles that appear on each of its sides 
and corners while it is selected: 

 

To use these handles, click and drag them in the direction in which you want the chart 
enlarged or made smaller. Using the handles on the sides you can modify the chart size in 
one direction (horizontal and vertical), while the corner resize handles allow you to resize 
the chart size in both directions at the same time.  
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You can also find some resize options in the Format Chart Area task pane, in the Size and 
Properties section: 

 

Included are both the Height and Width increment boxes, as well as options to adjust the 
height and width scaling. You would use the scaling options if you would like to decrease 
the size of your chart by half (50%) or increase it by half (150%). You will also find the Lock 
aspect ratio check box. For example, when checked this prevents your chart from getting 
skewed when you try to change only the height but not the width.  
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Adding Additional Data 

Once a chart has been created, the data that it represents does not have to be static. You 
can add or remove information from the data range and have the chart represent these 
changes instantaneously. To do this, first click to select the chart. While the chart is 
selected, you will see that the associated data range appears outlined and shaded on the 
worksheet:  

 

Clicking and dragging the resize handles for these outlines lets you choose which data you 
would like to include in the chart. For example, if you want to include the additional line of 
information shown in the example above, you would click and drag the resize handle 
downwards:  
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Once the range area has been successfully resized, the new data is immediately 
incorporated into the chart. In this case you can see that F is now represented: 
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Switching Between Rows and Columns  

Occasionally, with some chart types, you may find the need to switch between rows and 
columns so that your chart represents the data more clearly. In the example below, the 
chart is displaying SKU sales by month, but the columns are grouped by the SKU number, 
and each column in the group represents a month in the quarter. You would prefer to group 
the data by month, and have each column in the group represent a SKU. To quickly make 
this change, first select your chart, then click Chart Design → Select Data:  

 

This action displays the Select Data Source dialog box. Click the Switch Row/Column button 
to make the month the horizontal axis: 
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Clicking the OK button applies the new changes and they are represented in the chart: 
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Activity 4-1: Creating Charts 

You need to produce a chart that easily demonstrates to your supervisor which salesperson 
made the most sales in week 1. 

1.  To begin, open Activity 4-1 from your Exercise Files folder:  

 

2.  First, you need to select the dataset with which you would like to work. Use your 
cursor to select cells C4:C14 and E4:E14. Remember to hold the Ctrl key down 
when selecting non-adjacent cell ranges:  

 

3.  Next, click Insert → Insert Column or Bar Chart → Clustered Column:  
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4.  The new chart now appears on the current worksheet, overlapping some of the 
data: 

 

5.  Click and drag this chart to a location on the worksheet where it is not overlapping 
anything:  
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6.  Examine the new chart. You will quickly see that Thompson made the most sales in 
week 1, with Harrison as the next runner up. McCain clearly has some work to do: 

 

7.  Save the current workbook as Activity 4-1 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC B: Modify and Format Charts 
Charts can be added quickly and easily using the default chart configurations, but 
sometimes those configurations are not ideal for your requirements. In such cases, you will 
need to know how to modify your chart to include more or less data, display or hide 
elements, and apply formatting.  

 

Topic Objectives 

In this session, you will learn: 

• About modification vs. formatting  

• About chart elements 

• Guidelines for including chart elements 

• About the Chart contextual tabs 

• About formatting the chart with a style  

• How to add a legend to the chart 
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The Difference Between Modifying and Formatting 

While modifying and formatting charts sound like the same thing, they are actually different 
in this context. When you choose to modify a chart, you are changing the various elements 
that are used to illustrate the data. For example, adding or removing chart elements or 
changing the chart type would be considering modifying a chart.  

Formatting is the process of altering the overall appearance of the chart. This includes 
changing the chart’s colors, fonts, and/or size. For example, if you need to change a chart to 
incorporate your organization’s branding rules, you would be formatting it.  
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Chart Elements 

Chart elements are the individual pieces of the chart that come together to create it. There 
will always be at least one chart element present in a chart, but the combination of chart 
elements largely depends on the chart type. Here is a sample column chart:  

 

The above chart contains six chart elements: Chart Title (1), Gridlines (2), Data series (3), 
Legend (4), Data table (5), and Axis Titles (6).  

Note that elements differ for each individual chart. 

 
Minimize Extraneous Chart Elements 

When modifying charts, you can have a significant impact on how and what information is 
conveyed. Because of this, it is best to keep your charts as simple as possible. This allows 
the data to speak for itself without cluttering it with extraneous information that the chart 
was trying to simplify in the first place. However, there are some instances where chart 
elements can help add meaning and context to the information being displayed. For 
example, the legend can be helpful when you are dealing with multiple sets of data, but less 
so when you are working with only one dataset.  
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The Chart Contextual Tabs 

When a chart is selected in the worksheet, the Chart Design and Format contextual tab sets 
will become available on the ribbon. 

The Chart Design Tab  

 

The Chart Design tab includes commands to change the overall appearance of the selected 
chart. This includes things such as adding and removing chart elements, changing the chart 
layout, colors, and applying chart styles. Additionally, this tab gives you access to commands 
to change the chart’s dataset range and switch row and column data. The Type group 
contains a command to change the chart type, while the Location group contains a 
command that is used to move charts between worksheets in the current workbook. 

The Format Tab  

 

On the Format tab, the Current Selection controls allow you to select individual chart 
elements to edit, as well as access the Format Selection dialog box. Shape styles can be 
applied and configured using the commands in the Shape Styles group. The WordArt Styles 
group is used to configure and format chart text. Inside the Arrange group you will see 
controls to change the layered order of elements on a chart, as well as change the 
orientation of selected chart elements. Finally, the Size group is used to view and change 
the overall size of the currently selected chart.  
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Formatting the Chart with a Style 

Chart styles are used to slightly adjust how a chart is arranged without changing the 
primary color scheme. This is excellent for adding visual flair to your chart and on occasion a 
new chart style can also help a chart’s readability.  

To format a chart with a style, first click to select the chart and then click Chart Design. 
Examine the Chart Styles group and you will see a gallery of different chart styles that you 
can choose from:  

 

Move your cursor over these chart styles and you will see a preview of how these styles 
look once applied to your chart. Clicking on a style applies it:  
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You can also find these styles by clicking the Chart Styles button that appears to the top 
right of a selected chart:  

 

This button displays a scrolling menu of the same chart styles that you can select from:  
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Adding a Legend to the Chart 

When working with charts, legends can be very important to the understanding of the data 
that a chart is trying to convey. While legends are usually displayed by default, you are able 
to toggle on or off this legend, as well as reposition it. To do this, select the chart by clicking 
Chart Design → Add Chart Element → Legend → [Position]: 

 

Alternatively, you can use the Chart Elements buttons and submenu that appears near the 
top right-hand corner of a selected chart. 
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Activity 4-2: Modifying and Formatting Charts 

You have created a chart that illustrates the weekly sales made by your sales staff. You 
would like to improve the look of the chart.  Additionally, it looks as though George 
Jackson’s data has been accidentally left out of the chart.  

1.  To begin, open Activity 4-2 from your Exercise Files folder:  

 

2.  Click to select the chart on the current worksheet. You will see the Chart Design 
and Format contextual tabs appear on the ribbon:  

 

3.  First, you should add a title to this chart. Click Chart Design → Add Chart Element 
→ Chart Title → Above Chart:  
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4.  The chart title is now displayed above the data series on the chart:  

 

5.  Next, you should add gridlines to make this chart a little easier to read. Click to 
select the chart and then click the Chart Elements button that appears near the 
top right-hand corner:  
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6.  From the menu that appears, check the Gridlines check box:  

 

7.  Major gridlines are now displayed on the chart:  
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8.  Finally, you might as well remove the legend as it is fairly self-evident what this 
data represents. Click Chart Design → Legend → None:  

 

9.  Now you need to adjust the color of this chart. Click the Chart Design contextual 
tab. Within the Chart Styles gallery, click any of the chart styles presented:  
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10.  The new style is now applied to the selected chart:  

 

11.  Finally, with the chart selected, click and drag the handle of the highlighted data 
selection, at the bottom right of cell E13, and drag it down one row: 
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12.  A column representing the weekly sales of George Jackson will be added to the 
chart: 

 

13.  Save your current workbook as Activity 4-2 Complete and close Microsoft 365 Excel 
to complete this exercise. 
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TOPIC C: Create a Trendline 
Trendlines are designed to help you better understand the data that a chart shows, as well 
as to try to predict future trends. In this topic, we will learn all about trendlines, the 
different types that are available, and how to add them.  

 

Topic Objectives 

In this session, you will learn: 

• About trendlines  

• About the types of trendlines  

• How to add a trendline 

• About the Format Trendline task pane  
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Trendlines 

Trendlines are used to graphically depict trends that exist within your data or show a 
forecast of future data in a chart. For example, here you can see a trendline that forecasts 
two years ahead that shows a trend towards increasing revenue:  
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Types of Trendlines 

Excel includes six different trend types that you can add to a chart. The type of trendline 
that you add depends on the type of data that the chart represents. Let’s breakdown each 
type of trendline and the type of data that they are best suited to represent:  

Exponential – These types of trendlines are curved to illustrate data rising or falling at 
constant rates: 

 

Linear – This trendline is typically used to represent simple linear data sets. It is a way to 
illustrate that something is increasing or decreasing over time:  
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Logarithmic – This trendline is best suited for data that changes quickly and then evens out 
over time: 

 

Polynomial – This type of trendline is curved to help illustrate fluctuating data points. It is 
divided in three orders: Order 2, Order 3, and Order 4. Order 2 trendlines include one hill or 
valley. Order 3 trendlines have one or two hills or valleys, while Order 4 trendlines have up 
to three hills or valleys:  
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Power – This type of trendline is also curved but is used with data sets that compare 
measurements at a specific rate. For example, you could use this trendline to measure 
acceleration over time:  

 

Moving Average – This type of trendline is intended to smooth out data that includes a lot 
of fluctuation. It does this by averaging a chosen number of data points. The number of data 
points is decided by setting the Period option. If this option is set to “2” then the first two 
points are used to create the trendline:  
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Adding a Trendline 

Trendlines can be added to charts in Excel through a number of different methods. The first 
method involves selecting the chart and then click Chart Design → Add Chart Element → 
Trendline → [Trendline]: 

 

Alternatively, you can click to select the chart to display the Chart Elements button. Click 
this button and click the arrow icon that appears next to the Trendline listing. Click the 
trendline that you would like to add:  
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The Format Trendline Task Pane 

The Format Trendline task pane allows you to add and modify a trendline in a number of 
different ways. To open this task pane, click Chart Design → Add Chart Element → 
Trendline → More Trendline Options:  
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Alternatively, you can click More Options from the Trendline submenu when the Chart 
Elements button is clicked: 
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Activity 4-3: Create a Trendline 

You would like to add a moving average trendline to a chart that illustrates sales data over 
the period of several weeks. 

1.  To begin, open Activity 4-3 from your Exercise Files folder:  

 

2.  Click to select the large chart that appears on Sheet1 of the current workbook:  
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3.  Click Chart Design → Add Chart Element → Trendline → More Trendline Options:  
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4.  The Format Trendline task pane now appears on the right side of the Excel 
window. Click the Moving Average radio button:  
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5.  Ensure that the Period setting is set to “2” and that the Trendline Name radio 
button is set to Automatic:  
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6.  Close the Format Trendline task pane by clicking the Close button ( ) in its upper 
right-hand corner:  

 

7.  Examine the graph and you will see that the trendline that has been added better 
illustrates the fluctuation in this data over time:  

 

8.  Save the current workbook as Activity 4-3 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC D: Create Advanced Charts 
Beyond the basic chart types that are available and the simple modifications that you can 
make to them, Excel 365 offers more advanced charts that can be used to represent your 
data. During this topic you will learn how to create advanced charts. 

 

Topic Objectives 

In this session, you will learn: 

• About combination charts 

• About dual axis charts  

• How to create custom chart templates  
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Combination Charts 

When you are working with more than one kind of information in a data set it can be 
challenging to represent it clearly in one chart. It can also be confusing for the audience 
who need to understand the information. Combination charts provide an effective way of 
presenting different, but related, data series in a single graphic. 

As an example, if you want to compare your company’s sales results over time against the 
number of outgoing sales calls, over the same period, it is difficult to see how a single chart 
could represent this data. Using two different chart types in the same graphic, though, 
could provide a clear comparison that is simple and easy to understand. 

To create a combination chart, you must first have your data in an existing chart of a single 
type. You would then select one of the data series by clicking on one of the elements: 
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You would then click Chart Design → Change Chart Type: 

 

The Change Chart Type dialog box opens, and the Combo category should be selected 
automatically: 
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In the “Choose the chart type and axis for your data series” window, you can now select a 
different chart type for either of the data series by clicking on the “Chart Type” drop-down 
menu for the chosen “Series Name”: 
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Once you have selected the desired chart type, clicking OK closes the Change Chart Type 
dialog box and your chart now contains a different chart type for each data series, as 
indicated in the legend:

: 
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Dual Axis Charts 

When using combination charts, it is often helpful to use a unique axis for each of the data 
series, so it is easier to compare, and understand. In our previous example, the number of 
outgoing sales calls is significantly less than the revenue values, resulting in a chart that 
does not clearly show the relationship between the two values. By adding another axis for 
the sales call volume, we can make the comparison clearer for the viewer.  

To add a secondary axis to your chart, first select the data series you want to use, then click 
Format → Format Selection:  

 

This opens the Format Data Series task pane, where you can click the Secondary Axis radio 
button: 
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A second axis now appears for the chosen data series, opposite to the primary axis: 

  

To adjust the positioning of the data points, relative to the other axis, first click to select the 
secondary axis on your chart, or, with your chart selected, you can click on the Chart 
Elements drop down menu in the Current Selection group of the Format contextual tab, and 
select the Secondary Vertical (Value) Axis: 
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This launches the Format Axis task pane, where you can click the Axis Options icon and 
adjust the bounds of the axis to determine how the data is displayed. In this example, 
increasing the maximum bounds widens the axis and move the stacked line lower, 
compared to the revenue axis. As you can see, there are many options in the Format Axis 
task pane that you can explore and experiment with, to achieve your desired result: 
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The chart now more clearly shows how the volume of sales calls compares to the revenue: 

 

 

Creating Custom Chart Templates 

As you have seen in the previous example, it can take a long time to create a fully 
customized chart to suit your exact needs. Excel includes the ability to save an existing chart 
as a chart template (.crtx). This allows you to quickly recreate this type of chart again, using 
a different data set.  
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To create a custom chart template, first click to select the chart that you want to work with. 
Next, right-click this chart and then click Save as Template:  
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This action displays the Save Chart Template dialog box, with the Charts folder already 
open. In the File name text box, enter a name for this new template and then click Save:  

 

Now, with the new custom chart template saved, you can create new charts using this 
template by selecting the Templates category of the All Charts tab in the Change Chart 
Type dialog box, then clicking on the desired template, and clicking OK: 
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Activity 4-4: Creating Advanced Charts 

Using weekly sales data, you would like to create a dual axis chart to compare sales and 
expenses, and then save the finished chart as a template.  

1.  To begin, open Activity 4-4 from your Exercise Files folder:  

 

2.  Use your cursor to select cells A4:C14 on the current worksheet:  
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3.  Click Insert → Insert Column or Bar Chart → Clustered Column: 

 

4.  With the chart now added, you need to select the second data series. Click Format 
→ Chart Elements → Series “Expenses”: 

 

5.  Next, click Chart Design → Change Chart Type:  
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6.  In the Change Chart Type dialog box, click the “Chart Type” drop-down menu for 
the “Expenses” series and select “Stacked Line with Markers” from the Line 
category: 
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7.  Now click to select the “Secondary Axis” checkbox for the “Expenses” series, then 
click OK: 
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8.  Right-click on the secondary axis of your chart and then click Format Axis: 

 

9.  In the Format Axis task pane, type “1000” in the Maximum window of the of the 
Axis Options Bounds, then press Enter:  
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10.  The chart is complete, showing the comparison of weekly sales to expenses: 
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11.  Now, to save your chart as a template, right-click the chart, then click Save as 
Template:  
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12.  The Save Chart Template dialog box is now displayed. Type “Activity 4-4 
Complete” into the File name text box and then click Save: 

 

13.  Save the current workbook as Activity 4-4 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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Summary 
This lesson taught you how to insert charts into worksheets as well as the best way to 
format charts to meet your specific needs and those of your audience. Additionally, you 
learned about the wide variety of charts that are available to you depending upon the data 
with which you are working. You should now feel comfortable modifying as well as 
formatting existing charts. You should also understand how to work with dual axis charts 
and create custom chart templates. 

 

 

Review Questions 
1. What are charts? 

 

2. What is a line chart typically used for? 

 

3. What is the difference between modification and formatting? 

 

4. When is the Chart contextual tab displayed? 

 

5. What is the command sequence to add a trendline using the ribbon? 
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LESSON 5: 
ANALYZING DATA WITH PIVOTTABLES, 

SLICERS, AND PIVOTCHARTS 

 

Lesson Objectives 

In this lesson you will learn how to: 

• Create a PivotTable 

• Filter data using slicers 

• Analyze data using PivotCharts 

 

 

 



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

240 

TOPIC A: Create a PivotTable 
One of the most powerful tools that you have at your disposal when analyzing data in Excel 
is the PivotTable. While extremely useful and interactive, they can be somewhat 
cumbersome to use properly and are often misused. For this reason, it is important to 
understand how they work and gain some fundamental understanding of their purpose 
before creating PivotTables of your own data.  

 

Topic Objectives 

In this session, you will learn: 

• About PivotTables 

• How to start with questions and end with structure 

• About the Create PivotTable dialog box 

• About the PivotTable Fields task pane  

• How to summarize data in a PivotTable  

• About the “Show value as” functionality  

• How to format a PivotTable 

• About using external data with PivotTables 

• About PowerPivot 

• About PowerPivot functions 
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PivotTables 

Why are PivotTables called PivotTables? Because they let you move data around easily (by 
dragging and dropping fields) to perform a sort of rotation on the structure of your table 
and at the same time, change your view of the data. With PivotTables, columns can become 
rows and rows can become columns, all without altering the original data.  

When a PivotTable is created, you are given the option to place it on the worksheet that 
you currently have open or on a new one. In either case, once the PivotTable is created you 
can pivot, re-pivot, sort, and summarize your data without affecting it directly. You are able 
to choose the level of detail that you want to view depending on your needs. Additionally, 
you have access to all of the summary functions in Excel to complete your data analysis.  

Below you can see an example of a very simple PivotTable:  

 

In this case, the SKU (first column), Quantity, and Value columns have been pivoted to 
appear as rows. A summary of each numerical column in this PivotTable is displayed by 
default. 
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Start with Questions, End with Structure 

Before you even create a PivotTable, you need to think of the questions that you are trying 
to answer by using it. Just like when you are working with functions or formulas, half of the 
work in data analysis is finding the right questions. This process is especially important for 
PivotTables because how you construct them depends on the question that you are asking. 
Once you know the question that you would like the PivotTable to answer, you can start 
constructing the PivotTable. While there are no hard and fast rules to constructing a 
PivotTable, there are some ways to make it easier.  

Here are a few tips to keep in mind when constructing your PivotTable. 

• First, it is usually best to create rows and columns using fields that have a relatively 
low set number of entries. Using entries that span a huge swath of data (such as five 
years of transaction numbers) to create rows and columns can only cause confusion 
rather than answer any specific questions.  

• Next, it is almost always a good idea to create a row out of a field that you need an 
answer from and then create a column out of that criterion to narrow down the 
answer.  

Examine the worksheet below. You will see a range that contains 34 rows of data about 
product SKUs, their warehouse location, their quantities, and their value:  
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A PivotTable created from this dataset answers the question, “What is the total value of 
the products stored in each warehouse?” 

 

As you can see, the warehouses are listed by row and the value (the criterion) is listed as a 
column. A SUM function automatically totals the value of each SKU stored by each 
warehouse. 

To answer a question, you can change the function that is used by the PivotTable. For 
example, suppose you want to see how many different products each warehouse has, not a 
total count. You could do this by adding the SKU field as a column and applying the COUNT 
function:  
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The Create PivotTable Dialog Box 

The first step to creating a PivotTable is to open the Create PivotTable dialog box by clicking 
Insert → PivotTable:  

 

The controls in the Create PivotTable dialog box are used to choose the dataset (or data 
source) for the new PivotTable that you are creating, and where you want it to be placed. 
By default, new PivotTables are placed on new worksheets, but you do have the option of 
adding them to existing worksheets in your workbook: 

 

Once you have set your options, click OK to create the PivotTable. 
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The PivotTable Fields Task Pane 

When you insert a PivotTable into your workbook, the PivotTable Fields task pane is 
automatically displayed on the right hand-side of the Excel 365 window:  
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The PivotTable Field task pane is the primary tool that you will use to configure PivotTables. 
(Note that it is hidden when the PivotTable is not selected.) The top portion of this pane (1) 
lists all of the fields from the dataset that you can add to the PivotTable. To add or remove a 
field from the PivotTable, toggle the corresponding checkbox. Alternatively, to give you 
more control over field placement on the PivotTable, you can click and drag these fields to 
the PivotTable itself. Note that field names are derived from the column header in the 
dataset:  

 

The bottom half of this pane is comprised of four areas (2): Filters, Columns, Rows, and 
Values. If you drag fields between these areas, you are able to change the structure of the 
PivotTable and choose the values that will be used to make calculations.  

Here is an overview of these four areas. 

• Adding fields to the Filters area will include those field values as filter criteria.  

• The Columns area will create columns out of unique field entries.  

• Similarly, the Rows area will create rows out of unique field entries.  
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• Finally, fields that are dragged to the Values area will have calculations performed on 
them or their values summarized.  

• Note that any fields that appear in these four areas will include a pull-down arrow (3) 
that gives you access to a number of different settings, and the Field Settings dialog 
box, which you can use to further customize your PivotTable.  

Remember that any changes that you make in the PivotTable Field task pane are applied 
dynamically.  

 

Summarize Data in a PivotTable 

Combining options from the Summarize Values By and the Show Values As tabs on the 
Value Field Settings dialog box will provide further insight into your data. For example, 
suppose that you want to calculate the total unit price of all the products that each 
warehouse is storing. You can do this by dragging the Unit Price field to the Values area of 
the PivotTable Field task pane. Next, you click the drop-down arrow for this field and click 
the Field Settings option to open the Value Field Settings dialog box. Inside the Value Field 
Settings dialog box, ensure that the Sum function was selected: 
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The PivotTable then displays the sum of the unit prices found in each warehouse:  
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As you can see, Pivot Tables are an excellent tool to quickly summarize large amounts of 
data, but because they are dynamic, it may seem difficult to use the PivotTable results in 
other parts of your workbook. Fortunately, Excel has a function to do just that. You can 
retrieve results from PivotTables in other parts of your workbook using the GETPIVOTDATA 
function. The syntax is as follows: 

GETPIVOTDATA(data_field, pivot_table, [field1, item1, field2, item2], ...)  

While this syntax seems complicated, Excel simplifies the process of building the function by 
automatically inserting it. When you select a cell outside of the pivot table, even in another 
worksheet, or workbook, and type the equal sign (=), then click on the field in the Pivot 
Table that contains the value you want to retrieve, Excel automatically inserts the 
GETPIVOTDATA function, with the correct syntax. 

In the following example, selecting cell D2, typing “=”, then clicking on cell B9 (which 
contains the sum of the value of the SKU 1567), will create the GETPIVOTDATA function 
automatically: 

 

The value of this function is that it will return the correct value, as long as it remains visible 
in the Pivot Table. 
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The “Show Values As” Functionality of a PivotTable 

Now that we have seen how to use the Summarize Values By tab or the Value Field Settings 
dialog box, let’s use the same example and suppose that you want to see the percentage of 
the total inventory value that each warehouse holds. While you could do this calculation 
manually, it would be easier to change how the values are shown. Within the Show Values 
As tab of the Value Field Settings dialog box, you would click the % of Grand Total option 
from the Show values as drop-down menu:  

 

You will now see what percentage of the grand total each warehouse holds. In this case you 
can see that Warehouse A contains products with a larger value, while Warehouse C has the 
lowest value: 
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Format a PivotTable 

When you are working with PivotTables, you will see two contextual tabs. One of these is 
the Design tab:  

 

This tab allows you to add layout elements to your PivotTable, customize style options, and 
apply a style (in the same way that you would with a regular table). You can modify these 
options at any time. 

 
External Data 

If the data that you would like to analyze exists outside of Excel, such as in a Microsoft 
Access database, you can still use PivotTables to summarize it. To do this, you need to 
create a connection to that external data by opening the Create PivotTable dialog box and 
then clicking the Use an external data source radio button. Next, click the Choose 
Connection button:  
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The Existing Connections dialog box then allows you to choose from existing connections 
that exist, as well as browse for more connections:  
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PowerPivot 

PowerPivot is an add-in that is available for Excel 365. It is additional software that is 
included with some editions of Excel 365, but by default, it is not enabled. In cases where it 
is not included, it can be added later if required. Once installed, this additional software 
extends the functionality of Excel to allow for greater data analysis. 

What makes PowerPivot special is that is uses compression and processing algorithms that 
allow you to work efficiently with large amounts of data. This facilitates analysis with data 
that would otherwise be too cumbersome to work with. Additionally, PowerPivot also 
facilitates the integration of data from multiple sources and has been designed with extra 
features and flexibility for environments that rely on Microsoft SharePoint and/or Microsoft 
SQL servers. 

 

PowerPivot Functions 

DAX (Data Analysis Expression) is a type of formula language that is used to create custom 
calculations inside calculated columns in a PowerPivot table. It is also used to create 
measures inside a PivotTable. This means that PowerPivot provides you with additional 
functions using DAX that can be used to work with relational data in a much more powerful 
manner.  

Arguments in a DAX function commonly use tables and columns. For example, below you 
can see a DAX function that uses the Totals and Date columns from the Employee Sales 
table as arguments:  

=TOTALQTD(SUM(‘Employee Sales’[Totals]), ‘Employee Sales’[Date]) 

While there are lots of DAX functions that you can choose from, each is classified under one 
of the following categories:  

• Data and Time functions: Functions of this type are used to manipulate date and 
time values. As such, they are similar to the data and time functions that can be used 
in Excel.  

• Filter functions: These functions are used to manipulate data and filter it 
dynamically. 
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• Information functions: This type of function is used to scan the values inside a cell 
range and match them against an expected data type.  

• Logical functions: Typically, these functions are used to validate expressions and 
values, and then work with other data that is based upon the evaluation. 

• Math and Trigonometric functions: Functions of this type are used to perform 
mathematical calculations.  

• Statistical functions: These functions are used to generate statistical data such as 
minimum and maximum values, as well as averages. 

• Time Intelligence functions: This type of function is used to manipulate data using 
time periods. It can be used to compare data of one time period against another. 
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Activity 5-1: Creating PivotTables 
You have been given the raw transactional data for the daily sales numbers of your sales 
staff. To determine the total sales numbers for each sales associate, you would like to 
create a PivotTable using this data.  

1.  To begin, open Activity 5-1 from your Exercise Files folder:  

 

2.  Use your cursor to select cells A4:E40: 
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3.  Next, click Insert → PivotTable:  

 

4.  The Create PivotTable dialog box is now displayed. The data range that you 
previously selected is shown within the Table/Range text box: 
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5.  You want this new PivotTable to be inserted into the current worksheet, so click 
the Existing Worksheet radio button:  

 

6.  Inside the Location text box, click the range picker button:  
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7.  Use your cursor to select cell H4:  

 

8.  Press Enter to apply the new location. Back at the Create PivotTable dialog box, 
click OK to apply the new settings:  
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9.  The PivotTable is now added to the current worksheet in the location that you 
previously set:  

 

10.  In the Pivot Table Fields task pane, click the Last Name, Daily Sales and Bonus field 
checkboxes: 
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11.  You will see that the daily sales and bonuses have been summarized by Sales 
Representative: 

 

12.  To improve the number formatting, click the Sum of Daily Sales drop-down arrow 
in the Values area and select Value Field Settings: 
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13.  Now click Number Format: 

 

14.  In the Format Cells dialog box, click Currency, then click OK: 
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15.  Click OK in the Value Field Settings dialog box: 

 

16.  Repeat the steps for the Bonus column. Once complete, the daily sales and bonus 
values should be formatted correctly: 

 

17.  Save the current workbook as Activity 5-1 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC B: Filter Data Using Slicers 
While regular filters can be effective in obtaining more detail from your data, they can 
quickly become a chore to manage. Between having to clear existing filters before applying 
new ones and trying to determine which data is actively being filtered out, filters definitely 
have some downsides. To give you more control over filtering capabilities, Excel provides 
slicers. These are easy-to-use filters that can be applied multiple times without negative 
effects on the data’s readability. Throughout this topic you will learn about slicers and how 
to use them to filter data in a PivotTable. 

 

Topic Objectives 

In this session, you will learn: 

• About slicers 

• About the Insert Slicer dialog box 
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Slicers 

Slicers can be a great help when working with PivotTable data. While the main purpose of 
PivotTables is to help you analyze information and find patterns or trends that might be 
difficult to spot in a large volume of raw data, the Slicer tool takes this idea to the next level.  

Slicers can be created out of any field that exists within the dataset for the PivotTable. 
These slicers can then be used to filter each field by its unique entries. For example, if you 
wanted to filter out data from one of the three warehouses in a worksheet that tracks 
inventory, a slicer would be able to do that for you easily. Slicers can also be linked to more 
than one PivotTable. Typically, this occurs when using raw transactional data as a dataset 
and multiple PivotTables exist for that data.  

Slicers are displayed graphically as a small pane that contains a series of buttons that 
represent each unique value from the field that the slicer is associated with. To toggle 
between filtering and not filtering unique values from the field, you can simply click these 
buttons:  

 

Filters in a slicer that are not applied appear blue, while those that are white are active. 
Should a filter button appear grayed out, this indicates that an already active filter has 
removed the values represented by this filter from view. Multiple filters that exist in the 
same slicer can be applied at once by holding down the Ctrl key and clicking on each filter 
that you would like to apply. Additionally, the Clear Filter button in the top right-hand 
corner of a slicer will deactivate all of its filters.  
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The Insert Slicers Dialog Box 

To create a slicer, first click anywhere in the PivotTable to display the PivotTable Tools tabs. 
Next, click Insert → Slicer:  

 

This action displays the Insert Slicers dialog box: 

 

This dialog box lists each field in the PivotTable with a checkbox. To create a slicer from a 
field, check its associated checkbox. Once you have finished choosing the fields that you 
would like to appear as filters, click OK to apply your settings. 
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Returning to the worksheet, you will now see the slicer(s) placed there: 

 

  



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

267 

Activity 5-2: Filtering Data Using Slicers 

You have constructed a PivotTable that displays the total sales made by each sales 
associate, as well as the total amount of bonuses they each received. Jerry Harrison and 
Leah Thompson are going to form their own sales department that sells a specialty product. 
In an effort to estimate bonus payouts and sales goals you would like to use slicers to 
display only their data in the PivotTable. 

1.  To begin, open Activity 5-2 from your Exercise Files folder:  

 

2.  Click inside the PivotTable to display the PivotTable Tools contextual tabs. Next, 
click PivotTable Analyze → Insert Slicer:  

 

3.  The Insert Slicer dialog box is now displayed: 
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4.  Check the Last Name checkbox and then click OK:  

 

5.  A slicer for the Last Name field now appears on your worksheet: 
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6.  For this exercise you want to filter out everyone except for Jerry Harrison and Leah 
Thompson. While holding down the Ctrl key, click the Bressan, Prestwick, and 
Williamson buttons:  

 

7.  The entries that you clicked on in the slicer are now filtered out of the PivotTable:  

 

8.  Save the current workbook as Activity 5-2 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC C: Analyze Data with PivotCharts 
PivotTables are fantastic at helping you analyze your data, but they are not so great at being 
able to quickly convey it. To solve this problem, PivotTable data can quickly be converted 
into charts in the same way as regular datasets. In this topic you will learn how to use 
PivotCharts to present PivotTable data visually. 

 

Topic Objectives 

In this session, you will learn: 

• About PivotCharts 

• How to create PivotCharts  

• How to apply a style to a PivotChart 
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PivotCharts 

PivotCharts are just like regular charts in that they are designed to convey data analysis in a 
visual form. The primary difference is simply that PivotCharts are linked to PivotTables, 
while charts are linked to data ranges or tables. Despite this difference, both PivotCharts 
and regular charts share many of the same features, such as dynamic updating, lots of chart 
types to choose from, and easy creation.  

 

Creating PivotCharts 

To insert a PivotChart into your worksheet, first click to select the PivotTable that you would 
like to work with. Next, click PivotTable Analyze → PivotChart:  
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This action displays the Insert Chart dialog box. Just like when you are working with regular 
charts, you need to consider what chart type best suits your data. For this example, the 
Clustered Column chart type has been selected: 

 

Once you click OK, the PivotChart is added to the current worksheet, displaying data from 
the selected PivotTable: 
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Applying a Style to a PivotChart 

PivotChart styles are used to slightly adjust how a chart is laid out without changing the 
primary color scheme. This is excellent for adding visual flair to your chart and on occasion, 
a new chart style can also help a chart’s readability.  

To format a PivotChart with a style, first click to select the PivotChart and then click the 
Pivot Chart Design contextual tab. Examine the Chart Styles group and you will see a gallery 
of different chart styles that you can choose from:  

 

Move your cursor over these chart styles and you will see a preview of how these styles will 
look once applied to your chart. Clicking on a style applies it:  

 

You can also find these styles by clicking the Chart Styles button that appears to the top 
right of a selected chart. 
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Activity 5-3: Analyzing Data with PivotCharts 

Now that you have completed a PivotTable, you would like to visualize its results using a 
PivotChart. 

1.  To begin, open Activity 5-3 from your Exercise Files folder: 

 

2.  Click inside the PivotTable to select it and then click PivotTable Analyze → 
PivotChart:  
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3.  The Insert Chart dialog box is now displayed. For this exercise, click the Pie 
category:  
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4.  With the default pie chart selected, click OK to apply the new settings:  

 

5.  The new PivotChart now appears on your worksheet: 
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6.  As you can see, Williamson generated most of the total sales, so you should filter 
his results out to focus on the remaining associates. On the PivotChart, click the 
Last Name drop-down list:  

 



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

278 

7.  On the menu that appears, deselect the Williamson checkbox and then click OK:  
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8.  The results for Williamson are no longer displayed on the PivotChart or the 
PivotTable:  

 

9.  Save the current workbook as Activity 5-3 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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Summary 
In this lesson you learned what PivotTables are and how they can be best used to answer 
different types of questions related to your data. You now know how to insert a PivotTable, 
as well as how to add and remove fields from it. Additionally, you are able to generate 
PivotCharts from a PivotTable, and use slicers to selectively filter out unique field entries.  

 

 

Review Questions 
1. What is pivoting in Excel? 

 

2. Where do the field names come from in the Choose fields to add to report section of 
the PivotTable Fields task pane?  

 

3. What happens to fields that are dragged to the Values area on the PivotTable Field 
task pane? 

 

4. What is the command sequence to insert a PivotChart? 

 

5. What do the buttons on a slicer represent? 
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LESSON 6: 
WORKING WITH GRAPHICAL OBJECTS 

 

Lesson Objectives 

In this lesson you will learn how to: 

• Insert and modify graphical objects 

• Layer and group graphical objects 

• Incorporate SmartArt into your workbooks 
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TOPIC A: Insert and Modify Graphic Objects 
While the default appearance of your worksheets can be quite plain, Excel offers you access 
to a variety of graphical objects that you can use to enhance their visual appeal. In this 
topic, you will learn all about the various types of graphical objects that you can add to your 
worksheets, as well as the contextual tabs that are used to work with them.  

 

Topic Objectives 

In this session, you will learn: 

• About graphical objects 

• How to insert shapes  

• How to insert WordArt 

• How to insert text boxes  

• How to insert images  

• About the Picture Format contextual tab  

• About the Shape Format contextual tab  

• About the SmartArt contextual tabs  
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Graphical Objects 

In Excel there are six types of graphical objects that can be inserted into a workbook: 
pictures, shapes, icons, 3D models, SmartArt, and screenshots. While each graphical object 
type is mostly tailored to a specific purpose, all of them behave in the same way once they 
are placed on a worksheet. For example, they are all able to be resized, changed, and 
moved using the same techniques.  

The commands to insert graphical objects are located in the Illustrations group on the 
Insert tab:  

 

Here is an overview of these commands: 

• The Pictures drop-down command allows you to insert image files from outside of 
Excel into your worksheet. These can be pictures on your device, from a stock library, 
or from online. Most common image formats are supported.  

• The Shapes drop-down command inserts basic shapes, including circles, squares, 
rectangles, text callouts, and arrows. You can customize all of these objects in a 
variety of ways.  

• The Icons command allows you to select from a wide array of available icons, 
searchable by category. 

• The 3D Models drop-down command allows you to insert 3D models from your own 
device or from a Microsoft online library, searchable by category. 

• The SmartArt command allows you to choose and insert a SmartArt graphic. These 
types of graphics are pre-configured and are typically used to graphically represent 
text-based content, such as flowcharts and lists.  

• Finally, the Screenshot drop-down command allows you to take a screenshot of any 
open window or your desktop. This screenshot is then inserted into the current 
worksheet. 
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Inserting Shapes 

To insert a shape into the current worksheet, first click Insert → Shapes:  

 

This dropdown command reveals that there are nine major categories in the Shapes menu:  

• Recently Used Shapes: Contains the most recently used shapes (up to the last 24). 

• Lines: Create a variety of lines and plain arrows. 

• Rectangles: Create a variety of rectangular shapes. 

• Basic Shapes: Create basic shapes, such as circles and triangles. Fun shapes such as 
smiley faces are also included here. 

• Block Arrows: Create block-style arrows and lines. 

• Equation Shapes: Create mathematical shapes. 
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• Flowchart: Create shapes used in flowcharts, such as decision points and terminators. 

• Stars and Banners: Offers 20 different types of these shapes. 

• Callouts: Annotate other drawings and images. 

Once you decide on the shape that you would like to insert, click on its listing in the drop-
down menu. This action causes your cursor to change into a crosshair. You can then click 
once to add the shape using its default dimensions or click and drag over the worksheet 
area to add it using custom dimensions of your own selection:  

 

Upon releasing your mouse button, the shape now appears on the worksheet. You can then 
manipulate and work with it as you would any other object in Excel: 
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Inserting WordArt 

WordArt is special text that you can add to your workbook that includes decorative flair 
such as drop-shadows and other accents. To insert WordArt into the current worksheet, 
click Insert → WordArt → [WordArt Style]:  

 

The WordArt is then added in its own text box using the style that you selected:  

 

Click inside of this text box and type the content that you would like to appear inside of it:  

 

You can then move this text around on the current worksheet in the same manner as you 
would move any other object in Excel.   
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Inserting Text Boxes 

As the name suggests, text boxes are simply boxes that you can add to a worksheet that are 
used to display text without having to embed that text directly within a cell. This provides 
some added flexibility when designing your worksheets and it is commonly used to add 
additional information without interfering with the data.  

To insert a text box into a worksheet, click Insert → Text Box:  

 

This action changes the shape of your cursor. Use your cursor to draw the text box on the 
current worksheet through the click and drag method:  

 

Upon releasing your mouse button, the new text box is added and selected. Inside this text 
box, you can immediately begin adding any text that you want included: 
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Inserting Images 

Images are able to be inserted into your workbooks from your computer or from online 
sources. To insert images from your computer, first click Insert → Pictures → This Device:  

 

This action displays the Insert Picture dialog box. Use its controls to browse to the location 
on your computer where the image that you would like to insert is located. Click to select 
the image and then click Insert: 
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The picture is then inserted into your worksheet where you can move and resize it like any 
other object in Excel:  

 

To insert an online picture, click Insert → Pictures → Online Pictures:  
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This action displays the Online Pictures dialog box. Listed inside you will see the option to 
search the web for images using Bing. You will likely also see an image library, which is 
searchable by category, as well as a link to your OneDrive account: 

 

To use the Bing image search functionality, type keywords into the provided text box and 
press Enter. Results from you search are displayed. Click to select the result that you would 
like to add to the current worksheet and then click Insert: 
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The selected image is then inserted into the current worksheet. You can then work with this 
image in the same way you would work with any other graphical object in Excel: 

 

 

The Picture Format Contextual Tab 

The Picture Format contextual tab is displayed whenever a graphical object that is 
considered a picture is selected. This tab displays many of the tools and commands that you 
will need to format and edit a picture in Excel:  

 

This tab contains the following groups: 

• The Adjust group contains image editing tools, including options to remove the 
background and touch up the picture. 

• The Picture Styles group contains pre-configured styles that you can apply to an 
image, as well as menus to customize the border, layout, and effects applied to the 
image. 

• The Arrange group allows you to manage the position of images. 

• The Size group gives you control over the height and width of the image. 
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The Shape Format Contextual Tab 

The Shape Format contextual tab is displayed whenever a graphical object that is 
considered a drawing (such as a shape) is selected. This tab displays many of the tools and 
commands that you will need to format and edit a drawing in Excel:  

 

This tab contains five groups with commands that can be used to edit drawings in some 
way:  

• The Insert Shapes group allows you to insert more shapes into the current 
worksheet, as well as insert text boxes and change the type of shape.  

• The Shape Styles group includes a gallery that contains a variety of pre-configured 
styles from which you can choose. You can also customize the fill, outline, and effects 
of a selected shape. 

• The WordArt Styles group also contains a gallery, but this one includes a variety of 
WordArt styles that can be added to drawings. You can also customize the fill, 
outline, and effects of the WordArt. 

• The Arrange group allows you to adjust how objects are placed on a worksheet and 
the order in which they appear if they overlap.  

• Finally, the Size group includes two increment boxes that are used to change the 
width and height of a selected object. 

 

The SmartArt Contextual Tabs 

The SmartArt contextual tab set is displayed whenever a SmartArt graphic is selected. This 
contextual tab set consists of two tabs: SmartArt Design and Format.  

The SmartArt Design Tab 

The SmartArt Design tab is comprised of four groups that contain commands to change the 
structure of SmartArt graphics, apply styles, and more: 
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Let’s look at each of these groups: 

• The first group on the SmartArt Design tab is the Create Graphic group. This is where 
you will find commands to add SmartArt shapes and text to the selected SmartArt 
graphic. Additionally, this group also contains commands to position the selected 
SmartArt graphic in the hierarchy of other SmartArt graphics.  

• The Layouts group contains a gallery of possible layout options from which you can 
choose and then apply.  

• The SmartArt Styles group contains a gallery with styles to change the color scheme 
and effects of the selected SmartArt graphic. You can also change the overall color 
scheme from this group. 

• Finally, the commands inside the Reset group are used to remove customization from 
the selected graphic, as well as convert SmartArt graphics into basic Excel shapes. 

 

The Format Tab 

The Format tab is comprised of five groups. Most of the commands on this tab are used to 
customize individual shapes within a SmartArt graphic: 

 

Let’s look at each of these groups: 

• The Shapes group contains commands to change the shape and size of individual 
SmartArt shapes.  

• The Shape Styles group includes a gallery of styles that can be applied to a selected 
SmartArt shape.  

• The WordArt Styles group also contains a gallery, but this is used to apply formatting 
to text inside a SmartArt shape.  

• The Arrange group includes commands for customizing how shapes are arranged and 
placed on the worksheet. 

• The Size group contains increment controls to change the size of the selected 
SmartArt shape. 
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Activity 6-1: Inserting Graphical Objects 

To add visual flair to one of your workbooks, you would like to insert a few graphical 
objects. 

1.  To begin, open Activity 6-1 from your Exercise Files folder:  

 

2.  Let’s start by inserting some online pictures. Click Insert → Pictures → Online 
Pictures:  

 

3.  The Insert Pictures dialog box is now displayed: 

 



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

295 

4.  Click inside the search text box and type “Calculator.” Execute the search by 
pressing Enter: 

 

5.  The results from the search are now displayed. Click any result that you like, then 
click Insert:  
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6.  The selected Clip Art is placed on the current worksheet:  

 

7.  If necessary, click and drag the top right-hand corner handle of the image to make 
the image about the same size as the example shown below: 

 

(You may be able to skip this step if you picked a small image.) 
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8.  Now, click and drag the image so that it appears just under the existing PivotTable:  
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9.  Now, you just need to add a small shape to the title. Click Insert →  
Shapes → 5-Point Star:  

 

10.  Your cursor turns into a crosshair. Just to the right of the title, click and drag until 
the star shape is roughly the same height as row 1:  
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11.  Release your mouse button to add the shape. Click on a blank area of the 
worksheet to deselect the new shape. The worksheet now looks similar to this:  

 

12.  Save the current workbook as Activity 6-1 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC B: Layer and Group Graphical Objects 
Once you have added graphical objects to a worksheet, it is important to know how to 
organize their positioning in relation to one another. Using layers, you can choose which 
object overlaps another, while grouping allows you to group multiple graphical objects 
together so that you can adjust their properties all at the same time. In this topic, you will 
learn all about layering and grouping graphical objects in Microsoft 365 Excel.  

 

Topic Objectives 

In this session, you will learn: 

• About layering objects  

• About grouping objects  

• About positioning objects 
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Layering Objects 

When a graphical object is added to a worksheet, it is added to its own layer so that it can 
overlap any existing objects. You can manipulate a layer and how it interacts with others by 
moving it forward or backward in the stack of layers – just like moving the top-most card in 
a deck below the next and vice-versa. To do this, first click to select the object that you 
would like to work with and then click Picture Format (or Drawing Format) → Bring 
Forward or Send Backward:  

 

If you would instead like to move a selected graphical object to the bottom or top of the 
stack of layers, the Bring Forward → Bring to Front, or Send Backward → Send to Back 
commands can be used: 

 

Alternatively, you can view and interact with the various graphical objects that exist on 
layers within the worksheet by opening the Selection task pane. To do this, click Picture 
Format (or Shape Format) → Selection Pane: 
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This Selection task pane lists all of the graphical objects that exist on the current worksheet 
and how they are currently arranged:  

 

If you would like to change how these objects are arranged, click and drag them around in 
this list to shift their location: 
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Grouping Objects 

If you would like to work with multiple objects as a group, such as moving them all at the 
same time, you can group them together. To do this, select each graphical object that you 
would like to group (hold the Ctrl key while clicking on each object). Next, click Picture 
Format (or Shape Format) → Group → Group:  

 

Once two or more graphical objects are grouped together, any changes made to the group 
are applied to all of its members – including size, position, and more: 

 

To ungroup any objects that have been grouped together, first click to select the group and 
then click Picture Format (or Shape Format) → Group → Ungroup:  

 

After ungrouping a group, you can quickly reform it by selecting one of the objects that was 
a member of the previous group and clicking Picture Format (or Shape Format) → Group → 
Regroup. 
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Positioning Objects 

Objects can be positioned in relation to the grid of the worksheet, as well as in relation to 
other shapes that appear on it. You can enable either of these options by clicking Picture 
Format → Align → Snap to Grid (or Snap to Shape) while the object that you would like to 
work with is selected: 

 

To align objects in relation to themselves, select the objects you wish to align, then click 
Shape Format → Align, then select from the available options: 

 

In this example, selecting Align Center aligns the two shapes horizontally, then repeating 
the process and selecting Align Middle, aligns the shapes vertically, centering one over the 
other: 
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Activity 6-2: Layering and Grouping Shapes 

The workbook that you have been working on includes multiple shapes. You would like to 
arrange how these objects are layered, as well as group them together.  

1.  To begin, open Activity 6-2 from your Exercise Files folder:  

 

2.  First, you need to move the star shape so that it appears in front of the calculator 
drawing. Click to select the calculator image and then click Picture Format → Send 
Backward → Send to Back:  
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3.  The star shape layer now appears above the calculator drawing: 
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4.  While holding down the Ctrl key, click to select both the calculator drawing and 
the star shape:  

 

5.  Click Picture Format → Group → Group:  

 



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

308 

6.  The two graphical objects are now grouped together. Click and drag this group so 
that it is placed to the right of the table:  

 

7.  Save the current workbook as Activity 6-2 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC C: Incorporate SmartArt 
SmartArt combines text-based information with graphics to create a more appearance-
driven look. Using Excel’s tools, you will be able to create SmartArt that can be used 
enhance the presentation of your text-based information. During this topic, you will learn 
how to insert SmartArt into your workbooks, and how to customize it. 

 

Topic Objectives 

In this session, you will learn: 

• About SmartArt graphics  

• About the Choose a SmartArt Graphic dialog box 

• About the Text pane  
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About SmartArt 

SmartArt graphics are used to visually represent text-based content. A great example of this 
is a flowchart or hierarchy diagram. While you can describe these things, it is much more 
intuitive to the reader to see a graphic that describes and separates each step. Just like 
other graphical objects, SmartArt graphics are individual objects on a worksheet that can be 
moved and modified as group when needed. Some of these changes are made using the 
sizing handles (1). The Text Pane (3) allows you to quickly add text. This pane is toggled by 
clicking the arrow button (2) that appears on the left side of a SmartArt object: 
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The Choose a SmartArt Graphic Dialog Box 

To insert SmartArt into a worksheet, click Insert → SmartArt:  

 

This action displays the Choose a SmartArt Graphic dialog box:  

 

The Choose a SmartArt Graphic dialog box is divided into several categories of graphics, 
each of which is displayed in a panel on the left. Here is an overview of each of these 
categories. 

• The List category is used to create bulleted lists with some visual flair  

• The Process category is used to illustrate information in sequential order, such as a 
series of steps to complete a task  

• The Cycle category is intended to illustrate continuous processes  

• The Hierarchy category will display the steps in a process or the people in an 
organizational chart  
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• The Relationship category is used to show how elements can connect to each other 

• The Matrix category is used to show how elements in a system relate to it 

• The Pyramid category is used to create diagrams that display how elements of 
varying importance, size, or power relate proportionally to each other  

• The Picture category is used to create diagrams that display content using a 
combination of text and graphics 

• The Office.com category displays additional layouts that are available on Office.com. 

Clicking on these categories changes which type of SmartArt layouts are displayed in the 
middle pane. Clicking the thumbnail for a SmartArt graphic displays a preview for that 
graphic as well as a brief description for it. With the thumbnail still selected, click OK to 
insert this graphic.  

 

About the Text Pane 

When you first insert SmartArt into a worksheet, the Text pane is displayed beside it:  

 

Using this pane, you are able to enter text into the SmartArt graphic. While you are still able 
to enter text directly into the graphic by clicking on the placeholder text and typing over it, 
the Text pane offers broader control.  

For example, if you are working with bulleted lists, the Text pane gives you a clear indication 
where you are inserting text in relation to the other bullet points. Additionally, because 
each bullet point represents a graphic, adding new graphics is usually as simple as adding 
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another bullet point inside the Text pane. (However, note that not all SmartArt graphics 
work this way. Depending upon exactly which SmartArt graphic that you are working with, 
adding new bullet points may just add a bullet point to the text within the shape.) 
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Activity 6-3: Incorporating SmartArt 

You need to create a simple SmartArt graphic that lists all of the sales associates in your 
department. 

1.  To begin, open Activity 6-3 from your Exercise Files folder:  

 

2.  Click Insert → SmartArt:  

 

3.  The Choose a SmartArt Graphic dialog box is now displayed. Ensure that either the 
All or List category has been chosen and then ensure that the Basic Block List 
graphic has been selected. Click OK: 
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4.  The SmartArt graphic is now placed on the current worksheet: 

 

5.  Inside the Text pane, type “Williamson”:  

 

(If you do not see the Text pane, click SmartArt Design → Text Pane.) 

6.  Click to select the next bullet point in the list. This time type “Bressan”: 
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7.  Repeat the above steps until the Text pane looks like the example shown here:  

 

8.  With the SmartArt still selected, click SmartArt Design contextual tab, then hover 
your mouse over the various styles in the SmartArt Styles group. Click the Polished 
style: 
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9.  Now click SmartArt Design → Change Colors → Colorful – Accent Colors: 

 

10.  Save the current workbook as Activity 6-3 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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Summary 
This lesson showed how graphical objects can be used to enhance the appearance of your 
workbooks. You learned how to insert different types of graphical objects into worksheets 
as well as how to modify them to suit your needs. Additionally, you learned about SmartArt, 
how it works, and how to add it to a worksheet. 

 

 

Review Questions 
1. What are the six types of graphical objects that can be inserted into Excel workbooks? 

 

2. Are shapes considered pictures or drawings? 

 

3. How do you open the Selection pane? 

 

4. What are SmartArt graphics used for? 

 

5. How do you open the Choose a SmartArt Graphic dialog box? 
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LESSON 7: 
ENHANCING WORKBOOKS 

 

Lesson Objectives 

In this lesson you will learn how to: 

• Customize workbooks 

• Manage themes  

• Protect files  

• Prepare a workbook for audiences 
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TOPIC A: Customize Workbooks 
Your workbooks can be customized in a number of different ways. In this topic, we will 
focus on customization through the addition of notes, comments, watermarks, and 
background pictures. 

 

Topic Objectives 

In this session, you will learn: 

• About notes and comments 

• About watermarks  

• About background pictures  
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Notes and Comments 

The information and analysis contained in Excel workbooks is often meant to be shared with 
and used by individuals other than the author. Making sure that the information is clear and 
easily understood by other users can often be challenging, especially when you are dealing 
with large amounts of data and often complex analysis. Fortunately, Excel 365 provides two 
ways to communicate additional information related to a specific cell in a spreadsheet, 
helping you collaborate and eliminating confusion. Comments allow for a threaded 
conversation about the data with multiple users, and Notes allow for making annotations, 
which are typically used to add additional context to a cell. 

 

Comments 

To add a comment, first select the cell to which you would like to add the comment. Next, 
click Review → New Comment:  
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This action creates a new comment dialog box and a violet comment indicator appears in 
the upper right-hand corner of the currently selected cell. The new comment is labeled with 
the current user’s name and the cell reference. To add text to the comment, type inside the 
provided text area, then press the Post ( ) icon:  

 

Once you are done, click anywhere outside of the comment dialog box to hide it. The violet 
comment indicator remains visible:  
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Other users can now respond to the comment by hovering the cursor over the commented 
cell, selecting the reply field, then typing the comment, and pressing Post: 

 

The comment now contains the response, including the user name, and the date and time 
of the reply: 
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Clicking Review → Show Comments opens the Comments task pane on the right side of the 
worksheet. It displays all of the comment threads in the worksheet. If a cell with a comment 
is selected, that comment is highlighted by a violet bar to the left of the comment: 

 

To close a conversation, hover over the commented cell, select more actions (…), then click 
Resolve thread: 
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Now, the violet indicator, and all of the comments in the thread, are grayed. You still have 
the option to either reopen the thread, or delete the thread: 

 

You can also delete a comment by clicking Review → Delete, clicking Delete thread in the 
Comments task pane, or by right-clicking the commented cell and selecting Delete 
Comment. 

 

Notes 

To add a note to a cell, first select the cell, then click Review → Notes → New Note: 
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A new note is created, and a red note indicator appears in the upper right-hand corner of 
the currently selected cell. The note is labeled with the current user’s name: 

 

To complete the note, type the desired information, then click outside of the cell. The note 
is hidden but the red note indicator remains: 

 

To show all notes on a worksheet, click Review → Notes → Show all Notes: 
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All notes on the worksheet are displayed: 

 

Clicking Review → Notes → Show all Notes again hides all notes on the worksheet. 

Finally, you can convert all notes to comments by clicking Review → Notes → Convert to 
Comments: 

 

You will receive a warning that converting notes to comments will remove any formatting or 
images within the notes: 
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Watermarks 

While Excel 365 does not include a direct way to create watermarks, there is a way that you 
can add them, using WordArt. To do this, first insert WordArt by clicking Insert → WordArt 
→ [WordArt Style]:  

 

Next, type the text for the watermark:  
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With the WordArt selected, right-click and then click Format Shape: 
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The Format Shape task pane opens to the right of the worksheet. In the Text Fill & Text 
Outline category of the Text Options section, adjust the Transparency slider:  

 

You can also rotate the WordArt Shape by clicking and holding the rotation handle at the 
top of the shape. Holding Ctrl while doing so will limit the adjustment to preset increments: 
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The watermark is now ready, and you can reposition it as needed: 

 

 
Background Pictures 

To add design elements to your workbooks, you have the option to add background 
pictures. These pictures appear entirely in the background of a worksheet without 
interfering with the contents of the cells.  

To insert a background picture, click Page Layout → Background: 
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This action displays the Insert Pictures dialog box. Using the options provided here, you can 
insert a picture that resides on your computer or local network, or a picture from a web 
search, your OneDrive storage, or even Facebook and Flickr if you are using a Microsoft 
account: 

 

Once you find and select a background picture, it is added to the current worksheet. If the 
image does not span the entire dimensions of the worksheet, it is tiled automatically:  
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To remove a background image, click Page Layout → Delete Background:  
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Activity 7-1: Customizing Workbooks 

Your supervisor has sent you a workbook with notes indicating his requests. 

1.  To begin, open Activity 7-1 from your Exercise Files folder:  

 

2.  First, you would like to view all the notes on the worksheet. Click Review → Notes 
→ Show All Notes:  

 

3.  There are two notes from John Smith. The first, in cell A2, asks you to add a 
background to the worksheet: 
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4.  Click Page Layout →Background: 

 

5.  The Insert Pictures dialog box opens. Click From a file:  

 

6.  Browse to your exercise folder and select Activity 7-1.png, then click Insert:  
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7.  The background picture is added to the worksheet: 

 

8.  The second note asks how much it would cost to lower the daily sales goal to 
$2,000: 

 



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

337 

9.  First note that the total of bonuses in cell I10 are $1,350. Now click cell I2 and type 
“2000” to change the daily goals value, then press Enter: 

 

10.  The calculated total bonuses in cell I10 is now $1,500. It would cost $150 to lower 
the daily sales goal. Press Ctrl + Z to undo the change made to cell I2, then click 
Review → Notes → Convert to Comments so you can add your comments to the 
notes: 

 

11.  In the Excel alert dialog box, click Convert all notes: 
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12.  Now click Review → Show Comments: 

 

13.  In the Comments task pane, in the first comment, in the reply text box, type 
“Done”, then click Post: 
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14.  In the second comment type “An extra $150.” Again, click Post: 
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15.  Close the Comment task pane, then hover your cursor over cell I2. Note that only 
your comment has a date and time, as the previous comment was converted from 
a note: 

 

16.  Save the current workbook as Activity 7-1 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC B: Manage Themes 
Excel offers themes to control and change the look of your workbook with the simple click 
of a button. Each theme consists of different colors, fonts (for headings and body), and 
effects for shapes and SmartArt. Changing a theme, or customizing one, can quickly and 
dramatically change the look and feel of your workbook. During this topic you will learn 
about themes in Excel 365 and how you can change and customize them.  

 

Topic Objectives 

In this session, you will learn: 

• About themes  

• How to customize themes 
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About Themes 

Themes are a combination of preset colors, fonts, and effects. Each theme includes 12 
colors, two fonts (Header and Body), and colors and effects for shapes and SmartArt. Much 
of the formatting that you apply to elements of your workbook can be changed, simply by 
changing the theme of the workbook. 

On the Home tab, in the Font group, you can see the Theme Fonts of the currently selected 
theme: 

 

You can also see the Theme Colors: 
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To change a workbook’s theme, click Page Layout → Themes: 

 

This shows a gallery of themes. As you move you mouse over each thumbnail in this gallery, 
you will see a preview applied to your workbook (if it has theme elements such as SmartArt, 
headers, or body text). Click the new theme to apply it:  
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You can now see that the Theme Fonts, and the Theme Colors, have changed in the Font 
group on the Home tab: 

 

 

 

Customizing Themes 

The default theme for new workbooks in Microsoft 365 Excel is Office. You can customize 
elements of this theme or any other theme that is currently applied, by choosing new style 
options from the Colors, Fonts, and Effects drop-down commands that are found inside the 
Themes group of the Page Layout tab. 

 

  



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

345 

Choosing a different Color, Font, or Effects element creates a customized theme that 
maintains the elements of the original theme that were not changed. In the example below, 
selecting the Blue Green color theme changes the color elements but does not change the 
font and effect elements: 
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To save a customized theme, click Theme → Save Current Theme: 

 

In the Save Current Theme dialog box, give the custom theme a unique name, then click 
Save: 
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The custom theme is now available in the Custom category of the Themes command drop-
down gallery: 
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Activity 7-2: Managing Themes 

You would like to apply a new theme to a workbook that you have been working on and 
then customize its colors. 

1.  To begin, open Activity 7-2 from your Exercise Files folder:  

 

2.  First, apply a new theme to this workbook by clicking Page Layout → Themes → 
Badge: 
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3.  With the new theme applied, you will see that the primary colors and text have all 
been modified. While you like the font change, you would prefer a different color 
scheme. Customize this theme by clicking Page Layout → Colors → Green:  

 

4.  Examine the workbook and you will see that its colors have been updated. Now 
that you are satisfied with the colors, fonts, and effects, save the customized 
theme by clicking Themes → Save Current Theme:  
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5.  In the Save Current Theme dialog box, give your customized theme a file name of 
“Badge Green.thmx” and click Save: 

 

6.  Confirm your customized theme has been saved by clicking the Themes command 
drop-down and looking under custom: 

 

7.  Save the current workbook as Activity 7-2 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC C: Protect Files 
One of the more important aspects that you need to understand while working with your 
data in Excel is how to protect Excel files from data loss, as well as unauthorized access. In 
this topic you will learn about the various ways that Excel 365 can protect your workbooks. 

 

Topic Objectives 

In this session, you will learn: 

• How to recover lost data  

• About the Protect group on the Review tab  

• About worksheet and workbook protection  

• About marking a workbook as final 

• How to encrypt a workbook 

• About digital signatures 
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Recovering Lost Data 

Excel 365 has an AutoRecover feature that works in the background to automatically save 
the workbook that you are working on. This saved copy of the file is called a version and it 
can be recovered if Excel or your computer experiences an error. If you have automatically 
saved versions of your workbook, you can find them by clicking File → Info, and then 
examining the Manage Workbook section:  

 

Each version listed here includes the date and time that it was saved, as well as the 
circumstances in which it was saved (such as closing Excel without saving the changes). 
Clicking on any version that is listed here opens it and you will be asked to overwrite any 
previously saved versions of this file by clicking the Restore button on the message bar:  
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If you experience an error and have not previously saved the workbook that you have been 
working on at all, you may still be able to acquire a saved version of it by clicking File → Info 
→ Manage Workbook → Recover Unsaved Workbooks:  

 

This action displays the Open dialog box, in which you can select an unsaved version and 
then click Open:  
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Once the version is open, you can save it to another location by clicking the Save As button 
on the message bar: 

 

 

The Protect Group  

Most of the commands that you need to protect your files can be found within the Protect 
group on the Review tab: 

 

Let’s look at the purpose of these commands: 

• Protect Sheet – This command prevents others from making unwanted changes to 
the current worksheet by limiting their editing options. 

• Protect Workbook – Clicking this command prevents others from making structural 
changes to the current workbook, such as adding or deleting worksheets. 

• Allow Users to Edit Ranges – Clicking this command allows users to protect specific 
ranges with a password. 

Unshare Workbook is part of a legacy feature that has been replaced by Co-authoring 
and is typically grayed out. 

 

The Protect Worksheet Option 

We know that workbooks (individual Excel files) are composed of one or more worksheets. 
Complex workbooks might make use of several worksheets, each of which might contain 
important data that is used by the rest of the workbook. To help protect your data, using 
the File menu you can choose to protect individual worksheets in a workbook. 
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To begin, make sure you are viewing the worksheet you want to protect and then click 
Review → Protect Sheet: 

 

The Protect Sheet dialog box appears and prompts you to specify what sort of editing 
actions are permitted and not permitted after a worksheet has been protected. 

There are 15 types of editing restrictions that you can apply: 
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You can use this dialog box in two ways: with or without a password. You can simply check 
to allow items in the Allow all users of the worksheet to box and click OK to apply the 
restrictions without a password. For example, here we have checked Insert columns: 

 

If this protection is applied, users can still insert columns, but the command to insert sheet 
rows are grayed out: 

 

Also, if a user attempts to edit a locked cell, a warning message appears, indicating that the 
cell is protected and to make a change the sheet must be unprotected, and a password 
might be required:  
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By default, all cells on a worksheet are locked when a worksheet is protected. To allow 
specific cells to be edited when a sheet is protected, first unprotect the sheet, then select 
those cells and press Ctrl + 1. The Format Cells dialog box opens: 

 

Click the Protection tab, uncheck the Locked checkbox, then click OK: 
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When the sheet is again protected, users are now allowed to edit those cells that have been 
unlocked, but the protection remains for all others. 

To remove the restrictions simply click Unprotect Sheet: 

 

Now suppose that you would like to better protect the worksheet by assigning it a password 
in the Protect Sheet dialog box. In this case you would add a password to the Password to 
unprotect sheet text box: 

 

When the OK button is clicked, a dialog box appears in which you are asked to confirm the 
password that you supplied: 
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The sheet has the same restrictions as when it was protected without a password, only 
now, users are prompted to enter the password after clicking Unprotect Sheet: 

 

 

 

The Protect Workbook Option 

To prevent other users from viewing hidden worksheets, adding, moving, hiding, or deleting 
worksheets, or renaming worksheets, you can protect your workbook structure with a 
password. 

To protect your workbook, click Review → Protect Workbook: 

 

You can also complete this action by clicking File → Info → Protect Workbook → Protect 
Workbook Structure. 

This action displays the Protect Structure and Windows dialog box. Here, you can apply a 
password to help prevent unauthorized changes. Enter your password and click OK to 
activate the protection: 
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Note that the Windows option is only available for earlier versions of Excel and some Mac 
OS versions. 

As with protecting worksheets, you will be asked to confirm your password. Reenter your 
password and click OK: 

 

Unlike the Protect Sheet process, where the command changes to Unprotect Sheet when 
the sheet is protected, the Protect Workbook command acts as a toggle: the command 
remains highlighted, but the name of the command does not change, when the workbook is 
protected: 

 

Clicking Protect Workbook when it is highlighted opens the Unprotect Workbook dialog 
box, where you can enter the password and click OK to unprotect the workbook: 
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Mark Workbooks as Final 

When you finish working with your workbook, and do not plan to make any further 
changes, you should consider marking it as final. This alerts others who may use your data 
that the work is complete, and it helps jog your memory if you have not touched the 
workbook in a long time. To mark your work as final, click File → Info → Protect Workbook 
→ Mark as Final: 

 

Click OK to confirm your choice and save the file: 
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Your will receive a final notification explaining the document has been marked as final to 
indicate that editing is complete and that this is the final version of the document: 

 

The Backstage menu now displays a visual warning stating the file has been marked as final: 

 

A similar warning is shown in the message bar, and the title bar shows that the file has been 
marked as Read-Only.  

 

You can click the Edit Anyway button on the message bar to release the read-only lock and 
return the files normal status.  

There is also a small notification in the status bar: 

 

You can mark a document as final as many times as you want but keep in mind that any 
changes will remove this notification and status. 
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Encrypting a Workbook 

Encrypting a document with Excel 365 is very easy, despite the complexity of the underlying 
encryption operation. In fact, encrypting a workbook using a password is one of the easiest 
ways to protect sensitive information. To lock a workbook using a password, click File → 
Info → Protect Workbook → Encrypt with Password: 

 

Enter a password and click OK: 
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You will be asked to confirm the password: 

 

Once encrypted, the Backstage menu indicates to you that the workbook has been 
password-protected: 

 

When it comes time to open the file, you (and anyone else) will be prompted for the 
password before you can even see the data. Enter the password and click OK: 
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To remove a password, click File → Info → Protect Workbook → Encrypt with Password:  

 

All you have to do is clear the Password field and click OK: 

 

Encryption works by using the password as a way to jumble up the contents of a file. 
Anyone who intercepts the encrypted file and examines the contents would only see a 
garbled mess. When the proper recipient enters the password, the “jumbling” process is 
performed backwards, and the result is a perfectly readable and usable file. 
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Digitally Signing a Workbook 

Another way of protecting your workbook is to digitally sign it. A digital signature is an 
electronic, encrypted, certificate of authenticity. It provides reassurance to the recipient 
that the workbook really came from you. The actual makeup of the digital signature is 
directly linked to the structure of the file. If something in the file changes, the digital 
signature becomes corrupted. If the signature is corrupted, that means the data has 
somehow been intercepted and changed. 

To create a digital signature, you must have a signing certificate. Certificates are issued by a 
certification authority, similar to a notary public. Like other types of identification, digital 
signatures can be revoked.  

If your document requires this level of security, speak with your IT department, or contact a 
digital security company to determine what type of digital signature will be best for your 
needs.  
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Activity 7-3: Protecting a Worksheet and a Workbook 

You want to protect a worksheet from unauthorized changes. 

1.  To begin, open Activity 7-3 from your Exercise Files folder:  

 

2.  With the workbook open, select cells H2 and I2. Press Ctrl + 1:  

 

3.  This opens the Format Cells dialog box. Click the Protection tab: 
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4.  Click to uncheck the “Locked” checkbox, then click OK: 

 

5.  Now click Review → Protect Sheet: 
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6.  This action displays the Protect Sheet dialog box. Type a memorable password into 
the Password to unprotect sheet text box: 

 

7.  Check the “Format Cells” checkbox and then click OK:  
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8.  Next, you will be required to re-enter the password that you selected. Do so and 
then click OK:  

 

9.  Back on the worksheet, right-click on cell D5, then click the Bold button on format 
menu:  
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10.  The contents of cell D5 are now bold: Now try to change the value of cell D5 by 
typing a new value into it: 

 

11.  A warning message appears, informing you that the cell you are trying to change is 
protected. Click OK: 

 

12.  Now select cell I2. Type the value “2000” and press Enter: 
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13.  Because the cell has been unlocked, you are able to change the value in the cell. All 
the formulas that reference that cell have updated results: 

 

14.  Now click Review → Unprotect Sheet, to remove the protection: 

 

15.  Enter your password and click OK: 

 

16.  Save the current workbook as Activity 7-3 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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TOPIC D: Preparing a Workbook for Multiple 
Audiences 
One thing to keep in mind when working with and managing workbooks created by Excel 
365, is that multiple audiences from other regions of the world, or with different abilities, 
may be required to use and understand them. For this reason, it is important to understand 
how you can adapt your workbooks for different audiences, when required.  

 

Topic Objectives 

In this session, you will learn: 

• How to display data in multiple international formats  

• How to utilize international symbols  

• How to add alternative text to objects 
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Displaying Data in Multiple International Formats  

If you encounter data that appears in a different language or unit of measurement, Excel 
can accommodate this information and modify it to suit your own preferences.  

When working with other languages, you have the option to change the interface and the 
languages that are used for editing. You can find these settings within the Excel Options 
dialog box, in the Language category:  

 

Within the Office display language section, you can choose the language for buttons, 
menus, and other controls. Select your preferred language and then click Set as Preferred. 
If the language you prefer is not displayed, you can click Install additional display languages 
from Office.com.  

In the Office authoring languages and proofing section you can similarly choose languages 
for creating and editing documents, including proofing tools such as spelling and grammar 
check. 
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The Proofing category of the Excel Options dialog box includes settings for customizing 
dictionaries and setting modes for the French and Spanish language. You can also select the 
dictionary language here: 

 

 

Translation 

If you are dealing with other languages, Excel also has a translation function available, in 
the Review tab, allowing you to select text within your spreadsheet and translate between 
more than 60 languages. To launch the Translator task pane, click Review → Translate: 
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The Translator task pane opens on the right side of your worksheet, where you can set the 
From and To languages, then select cells on your worksheet that contain text to see the 
translation:  
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You can also type directly into either field to see a translation in the other field: 

 

Finally, you can copy text from either field to use in your worksheet, by right-clicking the 
selected text, then clicking Copy: 
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Date and Numerical Formats 

Date and numerical formats can also be adjusted to international units. To do this, select 

the data that you would like to adjust and then click the Option button ( ) within the 
Number group on the Home tab:  

 

This action displays the Format Cells dialog box. From the list of categories on the left side 
of this dialog box, select the data that you are working with and you will see either the 
Symbol drop-down or the Locale (location) drop-down that you can use to choose a 
different regional option:  
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Utilize International Symbols 

Many languages can be entered using a standard keyboard, but some do require special 
international characters. To find and insert one of the symbols, click Insert → Symbol:  

 

This action opens the Symbol dialog box to the Symbols tab. First, from the Font drop-down 
menu select the font that you would like to use. Next, double-click the symbol that you 
would like to insert into the last location that was selected on the current worksheet. The 
Symbol dialog box remains open, allowing you to enter more than one symbol in your 
selected cell. When you are finished adding symbols, click Close:  
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Adding Alternative Text to Objects 

You can create alternative text (Alt Text) for shapes, pictures, charts, or other objects in 
your Excel workbooks. This helps people with visual impairments, who use screen readers, 
to better understand your graphical content. When you add Alt Text to an object, a screen 
reader reads out the Alt Text when it encounters the object. Without Alt Text, the screen 
reader user only knows they have reached an object without knowing what it shows. 

To add Alt Text to an object, first select the object, then click Format → Alt Text: 

 

The Alt Text task pane opens, where you can type a description of the object (typically one 
or two sentences), to help communicate the information it presents: 
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If you instead check the Mark as decorative checkbox, the object will not expose a 
description to screen readers. This allows you to identify to the user objects as decorative, 
rather than informational: 
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Activity 7-4: Preparing a Workbook for Multiple Audiences 

The workbook that you have been working on needs to be sent to customers in Quebec, a 
French speaking Canadian province. You have been asked to prepare it for them. 

1.  To begin, open Activity 7-4 from your Exercise Files folder:  

 

2.  Use your cursor to select cells C8 to D22:  
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3.  Next, press Ctrl + 1.  The Format Cells dialog box opens. Click the Number tab if it is 
not already displayed:  
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4.  Ensure that the Accounting category is selected from the Category list on the left, 
then click the Symbol drop-down menu and click the French (Canada) option: 

 

5.  With the new currency symbol selected, click OK to apply your changes: 
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6.  Back at the worksheet, you will see that the cells have been updated with the new 
currency format:  

 

7.  Now select cell B3, then hold Ctrl and also select cell B5. Once both cells are 
selected, press Ctrl + 1, to again open the Format Cells dialog box: 
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8.  Ensure that the Date category is selected from the Category list on the left, then 
click the Locale (location) drop-down menu and select the French (Canada) option: 

 

9.  With the new date locale selected, click OK to apply your changes: 
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10.  The date formats have now been updated:  

 

11.  Now, to translate the title and the date labels, click Review → Translate: 
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12.  In the Translator task pane, leave the From language selector set to Auto-detect 
and click on the To drop-down menu and scroll to find, then select, French: 

 

13.  Now click on cell A1. You will see that the translation is, likely, “Ventes de 
produits.” Type this into cell A1, then press Enter: 
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14.  Now, click on cell A3. Type the translation, “De:”, in cell A3, and press Enter: 

 

15.  Now select cell A5. You will see that the translation for “To:” is “À:” (A with an 
accent grave). To enter this in the cell, first delete the contents of cell A5, then 
click Insert → Symbol: 

 

16.  The Symbol dialog box will open to the Symbols tab. Select the capital letter A with 
grave, then click Insert, then click Close: 

 



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

390 

17.  Add the colon to complete the entry on cell A5, then press Enter: 

 

18.  Save the current workbook as Activity 7-4 Complete and then close Microsoft 365 
Excel to complete this exercise. 
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Summary 
During this lesson you learned about the various ways that you can enhance your 
workbooks in Excel 365. You should now be familiar with the customization options that are 
available, including notes and comments, as well as how to manage themes to control the 
appearance of your workbooks. At this point, you should also be comfortable with 
protecting your workbooks against data loss and unauthorized access. Finally, you now 
know how to prepare your workbooks when working with multiple audiences.  

 

 

Review Questions 
1. What is the command sequence to insert a comment?  

 

2. What are themes?  

 

3. How do you add a background image to your worksheet?  

 

4. In which group on the Review tab can you find the Protect Sheet command?  

 

5. What is the command sequence to open the Alt Text task pane?  
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LESSON LABS 

Lesson 1 
Lesson Lab 1-1 

 

Objective To understand how to apply and use range names, as well as 
apply and use specialized functions. 

Briefing You have a workbook that lists the total sales for every branch 
of your company. You need to calculate the average sales for 
each region, for stores with sales under $1,000,000.  

Task Apply the following range names to the indicated cells: 

• A4:A27: Store  
• B4:B9: Region_1 
• B10:B14: Region_2  
• B15:B17: Region_3 
• B18:B22: Region_4 
• B23:B27: Region_5  

In the designated cells, use the AVERAGEIF function to 
calculate the average of the stores by region only where the 
stores earned under $1,000,000 in sales. 

Hints Remember that logical operators need to be enclosed in 
double quotations when constructing this function. 

Sample Data  
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Lesson 2 
Lesson Lab 2-1 

 

Objective To understand how to analyze data using functions. 

Briefing You have been tasked with finishing a sales worksheet that lists 
the actual sales and sales goals for each store in your company.  

Task Use an IF function to determine if each store in every region 
has met their sales goal outlined in the worksheet.  

Hints Remember that the IF function syntax is as follows: 
IF(logical_test, value_if_true, value_if_false). 

Sample Data  

Follow-Up Questions Use the UPPER function to convert the text found in cell A1 
entirely to uppercase. 
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Lesson Lab 2-2 

 

Objective To understand how to use lookup functions. 

Briefing You need to use a LOOKUP function to find specific information 
from the provided worksheet.  

Task Add a LOOKUP function to cell G2 to find out if store 358 met 
its sales goal.   

Hints Remember that the syntax for a LOOKUP function is as follows: 
=LOOKUP(lookup_value, lookup_area, results_area).  

Sample Data  

Follow-Up Questions Add the current date to cell E1 using the TODAY function. 
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Lesson 3 
Lesson Lab 3-1 

 

Objective To understand how to create and customize tables, as well as 
sort table data.  

Briefing A worksheet that you have been working on requires a table. 
Additionally, you need to sort this data to better see which 
stores have not met their sales goal. 

Task Create a new table from the data in the A3:D27 range in the 
sample workbook. Apply any one of the table styles that are 
available. 

Sort the data in the table by the Sales Goal Met column from A 
to Z. 

Hints You can find the table styles in the Table Styles gallery on the 
Table Tools – Design tab. 

Sample Data  

Follow-Up Questions Add a Total Row to the table and calculate the sum of total 
sales, the sum of the sales goals, and a count of the stores that 
met their sales goals. 
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Lesson 4 
Lesson Lab 4-1 

 

Objective To understand how to create and modify charts based on 
existing data. 

Briefing For an upcoming presentation, you would like to create a chart 
based upon sales data with which you have been working.  

Task Using the B3:C15 range in the provided Sample Data file, 
create a new chart that will best illustrate actual sales numbers 
against sales goals for the store.  

Once you have chosen and inserted a new chart, remove the 
title. 

Hints Remember that each chart type is best suited to a specific type 
of data, so if one chart does not look right, try another type. 
There might be a number of different solutions.  

Sample Data  

Follow-Up Questions Apply a new style to the chart that you just created. 
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Lesson Lab 4-2 

 

Objective To understand how to utilize trendlines while working with 
charts. 

Briefing To get a better picture of the order value by age group that has 
been collected over a period of time, you would like to add a 
trendline to a chart.  

Task Add a polynomial trendline to the chart that appears on the 
supplied worksheet, then format the trendline in red to stand 
out from the data plots. 

Hints Ensure that the polynomial trendline is set to an order of 2.   

Sample Data  

Follow-Up Questions Experiment with the other trendline types to see how they 
represent the data. 
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Lesson 5 
Lesson Lab 5-1 

 

Objective To understand how to create and use PivotTables to analyze 
data. 

Briefing Using a PivotTable, you would like to see the total amount of 
sales made by stores that reached their sales goal and stores 
that did not.  

Task Using the provided data (A3:D27) in the Sample Data file, 
create a new PivotTable on the current worksheet (Sheet1) 
that starts in cell F3. 

Add data to the PivotTable by adding the Sales Goals Met field 
as a column. Next, add the Sales field to the Values area. 
Ensure that the Sales field uses the SUM function. 

Apply the appropriate data formats to the resulting table and 
adjust the column widths as necessary.  

Hints Remember that you can click and drag fields from the field list 
in the top half of the PivotTable Field task pane to the four 
areas on the bottom half.  

Sample Data  
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Lesson Lab 5-2 

 

Objective To understand how to present data using PivotCharts, as well 
as filter data using slicers.  

Briefing Using a PivotTable that you previously created, you would like 
to create a PivotChart that best illustrates the data that it 
presents. 

Task Create a PivotChart on the worksheet of the Sample Data file 
that uses the Column chart type.  

Insert a slicer that filters out data from store 122 as this 
location recently closed.  

Hints You can insert a slicer by clicking PivotTable Analyze → Insert 
Slicer. Additionally, by holding down the Ctrl key and clicking 
on a button in the slicer you can choose to filter out that 
option. 

Sample Data  

Follow-Up Questions On the PivotChart, add data labels to the outside end position. 
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Lesson 6 
Lesson Lab 6-1 

 

Objective To understand how to work with graphical objects. 

Briefing You are going to be presenting the results of a customer 
survey. To improve the visual elements of this worksheet, you 
would like to add some graphical objects. 

Task Align, order, and group the happy and unhappy face shapes 
with the colored circles to create icons for satisfactory and 
unsatisfactory results, then size the grouped shapes to fit next 
to the average score and the scores for each CSR. Copy and 
paste as required to add an icon to each score. Scores above 6 
get a happy face and scores below 6 get an unhappy face. 

Next, search stock art and online to find and add an image 
below the title that is related to customer satisfaction. 

Hints Remember that clicking Shape Format → Selection Pane will 
open the Selection task pane, where you can arrange the 
layers of the shapes. 

Sample Data  

Follow-Up Questions Add a SmartArt graphic to show the CSR results, from highest 
to lowest. Use colors in the individual shapes that match the 
icons. 
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Lesson 7 
Lesson Lab 7-1 

 

Objective To understand how to manage themes, add backgrounds, and 
protect a workbook. 

Briefing You need to send a confidential workbook to an international 
branch to confirm the inventory value.  

Task Change the theme of the document to “Feathered,” then use 
the Lesson Lab 7.1.png image to add a background to the 
workbook. Unlock the cells in the range C5:C34, to allow for 
editing, then protect the worksheet, making sure you select 
“Edit objects” in the “Allow all users of this workbook to” field. 
(Allowing “Edit objects” lets users add notes to a worksheet 
even when it is protected.) Use the password “1234” (without 
the quotation marks). Finally, encrypt the document, again 
with the password “1234”. 

Hints When choosing a background, ensure that you choose the 
Browse button that appears in the From a file section. Also 
remember that you click File → Info → Protect Workbook to 
encrypt with a password. 

Sample Data  

Follow-Up Questions Try editing the values in column C, then column B. 
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Lesson Lab 7-2 

 

Objective To understand unprotecting workbooks, marking them as final, 
using comments and notes, and using translation. 

Briefing An international branch has returned a confidential workbook 
in response to your request. You must finalize it. 

Task Open the workbook using the password “1234” (without the 
quotation marks). Also unprotect the sheet with the same 
password. You can now remove the background and change 
the theme back to Office. Find any notes on the worksheet and 
translate them to English. Convert the note to a comment and 
add the translation in a new thread. 

Hints You can copy the text from the note and paste it into the 
translator. You can use the Auto-detect feature if you are not 
sure what the language is. Also, remember to clear the 
password from the document encryption. 

Sample Data  
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COURSE WRAP-UP 

Post-Course Assessment 
1. Where can you search for different types of functions? 

a. In the Microsoft Search box 

b. In the Insert Function dialog box 

c. In the Formulas tab 

d. All of the above 

 

2. What is the LEN function used for? 

a. It returns a set number of characters from a string 

b. It counts the number of cells in a row 

c. It returns the number of characters in a string 

d. It counts the number of rows in a column 

 
3. When does the AND function return a TRUE value? 

a. When one of the arguments is true 

b. When all the arguments are true 

c. When all the arguments are false 

d. When there is only one argument. 
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4. What is the last argument in all of the database functions? 

a. criteria 

b. database 

c. lookup_value 

d. row_num 

 

5. What are the two contextual tabs available when you have a chart selected? 

a. Chart Task Pane 

b. Chart Design 

c. Format 

d. Add Chart 

 
 
6. What do dual axis charts display? 

a. A unique axis for both data series in a combination chart 

b. Two different axis titles 

c. Values above and below zero 

d. Two charts beside each other 

 
7. What does a slicer do, in relation to PivotTables? 

a. Adds columns to the table 

b. Filter fields by unique entries 

c. Adds rows to the table 

d. Separates column data 
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8. How can you see the layers of all shapes and pictures on a worksheet? 

a. Click Shape Format → Group → Group 

b. Click Picture Format → Selection Pane 

c. Click Picture Format → Bring Forward → Bring to Front 

d. Click Shape Format → Selection Pane 

 
9. What is a digital signature? 

a. A scan of your signature 

b. A link to your company website 

c. A fingerprint scanner 

d. An electronic, encrypted, certificate of authenticity 

 
10. What is Alt Text used for? 

a. To add translations to objects in your workbook 

b. As a programming language 

c. To give context to objects in your workbook for users with screen readers 

d. To add animations to your workbook objects 
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Course Summary 
Congratulations on completing the second part of Microsoft 365 Excel training. During this 
course, you learned how to: 

• Create advanced formulas  

• Analyze data with logical and lookup functions  

• Organize worksheet data with tables 

• Visualize data with charts  

• Analyze data with PivotTables, slicers, and PivotCharts  

• Work with graphical objects 

• Enhance workbooks 

 

You should now know which formulas and functions are used to complete which tasks, as 
well as how to use those formulas and functions for data analysis. You should be 
comfortable with the variety of data visualization tools that are available in Excel, as well as 
the use of graphics and the many ways that you can enhance your workbooks. 
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ANSWER KEYS  

Lesson 1 Review Questions  
1. For a selected range, where do you type in a new range name? 

You type a new range name for a selected range into the Name Box. 

 

2. How many function categories are there in Microsoft 365 Excel? 

In Excel 365, there are 12 function categories. 

 

3. What is the command sequence to show formulas rather than calculated values in 
cells? 

The command sequence to show formulas rather than calculated values in cells is 
Formulas → Show Formulas. 

 

4. What is a nested function? 

A nested function is a function within the arguments of another function. 

 

5. What is the command sequence to change workbook calculations to manual? 

The command sequence to change workbook calculations to manual is Formulas → 
Calculate Options → Manual. 
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Lesson 2 Review Questions  
1. What is the TRIM function used for? 

The TRIM function is used to remove empty spaces from a string, excluding those that 
appear between two words.  

 

2. What is the TEXTJOIN function used for? 

The TEXTJOIN function is used to combine (concatenate) text strings together, with or 
without delimiters, from multiple cells into one single cell. 

 

3. What are the only two possible outputs from a logical function?  

The output from a logical function is either TRUE or FALSE. 

 

4. What is the difference between the TODAY function and the NOW function? 

The difference between the TODAY function and the NOW function is that the TODAY 
function will only print the current date, while the NOW function prints both the date 
and time. 

 

5. What is the FV function used for? 

The FV function is used to calculate the future value of an investment that has a fixed 
interest rate, as well as a fixed or periodic payment schedule. 
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Lesson 3 Review Questions  
1. What is the command sequence to add a table? 

To add a table, click Insert → Table. 

 

2. How do you add a Total Row to a table? 

To add a Total Row, click Table Design → Total Row.  

 

3. What type of functions do Total Rows use by default? 

Total Row formulas use the subtotal function to display the results of common 
operations. This means the formulas will display totals only for rows that are not hidden. 

 

4. How can you remove duplicate values from a table? 

To remove duplicate values from a table, first select a cell within the table and click 
Table Design → Remove Duplicates. 

 

5. When you convert a table to a range, what happens to the structured references? 

Structured references are replaced with cell references when you convert a table to a 
range. 
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Lesson 4 Review Questions  
1. What are charts? 

Charts are graphical representations of data and its relationships. 

 

2. What is a line chart typically used for? 

Line charts are typically used to display data changes over a period of time. 

 

3. What is the difference between modification and formatting? 

When you choose to modify a chart, you are changing the various elements that are 
used to illustrate the data. Formatting, on the other hand, is the process of altering the 
overall appearance of the chart. 

 

4. When are the Chart contextual tabs displayed? 

The Chart contextual tab set is displayed whenever a chart is selected. 

 

5. What is the command sequence to add a trendline using the ribbon? 

The command sequence to add a trendline using the ribbon is Chart Design → Add 
Chart Element → Trendline → [Trendline]. 
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Lesson 5 Review Questions  
1. What is pivoting in Excel? 

Pivoting is the act of moving data around to change the table’s structure.  

 

2. Where do the field names come from in the Choose fields to add to report section of 
the PivotTable Fields task pane?  

The field names are derived from the column headers in the table or range used to 
create the PivotTable.   

 

3. What happens to fields that are dragged to the Values area on the PivotTable Field 
task pane? 

Fields that are dragged to the Values area of the PivotTable Field task pane will have 
calculations performed on them or their values summarized.  

 

4. What is the command sequence to insert a PivotChart? 

The sequence to insert a PivotChart is PivotTable Analyze → PivotChart. 

 

5. What do the buttons on a slicer represent? 

The buttons on a slicer represent unique entries that exist within the field that is 
associated with the slicer.  
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Lesson 6 Review Questions  
1. What are the six types of graphical objects that can be inserted into Excel workbooks? 

The six types of graphical objects that can be inserted into Excel workbooks are Pictures, 
Shapes, Icons, 3D Models, SmartArt, and  screenshots. 

 

2. Are shapes considered pictures or drawings? 

Shapes are considered drawings. 

 

3. How do you open the Selection pane? 

To open the Selection pane, click Picture Format (or Shape Format) → Selection Pane. 

 

4. What are SmartArt graphics used for? 

SmartArt graphics are used to visually represent text-based content in a chart or 
diagram. 

 

5. How do you open the Choose a SmartArt Graphic dialog box? 

To open the Choose a SmartArt Graphic dialog box, click Insert → SmartArt. 
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Lesson 7 Review Questions  
1. What is the command sequence to insert a comment?  

To insert a comment, click Review → New Comment. 

 

2. What are themes?  

Themes are combinations of preset colors, fonts, and effects 

 

3. How do you add a background image to your worksheet?  

To add a background image, click Page Layout → Background. 

 

4. In what group on the Review tab can you find the Protect Sheet command?  

You can find this command in the Protect group on the Review tab.  

 

5. What is the command sequence to open the Alt Text task pane?  

To open the Alt Text task pane, click Format → Alt Text. 
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Post-Course Assessment 
1. Where can you search for different types of functions? 

a. In the Microsoft Search box 

b. In the Insert Function dialog box 

c. In the Formulas tab 

d. All of the above 

All of these methods can help you find and use functions. 

 

2. What is the LEN function used for? 

a. It returns a set number of characters from a string 

b. It counts the number of cells in a row 

c. It returns the number of characters in a string 

d. It counts the number of rows in a column 

The LEN function returns the numbers of characters in a cell that contains text, or in a 
text string, and is often used to ensure text strings are the correct length. 

 
3. When does the AND function return a TRUE value? 

a. When one of the arguments is true 

b. When all the arguments are true 

c. When all the arguments are false 

d. When there is only one argument. 

The AND function only returns TRUE when all of the arguments are true.  
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4. What is the last argument in all of the database functions? 

a. criteria 

b. database 

c. lookup_value 

d. row_num 

The last argument in a database function is criteria, where the criteria is defined withing 
the workbook, directly below a column name that exactly matches a column name in 
the database.  

 

5. What are the two contextual tabs available when you have a chart selected? 

a. Chart Task Pane 

b. Chart Design 

c. Format 

d. Add Chart 

When a chart is selected in a worksheet, the Chart Design and Format contextual tabs 
will become available on the Ribbon. 

 
 
6. What do dual axis charts display? 

a. A unique axis for both data series in a combination chart 

b. Two different axis titles 

c. Values above and below zero 

d. Two charts beside each other 

A dual axis chart allows you to display a unique axis for both data series in a 
combination chart. This makes it easier to compare different but related values. 
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7. What does a slicer do, in relation to Pivot Tables? 

a. Adds columns to the table 

b. Filter fields by unique entries 

c. Adds rows to the table 

d. Separates column data 

A slicer allows you to quickly filter fields in your pivot table using unique values in that 
field. 

 

8. How can you see the layers of all shapes and pictures on a worksheet? 

a. Click Shape Format → Group → Group 

b. Click Picture Format → Selection Pane 

c. Click Picture Format → Bring Forward → Bring to Front 

d. Click Shape Format → Selection Pane 

You can see the layers of all the shapes and pictures on a worksheet by first selecting a 
picture or a shape, then clicking Shape Format → Selection Pane, or Picture Format → 
Selection Pane. 

 
9. What is a digital signature? 

a. A scan of your signature 

b. A link to your company website 

c. A fingerprint scanner 

d. An electronic, encrypted, certificate of authenticity 

A digital signature is an electronic, encrypted, certificate of authenticity. It provides 
assurance to the recipient of a file that it really came from you and has not been altered. 
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10. What is Alt Text used for? 

a. To add translations to objects in your workbook 

b. As a programming language 

c. To give context to objects in your workbook for users with screen readers 

d. To add animations to your workbook objects 

Alt Text allows you to give context to shapes, pictures, charts, and other objects in your 
workbook to assist users with visual impairments, who use screen readers to view your 
files. 

 

  



Microsoft 365 Excel: Part 2 

 

© 2005-2022 Velsoft Training Materials Inc.  

418 

APPENDICES 

Keyboard Shortcut Quick Reference Sheet 

Fi
le

 M
an

ag
em

en
t  

Open a new workbook Ctrl + N 

Save a file Ctrl + S 

Open a file Ctrl + O 

Print worksheet Ctrl + P 

Close Microsoft Excel Alt + F4 

W
or

ks
he

et
 

Switch between worksheet tabs (left to 
right) 

Ctrl + Page Up 

Switch between worksheet tabs (right to 
left) 

Ctrl + Page Down 

Insert cells Ctrl + Shift + + 

Delete cells Ctrl + - 

Te
xt

 E
di

tin
g  

Select all items in current worksheet Ctrl + A 

Copy text Ctrl + C 

Cut text Ctrl + X 

Paste text Ctrl + V 
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O
pe

n 
Di

al
og

s 

Open Find tab of Find and Replace dialog Ctrl + F 

Open Replace tab of Find and Replace 
dialog 

Ctrl + H 

Open Go To dialog Ctrl + G 

Open Font tab of Format Cells dialog Ctrl + Shift + F 

Check spelling  F7 

Get Help F1 

Te
xt

 F
or

m
at

tin
g 

To
ol

s  

Apply bold formatting Ctrl + B 

Apply underlining Ctrl + U 

Apply italic formatting Ctrl + I 

Align text to center Ctrl + E 

Align text to left Ctrl + L 

Align text to right Ctrl + R 

Justify text Ctrl + J 

Increase font size Ctrl + Shift + . 

Decrease font size Ctrl + Shift + , 

Undo last action Ctrl + Z 

Redo last action Ctrl + Y 
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Glossary 
absolute reference 

A type of reference that will not change even if it is moved or copied to another location.  

add-in 

Small components that can be added to Excel to add features and functionality. 

array 

Any grouping of two or more adjacent cells. 

arguments 

Data used by functions to complete calculations. 

AutoFill 

A feature that is used to automatically fill sequential data into a range of cells. 

AutoFilters 

Preconfigured filters that can be quickly applied or removed. 

Anova 

Short for Analysis of Variance. Used to examine if the averages of samples are different in a 
significant way. 

cell 

The intersection of a row and column on a worksheet. 

charts 

Visual representations of numeric data in a dataset. 

conditional formatting 

A formatting type that will highlight cells whose data satisfies certain criteria. 

consolidation 

The process of combining, condensing, and summarizing data from multiple sources into 
one destination. 

correlation  

Indicates if data sets trend or change with each other. 
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criteria range 

Used in database functions or advanced filters, this refers to the range that contains criteria 
needed to perform an operation. 

database functions 

Functions that allow you to perform operations on multiple fields in an Excel database. 

delimited text 

Data that is entered with one row equaling one line of text. 

dependent cells 

Cells that are affected by the contents of another cell. 

exporting 

The process of sending data from one application to another. 

external reference 

A link to the contents of one or more cells within the worksheet of another workbook. 

fields 

Columns that appear in a dataset that is used for a PivotTable. 

fill 

Formatting that adds background color to cell(s). 

fill handle 

The small black box that appears in the bottom right-hand corner of a selected cell or cell 
range. Used to activate the AutoFill feature. 

filtering 

Removing data from view based upon set criteria. 

Flash Fill 

Feature that will automatically extract or combine data based on a pattern. 

font  

A design for a set of characters, combining typeface and other qualities such as size, pitch, 
and spacing. 
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form  

An interface element of a workbook that is used to collect data or execute an action. 

Format Painter 

A tool that is used to copy formatting from one selection of text to another. 

formula  

A mathematical relationship expressed through symbols. 

Formula Bar 

A part of the Excel interface that displays the cell name, as well as values and formulas in 
the selected cell. 

function 

A preconfigured formula that is used for a specific purpose. 

HTML 

A programming language that describes how to display data. 

importing 

The process of opening data in one application that was saved in another application. 

logical operators 

A type of operator that is used to compare values and determine if those values meet 
specified criteria. 

logical values 

A type of value that expresses whether data is TRUE or FALSE based on specified criteria. 

macros 

Small programs that are created to complete a specific task or set of tasks. 

mixed references 

Cell references that include both relative and absolute references. 

multi-cell array formula 

A type of array formula that performs multiple calculations on one or more arrays and then 
displays the results. 
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outline 

A feature in Excel that allows you to organize datasets in a worksheet into hierarchical 
groups. 

PivotChart 

Similar to regular Excel charts, a PivotChart is a visual representation of data that is being 
displayed in a PivotTable. 

PivotTable 

A data analysis tool that dynamically allows you to pivot columns and rows of raw data 
without altering it. 

precedent cells 

Cells within a worksheet that provide data for a formula. 

range names 

Meaningful names that can be added to cell ranges so that they can be easily referred to 
and understood later. 

relative reference 

A cell reference that will change relative to its positioning in a worksheet. 

scenario 

A set of cell values that are saved and substituted into your worksheet at your convenience. 

single-cell array formula 

A type of array formula that performs multiple calculations on arrays and then displays the 
results in a single cell. 

slicers 

A type of data analysis tool that works in conjunction with PivotTables to sort data based on 
unique data entries. 

Sparklines 

Small graphs contained within a single cell that are used to summarize data and display 
trends. 
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spreadsheet 

Either a paper or electronic file that is used to store and work with data (mostly numbers) in 
a tabular fashion.  

SUBTOTAL functions 

A type of Excel function that is used to perform calculations on subsets of data. 

subtotals feature 

A feature that is used to quickly perform the SUBTOTAL function on a subset of data within 
a dataset. 

summary functions 

A feature that uses SUBTOTAL functions on subsets of data within a table. 

table 

A dataset that is comprised of rows and columns but is treated as one object (unlike regular 
data ranges). 

Tell Me 

Natural language help feature accessed directly on the ribbon interface. 

Text pane 

Part of the interface when SmartArt is added or selected in Excel. Typically used to add text 
to SmartArt. 

tracer arrows 

Colored arrows used to indicate the direction of the data flow to and from cells and 
formulas. 

transactional data 

Data that represents each transaction (or event) in a series. It is not summarized in any way 
and is considered raw data without row labels.  

VBA 

Visual Basics for Applications, a programming language that can be used to automate 
procedures in Microsoft Office 

workbook 

An Excel file that stores multiple worksheets. 
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worksheet 

An electronic spreadsheet. 

workspace 

Saved set of Excel files. 

XML 

A commonly used programming language that is frequently used to describe data. Stands 
for Extensible Markup Language 
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Formatting ....................................................................................................................................................................... 195 
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Mark as Final ..................................................................................................................................................................... 363 

Read-Only ......................................................................................................................................................................... 364 

Removing password .......................................................................................................................................................... 367 

Formulas 

Showing and Hiding ............................................................................................................................................................ 47 

Functions 

Arguments .......................................................................................................................................................................... 41 

AVERAGEIF .......................................................................................................................................................................... 37 

AVERAGEIFS ........................................................................................................................................................................ 38 

Categories of ....................................................................................................................................................................... 34 

CONCATENATE .................................................................................................................................................................... 63 

COUNTA .............................................................................................................................................................................. 39 

COUNTIF ............................................................................................................................................................................. 38 

COUNTIFS ............................................................................................................................................................................ 38 

Database ........................................................................................................................................................................... 171 

DAVERAGE ........................................................................................................................................................................ 172 

DAY ................................................................................................................................................................................... 100 

Entering .............................................................................................................................................................................. 42 

Finding ................................................................................................................................................................................ 39 

Function Arguments dialog box .......................................................................................................................................... 45 

FV (Future Value) ...................................................................................................................................................... 109, 114 

GETPIVOTDATA ................................................................................................................................................................. 250 

HLOOKUP ............................................................................................................................................................................ 87 

HOUR ................................................................................................................................................................................ 100 

INDEX .................................................................................................................................................................................. 92 

Insert Function dialog box .................................................................................................................................................. 44 

IPMT .................................................................................................................................................................................. 105 

LEFT ..................................................................................................................................................................................... 58 

LEN ...................................................................................................................................................................................... 60 

LOOKUP .............................................................................................................................................................................. 84 

LOWER ................................................................................................................................................................................ 62 

MATCH ................................................................................................................................................................................ 89 

MID ..................................................................................................................................................................................... 59 

MINUTE ............................................................................................................................................................................. 100 

MONTH ............................................................................................................................................................................. 100 
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Nested ................................................................................................................................................................................. 46 

NOW ................................................................................................................................................................................... 99 

NPV ........................................................................................................................................................................... 108, 112 

PMT ..................................................................................................................................................................................... 50 

PPMT ................................................................................................................................................................................ 107 

PROPER ............................................................................................................................................................................... 62 

RIGHT .................................................................................................................................................................................. 58 

SECOND ............................................................................................................................................................................ 100 

Serializing Dates and Times ............................................................................................................................................. 100 

SUMIF ................................................................................................................................................................................. 36 

SUMIFS ................................................................................................................................................................................ 38 

Text ..................................................................................................................................................................................... 58 

TODAY ................................................................................................................................................................................. 98 

TRANSPOSE ......................................................................................................................................................................... 65 

TRIM .................................................................................................................................................................................... 61 

UPPER ................................................................................................................................................................................. 62 

VLOOKUP ............................................................................................................................................................................ 86 

YEAR ................................................................................................................................................................................. 100 

G 

Graphical Objects ................................................................................................................. 284 

H 

Headers and Footers 

And themes ...................................................................................................................................................................... 345 

I 

Images 

Inserting ........................................................................................................................................................................... 289 

Picture Format tab ........................................................................................................................................................... 292 

International symbols .......................................................................................................... 381 

Iterative Calculations 

Enabling .............................................................................................................................................................................. 48 
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Language Preferances .......................................................................................................... 376 

Logical Functions 

AND function ...................................................................................................................................................................... 74 

IF function ......................................................................................................................................................... 70, 76, 81, 82 

Operators ............................................................................................................................................................................ 73 

OR function ......................................................................................................................................................................... 75 

What are? ........................................................................................................................................................................... 73 
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What are? ........................................................................................................................................................................... 84 

M 

Microsoft PowerPivot for Excel ........................................................................................... 254 

What is? ............................................................................................................................................................................ 254 

N 

Name Manager ...................................................................................................................... 22 

Nested Functions ................................................................................................................... 46 
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Adding ............................................................................................................................................................................... 327 
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Numerical formats .............................................................................................................. 380 
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Apply a style .................................................................................................................................................................... 274 

Creating .................................................................................................................................................................... 272, 275 

Filtering ............................................................................................................................................................................ 278 

What is? ........................................................................................................................................................................... 272 

PivotTable .................................................................................................................... 123, 248 

And PivotCharts ........................................................................................................................................................ 271, 280 

And slicers ........................................................................................................................................................................ 264 

Creating .................................................................................................................................................................... 245, 257 

Designing ......................................................................................................................................................................... 243 

External data source ........................................................................................................................................................ 252 

Field task pane ................................................................................................................................................................. 247 

Formatting ....................................................................................................................................................................... 252 

Modifying fields displayed ............................................................................................................................................... 247 

Value Field Settings dialog box ........................................................................................................................................ 248 

What is? ........................................................................................................................................................................... 242 

R 
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Creating from selection ...................................................................................................................................................... 29 
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Inserting ............................................................................................................................................................................ 266 
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