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ABOUT THIS COURSE 

Course Prerequisites 

This manual assumes the user has completed, or has an understanding of the materials 
covered, in the first and second parts of the Microsoft Office Excel 365 courseware, 
including: 

• Excel basics 

• Working with data 

• Modifying worksheets 

• Printing workbook contents 

• Managing large workbooks 

• Customizing the Excel environment 

• Creating advanced formulas  

• Analyzing data with logical and lookup functions  

• Organizing worksheets data with tables 

• Visualizing data with charts  

• Analyzing data with PivotTables, slicers, and PivotCharts  

• Working with graphical objects 

• Enhancing workbooks 
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Course Overview  

Welcome to the third part of our Microsoft 365 Excel courseware. Excel is Microsoft’s 
powerful and easy-to-use spreadsheet program. This new version of Excel incorporates 
some new features and connectivity to make collaboration and production as easy as 
possible. 

This course is intended to help all users get up to speed quickly on the advanced features of 
Excel. We will cover: 

• Using Excel Online  

• Worksheet Automation 

• Auditing and Error Checking  

• Data Analysis and Presentation 

• Working with Multiple Workbooks 

• Exporting and Sorting Data 

 

Note: This course is written for the desktop version of Microsoft 365 Excel. 

 
Course Objectives 

By the end of this course, users should be comfortable in both the online and desktop 
environments, using automating functions, analyzing and presenting data, auditing and 
error checking your work, working in multiple workbooks, and accessing and distributing 
data. 
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How to Use This Book 

This course is divided into six lessons. Each lesson focuses on several key topics, each of 
which are broken down into easy-to-follow concepts. At the end of each topic, you will be 
given an activity to complete. At the end of each lesson, we will summarize what has been 
covered and provide a few review questions for you to answer. Supplemental learning for 
selected topics is provided in the form of Lesson Labs at the end of this book. 

Before you begin, download the course’s Exercise Files to a convenient location. They will 
be referenced throughout this course and are a key part of your learning experience. 
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LESSON 1: 
EXCEL ONLINE  

 

Lesson Objectives 

In this lesson you will learn: 

• How to access and use Excel Online  

• Features that differ between Excel Online and the Excel desktop application 
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TOPIC A: Accessing and Using Excel Online 
One of the benefits of your Microsoft 365 subscription is the ability to use the online 
version of Excel. While this version of Excel has some limitations in its functionality in 
comparison to the desktop application, it also provides some convenient features that can 
enhance your productivity and improve your data security and accessibility. In this topic, 
you will review the basics of using Excel Online, switching between versions, and saving 
your workbooks. 

 

 

Topic Objectives 

In this session, you will learn: 

• About Excel Online 

• How to log in to Microsoft 365 

• How to identify where your workbook is saved 

• How to save a copy of your workbook to your local machine 

• How to copy a local workbook to OneDrive 
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About Excel Online 

Excel Online is an online version of Excel that it is available to you through your Microsoft 
365 subscription. It includes many of the basic functions available in the full Excel desktop 
application, and It works within your browser, so it can be accessed from any device with an 
internet connection, even if that device does not have the Excel desktop application 
installed. Using your Microsoft 365 account and OneDrive, you can store your files online, 
share them, and even collaborate with others in real time. Excel Online will also give you 
access to charting and survey tools that can help you gather and visualize data.  

 

Logging into Microsoft 365 

To use Microsoft 365, you will be given a username and password to access your online 
account. Once you have this information, open your browser (Edge, Firefox, Chrome, etc.) 
and then open the login page at https://login.microsoftonline.com: 
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With the login page open, enter the e-mail address that was given to you, then click the 
Next button: 

 

Type in your password, then click the Sign in button to complete the process: 
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Keep in mind that you can choose to keep yourself signed into the account by clicking the 
Yes button. This can save you time as you do not have to log into your account every day, 
but you should not select this option when using public computers. 

 

Once you are logged into your account, you will be greeted with the default Office landing 
page: 
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You can now open Excel Online by clicking on the Excel app, or by selecting an Excel file to 
open: 
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Edit Your File in the Excel Desktop Application 

When you have a workbook open in Excel Online, you may want to access some of the more 
advanced features that are available in the Excel desktop application. To edit an open Excel 
Online workbook in the Excel desktop application, simply click Open in Desktop App on the 
ribbon list: 
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Excel will open on your desktop and display the current workbook on your screen: 

 

Note that you may need to click Edit Anyway to start working with the file. 
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Even though you are working with the desktop version of Excel, any changes that you make 
will be automatically saved to the online file. This way you can have the full functionality of 
the Excel desktop application, combined with the versatility and portability of Excel Online, 
without having to worry about keeping track of multiple versions of the same file. When 
you are finished working with the desktop version of Excel you can simply close the program 
by clicking File → Close: 
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You can then return to your internet browser. If prompted, click Resume editing here: 

 

You will now be working with the updated version of your workbook: 
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Identify Where Your Workbook is Saved 

When working in Excel Online, all workbooks are stored either on OneDrive, OneDrive for 
Business, or a SharePoint site, and are saved automatically as you work. If you edit your file 
using the Excel desktop application, the file will continue to be automatically saved to the 
same location. You can confirm this in the desktop application by clicking on the file name 
at the top of the workbook window: 

 

You will see a dialog box, indicating the File Name and the Location: 

 

You can rename the file by editing the text in the File Name field: 
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You can also move the file by clicking on the Location field: 

 

The Choose a location dialog box will open, asking you to choose a location. You can 
navigate through the folders on OneDrive by either clicking on the up arrow (to go up one 
level) or clicking on the folders in the window (to go down a level). Click Move Here to 
confirm the location to which you want to move the file: 
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To see a history of your file versions, click Version History:  

 

The Version History task pane will display on the right side of your window and will list the 
saved versions of the file, with a brief description of the activity, the name of the user who 
saved the changes, and the date and time:  
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If a version of the file has been saved, and is available, you can open it by clicking on Open 
version, beneath the version description. The version will then be opened as a separate file 
in the Excel desktop application.  

 

To restore the most recent document to the previous version, click Restore below the 
ribbon. The workbook will be restored to the previous version: 
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Save a Copy of Your Workbook to Your Local Machine 

While using Microsoft OneDrive to store and manage your files provides for ease of access, 
version control, security, and data backup, there may be times that you will want to work 
on a file when you are offline.  

One simple way to copy a file to your local computer is to open OneDrive in your browser, 
navigate to the file you want to copy, right-click on the file and select Download from the 
option list: 
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Your file will be saved to the folder you have configured to receive downloaded files 
(typically the Downloads folder in Windows 10). To open the file from your browser, click 
Open file under the file name in the list of downloaded files at the bottom of the window: 
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If your workbook is already open in Excel Online, you can also click File → Save As → 
Download a Copy, with the same result: 
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Copy a Local Workbook to OneDrive 

It is important to note that if you have copied a workbook from OneDrive to work offline, 
the original workbook that you copied has not been updated to reflect any changes that you 
have made. If you want to ensure that the latest workbook is stored in OneDrive, you can 
copy the file from your local computer and either replace the original or use your own 
naming strategy to track the versions of your files. 

There are two ways to upload a workbook to OneDrive. The simplest method is to drag and 
drop the file from File Explorer or your desktop to the OneDrive window: 
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You can also click on the Upload button in the OneDrive window and click Files: 

 

This will launch the Open dialog box, where you can locate and select the workbook(s) you 
would like to upload. To complete the process, click Open: 
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The workbook(s) will be uploaded and will now be available in the OneDrive window: 
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Activity 1-1: Managing Workbooks Between Excel Online and the 
Excel Desktop Application 

In this activity, you will open a workbook in Excel Online and then edit the file in the Excel 
desktop application. 

1.  To begin, open your internet browser and log into Microsoft 365. 

2.  Once you are logged in, navigate to your OneDrive location by clicking the App 
launcher Icon, then clicking the OneDrive icon: 

 

3.  Now click Upload → Files: 
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4.  Navigate to the folder where you have stored your exercise files and select the file 
Activity 1-1, then click OK: 

 

5.  You can now click on the Activity 1-1 file in your OneDrive location to open it: 

 

6.  The workbook will now open: 

 

(If the workbook opens as Read-only click Edit Anyway.) 
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7.  Click Open in Desktop App on the ribbon list: 

 

8.  Your workbook will now be open in the Excel desktop application. Note that the 
AutoSave radio switch is set to On, indicating that the file is being saved 
automatically to the OneDrive location: 

 

(If the workbook opens as Read-only click Edit Anyway.) 

9.  Now select cell C5 and replace the current text by typing MacKenzie: 
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10.  Confirm the file location by clicking on the file name at the top of the workbook 
window: 

 

11.  Now click on Version History. The Version History task pane will appear on the 
right-hand side of the workbook window: 

  

12.  You can now close the file in the Excel desktop application and return to your 
browser window. In the open dialog box, click Resume editing here: 
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13.  You will see that workbook shows the edit you made in the Excel desktop 
application: 

 

14.  Now click File → Save As → Download a Copy: 

 

15.  You can now close the browser tab to close the Excel Online App. Navigate to your 
download folder, rename the downloaded file to Activity 1-1 Complete, and move 
it to your Exercise folder, to complete the activity: 
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TOPIC B: Features that Differ Between Excel 
Online and the Excel Desktop Application 
Now that you have been introduced to Excel Online and the advantages and conveniences it 
can offer, it is important to understand how it differs from the Excel desktop application, 
and how those differences may impact how and when you choose to use it. While this topic 
is not meant to be a detailed review of all the differences you will find, it should provide you 
with a good understanding of the limitations you may face when using Excel Online.  

 

Topic Objectives 

In this session, you will learn about: 

• Features in the Excel desktop application that are not available in Excel Online 

• Differences in features available in both versions of Excel 
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Features Not Available in Excel Online 

At first glance it may seem that Excel Online and the Excel desktop application are the same, 
but when we take a closer look through the tabs in the ribbon interface, the differences in 
functionality become clearer. 

To show these differences, we will compare the different tabs in the ribbon interface of 
each application. In the images that follow in this topic, the interface for Excel Online is 
illustrated above the interface for the Excel desktop application. 

The Home tab:  

  

In the Home tab, the available commands and functions are very similar. The primary 
difference is that the (1) Quick Styles options in the Styles group of the Home tab are 
available using the (2) Cell Styles command drop-down in the Tables group in Excel Online. 

The Insert tab:  

 

Here there are some significant differences.  

 In the Illustrations group you will see that you can only add pictures and shapes in 
Excel Online, whereas in the Excel desktop application, you can add pictures, icons, 
3D Models, SmartArt and screenshots. 

 Sparklines can only be added in the Excel desktop application, though they will 
display if opened in Excel Online. 

 Slicer and Timeline filters are not available in Excel Online. 



Microsoft 365 Excel: Part 3 

 

© 20019-2025Ultimate IT Courses Training Materials Inc.  

31 

 Advanced controls for some text elements, such as Text Boxes, are not available in 
Excel Online. 

 Symbol and Equation options are not available in Excel Online. 
 

The Page Layout tab:  

  

The Page Layout tab is only available in the Excel desktop application. Layout and print 
features in Excel Online are limited to the options available by clicking File → Print: 

 

The Formulas tab:  

 

The Formulas tab in Excel Online is limited to the Calculate Workbook and Calculation 
Options commands. You can insert functions by using the Function command in the 
Functions group of the Insert tab, or by clicking the Functions button in the formula bar, but 
many of the formula tools with which you are familiar are not available in Excel Online. 
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The Data tab:  

 

Let’s review the differences. 

 In the Connections group, the Excel desktop application provides many options to 
source and transform data while Excel Online is limited to refreshing connections. 

 Features in the Sort & Filter group are similar, except the Advanced filter is not 
available in Excel Online. 

 The Data Tools group in Excel Online only provides a limited set of the options 
available in the Excel desktop application. Notably, the Text to Columns option is not 
available in Excel Online. 

 The Forecast group is not available in Excel Online. 

 Subtotals are not available in the Outline group of Excel Online. 

The Review tab:  
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Again, let’s examine the differences. 

1: Proofing in Excel Online is limited to the Spelling option, where the Excel desktop 
application also provides options for using a thesaurus. 

2, 3, 4, 5, 6: The Insights, Language, Notes, Protect, and Ink groups are not available in 
Excel Online. 

The View tab:  

 

Finally, we will look at the differences in the View tab. 

 Excel Online is limited to only the Freeze Panes and New Window commands in the 
Window group, while there are many more options in the Excel desktop application. 

 You cannot hide the Formula bar in Excel Online 

 The Zoom group is not available in Excel Online. 

 The Macros group is not available in Excel Online. 
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Differences in Features Available in Both Excel Online and The Excel 
Desktop Application 

It is also important to understand that while some features are available in both Excel 
Online and the Excel desktop application, they do not necessarily perform in the same way, 
or have all the same options.  

For instance, both Excel Online and the Excel desktop application provide tools for creating 
charts to help you illustrate and analyze your data, and while the available types are similar, 
there are more types available in the desktop application, and options to edit and customize 
your charts in Excel Online can be limited in comparison. 

As an example, when creating a column chart in the Excel desktop application, you have 
options for both two-dimensional and three-dimensional column charts: 
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In comparison, Excel Online only provides options for two-dimensional column charts: 

 

Another difference when creating charts is the ability to create Combo charts. In the Excel 
desktop application, you can use two different chart types in the same chart to display 
related data series. You can also create a secondary axis, to better align the two chart types: 

 

In Excel Online, these options are currently not available. 
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When entering functions, you will also notice differences between the platforms. In the 
Excel desktop application, using the insert function command to select a function will lead 
you to the Function Arguments dialog box, where you can use the argument by argument 
references to assist you in building your function: 

 

In contrast, inserting a function in Excel Online will simply enter the function and an 
opening bracket in the selected cell:  
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Another difference between the platforms is the range and control of available colors. In 
Excel Online you are limited to using a very narrow color palette: 

 

The Excel desktop application, however, allows you to select from a range of color, font, 
and effects themes by clicking the Page Layout tab, then clicking Themes, which can 
immediately change all of the color, font, and effects elements of your worksheet: 

 

These are only a few examples of some of the differences in the features of Excel Online 
and the Excel desktop application, and, because both platforms continue to evolve over 
time, they may change in the future. Rather than knowing all of the distinct differences 
between each Excel platform, it is more important that you be aware of the potential 
limitations and benefits of each, as you decide how to best approach your projects.  
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Activity 1-2: Features that Differ Between Excel Online and the 
Excel Desktop Application 

You would like to explore the capabilities of Excel Online in comparison to the Excel desktop 
application.  

1.  To begin, open your internet browser and log into Microsoft 365. 

2.  Once you are logged in, navigate to your OneDrive location by clicking the App 
launcher Icon, then clicking the OneDrive icon: 

 

3.  Now click Upload → Files: 
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4.  Navigate to the folder where you have stored your exercise files and select the file 
Activity 1-2, then click OK: 

 

5.  You can now click on the Activity 1-2 file in your OneDrive location to open it: 

 

6.  The workbook will now open: 

 

(If the workbook opens as Read-only click Edit Anyway.) 
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7.  Now Create a clustered column chart with the data. Select the range A3:D7, then 
click Insert → Column → Clustered Column: 

 

8.  With the new chart selected, click Chart Tools Chart → Format: 
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9.  The Chart task pane will open. Click Format → Chart Title to expand the group, 
then type “Marketing Campaign Results” in the Chart Title field: 

 

10.  Now, click on the Horizontal Axis group to expand it, then click and drag the Gap 
Width slider button fully to the left: 
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11.  Now change the color of the Cost data series by clicking on the Series “Cost” group 
to expand it, then click on the Fill drop-down button: 
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12.  Click on the Green, Accent 6 color icon: 

 

13.  Now click Open in Desktop App on the ribbon: 
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14.  Now, in the Excel desktop application, select the chart and click Chart Design → 
Change Chart Type: 
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15.  The Change Chart Type dialog box will open. Select the Combo category on the All 
Charts tab, then click the Chart Type drop-down of the Value Add % series name in 
the Choose the chart type and axis for your data series section and select Stacked 
Line with Markers: 
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16.  Then click to enable the Secondary Axis checkbox next to the Value Add % series 
and click OK: 

 

17.  Right-click on one of the columns in your chart and then select Format Data Series 
from the menu: 
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18.  Type “50” in the Gap Width field to adjust the width of the columns: 

 

19.  Now click Page Layout → Themes → Integral to change the color theme of your 
workbook: 

 

Note that as you move your cursor over the different themes, the color of the Cost 
data series does not change, as it was customized in Excel Online. 
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20.  You can now close the workbook and return to the browser tab to review the 
results in Excel Online. Select the chart, then click Chart Tools Chart → Format. 
You will see in the Vertical Secondary Axis group that you can make changes to the 
bounds, units, and tick marks, even though you could not create a secondary axis 
using Excel Online:  

 

21.  Now you can close the Activity 1-2 tab in your browser, then right click the file in 
your OneDrive folder and select Download:  

 

22.  Now navigate to your download folder, rename the downloaded file to Activity 1-2 
Complete, and move it to your Exercise folder, to complete the activity: 
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Summary 
In this lesson you learned about using both Excel Online and the Excel desktop application, 
and the differences between them. You should now be comfortable managing your 
workbooks in OneDrive, opening and editing them in both applications, and understanding 
the benefits and obstacles that can be presented by each. 

 

 

Review Questions 
1. How do you open a workbook in the Excel desktop application from Excel Online?  

 

2. How can you check where your workbook is saved in the Excel desktop application?  
 

3. What is the one ribbon tab that is not available in Excel Online?  
 

4. Can you add Sparklines to a workbook in Excel Online?  
 

5. Which Excel application, Excel Online or the Excel desktop application, has access to 
Color themes? 
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LESSON 2: 
WORKSHEET AUTOMATION 

 

Lesson Objectives 

In this lesson you will learn how to: 

• Manage workbook properties 

• Record, create and edit a macro 

• Create and use a template 

• Use data validation in a workbook 
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TOPIC A: Managing Workbook Properties 
Workbook properties are details that are stored within an Excel workbook to provide 
information about the workbook author, the creation and modification dates, and more. 
This type of information is referred to as metadata and can be useful in managing multiple 
workbooks, especially in an online or shared environment. During this topic you will learn 
how to view, add, and edit workbook properties. 

 

 

Topic Objectives 

In this session, you will learn how to: 

• View, add and edit workbook properties 

• Use the Document Inspector  
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View Workbook Properties 

You can view your workbook properties by clicking File → Info → Properties → Advanced 
Properties: 

 

When the Workbook Properties dialog box opens, you will see that there are five tabs: 
General, Summary, Statistics, Contents, and Custom:  
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The General tab contains basic information about your workbook. This includes the file 
name, type, location, and size. It also displays the dates the file was created, last modified, 
and last accessed: 
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The Summary tab allows you to add information about the workbook to help you and other 
users understand the origin and purpose of the document. The fields available are Title, 
Subject, Author, Manager, Company, Category, Keywords, Comments, and Hyperlink base: 
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Like the General tab, the Statistics tab will display the date the workbook was created, last 
modified, last accessed, and last printed. It may also display the last user to have saved the 
file, the revision number (if available), and the total editing time. Like the General tab, this 
information is not editable: 
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The Contents tab lists the worksheets contained in the workbook, including hidden 
worksheets: 
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The Custom tab allows the user to add custom information about the workbook, based on 
more than 25 available options. The information can be added as Text, Date, Number, or 
Yes or no: 
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Using the Document Inspector 

The Document Inspector is a tool you can use to easily examine your workbook for personal 
or sensitive information that you may not want to include when sharing your workbook 
with other users. This information could include comments, document properties, personal 
information, hidden worksheets, hidden rows and columns, or external links. The Document 
Inspector also provides you with the ability to quickly delete this information.  

To access the Document Inspector, click File → Info → Check for Issues → Inspect 
Document: 

 

Because the Document Inspector can remove data that cannot be restored later, you will be 
encouraged to save your workbook prior to using it. This will allow you to restore to a 
previous version if you remove data that you did not intend. Click Yes to proceed: 
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The Document Inspector will open and allow you to choose the elements the Document 
Inspector should check for. By default, all the content will be inspected. To proceed click 
Inspect: 
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Once the inspection is complete, the Document Inspector will display details on any data it 
has found, as well as the option to remove it. To remove the data, click the Remove All 
button beside the data category you wish to remove. 

 

If you have chosen to remove any data, it is recommended that you click the Reinspect 
button to rerun the inspection and confirm that the data has been removed. You can also 
click the close button to return to the workbook to investigate any identified data that you 
are unsure of, such as hidden columns or rows, before returning to the inspector to once 
again inspect your workbook. 
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Activity 2-1: Managing Workbook Properties 
You need to send the commissions report to the accounting department for payment. The 
department requires that the properties information is completed for their record keeping. 
You also need to inspect the document to remove any comments that may have been 
added. 

1.  To begin, open Activity 2-1 from your Exercise Files folder:  

 

2.  Hover your mouse over cell I19 and note the comment: 

 

3.  To open the Properties dialog box, click on File → Info → Properties → Advanced 
Properties: 
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4.  The Properties dialog box will be opened. Click to select the Summary tab: 

 

5.  Type “Sales Commissions and Bonuses – January 2019” inside the Title field: 
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6.  Type your name in the Author field: 

 

7.  Type “Acme Widgets” in the Company field: 
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8.  Inside the Category field, type “Commissions:” 
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9.  Click OK to update the properties: 

 

10.  You will now see the updated properties on the right side of the Info category: 
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11.  Now click on Check for Issues → Inspect Document: 

 

12.  Click Yes to save the document: 
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13.  Click Inspect to start the inspection: 
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14.  Once complete you will note that there were comments found: 

 

15.  There were also document properties found, but you want to keep them. Click the 
Remove All button in the comments field to remove the comments: 
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16.  You can now click Close to return to the workbook: 

 

17.  Note that the comment in cell I19 has been removed: 

 

18.  Save the current workbook as Activity 2-1 Complete and then close Microsoft 
Excel 365 to complete the activity. 
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TOPIC B: Working with Macros 
One of the more powerful automation features of Excel is the ability to record and run 
Macros to streamline and execute repetitive tasks and procedures that you may encounter 
in your day-to-day use of the program. Not only can they save you time, but they can also 
help you reduce mistakes by reducing manual steps.  

 

Topic Objectives 

In this session, you will learn: 

• About macros 

• How to record a macro 

• About options for saving your macros 

• How to inspect your macro using the Visual Basic for Applications (VBA) editor 

• How to configure macro security 
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What is a Macro? 

A macro is a sequence of instructions, or code, written in the Visual Basics for Applications 
(VBA) language, that can be executed by a user to complete a task or set of tasks in Excel. 
You can create them by writing code in the VBA editor, which is built into Excel, or you can 
record your steps as you complete activities in Excel so you can run them in the future. 

 
Recording a Macro 

Recording a macro is a simple process of turning on a recorder before executing a series of 
steps in Excel, then stopping the recorder once the steps are complete. In this process you 
can name and save the macro, assign a shortcut key to activate it, and decide where you 
would like to store it. 

To start recording a macro, open the Record Macro dialog box by clicking View → Macros 
→ Record Macro: 
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In the Record Macro dialog box, you can enter a name, assign a shortcut key to execute the 
macro, define where the macro will be saved, and add a brief description of what the macro 
does: 

 

Clicking OK in the Record Macro dialog box will start recording any activities you execute in 
Excel. You can stop recording by clicking View → Macros → Stop Recording: 
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Saving a Macro 

There are very specific rules you must follow when naming your macro. The first character 
must be a letter, followed by your choice of letters, numbers, or the underscore character. 
No other characters, such as spaces or symbols, are accepted. The name must also not 
conflict with any macro names already saved in the workbook. An alert window will open 
warning you if your macro name syntax is not correct: 

 

Assigning a shortcut key to a macro is as simple as adding a character to the Shortcut key 
field. The Ctrl modifier key is included automatically, but you can add others, such as Shift, 
or Alt, by holding the selected key when you enter the character in the Shortcut key field: 
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You will be presented with three choices of where you would like to store your macro. They 
are the Personal Macro Workbook, a New Workbook, or This Workbook: 

 

Choosing to save your macro in a new workbook or the current (this) workbook restricts you 
to only use the macro when that workbook is open. 

The Personal Macro Workbook is a hidden workbook that is opened whenever you open 
the Excel desktop application. Storing a macro here makes it available to use any time you 
have your application open, but it will not be available if the workbook is opened on a 
different computer. 

To save a workbook that contains a macro you will be required to save it in a Macro-
Enabled Workbook format (.xlsm). Because macros can contain code from an unknown 
source, there is a security risk to your files and your computer. The macro-enabled 
workbook format provides increased security against malicious code by allowing users to 
confirm the trustworthiness of the source before opening the file. 
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If you try to save a standard (.xlsx) file that contains macros, an alert window will open, 
giving you the option to save the file without the macro, or directing you to exit the window 
and choose a macro-enabled file type to save the file with the macro included: 
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Inspecting and Editing Macros 

Once you have recorded your macro, you can view and edit the code using the Visual Basics 
for Applications Editor, a separate application that is built into all the Microsoft Office 
applications. To access the editor, you first must enable the Developer tab in the ribbon list. 
To do this, click File → Options → Customize Ribbon, then click to enable the Developer 
checkbox in the Main Tabs section of the Customize the Ribbon window, then click OK: 

 

You will now see the Developer tab is available in the ribbon list. Clicking on the Visual Basic 
command in the Code group will launch the VBA Editor:  

 

  



Microsoft 365 Excel: Part 3 

 

© 20019-2025Ultimate IT Courses Training Materials Inc.  

77 

Let’s review the basic parts of the VBA Editor interface:  

 

 The Standard toolbar, like other applications, includes commands that allow you to 
interact with the application. 

 The Project Explorer pane lists all open and visible workbooks and the elements that 
the VBA editor can interact with, including modules and forms. Macros that you 
record can be found in the Modules of the workbook in which you have stored 
them. 

 The Properties window will display and allow editing of the properties of the 
elements selected in the Project Explorer 

 The Code window allows you to write, display and edit VBA code. You can double-
click a module in your workbook and any code in this module will be displayed in this 
window. 

Writing and editing code in VBA can be very complex and is beyond the scope of this 
lesson, but using the VBA Editor to inspect macros that you record, or Macros that have 
been written by others, is an excellent way to begin to understand how your macros 
work and help you explore other opportunities to automate your workbooks. 
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Macro Security 

Because macros carry an increased risk of malicious code, Excel allows the user to set the 
level of security they would like to use when opening macro-enabled workbooks. To review 
these settings, click on Macro Security in the Code group of the Developer tab: 

 

The Trust Center dialog box will be displayed. If it is not already selected, click the Macro 
Settings category: 

 

In this category, there are four radio buttons available, under the Macro Settings heading. 
These options are arranged in descending order, from most secure to least. 
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Let’s review the options: 

• Disable all macros without notification disables all macros and security alerts.  

• Disable all macros with notification disables all macros, but a security alert will 
appear if there are macros present in the workbook, and you can selectively enable 
macros on a case-by-case basis. This is the default selection, and is a good balance 
between security and function: 

 

• Disable all macros except digitally signed macros disables all macros but a security 
alert will appear if there are macros present in the workbook. If the macro is digitally 
signed by a publisher, you will be notified to enable the macro and trust the 
publisher. 

• Enable all macros allows all macros to run. This option makes your computer 
vulnerable to potentially malicious code and is not recommended. 
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Activity 2-2: Working with Macros 
You have been asked to highlight the sales results of representatives that are at or above 
their sales targets, on a monthly basis. 

1.  To begin, open Activity 2-2 from your Exercise Files folder:  

 

2.  On the sheet January, click and drag to select the cells from D18 to D29: 

 

3.  Open the Record Macro dialog box by clicking View → Macros → Record Macro: 
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4.  In the Record Macro dialog box, type “At_or_Above_Target” in the Macro name 
field: 

 

5.  Click to select the Shortcut key field then press Shift + J: 
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6.  Click the Store macro in drop-down menu and select This Workbook: 

 

7.  Click OK: 
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8.  The Macro Recorder is now recording all your actions. Click Home → Conditional 
Formatting → Highlight Cells Rules → Greater Than…: 

 

9.  Enter “100000” in the field under Format cells that are GREATER THAN: and then 
select Green Fill with Dark Green Text from the drop-down list: 

 

10.  Click OK: 
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11.  Click View → Macros → Stop Recording: 

  

12.  To test your macro, clear the conditional formatting by clicking Home → 
Conditional Formatting → Clear Rules → Clear Rules from Selected Cells: 

 

13.  Open the Macros dialog box by clicking View → Macros: 
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14.  In the open Macros dialog box, select the macro you just recorded and execute it 
by clicking the Run button: 

 

15.  All the sales values greater than $100,000 are now highlighted in light green with 
dark green text: 
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16.  Press Alt + F11 to launch the VBA Editor: 

 

17.  You will see the code that was created when you recorded your macro in the Code 
window. Find the line in the code that reads “Formula1:="=100000"” and replace 
the number 1, after the equals (=) sign, with the number 2: 

 

18.  Save your changes by pressing Ctrl + S, then close the VBA Editor window by 
clicking the Close (X) button in the upper right-hand corner: 
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19.  Now go to the sheet February, select cells D18 to D29, Click View → Macros → 
View Macros: 

 

20.  Execute your macro again by selecting At_or_Above_Target in the Macro name list 
and clicking Run: 
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21.  Now, all the sales values greater than $200,000 are highlighted in light green with 
dark green text: 

 

22.  Save the current workbook as Activity 2-2 Complete and then close Microsoft 
Excel 365 to complete the activity. 
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TOPIC C: Create and Use a Template 
An Excel template is a tool that you can use to save time and automate your workflow when 
creating the same type of workbook repeatedly, such as regular reports or analyses. It 
allows you to build a standard workbook that contains a desired combination of content 
and formatting, and then use it as a template to create new workbooks, saving you time 
and helping to keep your work consistent. 

 

Topic Objectives 

In this session, you will learn how to: 

• Set the custom template directory 

• Save a workbook as a template 

• Edit a template 

• Open a new workbook based on your template 
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Set the Custom Template Directory 

Access to your custom templates is based on the Default personal templates location. You 
can set this location by clicking on File → Options, and then clicking the Save category in 
the Excel Options dialog box: 

 

The path is typically “C:\Users\[UserName]\Documents\Custom Office Templates” where 
UserName is your Username on the computer. 

If the location is not already set, you would enter the correct path and click OK.  
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Save a Workbook as a Template 

Once you have a workbook set up with all the correct layout and formatting to act as your 
template going forward, click File → Export → Change File Type, then select 
Template(*.xltx) from the Workbook File Types window, and click Save As: 

 

If required, navigate to the Default Personal Templates location, name your template, and 
click Save: 
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Edit a Template 

To edit an existing template, click File → Open, navigate to the Default Personal Templates 
location, and double-click on the template you would like to edit: 

 

Make any changes you wish to make to the template, and then simply save and close the 
template. 
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Open a New Workbook Based on a Template 

To create a new workbook based on your template, click File → New, then click the 
Personal category: 

 

You will be able to select from any available templates in the list. Click the template you 
would like to open: 
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A new workbook will open (named after the template with the addition of a number after 
the name), and you are ready to continue working with the file: 
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Activity 2-3: Create and Use a Template 
Every month you receive sales reports and you are then required to calculate the sales 
commissions that are payable to the sales reps. You would like to automate the process to 
save time and reduce the risk of errors. 

1.  To begin, open Activity 2-3 from your Exercise Files folder:  

 

2.  Click File → Options, and then click on the Save category in the Excel Options 
dialog box to ensure the Default personal templates location is set. Click OK once 
complete: 
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3.  Next, click File → Export → Change File Type, then select Template(*.xltx) from 
the Workbook File Types window, and click Save As: 

 

4.  If necessary, navigate to the Default personal templates location, and click Save: 

 

5.  Now close the open template, then open Excel 365. 
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6.  Click File → New, then click the Personal category, and select Activity 2-3: 

 

7.  A workbook titled Activity 2-31 will now be open: 

 

8.  Now open Activity 2-3A: 
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9.  Select the data in cells A8 to D19, then press Ctrl + C to copy the data: 

 

10.  Switch to open window of the workbook Activity 2-31, place your cursor in cell 
A10, then click Home → Paste → Paste Values: 
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11.  You will see that the calculations for commissions and bonuses update 
automatically. Now you can select rows 22 to 26, then select the Delete drop-
down in the Cells group in the Home tab, and click Delete Sheet Rows: 

 

12.  You can now type “March” in cell B3, and your report is complete: 

 

13.  Save the current workbook as Activity 2-3 Complete and then close Microsoft 
Excel 365 to complete the activity. 
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TOPIC D: Use Data Validation in a Workbook 
Data accuracy is always important when working with and analyzing information in your 
workbooks, and errors in data input can have embarrassing or time-consuming 
consequences. Data Validation provides you with tools to make sure that the data being 
entered in your workbooks is in the correct format and is the correct type. In this topic you 
will learn how to use data validation to improve data accuracy. 

 

Topic Objectives 

In this session, you will learn about: 

• The Data Validation dialog box 

• Data validation settings 

• Input messages 

• Error alerts 
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The Data Validation Dialog Box 

Microsoft Excel allows you to enter any type of data in any cell by default. This allows a 
great deal of flexibility when inputting data, but it also creates opportunities for making 
errors that could have a negative impact on your analysis or presentation. Data validation 
provides you with tools you can use, not only to prevent errors, but to also help automate 
your input. 

Let’s explore the available features of data validation by first looking at the Data Validation 
dialog box. To open, click the Data tab on the ribbon and then click Data Validation in the 
Data Tools group: 

 

The Data Validation dialog box has three tabs: Settings, Input Message and Error Alert. All 
three play a part in controlling what happens when entered data does not match the 
criteria you have defined. 
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Data Validation Settings 

The Settings tab allows you to set the Validation criteria to allow certain types of data in a 
selected cell or range of cells: 

 

The Allow field provides the following options: 

• Any value, meaning no restriction on text or numbers 
• Whole numbers defined by a logical condition (<, >, >=, etc.) 
• Decimal numbers defined by a logical condition 
• List, as defined by a range of cells from another location, or an input list 

• Date, defined by a logical condition 
• Time, defined by a logical condition 
• Text length with minimum/maximum length settings 
• Custom data, defined by a formula specific to your needs 

Each option allows for a set of conditions or a range to give you greater control of what is 
allowed in this cell or range. 
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Input Messages 

The Input Message tab allows you to define a message to be displayed when a user selects 
a cell that has data validation settings applied.  
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Error Alerts 

The Error Alert tab lets you define a custom message to display after invalid data is entered 
in a cell, and the Style drop-down determines how you enforce your validation rules: 

 

When the Style is set to Stop, invalid data will trigger the error message and the input is not 
allowed. Options are Retry, Cancel, and Help: 
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When the Style is set to Warning, invalid data will trigger the error message and the 
Warning alert will give the user four options: Yes, to accept the invalid data, No, to edit the 
data, Cancel, to remove the data, and Help: 

 

When the style is set to Information, invalid data will trigger the error message and the 
Information alert will give the user the option to accept the value, cancel the entry, or seek 
help: 
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Activity 2-4: Use Data Validation 
You are creating a worksheet to keep track of inventory receipts from three separate 
warehouses. The data will be used to update the company inventory records, so your data 
must be accurate. 

1.  To begin, open Activity 2-4 from your Exercise Files folder:  

 

2.  Select cells A4 to A20, then Click Data → Data Validation: 
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3.  Select Date from the Allow drop-down list in the Settings tab. Ensure there is a 
checkmark in the checkbox labeled Ignore blank: 

 

4.  Select Less than or equal to in the Data drop-down list: 
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5.  Enter “=TODAY()” in the End date field: 

 

6.  Select the Input Message tab, and enter “Purchase Order Receipt Date” in the 
Input message field: 
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7.  Select the Error Alert tab, and enter “Cell must contain a date of today or earlier” 
in the Error message field, then click OK: 

 

8.  Now select cells B4 to B20, click Data → Data Validation, and select List from the 
Allow drop-down list in the Settings tab. Ensure there are checkmarks in the 
checkboxes labeled Ignore blank and In-cell dropdown: 
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9.  Type “A, B, C” in the Source field and click OK: 

 

10.  Now select cells C4 to C20, click Data → Data Validation, and select Text Length 
from the Allow drop-down list in the Settings tab. Ensure there is a checkmark in 
the checkbox labeled Ignore blank: 
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11.  Select equal to in the Data drop-down list, and type “5” in the Length field: 

 

12.  Click on the Error Alert tab and select Warning from the Style drop-down list. Type 
“Most Purchase Order Numbers are 5 characters. Please check the PO Number 
for this entry.” Click OK to apply your changes: 
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13.  To test your new data validation, first select cell A4. You will see a ScreenTip 
appear with the input message you added: 

 

14.  Now enter a date that is greater than today. You will see the error message you 
configured in the Error Alert tab. Click Cancel: 

 

15.  In the same cell, A4, enter the current date. As the date falls within your guidelines 
nothing will happen, and the value will be accepted: 
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16.  Now select cell B4, click on the drop-down arrow, and you will be presented with 
the list you configured in the Data Validation dialog box. If you type “D”, an Error 
Alert window will open with the message “This value doesn’t match the data 
validation restrictions defined for this cell.” This is the default message that will 
appear if you do not enter a custom message in the Error Alert tab. Click Cancel 
and select B from the drop-down list: 

 

17.  Finally, select cell C4 and type “4597”, then press Tab. An Error Alert window will 
appear with the message you configured. Because you selected Warning in the 
Style drop-down list, you can accept this entry as correct by clicking Yes: 

 

18.  Save the current workbook as Activity 2-4 Complete and then close Microsoft 
Excel 365 to complete the activity. 
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Summary 
In this lesson you have learned about ways to automate worksheets and their functionality. 
You should now be comfortable managing workbook properties, recording and running 
basic macros, creating and using templates, and using data validation criteria. 

 

 

Review Questions 
1. Where can you find the Workbook Properties displayed? 

 

2. What is the name of the programming language that you can use to write Macros? 

 

3. Where can you store macros that you have recorded?  

 

4. How do you create a new workbook from a Personal template? 

 

5. How can Data Validation help you automate data entry? 
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LESSON 3: 
AUDITING AND ERROR CHECKING 

 

Lesson Objectives 

In this lesson you will learn about: 

• Tracing cells 

• Error checking 

• Evaluating formulas and using the Watch Window 

• Data List Outlines 
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TOPIC A: Tracing Cells 
An important part of being able to build accurate and error-free workbooks is 
understanding how your formulas work, where they source their data, and how the results 
may impact other elements in the workbook. Tracing cells can be a valuable tool to help you 
do this, by graphically displaying where data is coming from in your formulas, or how data in 
a cell is being used by other formulas. In this topic you will learn about these tools and how 
you can use them. 

 

Topic Objectives 

In this session, you will learn: 

• How to show formulas 

• How to trace precedents and dependents 

• About tracer arrows 
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Show Formulas 

By default, Microsoft Excel shows the calculated results of a formula, but there are times 
you may find it easier to understand what is happening in a worksheet, or identify the 
source of a problem, by being able to see which cells contain data and which contain 
formulas. You can quickly change the display in your worksheet to show formulas by clicking 
the Formulas tab, and then clicking Show Formulas in the Formula Auditing group. Clicking 
Show Formulas again will switch the view back to calculated results: 

 

When formulas are being displayed, you can click on any formula and Excel will display 
color-coded highlights that show all the cells that are used in the formula: 
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When calculated results are displayed, you first must select the cell that contains the 
formula then click your cursor in the formula bar to display these highlights: 

 

 
Trace Precedents and Dependents 

To get a more detailed view of how a formula is working, you can use either the Trace 
Precedents or Trace Dependents commands. This will display tracer arrows that will 
indicate the direction of the data flow to and from cells and formulas.  

Precedent cells are cells within a worksheet that are the source of data for a formula in the 
active cell. To display tracer arrows that indicate precedent cells, select a cell containing a 
formula and click Formulas → Trace Precedents: 
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Blue arrows will appear, originating from any cells that provide source data to the selected 
formula. 

Dependent cells are cells within a worksheet that use the contents of the active cell in 
formulas. To display tracer arrows that indicate dependent cells, select a cell that is 
referenced in a formula and click the Trace Dependents command: 

 

Blue arrows will appear, originating from the selected cell, and pointing to any cell that 
contains a formula that references that cell. 

Tracer arrows will continue to be displayed, even if you choose to select other cells and 
continue to add more tracer arrows. Clicking Formulas → Remove Arrows will remove all 
arrows. You also have the option to selectively remove either precedent or dependent 
arrows by clicking the Remove Arrows drop-down, and selecting either Remove Precedent 
Arrows, or Remove Dependent Arrows: 
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Tracer Arrows 

As illustrated, tracer arrows referring to cells on the active worksheet will appear in blue. 
References to cells on other sheets in the workbook, or in other workbooks, will display the 
tracer arrow as a dotted black line that ends in a small worksheet icon. 

 

You can double-click this dashed arrow to display the Go To dialog box. Selecting a 
reference in the Go to list and clicking OK will open the corresponding worksheet or 
workbook: 
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Activity 3-1: Tracing Cells 
You have been asked to take over the job of updating a workbook that tracks employee 
purchases of company products. To help you understand how the formulas work, you use 
the trace cells feature. 

1.  To begin, open Activity 3-1 from your Exercise Files folder:  

 

2.  First, let’s look at the formulas on the sheet. Click Formulas → Show Formulas: 

 

3.  Now click cell G4 to highlight the elements of the formula: 
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4.  To switch back to viewing calculated results Press Ctrl + `:  

 

5.  Cell G4 should still be the active cell. Click Formulas → Trace Precedents: 

 

6.  A blue arrow will be drawn through all the precedent cells for the formula in cell 
G4. You will see that Cells E1 and F4 are being used to calculate this value: 

 

7.  Remove the tracer arrow by clicking Formulas → Remove Arrows: 
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8.  Now click to select cell E4, then click Formulas → Trace Precedents: 

 

9.  You will see a blue arrow originating in cell C4, as well as a black dotted arrow that 
originates from a small worksheet icon. Double-click on the black dotted line: 

 

10.  The Go To dialog box will appear and list the reference “'[Activity 3-
1.xlsx]Sheet2'!$A:$B” in the Go to window: 
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11.  When you select this reference, it will appear in the Reference window. You can 
now click OK: 

 

12.  Sheet2 will become active and you will see the source of the data used in the 
formula: 
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13.  Now click on Sheet1 to make it the active sheet, and click Formulas → Remove 
Arrows:  

 

14.  Then click to select cell E1. Click Formulas → Trace Dependents: 

 

15.  Multiple blue arrows will show that the value in cell E1 is being used by the 
formulas in cells G4 to G16: 

 

16.  Save the current workbook as Activity 3-1 Complete and then close Microsoft 
Excel 365 to complete the activity. 
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TOPIC B: Error Checking 
Now that you have an understanding of how to identify formulas and trace their elements, 
we will look at the different types of errors that you may encounter, and the tools that you 
can use to identify and repair them. In this topic you will learn about invalid data, formula 
errors, and how to check for them. 

 

Topic Objectives 

In this session, you will learn about: 

• Invalid data 

• Formula errors and their types 

• How to check for errors 
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Invalid Data 

Even with our best efforts there are times that invalid data can be introduced into a 
spreadsheet. Invalid data is data that is not the correct type or quality required for any 
functions or formulas that make use of it. As an example, if you have a column of dollar 
values, and a date is inserted into a cell in this column, not only is the cell value incorrect, 
but it could also impact any dependent calculations the refer to this column. Fortunately, 
invalid data will often result in formula errors, which will alert you to a problem in your 
worksheet. 

 

Formula Errors and Their Types 

When you use functions to build formulas in Excel, it is expected that the data you 
reference has certain characteristics. For instance, when you multiply values, it is assumed 
that all the cells referenced in the function are numbers.  

When Excel does not find what it expects in precedent cells, it will often return an error 
value in the dependent cell that will give you an indication of the type of error that has 
occurred, which you can then use to resolve the error. 

Below is an overview of the error types and what they mean: 

Error Name Error Description 

#VALUE! Occurs when the type of data referenced does not match what the 
function expects. An example would be adding a text value where a 
number is expected. 

#REF! Occurs when a referenced cell is deleted or moved. An example would be 
creating a formula adding the values of two cells then deleting one of the 
cells. 

#DIV/0! Occurs when a mathematical function tries to divide a number by zero. 

#NAME? Occurs when Excel cannot find a named element. This often occurs when 
a string in a formula does not include quotation marks. 
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#NULL! Occurs when there is an incorrect operator in a range function. An 
example would be using a space instead of a colon in a sum function. 

#N/A Occurs when a function cannot find the value it is looking for. An example 
would be the VLOOKUP function not finding a result. 

#NUM! Occurs when a function references an invalid numeric value or returns a 
value larger that Excel can use. 

######## Occurs when the contents of a cell are too wide to be displayed. This can 
often be resolved by enlarging the column. 

 

 
How to Check for Errors 

To access error checking tools in Excel, you would first click the Formulas tab, then click the 
Error Checking drop-down arrow. The three available options are Error Checking, Trace 
Error, and Circular References. 
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Error Checking works in a similar way to a Spell Check function in a word processing 
program. When launched it will allow you to cycle through all the existing errors on the 
worksheet and use the available tools to resolve them: 

 

The Error Checking dialog box provides information on (1) the location of the error, and (2) 
a description of the error. You can use the buttons on the right to (3) Open the Help file for 
information on the error, (4) Show the calculation steps in the formula (or Trace the Error, 
if there is only one step), (5) Ignore the Error for the time being, and (6) Edit in the Formula 
Bar to manually correct the error. You can use the (7) Previous and Next buttons to cycle 
through all errors on the sheet. 

The Trace Error command will display tracer arrows to indicate any precedents in the 
formula. A red arrow will indicate the source of the error. Blue and black arrows behave the 
same as in the Trace Precedents command. This will often provide you with the information 
you need to correct the error: 
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The Circular References command highlights any cells that contain a formula with a circular 
reference. A circular reference is when a formula refers to any cell that contains a reference 
to the results of that formula.  

 

Typically, Excel will warn you at the time you attempt to create a circular reference: 
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Activity 3-2: Error Checking 

A colleague has been managing a worksheet for you while you were on holiday. When you 
return and review the worksheet, you notice there are errors in some of the formulas. You 
need to troubleshoot the errors: 

1.  To begin, open Activity 3-2 from your Exercise Files folder:  

 

2.  You notice there are several error types. Start by selecting cell G4, which contains a 
#REF! error, then click Formulas → Error Checking → Trace Error: 

  

3.  You will see that there is only one blue arrow tracing from the cell F4. It seems the 
formula has lost the reference to the discount amount: 
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4.  Click in the formula bar and select the “#REF!” text:  

 

5.  Now click on cell E1 to insert a reference to that cell in the formula: 

 

6.  Make sure to press F4 to create an absolute reference:  

 

7.  Then copy the corrected formula down to cell G16: 
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8.  Now click on cell H10, where there is a #VALUE! error, and again click Formulas → 
Error Checking → Trace Error. You will see a red arrow indicating the source of the 
value error, and that cell F10 will be selected: 

 

9.  Click Formulas → Error Checking, and you will see, under the Error in Value 
heading, that a value used in the formula is of the wrong data type: 
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10.  Click cell E9 and drag the handle down to copy the formula to cell E10. You will see 
that the error in cell F10 is replaced by the correct calculated amount, and the 
options in the Error Checking dialog are grayed out: 

 

11.  Click the Resume button in the Error Checking dialog box to move to the next 
error: 
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12.  The Error Checking dialog box will now be referencing a #NULL! error in cell H17, 
where the ranges in the formula do not intersect. As you can see in the formula, 
“=SUM(H4 H16),” a space has been used instead of a colon to separate the two cell 
references: 

 

13.  Click the Edit in Formula Bar button: 
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14.  Replace the space with a colon, then press Enter: 

 

15.  The #NULL! Error is replaced with the correct calculated value: 
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16.  Click the Resume button again and an Alert window will appear indicating that the 
error chick is complete. Click OK: 

 

17.  The Error Checking dialog box will close, and you will see that all the errors have 
been resolved: 

 

18.  Save the current workbook as Activity 3-2 Complete and then close Microsoft 
Excel 365 to complete the activity. 
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TOPIC C: Evaluating Formulas and Using the 
Watch Window 
As your formulas and workbooks become more complex, it can become difficult to keep 
track of the impact that any changes will make when you update and edit your files. 
Fortunately, Excel provides you with tools that you can use to monitor and evaluate your 
formulas so you can be sure they are operating correctly. In this topic you will learn about 
the tools you can use to track activity in your workbook or other open workbooks. 

 

Topic Objectives 

In this session, you will learn about: 

• The Watch Window 

• The Camera tool 

• The Evaluate Formula tool 
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The Watch Window 

As the workbooks you create or work with become larger and more complicated, you may 
find that there are formulas throughout the workbook that you will need to frequently 
check on as you work to ensure the values are correct, or that the results of changes are 
what you expect. The Watch Window provides you with the ability to display, in one place, 
the results of many formulas throughout your workbook. 

To use the Watch Window, click Formulas → Watch Window: 

 

The Watch Window dialog box will appear: 

 

To add a formula, or formulas, to the Watch Window, click the Add Watch button: 
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In the Add Watch dialog box that opens, you can select a cell, or cells, to watch. Once you 
have selected the cell(s), click Add: 

 

The watch window will now display information about your watched cells, including the 
workbook and worksheet in which the cells reside, the name of the cell (if it has been given 
a name), the cell reference, the value, and the formula. The Watch Window will remain 
visible even if you switch to another worksheet, or another workbook. Any changes to the 
watched value or to the formula will display immediately in the window: 

 

You can add more values to the window by clicking Add Watch and selecting more cells. To 
remove values, select the cell you would like to remove and click Delete Watch. When you 
are finished with the watch window you can simply click the Close (X) button. 
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The Camera Tool 

Another way to track changes in a separate worksheet or workbook is using the Camera 
tool. With it you can capture an image of a cell, a group of cells, or even charts or images. 
You can then place the image on the sheet you are working on, and it will update in real 
time to any changes that are made. 

The Camera tool is not available by default. To enable it right-click on any of the tabs in the 
ribbon list and click Customize the Ribbon: 
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The Excel Options dialog box will open with the Customize the Ribbon category selected. 
Select the Quick Access Toolbar category instead: 
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In the Choose commands from drop-down list select All Commands: 
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Scroll down the list and select Camera, then click the Add button to the right of the list, 
then click OK: 

 

You will now see the Camera tool icon in the Quick Access Toolbar: 
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To capture an image, first select the range of cells that you would like to monitor: 

 

Next, click the Camera icon in the Quick Access Toolbar: 
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Finally, go to the location where you want to place the image and click where you would like 
to place the top left corner. The image will be placed, and when data changes in the original 
range, it will be updated in the image. The image can also be moved, scaled, or formatted 
like any other picture: 

 

 

The Evaluate Formula Tool 

As your formulas become more complex, and their data sources expand, it can become 
more difficult to understand exactly how the result is calculated. The Evaluate Formula tool 
allows you to follow the steps through each operation in a formula, in the order they are 
executed, and see the values and functions that contribute to the result. 

To begin, first select a formula that you would like to evaluate and click Formulas → 
Evaluate Formula: 
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When the Evaluate Formula window opens, Excel will display the formula as it is written in 
the worksheet. The first part of the formula to be evaluated will be underlined: 

 

Clicking Evaluate triggers Excel to evaluate the underlined part of the formula and display 
the result, in italics. The next element of the formula to be evaluated will then be 
underlined: 
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Clicking Step In will let you examine the formula or value of the underlined cell. To continue 
evaluating click Step Out: 

 

You can continue to evaluate each step in the formula until you have reached the result, 
which is the result displayed in the cell you have selected. You can begin the evaluation 
again by clicking Restart, or finish the evaluation by clicking Close: 
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Activity 3-3: Evaluating Formulas and Using the Watch Window 

You have been asked to look at the impact of adjusting the sales commissions and bonuses 
for the sales team, but the inputs are on a separate sheet from the calculations.  

1.  To begin, open Activity 3-3 from your Exercise Files folder:  

 

2.  First, to understand the bonus calculation, click to select cell H10, then click 
Formulas → Evaluate Formula: 
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3.  In the Evaluate Formula dialog box, click the Evaluate button until the reference 
“$C$5” is underlined: 

 

4.  Now click the Step In button to show the value or source of the reference.  
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5.  You will see that the bonus percentage in cell C5 is located on Sheet2 in cell C2. 
Click the Evaluate button: 

 

6.  You will see that the value of cell C2 in Sheet2 is 3%. Click Step Out to return to the 
formula evaluation: 
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7.  Click the Evaluate button until the result is displayed. 

  

8.  You can now click the Close button to exit the dialog box: 
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9.  You now know you must change the commission and bonus values on Sheet2 to 
see the results in the total commissions and bonuses on Sheet1. Click Formulas → 
Watch Window to launch the Watch Window dialog box: 

 

10.  Now click and drag to select cells G22:J22, then click Add Watch in the Watch 
Window dialog box: 

 

11.  The Add Watch dialog box will appear. Confirm the selection is correct and click the 
Add button: 
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12.  The Watch Window dialog box will appear, and the details of the selected cells will 
be displayed: 

 

13.  Now click on the Sheet2 tab to switch to Sheet2. Select cell C2 and change the 
value to 4%. You will see the values in the Watch Window update to reflect this 
change: 

 

14.  You can now close the Watch Window dialog box and return to Sheet1. You can 
add the Camera tool to the Quick Access Toolbar by right-clicking any of the tabs in 
the ribbon list and clicking Customize the Ribbon: 
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15.  Select the Quick Access Toolbar category, then select All Commands from the 
Choose Commands From drop-down list, scroll down and click the Camera option. 
Click the Add button to add the Camera tool to the Customize Quick Access 
Toolbar list, then click OK: 
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16.  Click and drag to select cells G9:J22, then click the Camera icon in the Quick Access 
Toolbar: 

 

17.  Now switch to Sheet2 and click your mouse to the right of the Sales and Bonus 
Rates data. An image of the cells selected on Sheet1 will appear: 
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18.  Change the value in cell C2 to 5% and notice the values have changed in your 
image: 

 

19.  Save the current workbook as Activity 3-3 Complete and then close Microsoft 
Excel 365 to complete the activity. 
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TOPIC D: Data List Outlines 
Dealing with large amounts of data in a worksheet can make it difficult to isolate and 
understand the information that is most important for you, or other users. Outlines and 
subtotals are tools that can help you summarize and present information in a clear and 
concise way. In this topic you will learn how to use outlines and subtotals to organize your 
data. 

 

Topic Objectives 

In this session, you will learn about: 

• Outlines 

• Auto outlines 

• The Subtotal command 
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Outlines 

Outlines are an organizational tool that will allow you to group and present large amounts 
of data in a way that is easy to read and understand, while maintaining the ability to drill 
down into a detailed view.  

The first step to creating outlines is to group your data. You can do this manually by 
selecting rows or columns in your worksheet and clicking Data → Group: 

 

Above the selected columns, a bar will appear, with a minus (-) sign in a box to the right: 
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Clicking the minus (-) sign will collapse the columns so that they are no longer visible, and 
only a box will remain, containing a plus (+) sign: 

 

You will also see there are two boxes, in the top left of the window, one above the other, 
numbered one (1) and two (2). Clicking two (2) will expand the group, while clicking one (1) 
will collapse the group:  

 

To remove outlines, click the Ungroup drop-down in the Outline group, then click Clear 
Outline:  
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Auto Outline 

You can also have Excel group your data automatically, based on the data structure. To do 
this, click the Group drop-down arrow, then click Auto Outline: 

 

Excel will examine your data and create groups based on the structure. In this example, 
Excel has created a group for each quarter total and another one for the 6 Month Total: 
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The Subtotal Command 

In the previous example, you may have noticed that the two quarter period subtotals were 
already built into the data, so Excel was able to accurately assign the group to these 
columns. In Column A, though, there are no subtotals for the expense categories, therefore 
no groups were assigned. Using the Subtotal command, you can quickly add subtotals 
based on a column of data, in this case, the expense categories: 

 

First, you must make sure that your data is sorted by the column on which you wish to 
calculate the subtotal. To sort the data, click to select any cell in the data set and click Data 
→ Sort: 
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The Sort dialog box will open. Select the column to sort by in the Sort by drop-down list, 
and click OK: 

 

With the data sorted correctly, the Subtotal dialog box can be launched by clicking to select 
any cell in the data set, and clicking Data → Subtotal: 

 

In the At each change in drop-down list, you can select the column you wish to subtotal: 
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In the Use function drop-down list, you can select the function to use for the subtotal. The 
most commonly used function is Sum, but you can also use choose from other options, 
including Count, Average, Max, Min, and Product: 

 

In the Add subtotal to list, select the columns that you want to show a subtotal value in. 
Click the checkbox next to each column to select or deselect it: 
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Finally, you can choose to replace current subtotals, add page breaks between groups, or 
add a Summary (grand total) below your data, by clicking to select the corresponding 
checkbox. To complete the process, click OK: 

 

Subtotals for each category will be created, a grand total will be added, if selected, and 
outline bars will appear to the left of the window: 
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Activity 3-4: Creating a Data List Outline 

You have been asked to create a Sales Expense budget for the last six months of the year. 
To simplify the presentation of the data you choose to use outlines. 

1.  To begin, open Activity 3-4 from your Exercise Files folder:  

 

2.  Select columns C to E, then click Data → Group: 

 

3.  Click on the minus (-) sign next to the outline bar above the data: 
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4.  You will see that the columns have collapsed and there is a plus (+) sign above 
column F: 

 

5.  Now click the number two (2) in the box above the row numbers: 
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6.  The columns C through E will be expanded: 

 

7.  To remove the outline, click the Ungroup drop-down in the Outline group, then 
click Clear Outline: 

 

8.  Now click on any cell in your sheet to clear the selection of columns C to E, then 
click the Group drop-down in the Outline group, then click Auto Outline: 

 

9.  You will see that there are now outlines above both quarters, and also above the 
full six months, but there are no groups for the expense categories: 
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10.  To subtotal the expense categories, click Data → Subtotal: 

 

11.  Select Category in the At each change in drop-down list, select Sum in the Use 
function drop-down list, click in the checkboxes for all columns except for 
Category and Expense, and ensure the Summary below data checkbox is enabled, 
then click OK: 
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12.  You will see that subtotals have been added for each category and that the outline 
bars have appeared to the left of the data. You will also note that the outline bars 
above your columns are no longer there: 

 

13.  Click Data → Group → Auto Outline again. An alert window will appear to confirm 
you want to modify the existing outline. Click OK: 

 

14.  You will now see that outlines have been applied for all columns and rows: 
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15.  Now click the number two (2) in the box above the row numbers, and in the box 
across from the column letters. You now have a simplified view of your data: 

 

16.  You can now click the plus (+) sign beside any of the categories, or above either of 
the quarters, to show the detailed data: 

 

17.  Save the current workbook as Activity 3-4 Complete and then close Microsoft 
Excel 365 to complete the activity. 
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Summary 
During this lesson, you learned about the variety of tools you can use to help you 
understand errors in your formulas and data, and how they work together. You also learned 
about tools to help you summarize and present your data clearly. You should now be 
comfortable using the formula auditing tools to trace errors and evaluate formulas. You 
should also be able to track your formulas using the Watch Window, and the Camera tool. 
Finally, you should have a good understanding of how to arrange and display your data 
using the Group commands. 

 

Review Questions 
1. What does a black dotted tracer arrow indicate? 

 

2. What are dependent cells? 

 

3. What does the “#DIV/0!” error indicate? 

 

4. What does the Step In button in the Evaluate Formula dialog box do? 

 

5. What needs to be done to your data before you use the Subtotal command? 
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LESSON 4: 
DATA ANALYSIS AND PRESENTATION 

 

Lesson Objectives 

In this lesson you will learn how to: 

• Use the Quick Analysis tool 

• Add sparklines 

• Perform What-If analysis 

• Load and use the Analysis ToolPak 
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TOPIC A: Quick Analysis Tool 
In previous lessons you have learned about many of the tools that are available to analyze 
your data, including Custom Formatting, Charts, and Formulas. The Quick Analysis tool 
provides you with access to many of these tools in one location so you can quickly analyze a 
selected set of data. In this topic you will learn about the Quick Analysis tool and how to use 
it.  

 

Topic Objectives 

In this session, you will learn: 

• How to access the Quick Analysis tool 

• About available Quick Analysis options 
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Access the Quick Analysis Tool 

The Quick Analysis tool is a feature in Excel 365 that lets you quickly select from many of 
the application’s most commonly used analysis tools after selecting a range of data. It 
presents itself as a small button, at the bottom right corner of a selection of two or more 
cells. To access the options in the tool, simply click the button: 
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The Quick Analysis toolbar will appear with tabs for Formatting, Charts, Totals, Tables, and 
Sparklines. Below each heading tab are buttons to select specific actions to apply to your 
data: 

 

Clicking on a heading tab will reveal the options under that heading: 
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Hovering over an option will display a preview of the analysis: 

 

Clicking the option will complete the analysis and close the Quick Analysis toolbar: 
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Quick Analysis Options 

Each headings tab in the Quick Analysis toolbar presents options for analysis: 

The Formatting tab allows you to preview and apply the most popular conditional formats: 

  

The Charts tab allows you to preview and select recommended charts: 

  

The Totals tab allows you to preview and insert basic calculations. Clicking the arrows at 
either end allows you to see more options: 
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The Tables tab allows you to preview and insert a table or different pivot tables options: 

  

The Sparklines tab allows you to preview and insert Sparkline graphics: 
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Activity 4-1: The Quick Analysis Tool 

You are considering ways to analyze and present the data in one of your worksheets, but 
you are not sure what the best approach would be. 

1.  To begin, open Activity 4-1 from your Exercise Files folder:  

 

2.  Click and drag to select cells D4 to I15. Click on the Quick Analysis Tool button that 
appears at the bottom right of your selection: 

 

3.  Try using conditional formatting to highlight the differences in the sales results for 
each sales rep. Hover your mouse over the Color button: 
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4.  Next, hover your mouse over the Data Bars button: 

 

5.  You decide you want to highlight sales amounts that were above the monthly sales 
target. Click on the Greater (than) button: 

 

6.  In the Greater Than dialog box that appears, type “100,000” in the Format cells 
that are GREATER THAN: field, then select Green Fill with Dark Green Text from 
the with drop-down list. Click OK: 
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7.  Cells with a value greater than $100,000 are now highlighted so they can be quickly 
identified: 

  

8.  Now you would like to compare sales performance by sales rep for the year to 
date. Again, select cells D4 to I15 (if required) and click on the Quick Analysis Tool 
button that appears at the bottom right of your selection: 
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9.  Click the Totals tab and hover over the Sum button on the right: 

 

10.  Now that you see the preview, click on the Sum button to accept adding the sum 
formulas: 

 

11.  Now select cells J4 to J15, the totals you just added, and click on click on the Quick 
Analysis Tool button: 

 



Microsoft 365 Excel: Part 3 

 

© 20019-2025Ultimate IT Courses Training Materials Inc.  

184 

12.  Hover over the Color button to preview the conditional formatting: 

 

13.  The colors allow you to see at a glance the sales performance of the sales reps, 
relative to each other. Click the Color button to accept the conditional formatting: 

 

14.  Save the current workbook as Activity 4-1 Complete and then close Microsoft 
Excel 365 to complete the activity. 
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TOPIC B: Adding Sparklines 
A Sparkline is a small chart graphic that is contained within a single cell to provide a visual 
representation of a set of data. You can use Sparklines to show trends in a series of values 
so users can quickly analyze the related information. To be effective, they should be 
positioned close the data they are representing. In this topic you will learn about the 
different kinds of Sparklines and how to use them. 

 

 

Topic Objectives 

In this session, you will learn about: 

• Available Sparkline types 

• Inserting and editing Sparklines 

• The Sparkline Design tab 
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Sparkline Types 

Like regular charts in Excel, different types of Sparklines are available to help you better 
show the trends in the data with which you are working. The three types of Sparklines you 
can use are Line, Column, and Win/Loss: 

 

The Line type of Sparkline is used to show the upward or downward trend for a set of data, 
just like the standard line chart in Excel: 

 

The Column type of Sparkline also shows upwards or downwards trends, but the data is 
plotted using a column graph instead of a line graph: 

 

The Win/Loss type of Sparkline shows if the referenced data is above or below zero: 
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Inserting and Editing Sparklines 

To launch the Create Sparkline dialog box, click the Insert tab on the ribbon list, then from 
the Sparklines group, click on the button representing the type of Sparkline you would like 
to insert: 

 

In the Create Sparklines dialog box, select or type the data range in the Data Range field, 
then select or type the location you would like the Sparkline to be placed, in the Location 
Range field: 
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To complete the process, click OK. The Sparkline will appear in the selected cell: 

 

 

The Sparkline Tab 

Once a Sparkline has been inserted into a cell, and that cell is the active cell, the Sparkline 
contextual tab will be displayed on the ribbon: 

 

Clicking on the Sparkline contextual tab in the ribbon will present several groups of options 
for modifying your Sparkline(s): 

 

The (1) Sparkline group contains a single drop-down command that you can use to edit the 
data source and the Sparkline placement. 

The (2) Type group lets you select between the three types of Sparklines. 

The (3) Show group contains six checkboxes that let you use markers or colors to highlight 
elements of the data. 

The (4) Style group contains the style gallery, where you can choose from an assortment of 
preconfigured styles for each Sparkline type. You can also choose colors for the lines or 
columns, as well as for the markers. 
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The (5) Group lets you select options for grouping or ungrouping Sparklines. Grouping 
Sparklines lets you make modifications to all the Sparklines in the group at once. You will 
also find options here to control the axis features, such as scaling, and direction. 
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Activity 4-2: Adding Sparklines 

You are preparing a worksheet showing the monthly sales revenue for each member of your 
sales team. You would like to be able to visualize the trends from month to month for each 
salesperson, and decide to try Sparklines. 

1.  To begin, open Activity 4-2 from your Exercise Files folder:  

 

2.  Click the Insert tab, then click the Column button in the Sparklines group: 

 

3.  In the Create Sparkline dialog box, type or select the range “D4:I15” in the Data 
Range field. In the Location Range field type or select “$J$4:$J$15,” then click OK: 
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4.  The column Sparklines, showing the monthly trends for each salesperson, will be 
displayed in column J: 

 

5.  You decide you would like to try the Line type Sparklines to see if they will illustrate 
the trends better. With the Sparklines selected, the Sparkline contextual tab should 
be displayed in the ribbon list. Click the Line button in the Type group, to convert 
the Sparklines: 
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6.  In the Show group, click the High Point and Low Point checkboxes to enable them. 
You will see that red markers have been placed on the Sparklines to indicate the 
highest and lowest value: 

  

7.  To differentiate between the high and low values, click the Marker Color drop-
down command, click High Point, then click the Green standard color: 
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8.  The marker indicating the highest value in the data series is now green. You can 
quickly see the trends in sales revenue for each salesperson and you can also 
quickly locate their highest and lowest revenue months: 

 

9.  Save the current workbook as Activity 4-2 Complete and then close Microsoft 
Excel 365 to complete the activity. 
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TOPIC C: What-If Analysis 
Excel users often encounter situations where they want to understand what would happen 
if certain variables in their data changed. One example would be wanting to understand 
how your profit would be impacted by changes in your revenue. Another example would be 
wanting to know what price you should set for a product if you want to make a specific 
profit. Approaching these problems manually could mean creating many different versions 
of the same worksheet, or even entering guesses in a field repeatedly until you get the 
result you are looking for. Fortunately, Excel provides us with tool that can help us 
automate this process and make it easier to explore many what-if scenarios. In this topic 
you will learn about the tools available in the What-If Analysis command and how to use 
them: 

 

 

Topic Objectives 

In this session, you will learn about: 

• Using the Scenario Manager 

• Using Goal Seek 

• Using the Solver 
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The Scenario Manager 

The Scenario Manager is a tool that will let you create and store different sets of variables 
as scenarios, which you can then apply to a data set to understand their impact. You can 
also create a summary report that will let you view the results of all your scenarios 
together. 

To access the Scenario Manager dialog box, click Data → What-If analysis → Scenario 
Manager: 

 

Once open, the Scenario Manager dialog box allows you to create a series of scenarios 
based on changing the values in key cells in your worksheet: 
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Clicking the Add button will open the Add Scenario dialog box, where you can assign a 
name for your first scenario and select the cells that will be changing: 

 

Clicking the OK button will open the Scenario Values dialog box, where the values that will 
change with each scenario can be added: 
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Clicking the OK button in the Scenario Values dialog box will return you to the Scenario 
Manager dialog box, which will now list the scenario created. You can now continue to build 
scenarios by clicking the (1) Add button and following the same sequence. The (2) Delete 
button removes the currently selected scenario. Using the (3) Edit button allows you to 
make changes to the currently selected scenario. The (4) Merge button allows you to 
import scenarios from other worksheets. The (5) Summary button allows you to create a 
report comparing all your scenarios, and the (6) Show button displays the values for the 
currently selected scenario in your worksheet: 
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Using Goal Seek 

If you know the result you want in a formula, Goal Seek can find the input value for one of 
the cells referenced in that formula, to produce that result (or goal) that you want to 
achieve. For instance, if you know you want your profit to be 10%, Goal Seek can calculate 
the revenue you will require, assuming your costs remain constant.  

To access the Goal Seek tool, click Data → What-If Analysis → Goal Seek: 

 

In the Goal Seek dialog box, type the cell reference, or click the cell, that you want to set as 
your goal value in the Set cell field. Type the goal value in the To value field, then type the 
cell reference, or click the cell, that you want to change to reach your goal value. In this 
example we are asking how much more salary (Cell B3) we need to make to save $10,000 
(Cell B19) a year: 
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Clicking the OK button will display the Goal Seek Status dialog box, confirming the solution, 
and will adjust the values in both the goal cell and the changing cell: 

 

Note that changes made by the Goal Seek tool can be undone by pressing Ctrl + Z. 
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Using Solver 

The Solver is a Microsoft Excel add-in program with a similar purpose as the Goal Seek tool, 
but it has the added ability to change more than just one variable to reach your goal, and 
also lets you set constraints on those variables using logical conditions.  

The Solver tool is an add-in that is included with Excel but is not loaded by default. To use 
the Solver, you must first enable the add-in in the Add-ins category of the Excel Options 
dialog box. We will show the steps of this process in this topic’s activity. 

Once the Solver add-in is loaded, you can access it by clicking Data → Solver: 

 

The Solver Parameters dialog box will open: 
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The (1) Set Objective field lets you set the objective cell, and the result that you want to 
achieve. You can set the value of the desired result by using the Max or Min radio buttons, 
or by selecting the Value of radio button and entering a specific value in the field. 

In the (2) By Changing Variable Cells field you can select or type the cells that will be 
changed to achieve the value in the Set Objective cell. 

The (3) Subject to the Constrains list box allows you to add, change, or delete constraints 
for any of the variable cells. Clicking the Add button will open the Add Constraint dialog box 
and allow you to select the variable cells and choose a constraint. 

The (4) Make Unconstrained Variables Non-Negative checkbox prevents the solver from 
setting variables without a constraint to a negative number. 

Solving Method descriptions can be selected in the (5) Select a Solving Method drop-down 
list. A description of the different methods and their use is below the drop-down list. 
Clicking the Options button will open an advanced feature option set. 

Once the Solver Parameters have been configured, clicking the Solve button will attempt to 
solve the variables to achieve the objective. The Solver Results dialog box will open, and 
any solution results will be displayed in your variables on your worksheet. You will have the 
option to keep the results or to restore the original values: 
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Activity 4-3: What-If Analysis 

You are thinking about moving to advance your career, but you want to understand how 
that might impact your finances.  

1.  To begin, open Activity 4-3 from your Exercise Files folder:  

 

2.  You have your budget based on your current income and expenses, and you have 
researched potential salaries and the cost of living in medium and large cities that 
you would consider moving to. To compare the different scenarios, click Data → 
What-if Analysis → Scenario Manager: 
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3.  Note in the Scenario Manager dialog box that opens, two scenarios have already 
been created, one named Current State and one named Medium City: 

 

4.  Click to select the Medium City scenario, then click the Edit button. You will see 
that the Changing cells field contains the cells that will change in this scenario: 
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5.  If you click to select the Changing cells field, you will see that the cells on the 
worksheet become highlighted: 

 

6.  Click OK, and in the Scenario Values dialog box you will see the values that have 
been entered for the corresponding cells for this scenario, based on your research: 
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7.  Clicking the OK button will return you to the Scenario Manager dialog box, where 
you will notice that a comment has been added for the Medium City scenario, 
indicating that you have modified the scenario: 
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8.  Click the Add button to create a new scenario. Type “Large City” in the Scenario 
name field, then click OK: 

 

9.  In the Scenario Values dialog box that opens, type “65000” in the $B$3 field, “0” in 
the $B$4 field, “24000” in the $B$8 field, “6800” in the $B$11 field, and “4500” in 
the $B$13 field. Click OK once complete: 
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10.  Click to select the Medium City scenario in the Scenarios list box, then click the 
Show button. You will see the values in the changing cells replaced. Note the 
decrease in Savings: 

 

11.  Follow the same steps to see the results for Large City: 
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12.  Now click the Summary button. The Scenario Summary dialog box will appear. 
Click to select the Scenario Summary radio button, and confirm the Results cells 
field contains the reference to cell B19, the yearly savings, then click OK: 

 

13.  The Scenario Summary dialog box will close, and a new worksheet, named Scenario 
Summary, will be created. The worksheet contains a table comparing the results of 
the scenarios:  
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14.  To restore your worksheet to the original, click the Sheet1 tab to return to Sheet1, 
click the What-If Analysis drop-down command, and click Scenario Manager. With 
the Scenario Manager dialog box open, click to select the Current State scenario, 
click the Show button, then click Close: 
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15.  In the Large City Scenario, you discovered that it would be possible to save $12,000 
a year. You would now like to explore how to do that in your current job. Close the 
Scenario Manager dialog box by clicking the Close button, so we can now load the 
Solver add-in. Click File → Options, then select Add-ins from the Excel Options 
dialog box categories. Select Excel Add-ins from the Manage drop-down list, then 
click the Go button: 
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16.  In the Add-ins dialog box, click the Solver Add-in checkbox to enable, then click OK: 

 

17.  You will see that the Data tab now has a new group, Analyze, containing the Solver 
command. Click the Solver command to launch the Solver dialog box: 
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18.  In the Solver Parameters dialog box, click to select or type cell $B$19 in the Set 
Objective field, then click to enable the Value Of radio button in the To section and 
type “12000” in the field. Now place your cursor in the By Changing Variable Cells 
field, then hold down the control key while you click to select cells B3, B4, B8, and 
B15. These are the variable that the Solver will adjust to achieve your objective: 
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19.  Click the Add button to the right of the Subject to the Constraints list box to add 
constraints to the variables. In the Add Constraint dialog box, click to select cell B3 
(Salary) in the Cell Reference field. Click the drop-down button on the logic 
operator list, select the Greater than or Equal to (>=) operator, then type “35000” 
in the Constraint field. Click the Add button to continue adding constraints to cells 
B4 (>=, 5000), B8 (>= , 9000) and B15 (>=, 2400). Once your constraints are added, 
click OK: 
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20.  Now that your constraints are set, click the Solve button: 
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21.  The Solver Results dialog box opens, reporting that Solver found a solution. You 
will see that the values in your worksheet have been updated. Click to enable the 
Restore Original Values radio button. In the Reports list box, click to select the 
Answer report, click to enable the Outline Reports checkbox, then click OK:  
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22.  Your variables are reset to their original values and a report is created in a new 
sheet named Answer Report 1, providing the details on the original and final values 
of both your objective cell and your variable cells: 

 

23.  Save the current workbook as Activity 4-3 Complete and then close Microsoft 
Excel 365 to complete the activity. 
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TOPIC D: The Analysis ToolPak 
Like the Solver tool, the Analysis ToolPak is an add-in program that is included with 
Microsoft Excel 365. It provides advanced and specific tools for financial, statistical, and 
engineering data analysis. While a comprehensive exploration of these complex analysis 
tools is beyond the scope of this course, this topic you will show you how to load the 
Analysis ToolPak and help you explore the tools.  

 

Topic Objectives 

In this session, you will learn: 

• How to load the Analysis ToolPak 

• About the Data Analysis dialog box 
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Load the Analysis ToolPak 

To load the Analysis ToolPak click File → Options: 
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Select Add-ins in the Excel Options categories, then ensure that the Excel Add-ins option is 
selected in the Manage drop-down menu, then click Go: 
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In the Add-ins dialog box, in the Add-ins available list box, click to enable the Analysis 
ToolPak checkbox, then click OK: 

 

 
The Data Analysis Dialog Box 

Now that the Analysis ToolPak is loaded, click Data → Data Analysis to open the Data 
Analysis dialog box: 
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The Data Analysis dialog box will be displayed, with a scrollable list of the available analysis 
tools: 

 

To launch an Analysis tool, click to select it from the list and click OK. A dialog box for that 
specific tool will be displayed: 
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Activity 4-4: Perform a Data Analysis with the Analysis ToolPak 

You would like to rank the performance of your sales representatives, over the past quarter, 
compared to sales representatives from other regions. You decide to use the Rank and 
Percentile analysis tool in the Analysis ToolPak. 

1.  To begin, open Activity 4-4 from your Exercise Files folder:  

 

2.  To load the Analysis ToolPak add-in. Click File → Options, then select Add-ins from 
the Excel Options dialog box categories. Select Excel Add-ins from the Manage 
drop-down list, then click the Go button: 
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3.  In the Add-ins dialog box, click the Analysis ToolPak checkbox to enable, then click 
OK: 

 

4.  Click the Data Analysis command in the Analysis group of the Data tab to launch 
the Data Analysis dialog box: 
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5.  Scroll down the Analysis Tools list box and click to select the Rank and Percentile 
analysis tool, then click OK: 

 

6.  Click in the Input Range field, then click and drag to select cells F3 to F45. Ensure 
the Grouped by Columns radio button is enabled: 
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7.  Next, click to enable the Labels in first row checkbox, then click to enable the 
Output Range radio button. Click in the Output Range field and then click cell K3. 
Now click OK: 

 

8.  You will now see the rank and percentile data has been entered on your sheet, 
sorted in order of ranking. The Point data, in column K, references the position of 
the sales representative in the original data set, and the Percent column, N, is the 
percentile of that ranking: 
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9.  Click to select cell G4 and examine the formula in the formula bar. This VLOOKUP 
formula compares the row value in the Point column (K) to the row value in the 
Order column (A), and returns the Percent in column N, aligning the correct 
percentile with the sales representative: 

 

10.  You can extend this formula down the column by hovering your mouse over the 
bottom right corner of cell G4 until the mouse pointer turns into a cross, then 
double-click: 

 

11.  The Percentiles are now displayed for all the Sales Representatives: 

 

12.  Save the current workbook as Activity 4-4 Complete and then close Microsoft Excel 
365 to complete the activity. 
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Summary 
In this lesson you learned about many of the advanced tools available in Excel 365 that you 
can use to analyze and present your data. You should now be comfortable using the Quick 
Analysis Tool to quickly access many of the standard analysis options. You should also be 
comfortable adding Sparklines to your data to illustrate trends. You should have a good 
understanding of the What-If Analysis tools and how to use them to explore different 
outcomes, and you should be familiar with the potential of the analysis tools in the Analysis 
ToolPak. 

 

Review Questions 
1. How do you access the Quick Analysis Tool? 

 

2. What are the three types of Sparklines? 

 

 

3. How many cell values can you change to reach the goal value in the Goal Seek tool? 

 

 

4. What should you use to create your first scenario in the Scenario Manager? 

 

 

5. What types of analysis tools are available in the Analysis ToolPak? 
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LESSON 5: 
WORKING WITH MULTIPLE WORKBOOKS 

 

Lesson Objectives 

In this lesson you will learn how to: 

• Arrange windows 

• Link to data in multiple workbooks 

• Consolidate data 
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TOPIC A: Arrange Workbooks 
It is not uncommon for Excel users to work in multiple workbooks at the same time, 
sourcing data and calculations from one or more workbooks into another. Switching back 
and forth between workbooks can be time consuming and, sometimes, confusing. In this 
topic you will learn about the tools that are available in Excel 365 to view and compare your 
open workbooks quickly and easily. 

 

Topic Objectives 

In this session, you will learn how to: 

• Arrange workbooks for viewing 

• View workbooks side by side 

• Use synchronous scrolling 
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Arrange Workbooks for Viewing 

Managing the on-screen presentation of your workbooks does not need to be a complicated 
series of selecting and resizing workbooks. You can quickly display and compare two or 
more workbooks at the same time by using the tools in the Window group of the View tab. 

To view two or more workbooks together on the same screen, click View → Arrange All: 

 

The Arrange Windows dialog box will open, with options for how you would like to display 
your workbooks: 

 

The Tiled option will display all open workbook windows, so they all fit on the screen: 
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Horizontal will display all open workbooks one above the other: 

 

Vertical will display all open windows side by side: 

 

Cascade will display all open windows overlapping one another, descending to the right: 
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View Workbooks Side by Side 

There are times that you may want to compare two specific workbooks, though you may 
have more than two open. You can do this by using the View Side by Side command to 
select specific workbooks to compare. 

To use the View Side by Side command, you would select the first workbook you would like 
to use in the comparison. You would then click View → View Side by Side: 

 

The Compare Side by Side dialog box will open. You can now select the second workbook 
you would like to use in the comparison and click OK: 
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The View Side by Side button will remain highlighted in gray and the two workbooks you 
want to compare now appear side by side (or one above the other) on your screen: 

 

To cancel viewing your workbooks side by side simply click View → View Side by Side again 
to deselect. 

 

Use Synchronous Scrolling 

Visually comparing two workbooks can be greatly simplified by using Synchronous Scrolling. 
Rather than switching between workbooks to scroll through your data, Synchronous 
Scrolling aligns the scrolling between the visible workbooks, so scrolling in one will result in 
the same scrolling in the other. 

To enable Synchronous Scrolling (once you have two or more workbooks arranged together 
on your display), first align the starting point by scrolling to the top of each sheet, then click 
View → Synchronous Scrolling: 
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The Synchronous Scrolling button remains highlighted in gray and, now, any navigation you 
perform on one workbook will occur simultaneously on the other workbook: 

  

To cancel Synchronous Scrolling simply click View → Synchronous Scrolling again to 
deselect. 
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Activity 5-1: Arrange Workbooks 
You are working on several workbooks containing product sales for different divisions and 
you would like to arrange and compare them to simplify your work. 

1.  To begin, open Activity 5-1A, Activity 5-1B, Activity 5-1C, and Activity 5-1D from 
your Exercise Files folder:  

 

 

2.  Once all your workbooks are open, select the frontmost window and Click View → 
Arrange All: 

 

3.  Click to enable the Tile radio button, then click OK:  
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4.  The four workbooks will be arranged equally on your screen: 

 

5.  Click in the window of Activity 5-1A to make it the active sheet, then click View → 
View Side by Side: 

 

6.  Note that the tools in the Window group may be collapsed, due to the size of each 
workbook window on the screen. The View Side by Side button will look like this: 
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7.  The Compare Side by Side dialog box will open. Click to select Activity 5-1C in the 
list box, then click OK:  

 

8.  If the two selected workbooks did not fill the screen, click the Reset Window 
Position button in the Window group: 

 

9.  The Activity 5-1A and Activity 5-1C workbooks will be displayed, one above the 
other: 
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10.  Click in the window of each workbook and scroll to the top of the sheet, so both 
windows show cell A1 in the top left corner: 

 

11.  Click in the window of Activity 5-1A, then click View → Synchronous Scrolling: 
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12.  Press the PgDn (Page Down) key, or the down arrow, repeatedly and watch the 
data in each workbook scroll at the same time: 

 

13.  You can now close the open workbooks, and close Microsoft Excel 365 to complete 
the activity. 
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TOPIC B: Linking to Data in Multiple 
Workbooks 
As your work in Excel becomes more advanced you will likely find yourself wanting to 
include data and calculations from other workbooks when you are building new ones. While 
it is fairly simple to copy data from a source workbook and paste it into a new one, that 
data then becomes static, and you would have to copy and paste the data again, every time 
the data in your source workbook changes. In this topic, you will learn how to create and 
edit links to other workbooks so that it is always up to date. 

 

Topic Objectives 

In this session, you will learn about: 

• External references 

• Editing links 

• Broken links 
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External References 

External references, which are sometimes referred to as links, are the same as cell 
references, but they refer to cells or ranges in other workbooks. Using external references 
avoids duplicate data in different locations and it also ensures that the data is up to date. 

The syntax of an external reference can appear in one of two ways, depending on whether 
the workbook containing the reference is open, or closed. 

If the workbook containing the referenced cell(s) is open, the external reference first refers 
to the (1) Workbook name, including the file extension, in square brackets, then the (2) 
Worksheet name, followed by an exclamation mark, and finally the (3) Cell reference, 
which can be relative, or absolute: 
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If the workbook containing the referenced cell(s) is closed, the external reference first 
refers to the (1) entire file path to the workbook, followed by the (2) Workbook name, 
(including the file extension), in square brackets, then the (3) Worksheet name, followed by 
an exclamation mark, and finally the (4) Cell Reference, which can be relative, or absolute. 
Note that the file path, workbook name, and the worksheet name, but not the exclamation 
are enclosed in single quotation marks: 

 

 

Editing Links 

It is easy to imagine a workbook that contains many external references to one or more 
workbooks, and how confusing that could become. Using the Edit Links tool is a simple and 
easy way to identify external links in your workbook and to manage them. 

To launch the Edit Links tool, click Data → Edit Links, in the Queries & Connections group: 
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The Edit Links dialog box appears. The list box will display a list of all the links in the 
workbook, indicating the source, the type, and the status: 

 

Click to select a link in the list box and use the command buttons on the right of the dialog 
box to update the values, change the source workbook, open the source workbook, break 
the link, or check the status of the link.  

If you choose to break a link, a caution window will appear, warning that breaking links 
permanently converts the formulas and external references to the existing value, and 
cannot be undone: 
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Broken Links 

Because external references are based on file paths, there is a risk that the link to your 
source data could be broken, as the result of a file being moved, or renamed. When you 
open a file that contains an external reference that cannot be resolved, you will see a 
caution window, informing you that Excel could not update some of the links in your 
workbook, and giving you the option to continue, or edit links: 

 

If you choose to continue, the link path will still be displayed in the formula, and the last 
known value will be displayed in the cell, but data will not be updated. 
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If you choose Edit Links, the Edit Links dialog box will open. Click to select the broken link in 
the list box, then click the Change Source button: 

 

A Change Source dialog box will open, where you can navigate to and select the correct 
source workbook. Click OK to confirm your selection: 
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Activity 5-2: Linking to Data in Multiple Workbooks 

You would like to summarize the sales results for several of your regional offices. You decide 
to use external references to collect the data. 

1.  To begin, open Activity 5-2A, Activity 5-2B, and Activity 5-2C from your Exercise 
Files folder: 

 

 

2.  Click to make Activity 5-2A the active workbook, then click to select cell B4, and 
type “=SUM(“: 

  

3.  Click View → Switch Windows, then click to select Activity 5-2B.xlsx: 
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4.  Click and drag to select cells B4 to B96, then press the Enter key: 

 

5.  Activity 5-2A will again become the active workbook. Click to select cell B4 and 
review the formula in the formula bar: 
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6.  Edit the formula to remove the dollar symbol ($) from before both column 
references (B) in the formula, then press the Enter key to confirm the change: 

 

7.  Hover your mouse over the bottom right corner of cell B4, until the mouse icon 
becomes a cross: 

 

8.  Click and drag to the right to copy the formula to cells C4 through G4: 

 

9.  Select the cells C4:G4, then click Home → Format → AutoFit Column Width to 
resize the cells:  
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10.  The formulas now summarize the sales for each month. Click to select cell C4 and 
inspect the formula:  

 

11.  Now click to select cell B5. Complete the same steps using workbook Activity 5-2C. 
Type “=SUM(“ in cell B5, click View → Switch Windows, and click to select Activity 
5-2C.xlsx: 

 

12.  Click and drag to select cells B4 to B96, then press the Enter key: 
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13.  Activity 5-2A will again become the active workbook. Click to select cell B5 and 
review the formula in the formula bar: 

 

14.  Edit the formula to remove the dollar symbol ($) from before both column 
references (B) in the formula, then press Enter to confirm the change: 

 

15.  Hover your mouse over the bottom right corner of cell B5, until the mouse icon 
becomes a cross: 

 

16.  Click and drag to the right to copy the formula to cells C5 through G5: 
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17.  The formulas now summarize the sales for each month. Click to select cell C5 and 
inspect the formula: 

 

18.  Now click Data → Edit Links: 

 

19.  The Edit Links dialog box will open, listing the external references. Click the Check 
Status button: 
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20.  The status in the list box for both links will switch to Source is Open: 

 

21.  Save Activity 5-2A as Activity 5-2A Complete, close the remaining workbooks, and 
you can now close Excel 365 to complete the activity. 
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TOPIC C: Consolidating Data 
When you want to gather large amounts of data, from multiple workbooks, the process of 
creating many formulas with external references to summarize the data can seem like a 
difficult task. Fortunately, Excel’s data consolidation features provide a simple and effective 
way to consolidate data from multiple workbooks, or worksheets, that contain a similar 
structure. During this topic you will learn about the Excel Consolidate tool and how it can 
help you collect and analyze data from multiple workbooks.  

 

Topic Objectives 

In this session, you will learn: 

• About data consolidation 

• About consolidation functions 

• How to use the Consolidate dialog box 
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Data Consolidation 

When you consolidate data, you collect and summarize values from different sources that 
are based on common references. As an example, a company has several divisions that all 
sell the same products. Each division reports their sales in a separate workbook, but the 
structure of each workbook is similar. With the Consolidate tool, you can quickly select the 
different sources of sales data, choose how you would like to analyze it, then collect it into a 
summary data set.  

 

Consolidation Functions 

When consolidating data, you have the option to summarize the result using a variety of 
functions. For instance, you may want to see an average of the related values in your 
sources, or you may want to sum the related values. 

Below is a list of the available functions and a brief explanation of the result they will return 
from the referenced sources: 

Sum Returns a Total of the related values. 

Count Returns a count of the related value cells. 

Average Returns an average of the related values.  

Max Returns the maximum of the related values. 

Min Returns the minimum of the related values. 

Product Returns the result of multiplying all the related values. 

Count Numbers Returns a count of the related value cells that are numbers. 

StdDev Returns the standard deviation of the related values. 

StdDevp Returns the standard deviation of the related values based on the 
entire population. 

Var Returns the estimated variance of the related values. 

Varp Returns the estimated variance of the related values based on the 
entire population. 
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Use the Consolidate Dialog Box 

When consolidating data from multiple sources it is recommended that you choose an 
empty worksheet, or ensure you have ample space for the consolidated data before you 
begin. 

To open the Consolidate dialog box, first select the cell you want to set as the starting point 
for your consolidated data, then click Data → Consolidate: 

 

The Consolidate dialog box will open. Here you can choose the function to apply to the 
related values in the referenced sources: 
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Click in the Reference field to select a data source for the consolidation: 

 

The simplest way to define a reference is to click View → Switch Windows, then select one 
of the source workbooks: 
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Click and drag to define the range of the data you wish to consolidate in the source, then 
click the Add button: 

 

The reference will appear in the All references list box: 
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Repeat the process until all sources have been added: 

 

Under Use labels in, click to enable the Top row and/or Left column checkboxes, if you 
want to use column and/or row labels to group the results. Click to enable the Create links 
to source data checkbox if you want to maintain the references to the source data. To 
complete the consolidation, click OK: 
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The consolidated data is loaded to your worksheet. If you have chosen to create links to the 
source data, the data will be grouped by the row and/or column headers. Clicking the plus 
(+) sign on one of the grouped outlines will reveal the source data, and you will see that the 
cells contain an external reference to the source: 

 

If you have chosen not to create links to your source data only the result will be returned, 
with no reference to the source data: 
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Activity 5-3: Consolidating Data 

You have been asked to summarize the sales report from three of your company’s regional 
divisions. You have been given a separate workbook for each region.  

1.  To begin, open Activity 5-3A, Activity 5-3B, Activity 5-3C, and Activity 5-3D from 
your Exercise Files folder: 

 

 

2.  In the Activity 5-3D workbook, on Sheet1, select cell A1. This will be the starting 
point for the placement of the consolidated data: 

 

3.  Now click Data → Consolidate: 
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4.  The Consolidate dialog box will now be displayed. Select SUM from the Function 
drop-down list, then click to select the Reference field: 

 

5.  Click View → Switch Windows, then click to select the Activity 5-3A workbook: 
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6.  Click and drag to select cells A3 to G96: 

 

7.  In the Consolidate dialog box, click the Add button: 
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8.  Now repeat the process to open the Activity 5-3B workbook and select cells A3 to 
G96: 

 

9.  Back in the Consolidate dialog box, click the Add button: 
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10.  Now open the Activity 5-3C workbook and select cells A3 to G96: 

 

11.  Back in the Consolidate dialog box, click the Add button: 

 



Microsoft 365 Excel: Part 3 

 

© 20019-2025Ultimate IT Courses Training Materials Inc.  

265 

12.  Click to enable the Top row, Left column, and Create links to source data 
checkboxes, then click OK: 

 

13.  The consolidated data is now displayed, and is grouped and outlined by SKU 
number: 
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14.  Click the plus (+) sign on the outline next to cell A5, then click to select cell C2. You 
will see the external reference to the source data in the formula bar: 

 

15.  Save Activity 5-3D as Activity 5-3D Complete, close the remaining workbooks, and 
you can now close Excel 365 to complete the activity. 
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Summary 
In this lesson you learned about working with multiple workbooks. You should now be 
comfortable arranging, viewing, and navigating between multiple workbooks. You should 
also have a good understanding of how to create and maintain links between workbooks, 
and how to resolve broken connections. You should also be comfortable with knowing 
when and how you can consolidate data from multiple sources. 

 

Review Questions 
1. How will multiple workbook windows appear if you arrange them vertically? 

 

2. How many ways can the syntax of an external reference appear? 

 

3. How can a link to an external data source be broken? 

 

4. Where is the best place to consolidate data? 

 

5. Do data consolidation sources have to have the exact same structure? 
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LESSON 6: 
EXPORTING AND SOURCING DATA 

 

Lesson Objectives 

In this lesson you will learn how to: 

• Export data 

• Use data sources 

• Use Microsoft Forms 
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TOPIC A: Exporting Data 
While Microsoft Excel is an excellent tool for storing, analyzing, and presenting data, there 
will be occasions where your data needs to be delivered in a different format. There could 
be many different reasons for this. The audience for the data may not have access to Excel, 
or you may want to prevent other users from making changes to your worksheet. It could 
also be that there is a wide audience for the information in your workbook and it is more 
practical to use a different platform to share it. Because there are many reasons to export 
your data, Excel provides several options to support them. In this topic you will learn about 
Excel’s export options and how to use them.  

 

Topic Objectives 

In this session, you will learn: 

• About export file format options 

• How to export worksheet data 
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Export File Format Options 

Excel provides you with several file format options to export your data, each with its own 
purpose and characteristics. Below we have outlined the more common options: 

Format Description 

CSV Comma-Separated Values – A simple file format used to store tabular 
data. Column data is separated by commas. All formatting is removed. 
Excel only saves the active worksheet. 

HTML Hypertext Markup Language – A file format used to enable viewing in a 
web-based browser application. 

ODS OpenDocument Spreadsheet – A file format used to store tabular data 
that is compatible with open source spreadsheet applications. 

PDF Portable Document Format – A file format, created by Adobe, used to 
create documents that maintain the format of the source, are highly 
accessible, but allow only limited editing. 

TXT Tab-Delimited Text – A simple file format used to store tabular data. 
Column data is separated by tabs. All formatting is removed. Excel only 
saves the active worksheet. 

XLS Excel 97-2003 Workbook – A file format compatible with older versions 
of Excel. Some current features or functionality may be lost. 

XML Extensible Markup Language – A complex file format used to store data 
in a text format, with custom tags to describe the structure.  

XPS XML Paper Specification – A file format, created by Microsoft, similar to 
PDF, used to create documents that maintain the original format, are 
highly accessible, but allow only limited editing. 
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Exporting Worksheet Data 

Exporting data enables you to create your data set in a format that is compatible with its 
intended use outside of Excel. While we have reviewed the more common options above, 
there are other options available, and even sub-categories for the options we have 
reviewed.  

To explore the different types of files you can create from your workbooks, click File → 
Export: 
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The options in the Export window are Create PDF/XPS Document, or Change File Type: 

 

Clicking the Create PDF/XPS Document button will open the Publish as PDF or XPS dialog 
box, where you will be presented with options to (1) name the file and select the file type, 
and (2) customize the available options: 
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Clicking the Change File Type button will show the Change File Type category, where you 
can select from the many available file types, and click the Save As button: 
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The Save As dialog box will open, where you can select the destination of your file, name it, 
and select a file type, this time from a more extensive list: 

 

Clicking the Save button will initiate the export of your data. If there are any alerts, or 
errors, they will be presented at this point. In the example below, the Alert window 
cautions that the selected file type does not support workbooks that contain multiple 
sheets: 
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Activity 6-1: Export Worksheet Data 

A customer has asked for a price list that they can load into their proprietary system. They 
have asked you to provide comma-separated values as it is the most compatible with their 
process. You need to export the price list as a CSV file. 

1.  To begin, open Activity 6-1 from your Exercise Files folder:  

 

2.  Before we begin the export, take note of some of the elements of the workbook. 
Click to select cell C4, and observe the formula used to calculate the price. Also 
note the formatting of the cells. Some have colored text, colored fill, or bold type. 
There is also a second worksheet, called Percentages: 
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3.  To export the file, Click File → Export: 
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4.  In the Export window, click to select Change File Type, then click to select CSV 
(Comma delimited) (*.csv) from the Change File Type category. Finally click Save 
As: 

 

5.  Choose a location for your file, leave the File Name as Activity 6-1.csv, and click the 
Save button: 

 

6.  Note the alert regarding multiple sheets, then click OK: 
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7.  The open workbook is now called Activity 6-1.csv, but you will note that the 
formatting and formulas are still visible, and the Percentages worksheet is still 
visible. You can now close the file: 

 

8.  If necessary, open Excel 365, then click File → Open and navigate to the Activity 6-
1.csv file you just saved. Click on the file to open it: 

 



Microsoft 365 Excel: Part 3 

 

© 20019-2025Ultimate IT Courses Training Materials Inc.  

279 

9.  You will now see that the formatting has been removed, the formulas are replaced 
with values, and the Percentages worksheet has been removed: 

 

10.  You can now save your changes as Activity 6-1 Complete.csv and close Microsoft 
Excel 365 to complete the activity. 
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TOPIC B: Using Data Sources 
The data that you analyze in Excel can come from many sources. How you access that data 
can have a big impact on the accuracy of your workbooks and your own productivity. During 
this topic you will learn about the tools available in Excel to help you access data quickly and 
efficiently. 

 

Topic Objectives 

In this session, you will learn about: 

• Data sources you can use in Excel 

• Importing a delimited file 

• Using a web query 
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Data Sources in Excel 

Not only does Microsoft Excel provide you with powerful tools to analyze and present your 
data, it also give the tools to access data from a wide array of sources, so the data in your 
workbooks can be as current and reliable as possible. The sources, and how you access 
them, vary from simple, to highly complex, and are closely related to the unique situation of 
the user. 

The tools used to access external data are available in the Get & Transform Data group of 
the Data tab: 

  

Clicking on the Get Data drop-down command will show the wide array of options that are 
available: 
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Hovering your cursor over each option in the list will display a sub-menu with more specific 
options for each group. Below are the options available in the From File sub-menu: 
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And here are the options available in the From Database sub-menu: 

 

An explanation of all these options, and their individual requirements, is beyond the scope 
of this course, but being aware of their potential could lead you to explore using some of 
these tools in your own unique situation.  
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Importing a Delimited File 

A delimited file is a simple file that is used to store tabular data (rows and columns). The 
column data is delimited (separated) by a unique character, often a tab or a comma, and 
the file does not contain formatting. Because the structure of these files is simple and 
predictable, they are very popular for transferring data between programs. 

With some delimited files, such as the CSV format, you can open them directly in Excel, by 
using the File → Open command. Excel will make assumptions about what type of data is in 
each column, and what the separator character is. In most cases this will produce the 
desired result. There may be times, though, that you need to define some of file’s data 
characteristics, or you just want the convenience of loading the data into an existing 
workbook. In these cases, you would import the data. 

To begin the import process, click Data → From Text/CSV: 

 

The Import Data dialog box will open, where you can navigate to and select the file you 
wish to import. Click the Import button to start the process: 
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The Get and Transform Data dialog box will appear, giving a preview of the data in the file. 
You can click to select the File Origin, Delimiter, and Data Type Detection options from 
their respective drop-down lists. Any changes made in these drop-down lists will be 
previewed in the data list: 

  

To create a new worksheet in the workbook and load the data as a table on that sheet, you 
would click the Load button. To select the destination of the data, you would click the Load 
drop-down arrow, then click Load To: 
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The Import Data dialog box will open, allowing you to select how you want to view the data 
in your workbook and where you want to put it. Clicking the OK button will load the data: 

 

You would then see the data loaded as a table on your worksheet. The Queries & 
Connections task pane will appear on the right of the window, and you will see that, under 
the Queries tab, the imported data source is displayed, and also indicating the number of 
rows which have been loaded:  
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Hovering your mouse over the query will display a Query dialog box, showing a preview of 
the data, and information on its contents, its status, and its source. To launch the Power 
Query Editor, an extensive tool that helps you customize your queries, click Edit: 

 

The Power Query Editor will appear, with a wide array of tools available to manage how the 
data from your source file appears in your workbook. To close the editor, click the Close (X) 
button: 
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If you are happy with the data, and do not want to maintain a query to the source file, you 
can click Convert to Range in the Tools group of the Table Design tab: 

 

An alert window will appear, warning that the query definition will be permanently 
removed. To continue, click OK: 

 

You will see that the data has converted to a normal range (the Table Design contextual tab 
has disappeared), and the Queries & Connections task pane indicates that the data source is 
a connection only. A connection is like a pointer to the source of the data that can be used 
again, but does not allow for updates: 
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Using a Web Query 

The internet can be a great source of useful information for your Excel projects, and using 
web queries can provide you with a quick and efficient method of loading that information 
into your workbooks and keeping it current. 

To create a web query, click Data → From Web: 

 

The From Web dialog box will open, where you can enter a URL address pointing to a web 
page that contains a data table you would like to access. You would enter the address in the 
URL dialog box and click OK: 

 

  



Microsoft 365 Excel: Part 3 

 

© 20019-2025Ultimate IT Courses Training Materials Inc.  

290 

The Access Web content dialog box will open, where you can define the type of access to 
use to access the web content. This allows you to use different types of credentials when 
accessing secure content. Once you have selected the appropriate type, and entered the 
correct credentials, click Connect: 

 

The Navigator dialog box will appear, displaying a list of any available tables in the left-hand 
list box. Selecting a table will display the table data in the Table View list box. Once you 
have located the data that you wish to load to your workbook, you would click the Load, or 
Load To button: 
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As with importing a delimited file, Excel will create a new worksheet and load the data as a 
table. The Queries & Connections task pane will appear on the right of the window listing 
the query in the Queries tab, and indicating the number of rows loaded: 

 

Hovering your mouse over the query will display a dialog box, named after the query, 
showing a preview of the data, information on its contents, its status, and its source. To 
make adjustments to the query, you would launch the Power Query Editor, by clicking Edit:  
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The Power Query Editor will open. Some of the many options here allow you to add or 
remove columns, filter rows, apply logic, or adjust the data type of the columns: 

 

If you have made any changes to your query, click the Close & Load command in the Close 
group of the Home tab to save and apply the changes: 

 

Back in the worksheet window, to refresh, or update, your query, you would first click to 
select a cell in the query table, click the Refresh drop-down arrow in the Queries & 
Connections group of the Data tab, then click Refresh All: 
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Activity 6-2: Using Data Sources 

You have been asked to create a price list, in Canadian dollars, for some of your company’s 
products. You will need to update it regularly using the current exchange rate. You first 
need to import your price list, then create a web query to load and maintain the current 
exchange rate. 

1.  To begin, open Activity 6-2 from your Exercise Files folder:  

 

2.  Click Data → From Text/CSV: 

 

3.  The Import Data dialog box will open. Navigate to your activity files and select 
Activity 6-2.txt, then click the Import button: 
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4.  The Get & Transform Data dialog box will open, displaying the data in the source 
file. If the selection in the Delimiter drop-down list reads --Custom--, and there is 
an extra header, click to select the Tab option in the Delimiter drop-down list: 

 

5.  With your data properly aligned in the list box, click the Load button: 
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6.  A new worksheet is created and the data from your text file is loaded as a table. 
The Queries & Connections task pane opens on the right of the screen: 

 

7.  Click on the Sheet1 tab to make it the active worksheet. Click to select cell A1, then 
press Ctrl + C to copy the URL of the exchange rate site: 

 

8.  Now click Data → From Web: 
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9.  The From Web dialog box will open. Click to select the URL field, then press Ctrl + 
V, to paste the URL. Click OK: 

 

10.  The Navigator dialog box will open. Click to select Table 0 in the list box on the left, 
confirm the data is present in the Table View window on the right, then click the 
Load button: 
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11.  A new worksheet is created and the data from the website is loaded as a table. The 
query appears under the Activity 6-2 query: 

 

12.  Hover your cursor over the web query in the Queries & Connections task pane, 
then click Edit in the table dialog box that appears: 
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13.  The Power Query Editor will launch. Click the filter button to the right of the 
header of the Country-Currency column, then click to select the Text Filters field 
and begin typing “Canada”. When Canada-Dollar is the only selected item, click OK: 

 

14.  Click the Close and Load command in the Close group of the Home tab: 

 

15.  You will see that the Web Query table now only displays the Canada-Dollar row of 
data from the data set: 
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16.  Click the Sheet2 tab to make it the active sheet, then click to select cell C2. Type 
the formula “=[@[US Dollars]]*VLOOKUP("Canada-Dollar",Sheet3!A:B,2,FALSE)”, 
then press the Enter key: 

 

17.  The table containing the price list will auto complete the formula for every row in 
the column: 
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18.  To refresh the data from the website, right-click on the query in the Queries and 
Connections task pane, then select Refresh: 

 

19.  You can now save your changes as Activity 6-2 Complete and close Microsoft Excel 
365 to complete the activity. 
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TOPIC C: Use a Microsoft Form for Data 
Collection 
Microsoft Forms is a simple app that lets you easily create online surveys and distribute 
them to a wide group of users. It is available to all Microsoft 365 subscribers and is 
integrated into Excel Online, allowing you to collect, analyze and present the data that is 
collected from the users. In this topic you will learn how to integrate forms into Excel 
Online, and how to manage them. 

 

Topic Objectives 

In this session, you will learn how to: 

• Insert a Microsoft form into a workbook 

• Add questions 

• Preview a form 

• Share a form 

• Review the results 

 

  



Microsoft 365 Excel: Part 3 

 

© 20019-2025Ultimate IT Courses Training Materials Inc.  

302 

Insert a Microsoft Form into a Workbook 

Many Excel projects rely on input from a group of users as an important source of data, but 
there can be a range of challenges with these processes, from data accuracy, to user access. 
Integrating a form into an Excel workbook is an effective way to simplify user access and to 
control the quality of the data that you collect.  

To insert a form into an Excel Online workbook, first click the Insert tab, then click the 
Forms drop-down arrow, and click to select New Form: 
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A new window will open in your browser and a new form will be created. Clicking on the 
name of the form will reveal a field, containing the name of the workbook, where you can 
give your form a distinct name and description: 

 

Typing the name of the form in this field will also change the name of the form in the 
header. You can also type a description that will be displayed to the users of the form: 
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Add Questions 

Adding questions allows you to define the type of input you want from your users. To add a 
question, click the Add New button: 

 

You will be presented with a choice of input methods for the form, including Choice, Text, 
Rating, and Date. By clicking on the drop-down arrow at the end of the choices, you will see 
the additional options of Ranking, Likert, File upload, and Net Promoter Score. There is also 
an option to create a Section in your form. Clicking any of these options will add a new 
question to your form: 
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You will also see a dialog box of prebuilt template options, with an icon on the right 
indicating the format of the user input. You can see additional templates by clicking on the 
tab buttons at the bottom of the dialog box: 
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Once a question has been added you will have intuitive options to customize the question. 
In the case illustrated below you can (1) define the question, (2) add an image to the 
question, (3) define the options, (4) add an option, or (5) add an “other” option. You can 
also (6) allow multiple answers, and (7) require an answer for this question: 
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You can also customize the appearance of your form by clicking the Theme button. The 
Theme gallery will be displayed, with many templated options to choose from, but you can 
also customize the appearance by clicking the Customize theme (+) button: 

 

 

Preview a Form 

To preview the appearance of your form, click the Preview button: 
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You will see a preview of the form as it will be presented to the user, where you can also 
test the interaction: 
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You can also click the Mobile button to preview and interact with the form as you would on 
a mobile device: 

 

Click the Back button to return to the editing screen: 
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Share a Form 

Once you are satisfied with the construction of your form, click the Share button: 

 

The Share task pane will appear on the right side of your browser window: 
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Here you can limit access to the survey to only those within your organization, or allow any 
user with a link to access it: 

 

  



Microsoft 365 Excel: Part 3 

 

© 20019-2025Ultimate IT Courses Training Materials Inc.  

312 

You can also choose how to distribute the survey. The option buttons are (1) copy and 
distribute a link, (2) create a QR code, (3) create code to embed in a website, or (4) use 
your default email application: 

 

To control the settings of your form, click the ellipsis at the top right of the window and 
select Settings: 
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The Settings task pane will appear at the right of your browser window. Here you can 
control access to the form, set options for responses, and set up notifications: 

 

You can close the form by closing your browser window: 
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Review the Results 

Back in the Excel workbook, a new worksheet will be created, and a table will be added: 

 

As the invited users respond to the survey, the survey results are added to the table in the 
Excel workbook, including start and stop time stamps, and identifying information, if 
available: 
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As long as the form exists, it will be available to users online. To delete the form, click the 
Forms drop-down command in the Insert tab, then click Delete Form: 

 

An Excel information alert will appear, warning that if you delete a form it cannot be 
recovered, but the response data will still be available. To continue, click OK: 

 

The table, and the data, will remain in the workbook: 
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Activity 6-3: Use a Microsoft Form for Data Collection 

You have been asked to support the Sales department by helping keep track of their 
mileage claims. Rather than enter them manually you have decided to integrate a Microsoft 
Form into an Excel workbook. 

1.  To begin, open Activity 6-3 in Excel Online: 

 

2.  Click Insert → Forms → New Form: 

 

3.  In the New Form window, select the name field and type “Mileage Reports”, then 
select the Description field and type “Report your mileage here.” 
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4.  Click the Add New button: 

 

5.  Click to select the Text option: 

 

6.  Enter Name in the Question field, then click on the right side of the Required 
toggle button to require an answer: 
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7.  Now click the Add New button again, to add another question. Again, click the Text 
option button: 

 

8.  Type “Trip Description” in the Question field, then click the right side of the Long 
answer and Required toggle buttons to enable them: 
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9.  Click the Add New button again, to add a third question, then, again, click the Text 
option command: 

 

10.  Type “Miles Traveled” in the Question field, then click the right side of the 
Required toggle button to enable it: 
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11.  Now click on the Preview button to review your form: 

 

12.  After proofing your form for accuracy and appearance, click the Mobile button to 
preview the form’s appearance on a mobile device: 
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13.  Once you are satisfied with your form, click the Back button to return to the form 
editing window: 

 

14.  Now click on the Share button: 
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15.  Click the drop-down arrow next to the Only people in my organization can 
respond text, then click to select Anyone with the link can respond: 

 

16.  Now click the Copy button next to the link field: 
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17.  You can now close the form by clicking the Close (X) button in the browser’s 
Microsoft Forms tab: 

 

18.  Launch a new tab in your browser, click to select the URL field, paste the copied 
URL by pressing Ctrl + V, then press the Enter key: 
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19.  The Mileage Reports form will open in your browser. Type your name in the Name 
field, “ABC Company Visit” in the Trip Description field, and “75” in the Miles 
Traveled field. When complete, click the Submit button: 

 

20.  The response will be acknowledged as submitted. Click the link Submit another 
response: 
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21.  Type your name in the Name field, “XYZ Company Visit” in the Trip Description 
field, and “40” in the Miles Traveled field. When complete, click the Submit 
button, then close the browser tab by clicking the Close (X) button: 

 

22.  Back in Excel Online, you will see that the data from your responses has been 
entered and time stamped: 
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23.  To delete the form, click Insert → Forms → Delete Form: 

 

24.  An information alert window will warn that if you delete a form, it cannot be 
recovered, but the data will still be available. Click OK: 

 

25.  Save your work as Activity 6-3 Complete and close the Excel Online browser tab to 
complete this activity. 
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Summary 
During this lesson you learned about the options available for exporting and importing data, 
as well as how to integrate Microsoft Forms with an Excel Online workbook. You should 
now be comfortable with the available file formats for exporting data, and how to create 
them. You should also have a good understanding of the different data sources that you can 
access, and how to use them. Finally, you should be comfortable with process of creating 
and sharing a Microsoft Form to support data collection. 

 

Review Questions 
1. Can you export more than one worksheet at a time when creating a CSV file? 

 

2. What are the benefits of using the PDF file format? 

 

3. How does Excel format data from a Web Query? 

 

4. What is a quick way to add questions to a Microsoft Form? 

 

 
5. Can you customize the appearance of a Microsoft Form? 
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LESSON LABS 

 

Lesson 1  
Lesson Lab 1-1 

 

Objective To understand how to access workbooks in OneDrive using 
Excel Desktop, and to explore the different features of each. 

Briefing You have been tasked with creating a chart to compare and 
visualize the performance of your sales representatives. 

Task Open a workbook in Excel Online and create a stacked bar 
chart of the sales results, by sales representative (cells A3 to 
D15), then open the workbook in Excel Desktop to change the 
color theme, and improve the readability, of your chart.  

Hints Click Page Layout → Colors to select a new color theme. 

Sample Data  

Follow-Up Questions Click on the file name at the top of workbook window to view 
the version history of the file.  
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Lesson 2  
Lesson Lab 2-1 

 

Objective To understand how to update workbook properties and how to 
record a macro. 

Briefing You need to update the properties of an employee assessment 
workbook, then record a macro to automate spell checking.   

Task Open the Advanced Properties dialog box and add “Employee 
Assessment Form” to the Title field. Then record a macro, with 
a keyboard shortcut, to check for spelling errors 

Hints To check for spelling errors, click Review → Spelling. Also, 
make sure you save your work as an Excel Macro-Enabled 
workbook (*.xlsm) 

Sample Data  

Follow-Up Questions Open the VBA editor to inspect your macro code. 
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Lesson Lab 2-2 

 

Objective To understand how to set up data validation and save your 
workbook as a template. 

Briefing To help automate the use of the employee review workbook, 
you want to add data validation, then save it as a template. 

Task Apply data validation to cell B4, to only allow dates equal to or 
less than today, and to cell C4, to select from a list of values, 
from 1 to 5, then save the workbook as a template. 

Sample Data  

Follow-Up Questions Use your new template to create a new employee assessment 
workbook. 
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Lesson 3  
Lesson Lab 3-1 

 

Objective To use cell tracing and error checking to understand formulas 
and to resolve formula errors.  

Briefing A colleague has given you a workbook that contains a 
confusing discount reference, and an error. You need to trace 
the precedents in the discount formula, to understand the 
correct value, then use Error Checking to resolve the error.  

Task Trace the precedents of the discount formula in cell E9, to 
confirm the correct discount, then use the Error Checking tool 
to correct the #NAME? errors in cells E12 and F12. 

Sample Data  

Follow-Up Questions Trace the precedents of cell B9 to find the SKU price data. 
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Lesson Lab 3-2 

 

Objective To use the Evaluate Formulas tool to understand the sequence 
of calculations in a formula, and to use the Camera tool to see 
changes happening on a different worksheet. 

Briefing Your colleague has made some changes to the discount 
workbook and you would like to understand how the formulas 
work and see how they impact the SKU prices. 

Task Select Cell A4, then use the Evaluate Formulas tool to help you 
understand how the formula calculates the discount. To see 
how changes in the discount affect the SKU prices, select cells 
A3 to C8 on the Price List sheet, then use the Camera tool to 
capture an image and place it on Sheet 1. Change the value in 
cell C4 to see the values in the camera image change. 

Hints Add the Camera tool to the Quick Access Toolbar using the 
Excel Options dialog box, then click the Camera icon on the 
Quick Access Toolbar to capture an image of the selected cells. 

Sample Data  

Follow-Up Questions Group columns D and E and close the outline to only show 
totals. 
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Lesson 4  
Lesson Lab 4-1 

 

Objective To understand the use of the Quick Analysis Tool to create 
Sparklines. 

Briefing You are reviewing your sales for the first four months of the 
year. You would like to visualize your performance from month 
to month. 

Task Create a Sparkline in cell H8 to visualize your sales 
performance over the past four months. By selecting cells B8 
to G8, you can use the Quick Analysis Tool to accomplish this. 
Add markers to your Sparkline to highlight the high point and 
low point. 

Hints Look for the small Quick Analysis Tool icon to appear on the 
bottom right of your selection. 

Sample Data  

Follow-Up Questions Make the marker for the high point green. 
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Lesson Lab 4-2 

 

Objective To understand the use of what-if analysis to examine scenarios 
and seek goals.  

Briefing You would like to understand how much you would have to sell 
in a month to make $6,000 in commission and bonus, then you 
want to see what your compensation will look like for the first 
six months of the year, depending on your sales for the 
remaining two months.  

Task Use Goal Seek to calculate, in cell F8, how much you would 
have to sell to make $6,000 in commission and bonus, in cell 
F11. Then use Scenario Manager to show your total 
compensation if you sell $90,000, $120,000, or $150,000 in 
both May and June. 

Hints Remember to make the first scenario your current state. 

Sample Data  

Follow-Up Questions Create a scenario summary report, using cell H11 as the  
results cell. 
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Lesson 5  
Lesson Lab 5-1 

 

Objective To view and compare multiple workbooks at the same time, 
and to understand the use of external references in formulas. 

Briefing You have been asked to review inventory counts from two of 
your regional warehouses, and to summarize the inventory 
values for both. 

Task Begin by opening Lesson Lab 5-1A, and Lesson Lab 5-1B. View 
the two workbooks side by side and enable synchronous 
scrolling to compare the same rows in each. Then open Lesson 
Lab 5-1C and create formulas in cells B4 and B5 to summarize 
the values of both inventories. 

Hints Clicking View → Switch Windows simplifies navigating 
between workbooks. 

Sample Data 

 

Follow-Up Questions Close Lesson Lab 5-1A and Lesson Lab 5-1B, then look at the 
external references in the sum formulas to note the difference. 
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Lesson Lab 5-2 

 

Objective To understand the use of data consolidation to collect and 
analyze data from different workbooks with similar values. 

Briefing You would like to collect and analyze data on the inventory 
counts of two warehouses, which have been supplied in 
different worksheets. 

Task Open Lesson Lab 5-2A and Lesson Lab 5-2B, then create a new 
worksheet. Use the Consolidate tool to collect the inventory 
data from both warehouses, in cells A3:D96, into one 
workbook. 

Hints Be sure to click to enable the checkboxes for Top row, Left 
column, and Create links to source data. 

Sample Data 

 

Follow-Up Questions Open the outlines of the individual SKUs to examine the data 
and links from each source. 
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Lesson 6  
Lesson Lab 6-1 

 

Objective To understand the process used to export a worksheet as 
comma separated values. 

Briefing You have been asked to provide the Art department with data 
on SKU sales for the last six months as a Macintosh compatible 
CSV file. 

Task Export the SKU sales data as a CSV file. 

Hints Click the Save as type drop-down in the Save As dialog box to 
locate the CSV (Macintosh) file type. 

Sample Data  

Follow-Up Questions Open the CSV file once it has been exported to compare the 
formatting to the source file. 
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Lesson Lab 6-2 

 

Objective To understand the process used to import a CSV file into a 
workbook and edit the related query. 

Briefing You have been asked to create a table in an Excel workbook, 
containing the data from a supplied CSV file. 

Task Create a new workbook, then import the data from the 
supplied CSV file. Use the Power Query Editor to remove any 
empty columns. 

Hints Select the empty column in the Power Query Editor, then click 
Home → Remove Columns. 

Sample Data  

Follow-Up Questions Open the CSV file in a text editor (like Notepad, or Wordpad), 
and change the name of SKU “AE685” to “New AE685”. Once 
the CSV file is saved, refresh the query in your new workbook 
and note the results in the table. 
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COURSE WRAP-UP 

Post-Course Assessment 
1. What ribbon tabs are only found in the Excel Desktop application? (Select all that 

apply.) 

a. Insert 

b. Page Layout 

c. Data 

d. Formula 

 

2. When naming a Macro, which of the following characters is not permitted? 

a. A letter 

b. An underscore 

c. A space 

d. A number 

 
3. Which of the following properties can be edited in the Workbook Properties dialog 

box? 

a. Type 

b. Title 

c. Modification date 

d. Size 
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4. What does the #N/A! error indicate? 

a. A referenced cell has been deleted or moved 

b. A function cannot find the value 

c. The contents of the cell are too wide to be displayed 

d. A mathematical function is attempting to divide a number by 0 

 

5. When using the Evaluate Formula tool, which part of the formula is underlined? 

a. Logical operators 

b. Bracketed functions 

c. The next part of the formula to be evaluated 

d. If statements 

 
6. Which of the following options is not available in the Quick Analysis Tool? 

a. Tables 

a. Trace Precedents 

b. Sparklines 

c. Charts 

 

7. Which of the following is a type of Sparkline? 

a. Win/loss 

b. Doughnut 

c. Marker 

d. Scatter 
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8. Where does Excel store workbook templates? 

a. The Desktop 

b. The Excel directory 

c. The Downloads folder 

d. The Default Personal Templates location 

 
9. How many cells can you change to reach your target value when using the Goal Seek 

tool? 

a. 1 

b. 3 

c. 10 

d. Unlimited 

 
10. The Goal Seek tool only allows for one value to be changed to calculate the correct 

goal. 

a. How do you refresh a query? 

b. Click Data → Queries & Connections 

c. Click Data → Refresh All 

d. Click Data → Get Data 

e. Save the workbook 
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Course Summary 
Congratulations on completing the Microsoft 365 Excel: Part 3 courseware. During this 
course, you learned how to: 

• Manage workbooks between Excel Online and Excel Desktop 

• Manage workbook properties 

• Work with macros 

• Create and use a template 

• Use Data Validation 

• Trace cells 

• Use Error Checking 

• Evaluate formulas and use the Watch Window 

• Create data list outlines 

• Use the Quick Analysis Tool 

• Add Sparklines 

• Perform What-If analysis 

• Use the Analysis ToolPak 

• Arrange workbooks 

• Use external references 

• Consolidate data 

• Export and import data 

• Use the Microsoft Forms app with Excel Online 

 

You should now feel comfortable working in both Excel Online and Excel Desktop, using 
worksheet automation tools, auditing and error checking your workbooks, using data 
analysis and presentation tools, working with multiple workbooks, and exporting and 
sourcing data. 
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ANSWER KEYS  

Lesson 1 Review Questions 
1. How do you open a workbook in the Excel desktop application from Excel Online? 

To open a workbook in the Excel desktop application from Excel Online, click Open in 
Desktop App on the Excel Online ribbon list. 
 

2. How can you check where your workbook is saved in the Excel desktop application? 

To see where your workbook is stored, click the file name at the top of the Excel 
desktop application workbook window. 
 

3. What is the one ribbon tab that is not available in Excel Online? 

The Page Layout tab is only available in the Excel desktop application. 
 

4. Can you add Sparklines to a workbook in Excel Online? 

Sparklines can be viewed in Excel Online, but can only be added to a workbook using the 
Excel desktop application. 
 

5. Which Excel application, Excel Online or the Excel desktop application, has access to 
Color themes? 

Color themes are only available in the Excel desktop application. Excel Online only has 
access to a limited color palette.   
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Lesson 2 Review Questions  
1. Where can you find the Workbook Properties displayed? 

To view the Workbook Properties, click File → Info, and you will see the information on 
the right side of the Info category. 

 

2. What is the name of the programming language that you can use to write Macros? 

Macros are written in the Visual Basics for Applications (VBA) language. 

 

3. Where can you store macros that you have recorded? 

You can store macros in the current workbook, a new workbook, or the Personal Macro 
Workbook, a hidden workbook that is opened whenever you open the Excel Desktop 
application.  

 

4. How do you create a new workbook from a Personal template? 

Click File → New, then click Personal in the New category, then select the template you 
want to use as the source for your new workbook. 

 

5. How can Data Validation help you automate data entry? 

You can use Data Validation to create drop-down lists in a cell or a range, to allow the 
user to select from a list of predefined options. 
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Lesson 3 Review Questions  
1. What does a black dotted tracer arrow indicate? 

The black dotted tracer arrow indicates that the data referred to in the selected formula 
is in a different sheet in the workbook or is in a different workbook. 

 

2. What are dependent cells? 

Dependent cells are cells within a worksheet that are affected by the contents of the 
active cell. 

 

3. What does the “#DIV/0!” error indicate? 

“#DIV0!” occurs when a mathematical function tries to divide a number by zero. 

 

4. What does the Step In button in the Evaluate Formula dialog box do? 

Clicking Step In will let you examine the formula or value of the underlined cell. 

 

5. What do you need to do to your data before you use the Subtotal command? 

You need to sort your data on the column that contains the categories you wish to 
subtotal on. 
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Lesson 4 Review Questions  
1. How do you access the Quick Analysis Tool? 

To access the Quick Analysis Tool, select a range of text and click on the small icon that 
appears at the bottom right of your selection. 

 

2. What are the three types of Sparklines? 

The three types of Sparklines are line, column, and win/loss. 

 

3. How many cell values can you change to reach the goal value in the Goal Seek tool? 

The Goal Seek tool only allows for one value to be changed to calculate the correct goal. 

 

4. What should you use to create your first scenario in the Scenario Manager? 

It is a good idea to make your first scenario based on the current state, so you do not 
risk losing the data. 

 

5. What types of analysis tools are available in the Analysis ToolPak? 

The Analysis ToolPak provides advanced and specific tools for financial, statistical, and 
engineering data analysis. 
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Lesson 5 Review Questions  
1. How will multiple workbook windows appear if you arrange them vertically? 

Vertically arranged windows will display side by side. 

 

2. How many ways can the syntax of an external reference appear? 

The syntax of an external reference can appear in one of two ways, depending on 
whether the workbook containing the reference is open, or closed. 

 

3. How can a link to an external data source be broken? 

The link to an external data source can be broken as the result of a file being moved 
from its original location, or from a file being renamed. 
 

4. Where is the best place to consolidate data? 

When consolidating data from multiple sources it is best to use an empty worksheet, or 
to have ample space available for the consolidated data on an existing sheet. 
 

5. Do data consolidation sources have to have the exact same structure? 

No. Data consolidation sources should be similar, but do not need to have all the same 
column and row labels. 
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Lesson 6 Review Questions  
1. Can you export more than one worksheet at a time when creating a CSV file? 

No, you can only export one worksheet at a time to a CSV (Comma Separated Value) file. 

 

2. What are the benefits of using the PDF file format? 

PDF (Portable Document Format) files maintain the format of the source file and are 
highly accessible. 

 

3. How does Excel format data from a Web Query? 

Data from a Web Query is loaded into an Excel worksheet as a table. 

 

4. What is a quick way to add questions to a Microsoft Form? 

The Microsoft Forms app has prebuilt templates that can be quickly loaded into a form  
and customized for your specific use. 

 
5. Can you customize the appearance of a Microsoft Form? 

Yes, you can customize the appearance of a form by clicking the Theme button, where 
you can select from existing templates, or click the customize button to access custom 
options. 
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Post-Course Assessment 
1. What ribbon tabs are only found in the Excel Desktop application? (Select all that 

apply.) 

b. Insert 

c. Page Layout 

d. Data 

e. Formula 

The Page Layout tab is not available in Excel Online.  

 

2. When naming a Macro, which of the following characters is not permitted? 

a. A letter 

b. An underscore 

c. A space 

d. A number 

The first character of a macro name must be a letter, and can only be followed by 
letters, numbers, or the underscore character. 
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3. Which of the following properties can be edited in the Workbook Properties dialog 
box? 

a. Type 

b. Title 

c. Modification date 

d. Size 

General workbook property information cannot be edited in the Workbook Properties 
dialog box. The Summary tab allows the user to add information, including Title, Subject, 
Author, Manager, and Company.  

 

4. What does the #N/A! error indicate? 

a. A referenced cell has been deleted or moved 

b. A function cannot find the value 

c. The contents of the cell are too wide to be displayed 

d. A mathematical function is attempting to divide a number by 0 

The #N/A error occurs when a function cannot find a value that meets the defined 
criteria. An example is the VLOOKUP function not finding a result. 

 

5. When using the Evaluate Formula tool, which part of the formula is underlined? 

a. Logical operators 

b. Bracketed functions 

c. The next part of the formula to be evaluated 

d. “If” statements 

The Evaluate Formula tool underlines the part of the formula that is the next to be 
evaluated, based on precedence in the order of operations.  

 
 
  



Microsoft 365 Excel: Part 3 

 

© 20019-2025Ultimate IT Courses Training Materials Inc.  

351 

6. Which of the following options is not available in the Quick Analysis Tool? 

a. Tables 

d. Trace Precedents 

e. Sparklines 

f. Charts 

The Quick Analysis Tool gives access to Formatting, Charts, Totals, Tables, and 
Sparklines. Trace Precedents is accessed by clicking Formulas → Trace Precedents. 

 

7. Which of the following is a type of Sparkline? 

a. Win/loss 

b. Chart 

c. Marker 

d. Scatter 

The three types of Sparklines are line, column, and win/loss. 

 

8. Where does Excel store workbook templates? 

a. The Desktop 

b. The Excel directory 

c. The Downloads folder 

d. The Default Personal Templates location 

The Default Personal Templates path is typically 
“C:\Users\[UserName]\Documents\Custom Office Templates”, where UserName is your 
Username on the computer. The location can be set in the Excel Options dialog box, in 
the Save category. 
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9. How many cells can you change to reach your target value when using the Goal Seek 
tool? 

a. 1 

b. 3 

c. 10 

d. Unlimited 

The Goal Seek tool only allows for one value to be changed to calculate the correct goal. 

 

10. How do you refresh a query? 

a. Click Data → Queries & Connections 

b. Click Data → Refresh All 

c. Click Data → Get Data 

d. Save the workbook 

To refresh a query, and update the data in the table, click Data → Refresh All. 
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APPENDICES 

Keyboard Shortcut Quick Reference Sheet 

Fi
le

 M
an

ag
em

en
t  

Open a new workbook Ctrl + N 

Save a file Ctrl + S 

Open a file Ctrl + O 

Print worksheet Ctrl + P 

Close Microsoft Excel Alt + F4 

W
or

ks
he

et
 

Switch between worksheet tabs (left to 
right) 

Ctrl + Page Up 

Switch between worksheet tabs (right to 
left) 

Ctrl + Page Down 

Insert cells Ctrl + Shift + + 

Delete cells Ctrl + - 

Te
xt

 E
di

tin
g  

Select all items in current worksheet Ctrl + A 

Copy text Ctrl + C 

Cut text Ctrl + X 

Paste text Ctrl + V 
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O
pe

n 
Di

al
og

s  
Open Find tab of Find and Replace dialog Ctrl + F 

Open Replace tab of Find and Replace 
dialog 

Ctrl + H 

Open Go To dialog Ctrl + G 

Open Font tab of Format Cells dialog Ctrl + Shift + F 

Check spelling  F7 

Get Help F1 

Te
xt

 F
or

m
at

tin
g 

To
ol

s  

Apply bold formatting Ctrl + B 

Apply underlining Ctrl + U 

Apply italic formatting Ctrl + I 

Align text to center Ctrl + E 

Align text to left Ctrl + L 

Align text to right Ctrl + R 

Justify text Ctrl + J 

Increase font size Ctrl + Shift + . 

Decrease font size Ctrl + Shift + , 

Undo last action Ctrl + Z 

Redo last action Ctrl + Y 
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Glossary 
absolute reference 

A type of reference that will not change 
even if it is moved or copied to another 
location.  

add-in 

Small components that can be added to 
Excel to add features and functionality. 

array 

Any grouping of two or more adjacent 
cells. 

arguments 

Data used by functions to complete 
calculations. 

AutoFill 

A feature that is used to automatically fill 
sequential data into a range of cells. 

AutoFilters 

Preconfigured filters that can be quickly 
applied or removed. 

Anova 

Short for Analysis of Variance. Used to 
examine if the averages of samples are 
different in a significant way. 

cell 

The intersection of a row and column on a 
worksheet. 

charts 

Visual representations of numeric data in 
a dataset. 

conditional formatting 

A formatting type that will highlight cells 
whose data satisfies certain criteria. 

consolidation 

The process of combining, condensing, 
and summarizing data from multiple 
sources into one destination. 

correlation  

Indicates if data sets trend or change with 
each other. 

criteria range 

Used in database functions or advanced 
filters, this refers to the range that 
contains criteria that is needed in order to 
perform an operation. 

database functions 

Functions that allow you to perform 
operations on multiple fields in an Excel 
database. 

delimited text 

Data that is entered with one row 
equaling one line of text. 
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dependent cells 

Cells that are affected by the contents of 
another cell. 

exporting 

The process of sending data from one 
application to another. 

external reference 

A link to the contents of one or more cells 
within the worksheet of another 
workbook. 

fields 

Columns that appear in a dataset that is 
used for a PivotTable. 

fill 

Formatting that adds background color to 
cell(s). 

fill handle 

The small black box that appears in the 
bottom right-hand corner of a selected 
cell or cell range. Used to activate the 
AutoFill feature. 

filtering 

Removing data from view, based upon set 
criteria. 

Flash Fill 

Feature that will automatically extract or 
combine data based on a pattern. 

font  

A set of typeface. 

form  

An interface element of a workbook that 
is used to collect data or execute an 
action. 

Format Painter 

A tool that is used to copy formatting 
from one selection of text to another. 

formula  

A mathematical relationship expressed 
through symbols. 

Formula Bar 

A part of the Excel interface that displays 
the cell name, as well as values and 
formulas in the selected cell. 

function 

A preconfigured formula that is used for a 
specific purpose. 

HTML 

A programming language that describes 
how to display data. 

importing 

The process of opening data in one 
application that was saved in another 
application. 

logical operators 

A type of operator that is used to 
compare values and determine whether 
those values meet specified criteria. 
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logical values 

A type of value that expresses whether 
data is TRUE or FALSE based on specified 
criteria. 

macros 

Small programs that are created to 
complete a specific task or set of tasks. 

mixed references 

Cell references that include both relative 
and absolute references. 

multi-cell array formula 

A type of array formula that performs 
multiple calculations on one or more 
arrays and then displays the results. 

outline 

A feature in Excel that allows you to 
organize datasets in a worksheet into 
hierarchical groups. 

PivotChart 

Similar to regular Excel charts, a 
PivotChart is a visual representation of 
data that is being displayed in a 
PivotTable. 

PivotTable 

A data analysis tool that dynamically 
allows you to pivot columns and rows of 
raw data without altering it. 

precedent cells 

Cells within a worksheet that provide data 
for a formula. 

range names 

Meaningful names that can be added to 
cell ranges so that they can be easily 
referred to and understood later. 

relative reference 

A cell reference that will change relative 
to its positioning in a worksheet. 

scenario 

A set of cell values that are saved and 
substituted into your worksheet at your 
convenience. 

single-cell array formula 

A type of array formula that performs 
multiple calculations on arrays and then 
displays the results in a single cell. 

slicers 

A type of data analysis tool that works in 
conjunction with PivotTables to sort data 
based on unique data entries. 

Sparklines 

Small graphs contained within a single cell 
that are used to summarize data and 
display trends. 

spreadsheet 

Either a paper or electronic file that is 
used to store and work with data (mostly 
numbers) in a tabular fashion.  
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SUBTOTAL function 

A type of Excel function that is used to 
perform calculations on subsets of data. 

subtotals feature 

A feature that is used to quickly perform 
the SUBTOTAL function on a subset of 
data within a dataset. 

summary function 

A feature that uses SUBTOTAL functions 
on subsets of data within a table. 

table 

A dataset that is comprised of rows and 
columns but is treated as one object 
(unlike regular data ranges). 

Tell Me 

Natural language help feature accessed 
directly on the ribbon interface. 

Text pane 

Part of the interface when SmartArt is 
added or selected in Excel. Is typically 
used to add text to SmartArt. 

tracer arrows 

Colored arrows used to indicate the 
direction of the data flow to and from 
cells and formulas. 

transactional data 

Data that represents each transaction (or 
event) in a series. It is not summarized in 
any way and is considered raw data 
without row labels.  

VBA 

Visual Basics for Applications, a 
programming language that can be used 
to automate procedures in Microsoft 
Office. 

workbook 

An Excel file that stores multiple 
worksheets. 

worksheet 

An electronic spreadsheet. 

workspace 

Saved set of Excel files. 

XML 

A commonly used programming language 
that is frequently used to describe data; 
stands for Extensible Markup Language. 
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